SharpCap ユーザーマニュアル

Copyright © 2018-2021 Robin Glover and David Richards

このバージョンでは、SharpCap 4.0について説明しています。

SharpCapは、主に天体写真とビデオ天文学のために設計された画像撮影アプリケーションです。

SharpCapのフォーラムでサポートを受けることができます。 http://forums.sharpcap.co.uk

Web形式版は ここに アクセスして見ることができます。

翻訳： 2021-11-30 Toshihito Watanabe


序文

SharpCapは、2010年2月にフラストレーションから生まれました。 その不満とは、当時の天体写真撮影でウェブカメラ撮影に使用されていた典型的なアプリケーションに対するものでした。AMCAPはその典型的な例で、カメラの設定を調整するのが非常に難しく、 前の撮影ファイルを上書きするような愚かなことも簡単にできました。これらの欠点は、暗闇の中で、ノートパソコンで、手袋をしながらプログラムを使おうとすると、 より一層明らかになりました。

これに対する私の反応は、 設計の悪いアプリケーションに遭遇したソフトウェア開発者にとっては標準的なものですが、「私はもっとうまくやれる」と自分に言い聞かせることでした。さらに珍しいことに、 私は実際に「もっとうまくやれるはずだ」と決心し、その後数日間かけてSharpCapを書き始めました。しかし、SharpCapという名前は簡単に決まりました。その名前は、 書かれているプログラミング言語のC#（シーシャープと発音します）に由来しています。

最初の1年間、 SharpCapは非常にシンプルなウェブカメラ撮影アプリケーションであり続けました。 使いやすく、標準的で親しみやすいWindowsのUI要素を使用し、カメラのコントロールを常にユーザーに示すように設計されていた。これは、 多くの人がSharpCapの使用を開始するのに十分な改善であると思われた。

SharpCapの最初のリリースから約1年後、 （私にとって）予想外のことが起こった。Baslerのカメラを販売している天文学の小売業者から突然、「SharpCapをそのカメラで使えるようにできないか」「サンプルのカメラを提供する」という申し出を受けたのです。 この偶然の出来事は、SharpCapの方向性を、ウェブカメラだけのアプリケーションから、今日の幅広い天体画像専用ハードウェアをサポートするアプリケーションへと変えました。

SharpCapは、長年にわたり、より多くのカメラに対応するとともに、 多くの機能を追加してきましたが、残念ながら「ただ使うだけ」のシンプルなアプリケーションではなくなったため、このユーザーマニュアルが必要になりました。 例えば、被写体を見つけるのは難しいので、様々な画像ブースト効果で微弱な被写体やピンボケの被写体を見つけやすくしたり、ピントを合わせるのは難しいので、 6つのフォーカスアシストツールを用意したり、DSOイメージングは難しいので、ライブスタックで簡単にしたり、もちろん、ポーラアライメントは難しいですが、 SharpCapの使いやすいポーラアライメントツールで簡単にしたりしています。

SharpCapを使うことで、天体画像の撮影が容易になることを願っています。

Robin Glover, April 2018

Copyright ©2018-2021 Robin Glover


前書き

SharpCapは、主に天体写真やビデオ天文学のために設計された画像撮影アプリケーションです。

SharpCapのフォーラムでサポートを受けることができます。

本書では、SharpCap 4.0について説明しています。

SharpCap 4.0 新機能

· シーケンスツール：SharpCapが実行する画像シーケンスを構築します

· 撮影

· オートフォーカス

· 冷却 / 準備開始

· フィルター切り替え

· その他多数

· シーケンスプランナー - 簡単に使えるdeep skyの画像計画作成ツール

· スチルカメラモード（ツールバーのライブビューをOFFにする）

· ADC アライメントツール（ツールメニュー ）

· 惑星 / ディスクの安定化

· ピクセルの明るさを読み取る

· プレートを解いた後、ピクセル位置を読み取り、クリックして最近のものに移動

· スカイグローを除去するための背景減算機能

· 機能追跡モードのROI追跡と重心追跡

· フォーカサーバックラッシュ補正オプション

· フィルター交換時のフォーカスオフセット対応

· マウントコントロールボタンの方向転換オプション

· ADVサポートに保存

· ホットキーによるマウントの移動（Ctrl + I / J / K / L / Ctrl + Num4 / Num6 / Num2 / Num8 ）

· モニターの性能向上を見る

· MGEN3のオートガイダー対応

· メニュー/ツールバー/カメラのコントロールを選択された言語に翻訳

· 多くのバグ修正


必要事項

サポートカメラ

SharpCapは様々なカメラに対応しています。 これらは3つの分類に分けられます。

1. SharpCapが直接サポートするカメラ - Altair、Atik、Basler、Celestron、Imaging Source、iNova、Moravian Instruments、Player One、Point Grey、QHY、SVBony、 StarlightXpress、ZWOなど、多くのブランドの天文学専用カメラが含まれます。

2. Windows Webカメラドライバーでサポートされているカメラ – ほとんどのWebカメラ（改造されているもの、改造されていないもの）、USBフレームグラバーのほか、 メーカーがWebカメラドライバー （WDMまたはDirectShowドライバと呼ばれることもあります）を提供している多くの特殊なカメラにも対応しています。

3. ASCOMドライバーでサポートされているカメラ - 多くの天文カメラメーカーが自社製品用のASCOMドライバーを提供しており、SharpCapはこれらを使用してカメラと通信することができます。

カメラには、上記の2つ（あるいは3つ）の方法でアクセスできる場合があります。 このような場合、通常はカメラのダイレクトサポートを使用するのが最も良い方法で、 これによりカメラの機能を最もよくコントロールできます。ダイレクトサポートは、常にメニューの一番上にあるカメラの項目になります。

Altair カメラ

ガイド、太陽、惑星、月、deep skyの画像のためのさまざまなCMOSカメラを提供する英国の納品業者です。 Altairのカメラは、英国およびその他の国のさまざまな販売店でも購入できます。 AltairのWebサイトは次の通りです。https://www.altairastro.com/

AstcamPan カメラ

AstcamPanでは、様々なCMOSカメラを販売しています。このカメラは、メーカーから直接購入できるほか、さまざまなオンラインマーケットプレイスでも購入でます。 同社のWebサイトは次の通りです。 https://www.astronomy-camera.com/

Atik カメラ

CCD、CMOSカメラを中心としたアストロ画像のための製品を提供しています。Atikのカメラは、英国およびその他の国の様々な販売店から購入することができます。 AtikのWebサイトは次の通りです。 https://www.atik-cameras.com/

Basler カメラ

幅広い産業用カメラを製造するドイツのメーカーで、中にはアストロ画像に適したカメラもある。 SharpCapは、ギガビットイーサネット接続を含むBaslerカメラをサポートしています。 SharpCapは、Basler社製カメラの一部のモデルにおいて、カメラの手動露光トリガーをソフトウェアで巧みに制御することにより、 カメラの通常の最大露光量を超える露光をサポートすることがでます。 Basler社のWebサイトは次の通りです。 http://www.baslerweb.com/en

セレストロン / イメージングソースカメラ

イメージングソース社は、以前からアストロ画像に使用されてきた産業用カメラを幅広く提供しています。 イメージングソース社のカメラは、現在セレストロン社のブランドで販売されています。 SharpCapは、イメージングソースとセレストロンのカメラの全製品をコントロールできるはずですが、テストではより一般的なUSBカメラのみをカバーしています。 イメージングソース社のWebサイトは次の通りです。 https://www.theimagingsource.com/

iNova カメラ

iNova社は、主にアストロ画像市場を対象とした小型センサーのCMOS/CCDカメラを販売しており、主に太陽・月・惑星の画像とオートガイドに適しています。 http://inovaccdusa.com/

Moravian Instruments カメラ

Moravian Instruments社は、アストロ画像用のCMOSおよびCCDカメラを幅広く販売しています。SharpCapは、CMOSカメラをサポートしており、CCDモデルでも動作する可能性があります。 Moravian Instruments社のWebサイトは次の通りです。 https://www.gxccd.com/

Player One カメラ

Player Oneは、月・太陽・惑星の撮影を目的とした一連のCMOSカメラを販売しています。同社のWebサイトは次の通りです。 https://player-one-astronomy.com/ カメラは、同社のWebサイトから直接購入できるほか、多くの販売店を経由して購入できます。

Point Grey カメラ (現在のFLIR)

Point Grey（現在はFLIRが所有）は、天体画像や科学的画像にも使用できる幅広い産業用カメラを販売しています。SharpCapは、ほとんどのPoint Grey製カメラをサポートしており、 その機能を完全にコントロールすることができます。Point Grey社のカメラの詳細については、次を参照してください。 https://www.flir.com/iis/machine-vision/

QHY カメラ

QHYは、ウェブカメラサイズからフルフレーム一眼レフまで、幅広いセンサーサイズのCCDおよびCMOSカメラを販売しています。 これらのカメラは、主に天体画像や科学市場向けに設計されています。 SharpCapは、QHY社のカメラの全製品をサポートしており、 内蔵フィルターホイール、GPSタイミングモジュール、ペルチェクーラー制御などの高度な機能をサポートしています。 QHY社のウェブサイトは次の通りです。 http://www.qhyccd.com/

StarlightXpress カメラ

StarlightXpress社は、天文学用に特別に設計されたCCDベースのカメラを製造しています。SharpCapは、人気の高いLodestarシリーズの高感度ガイドカメラを含む、 StarlightXpress社の全製品を制御することができます。StarlightXpressカメラの詳細については、次を参照してください。 https://www.sxccd.com/

SVBony カメラ

SVBony社は、CMOSアストロ画像カメラを製造しています。SV305とSV305Proは、SharpCapで直接サポートされていますが、 その他のモデル（SV105とSV205）は、ウェブカメラドライバーでのみサポートされています。SVBony社のカメラは、同社のWebサイトから直接購入できます。 https://www.svbony.com/categories/astronomy-camera/

ZWO カメラ

ZWO社は、ウェブカメラサイズからフルフレーム一眼レフまで、低ノイズ・高感度センサーを搭載したCMOSカメラを販売しています。同社のカメラは主に天体画像市場向けに設計されており、 一部のモデルではUSBハブを内蔵するなどの便利な機能を備えています。SharpCapは、ペルチェクーラーの制御やUSB帯域幅の調整などの高度な機能の制御を含む、 ZWOカメラの全製品をサポートしています。 ZWO社のWebサイトは次の通りです。 https://astronomy-imaging-camera.com/

ASCOM カメラ

多くのアストロカメラにはASCOMドライバーがあり、SharpCapはこれらのドライバーを使用してそのようなカメラを制御することができます。 これは、SharpCapがカメラを直接サポートしていない場合の良い代替手段となります。 ASCOM規格のWebサイトは次の通りです。

http://www.ascom-standards.org/Downloads/CameraDrivers.htm

なお、多くの一般的なデジタル一眼レフカメラは、ASCOM DSLRドライバーを介してSharpCapで使用することができます（詳細はこちら）。 https://github.com/FearL0rd/ASCOM.DSLR/ これらのカメラは通常、SharpCapの 静止モード で使用します。

DirectShow カメラ (ウェブカメラ)

Microsoft DirectShowは、Microsoft Windowsプラットフォーム上でメディアをストリーミングするためのアーキテクチャです。 市場には膨大な数のウェブカメラとフレームグラバーがあります。 SharpCapで利用できるコントロールは、ドライバーによって決定されます。 SharpCapは、ドライバーが利用できるコントロールを表示しているだけです。

仮想カメラ

SharpCapは、「仮想」カメラをサポートしています。これは、選択したフォルダから画像ファイルを読み込み、あたかもカメラから受け取ったフレームのように画像を扱うことで機能します。 SharpCapは、フォルダ内のすべての既存の画像を日付順に読み込み、その後、新しい画像が作成されるのを待ちます。カメラから画像を撮影してディスクに保存するプログラムがあれば、 仮想カメラを使って、以前に撮影した画像とのライブスタッキングなどのSharpCapの機能を使用することができます。

ASCOMとDirectShowの選択

カメラがASCOMとDirectShowで表示された場合、どちらを選択すればよいのでしょうか？

SharpCapが直接サポートしていないカメラを使用する場合、接続には2つの方法があります – ASCOMドライバー または DirectShowドライバー、 それぞれに長所と短所があります。

ASCOM | DirectShow
長所 · SharpCapパネルで露出を直接コントロール（連続可変）。 · ビニング が可能な場合があります。 · ROI が利用できる場合があります。 · 8以上の ビット深度 やRAWモードが利用できる場合があります。 · 長時間露光が可能になりそうです。 短所 · ASCOMでは露出とゲイン以外のコントロールができないため、 SharpCapのパネルには他のコントロールがほとんどありません。 · ASCOMは比較的低速なので、 フレームレート が遅くなります。 · ASCOMは、各メーカーが独自の方法で規格を解釈しているため信頼性が低く、ASCOMドライバーの中にはSharpCapとの互換性がないものもある。 | 長所 · パネルで使用できるカメラコントロールの選択肢が増えました（ガンマ、明るさ、コントラストなど）。 · 長時間露光が可能な場合もあります（1s、2s、4s、8s、16sなど）。 · 関心領域（ROI）が利用できる場合があります。 · カメラのDirectShow設定ダイアログで追加のコントロールが可能な場合があります。 · 高フレームレートが可能。 · ASCOMよりも互換性の問題が発生しにくい。 短所 · 露出は2の倍数でのみ変更可能です。 · ビット深度は8ビットに限定されており、RAWモードは使用できないと思われます。 · DirectShow経由でアストロカメラを使うのは、直接使うほどではありませんが（コントロールが少ない、露出のコントロールができない）、何もしないよりはマシです。

ソフトウェア

SharpCapは、Microsoft Windows上で動作します。最低限のバージョン要件は：

· SharpCap 2.9 (またはそれ以前のバージョン) – Windows XP, Vista, 7, 8, 8.1, 10

· SharpCap 3.0 – Windows Vista, 7, 8, 8.1, 10

· SharpCap 3.1, 3.2 and 4.0 – Windows 7 with SP1, 8.1, 10

SharpCapには、32ビット版と64ビット版があります。32ビット版は、32ビット版と64ビット版のWindowsの両方にインストールして動作しますが、 64ビット版は64ビット版のWindowsが必要です。

一般的には、SharpCapの32ビットバージョンを推奨します。高解像度のカメラ（12メガピクセル以上）でライブスタッキングを行う場合は、メモリ不足のエラーが発生する可能性を避けるために、 64ビットバージョンを使用することをお勧めします。なお、iNovaおよびStarlightXpressカメラは64ビット版ではサポートされておらず、一部のASCOMドライバーも64ビットに対応していません。

複数のメジャーバージョンを共存させることができます。例えば、3.1、3.2、4.0を同じマシンに一緒にインストールすることができます。 例えば、3.2.6480と3.2.6482のどちらかを同時にインストールすることができます。

ハードウェア

最低限必要なハードウェアは、使用するカメラの種類によって異なります。 カメラを購入する際には、メーカー / 販売業者が推奨する最低PCスペックをよく確認してください。

最高のフレームレートを実現するためには、以下の点を考慮する必要があります。

· プロセッサは、i5またはi7が望ましい。

· メモリは、32ビットWindowsでは最大3Gb、64ビットでは最低4Gbが必要です。

· ディスクは、SSDは従来のドライブよりも高速です。

· USBの、USB3（5Gb/s）はUSB2（480Mb/s）の10倍の速さです。

· Windows 32/64ビットの、64ビットは3GB以上のメモリをサポート。

SharpCapは、最近のコンピューターに搭載されている複数のCPUコアを利用するように設計されており、複数のCPUコアが利用できる場合には、 高速なカメラでもパフォーマンスが向上します。

高フレームレートや超高解像度のカメラを購入する際には、ハードウェアの要求を考慮してください。

最低限のハードウェアスペック

640x480の解像度を持つウェブカメラは、低スペックのPCでも問題なく使用できます。 この条件を満たすのがThinkPad X61（本マニュアルの作例の制作に使用）です。 以下のスペックであれば、USB2のウェブカメラで640×480で30fpsを実現できます。

· Core 2Duo 1.86Ghz プロセッサー

· 4Gb (32ビットWindowsでは3Gb使用可能)

· 120GbのSATA2ドライブ

· Windows 10 32ビット

推奨するハードウェアスペック

3000x2000ピクセル、50fpsの性能を持つ天文学専用カメラは、最大のパフォーマンスを発揮するために、高速なプロセッサー、より多くのメモリ、SSD、USB3ポートが必要となります。

高解像度のカメラ（10メガピクセル以上）を使用する場合は、撮影用のPC / ノートPCの性能を確認してください。

· 最低でもi5プロセッサを搭載していること。

· 大容量のハードドライブ（500Gb以上）、SSDが望ましい。

· 少なくとも8Gb（好ましくは16Gb以上）のメモリーを搭載。

· Windows OSの64ビット版。

この設定により、SharpCapがより多くのメモリにアクセスできるようになり、撮影中にメモリが枯渇する可能性が低くなります。 これは、RGBモードや、1ピクセルあたりのビット深度が12ビットまたは16ビットの場合に適用されます。


SharpCap Pro

SharpCapの高度な機能の多くは、SharpCap Proのライセンスを購入する必要があります。SharpCap Proのライセンスは、リーズナブルな価格で、1年単位で購入することができ、 次のサイトから購入することができます。http://store.astrosharp.co.uk/

なお、既存のライセンスがある場合は、アップグレードのたびにライセンスを購入する必要はありません。 SharpCapのすべてのバージョンが使用でき、新しいバージョンが利用可能になるたびにアップデートできます。

SharpCap Pro のインストール

SharpCap Proの機能を使用する場合、別バージョンのSharpCapをインストールする必要はありません。SharpCap Proの機能は、 通常のインストールされたバージョンのSharpCapにすでに搭載されており、SharpCap Proのライセンスキーを入力することで利用可能になります。

SharpCap Proを試す

ライセンスを購入する前に、SharpCap Proのほとんどの機能を試すことができます。ライセンスを購入せずに1つまたは複数のSharpCap Pro機能をお試しになる場合、 SharpCapは評価モードになり、アプリケーションを閉じてから再起動するまで画像を保存できません。評価モードでは、SharpCap Proの機能の効果を画面上で確認することができますが、 結果の画像を保存することはできません。

ライセンスがインストールされていない状態でSharpCap Proの機能を使おうとすると、以下のようなメッセージが表示されます。

・・・をクリックすると、評価モードで機能を使用するか、新しいライセンスを購入するか、すでに購入済みのライセンスを入力するか、 または機能を使用しないかを選択することができます。

各種オプションを選択すると、以下のような効果があります。

· 「ライセンスなしで試す Try without a license 」ー その機能や他のSharpCap Proの機能をトライアルモードで使用することができます。トライアルモードでは、 通常、画像をビデオファイルや画像ファイルに保存することはできません。つまり、画面上では結果を見ることができますが、結果を保存することはできません。

· 「SharpCap Proのライセンスを購入する Purchase a SharpCap Pro License 」ー このリンクをクリックすると、SharpCap Proのライセンスを購入できるWebサイトが表示されます。

· 「すでにSharpCap Proのライセンスをお持ちの方へ Already have a SharpCap Pro License? 」ー すでにSharpCap Proのライセンスをお持ちで、まだ入力されていない方は、 このオプションを選択すると、SharpCapのライセンスウィンドウが起動し、ライセンスキーを入力することができます。

· Get me out of here… ー SharpCap Proの機能を試すことに興味がない場合は、このオプションを選択してください。 SharpCapは機能を起動しませんので、トライアルモードにはなりません。

例えば、評価モードでシーケンサーまたはシーケンスプランナーツールを使用すると、実行するシーケンスの長さが5分に制限されるなど、 一部のSharpCap Proの機能では評価時に異なる制限があります。

SharpCap Proの機能

以下の表は、SharpCap Pro のライセンスが必要な機能の一覧です。これらの機能は、このユーザーガイドの残りの部分で言及されているところでは、 「SharpCap Pro」というテキストで強調されています。

機能 | 備考
ダーク減算 |
ライブフラット補正 |
極軸合せ | ライセンスがなくても、ポーラーアライメントの誤差を測定することができます。誤差を修正するための調整手引きは、ライセンスが必要です。
Python スクリプト言語 |
ライブスタックによるカラー調整 |
ライブスタックとヒストグラム表示自動ストレッチ | 手動での画像ストレッチの調整にはライセンスは必要ありませんが、「自動ストレッチ」ボタンの使用にはライセンスが必要です。
機能追跡 |
シーイングモニター | 「トリガー付き撮影を見る」と「 フィルタリングされた撮影を見る」は、ライセンスがないと起動できません。
スマートヒストグラム |
詳細なフォーカススコア機能 | ASCOMフォーカサーによる自動フォーカススキャンにはライセンスが必要です。
ライブスタック画像の強化 | アンシャープマスクによる鮮鋭化、ワイナーデコンボリューションによる鮮鋭化、バイラテラルフィルターによるノイズ除去。
ライブスタックのシグマクリップ |
PHD2によるライブスタックディザリング |
2つのモニター表示 | 2台目のモニターに表示される画像は、ライセンスを持っていない場合、透かしが入っています。
バンディング除去 |
フォルダーモニターカメラ |
ライブスタッキングの自動ディザリング |
シーケンサー と シーケンサープランナー | 評価中に画像を保存できますが、最大5分後にシーケンスが停止します。
惑星の安定化 |
クリックして最近に |
背景減算 |

SharpCap Proライセンスの購入

SharpCap Proのライセンスは次のサイトで購入できます。 https://store.astrosharp.co.uk お支払いにはPayPalをご利用いただけます。お客様がPayPalアカウントをお持ちでない場合は、アカウントを作成するか、 アカウントを作成せずにクレジットカードまたはデビットカードを使用して購入するかを選択できます（PayPalのリンクをたどると、 クレジットカードまたはデビットカードを使用して購入するオプションが表示されます）。

支払いが完了すると、PayPalサイトで使用したEメールアドレスにライセンスが送信されますので、間違いのないようにしてください。 ライセンスメールが「迷惑メール」フォルダに入ってしまうことがありますので、ライセンスメールがすぐに届かない場合は、必ず確認してください。 PayPalでの支払い完了後、ブラウザが自動的にAstroSharpのウェブサイトに戻るようにすると、新しいライセンスがWebブラウザに表示されます。

SharpCap Proライセンスのインストール

新しいSharpCap Proライセンスをインストールするには、SharpCapを起動し、「ヘルプ」メニューで「SharpCap Proのライセンス」を選択します。 Webブラウザまたは電子メールからライセンステキストをコピーして、ライセンスボックスに貼り付けます。 ライセンステキストがすべて含まれるように注意してください。

入力が完了すると、ライセンスは以下の例のように表示されます（ぼかしは入っていません！）。テキストの各行は、フィールド名（LicenseIdやExpiryなど）で始まり、 等号（'='）の後にフィールド値が続くようにします。他のテキストは含めず、表示されているすべての行を含めるようにしてください。

ライセンスが正しく入力されていれば、ライセンス入力ボックスの下にライセンスの状態が「Valid」と表示されます。

ライセンスの有効期限と更新

SharpCap Proのライセンスは、サブスクリプション方式で販売されており、1年間のライセンスを購入すると、購入日から1年間、SharpCap Proの機能を使用することができます。 つまり、1年間のライセンスを購入すると、購入日から1年間、SharpCap Proの機能を使用することができます。ライセンスの有効期限が切れると、 SharpCap Proの機能にアクセスできなくなります（ただし、SharpCapの多くの非Pro機能は引き続き使用できます）。サブスクリプションベースのライセンスは、 年間コストを非常に低く抑えることができます。

SharpCap Proのライセンスの有効期限が切れる数週間前に、ライセンスの更新時期をお知らせするリマインダーメールを2回お送りしています。 また、SharpCap本体にも、ライセンスの期限切れを知らせる通知が表示されます。

SharpCap Proのライセンスを更新することを選択した場合、新しいライセンスキーが発行されます。 SharpCap Proライセンスのインストール の手順に従って、SharpCapの既存のライセンスキーを新しいキーに置き換える必要があります。 新しいキーはすぐに有効になりますので、古いキーの有効期限が切れるのを待ってから変更する必要はありません。新しいライセンスキーをインストールする前に、 「SharpCapのライセンス」ボックスから古いライセンスキーのテキストを削除することを忘れないでください。

SharpCap Proライセンスの詳細

ライセンスメールが届かないのですが、どうしたらいいですか？

また、この種のメールは「バルク」メールとして分類され、転送が遅れることがありますのでご注意ください。

もし、まだメールが届いていない場合は、次のサイトにアクセスして、メールを再送してもらうことができます ライセンスの回復 ページ 。 ライセンスの購入時に使用したメールアドレスと（オプションで）PayPalのレシートに記載されている時間を入力するだけです。 自動的にライセンスメールが再送されます（PayPalのレシートの時間も入力できる場合は、ブラウザに表示されます）。

ライセンスを入力するにはどうすればいいですか？

SharpCapを起動し、「ヘルプ」メニューから「SharpCap Proのライセンス」を選択します。ウェブブラウザや電子メールからライセンステキストをコピーして、 ライセンスボックスに貼り付けます。ライセンステキストがすべて含まれるように注意してください。

私のライセンスは有効ではないと表示されますが、何か間違ったことをしたのでしょうか？

ライセンステキストが次のスクリーンショットのようになっていることを確認してください。

テキストの各行は、最初にフィールド名（LicenseIdやExpiryなど）、続いて等号（'='）、続いてフィールド値を記述します。それ以外のテキストは含めず、 表示されているすべての行を含めるようにしてください。

一部の電子メールアプリケーションでは、ライセンステキストに余分な改行が追加されることがありますので、手動で削除する必要があります。 自動翻訳ソフトがライセンスのテキストを翻訳しようとしないようにしてください。

ライセンスにアップグレードは含まれていますか？

お持ちのライセンスでSharpCapのどのバージョンでも使用でき、新しいバージョンが出ればいつでもアップデートできます。

SharpCapを複数のコンピューターで使用していますが、複数のライセンスを購入する必要がありますか？

SharpCapを個人で使用するために購入された場合、ライセンスは特定のコンピュータではなく、あなたのためのものです。

具体的には以下のようなルールがあります。

· あなたが個人の場合で SharpCapを購入された方 : 本ライセンスは、お客様が所有するPCと、お客様が所有していない追加のPC1台について、 お客様がその追加のPCの主たるユーザーである限り、使用することができます。（これにより、雇用主から支給されたノートPCでSharpCapを使用することができます）

· あなたが個人ではない場合 (例：企業、政府機関、教育機関、クラブ、協会などを代表してSharpCapを購入した場合など) : SharpCapのライセンスは、 SharpCapをインストールするPC1台ごとに購入する必要があります。

ライセンスを更新したが、SharpCapに反映されていないがどうすればよいですか？

ライセンスを更新すると、新しいライセンスキーがメールで送られてきます。この新しいキーをSharpCapに入れて、既存のキーと置き換える必要があります。 新しいキーは、すぐに使い始めることができます。

ライセンスを紛失してしまいましたが、どうしたらいいですか？

ライセンスの回復 ページにアクセスすることで、再送してもらうことができます。

ライセンスの購入時に使用したメールアドレスと（オプションで）PayPalのレシートに記載されている時間を入力するだけです。 自動的にライセンスメールが再送されます（PayPalのレシートの時間も入力できる場合は、ブラウザに表示されます）。

新品のカメラにSharpCap Proのライセンスをバンドルして請求する

カメラの中には、SharpCap Proの1年間のライセンスが付属しているものがあります。これらのカメラを購入された方は、以下の手順でライセンスを取得してください。

· PCがカメラを正しく検出するために必要なドライバーをインストールします（Altairカメラの場合は、使用するつもりがなくてもAltairCaptureをインストールする必要があります）。

· 最新のSharpCapをインストールする

· インターネットに接続されていることを確認してください - ライセンス申請手続きには、インターネットへの接続が必要です。

· カメラのプラグを適切なUSBポートに接続する

· SharpCapを起動します。SharpCap Proのライセンスをお持ちでない場合は、SharpCapの起動後すぐに画面上部に通知が表示されます。

· 「Claim License Now」ボタンをクリックしてください。

· ライセンス請求画面では、電子メールアドレスを入力します。電子メールでライセンスのコピーが送られてきますので、電子メールアドレスを正確に入力してください。 メールアドレスをカメラメーカーと共有して、最新情報や特典を受け取ることができます（これは完全に任意です。メールアドレスをカメラメーカーと共有しないことを選択した場合、 あなたのメールアドレスは、ライセンスキーの送信と期限切れのお知らせにのみ使用されます）。

· 「SharpCap Pro ライセンスの請求 Claim SharpCap Pro License 」 ボタンを押すと、請求が処理され、ライセンス請求が成功したことを示すメッセージが表示されます。 通常、数分以内にライセンスメールが届きます。

注意: 購入したカメラに同梱されているライセンスは、請求された特定のブランドのカメラに対してのみ有効です。

注意: カメラを中古で購入した場合、前の所有者がすでにそのカメラのライセンスを申請している可能性があります。 その場合、SharpCap Proのライセンスを申請することはできず、申請しようとすると次のメッセージが表示されます。


クイックスタート

この章では、すぐに始められることを説明し、経験豊富なユーザーやせっかちなユーザーを対象としています。

1. カメラメーカーのホームページから最新のカメラドライバーをダウンロードする。

2. カメラドライバーのインストール - 管理者プロンプトを承認するか、管理者としてインストーラーを実行する必要がある場合があります。

3. PC / ノートパソコンを再起動します。

4. カメラを取り付ける。

5. 最新のSharpCapは次のサイトからダウンロードできます。http://www.sharpcap.co.uk/sharpcap/downloads

6. SharpCapのインストール - 管理者プロンプトを承認するか、管理者としてインストーラーを実行する必要がある場合があります。

7. カメラメニューを表示し、デバイスの一覧からカメラを選択します。

8. カメラが望遠鏡やレンズに装着されている場合は、カメラの画像が表示エリアに表示されるはずです。

9. 画面の右端にあるボタンを使って、露出やゲインなどの設定を調整します。 コントロールの調整に応じて、画像が変化するはずです。

10. 新規ファイルへのビデオ撮影を開始する場合は「撮影開始」（または「クイック撮影」）ボタンを、1フレームをファイルに撮影する場合は「スナップショット」ボタンを使用します。

撮影が完了すると、ツールバーの直下に通知バーが表示されます。 ハイライトされたリンクをクリックすると、 撮影した画像のあるフォルダーに直接移動します。

11. これでSharpCapのインストールとテストは完了です。


インストールと最初のステップ

この章は、段階的なスタートガイドです。

カメラドライバーのインストール

ドライバーがインストールされるまでは、カメラを接続しないでください。 ドライバーは、管理者権限のあるWindowsユーザーアカウントでインストールするのが最適です。 ドライバーの入手方法は、カメラによって3通りあります。

1. カメラに付属のCD-ROMに収録されているドライバーです。 最新版ではない可能性がありますので、選択肢 2.をご検討ください。

2. カメラメーカーのWebサイトへのリンクは次の通りです http://www.sharpcap.co.uk/, サポートカメラ または カメラコントロール の中で、該当するメーカーの製品をご紹介しています。

3. MicrosoftがサポートするWebカメラ（DirectShowで動作するもの）は、カメラを接続すると自動的にドライバーをダウンロードする場合があります。

カメラドライバーがインストールされたら、Windowsを再起動し、カメラを接続して、コントロールパネルの「デバイス」からデバイス（カメラ）が正常に動作しているかどうかを確認してください。

SharpCapのインストール

SharpCapのダウンロードとインストールについて説明します。

1. http://www.sharpcap.co.uk/downloads からSharpCapをダウンロードします。

2. SharpCapをダウンロードしたフォルダに移動します。「SharpcapInstall - version-number .exe」をダブルクリックしてインストールします。

3. ライセンス契約条件に同意する場合はチェックを入れ、「インストール」ボタンを押してください。

4. 要求された場合は、管理者アカウント名とパスワードを入力してください。

5. 「インストールが正常に完了しました」のメッセージが表示されたら、「閉じる」をクリックしてインストーラーを閉じるか、「起動します」をクリックしてSharpCapをすぐに起動します。

6. SharpCapがインストールされました。

SharpCapのテスト

望遠鏡とカメラを木、煙突、ランプ、マストなどの対象物に向けて、室内から初期テストを行うことを検討してください。 大きな物体を選んでください。

7. カメラを望遠鏡に接続します。

8. カメラとPCを接続します。

9. SharpCapを起動します。 メインメニューから「カメラ」を選択します。 カメラが選択されている（チェックされている）ことを確認します。この例では、カメラはSVBONY SV305です。 カメラ名が2つ表示されている場合は、リストの中で一番高いものを選択してください。

10. SharpCapのメイン画面です。

主なエリアは以下の通りです。

撮影表示範囲 ー カメラが見ている画像がここに表示されます。

クイック撮影ボタン ー 新規ファイルへのビデオ撮影を開始します。

スナップショットボタン ー 1つのフレームをPNGファイルに撮影します。

露出時間 ー カメラの露出をコントロールします。

光の強さの変化に応じて画像が変化することを確認してください。例えば、望遠鏡やカメラのセンサーに光を当てて画像が明るくなることを確認したり、望遠鏡やセンサーを覆って画像が暗くなることを確認したりします。

望遠鏡のピントが合わない場合は、対角線を外したり、延長線を追加してみてください。

11. 「スナップショット」ボタンを押してみてください。 ツールバーの直下に通知バーが表示されます。 ハイライトされたリンクをクリックすると、 撮影した画像のあるフォルダに直接移動します。

12. デスクトップにあるこのフォルダ（SharpCap Captures\YYY-MM-DD）には、2つのファイルが入っています。 1つは画像、もう1つはカメラの設定を含むテキストファイルです。

13. カメラの設定ファイルは以下のようになっています。

14. 「クイック撮影」ボタンを押してみましょう。 メイン画面の右下に、プログレスバーが表示されます。

15. このビデオ撮影が完了したら、通知バーのリンクをクリックしてください。 撮影フォルダーには、動画ファイルとカメラ設定ファイルが含まれています。 ビデオをダブルクリックして再生してください。

16. 以上のことがうまくいけば、SharpCapとカメラのインストールのテストは成功したことになります。

SharpCapの削除

ここでは、SharpCapとその付属設定をすべて完全に削除する方法を説明します。 この作業は、古い設定をすべて削除してクリーンインストールを行うために必要な場合があります。 なお、管理者権限のあるアカウントで行うのが最適です。

SharpCapをアンインストールする - PCのコントロールパネルまたはスタートボタンから「プログラムと機能」に進み、SharpCapをハイライトしてアンインストールする。 [注意：複数のバージョンがある場合があります] 。

注意：SharpCapをアンインストールしてから再インストールしても、SharpCapのすべての設定をデフォルトに戻すことはできません。 すべての設定をデフォルトに戻す方法については、付録 を参照してください。


SharpCapユーザーインターフェースの説明

SharpCapを起動し、今日のヒント（Tip of the Day）のメッセージを解除すると、以下の画面が表示されます。

SharpCapのメイン画面は、7つの常設エリアと1つの臨時エリアで構成されています。

常設エリアは

1. タイトルバー - 選択された（有効な）カメラ（ある場合）とデフォルトの撮影フォルダーが表示されます。

2. メニューバー - SharpCapの機能にアクセスできます。

3. ツールバー - 画像の取り込みによく使うツールに素早くアクセスできます。 画像の取り込みが完了すると、ツールバーの下に、保存の詳細を示す通知バーが表示されます。

4. 撮影表示エリア - 選択したカメラで現在撮影されている画像を表示します。

5. カメラコントロールパネル - 選択したカメラで利用可能なすべてのコントロールにアクセスできます。 このパネルに表示される項目は、接続されているカメラの種類、モデル、サポートレベルによって異なります。

6. 作業エリア - 画像ヒストグラム、フォーカススコア、ライブスタックなどのツールの表示エリアとして使用されます。

7. ステータスバー - 撮影 / ドロップされたフレームと フレームレート に関する継続的な情報が表示されます。 撮影中は、ステータスバーの右端に進行状況バーが表示されます。

臨時のエリアは

1. 通知バー：撮影やスナップショットが完了すると、ツールバーの下に表示され、クリックするとファイルが保存されている適切なフォルダーに直接移動するリンクが表示されます。 通知バーは他の情報を提供するためにも使用されます。緑色の通知バーは成功を、黄色のバーは警告を、オレンジ色のバーはエラーが発生したことを示します。

タイトルバー

タイトルバーには、選択された（有効な）カメラと、撮影画像を保存するためのデフォルトのフォルダーが表示されます。

カメラが作動していない場合は、撮影画像を保存するためのデフォルトフォルダーのみが表示されます。

タイトルバーには、使用しているSharpCapのバージョンや、64ビット版のSharpCapかどうかも表示されるので注意が必要です。

メニューバー

メニューバーからは、SharpCapの様々な機能に簡単にアクセスできます。

ツールバー

ツールバーには、画像を撮影する際によく使う機能が集約されており、簡単にアクセスできます。

「静止画カメラ」モードでカメラを開いているときのツールバーの左半分です。

カメラを「ライブビュー」モードで開いているときのツールバーの左半分です。

ツールバーの右半分です。

左から順に、これらは

1. ライブビュー

2. 撮影開始

3. クイック撮影

4. 撮影停止

5. 一時停止

6. スナップショット

7. フレーミング撮影

8. 2つのモニターモード

9. ライブスタック

10. 天体名

11. フレームタイプ

12. 効果

13. 領域の選択

14. レチクル重ね

15. 拡大

16. 画像ヒストグラム

17. フォーカススコア

SharpCap画面の幅が、すべてのツールアイコンを収容するのに十分でない場合、ツールバーは、右端に右向きの記号が付いたこのような形になります。

この記号をクリックすると、残りのツールアイコンにアクセスできます。

撮影表示領域

撮影表示領域には、有効なカメラが現在見ている景色が表示されます。

SharpCapでカメラを選択すると（またはSharpCapの起動時に自動的にカメラを選択すると）、カメラがライブビューモードの場合、SharpCapはすぐにフレームの取り込みと表示を開始します。 SharpCapはこれらのフレームを保存せず、画面上に表示します。 使用する露出時間によって、画像は1秒間に何度も更新される場合と、 数秒に1度（またはそれ以下）しか更新されない場合があります。 SharpCapは、「撮影開始」または「スナップショット」ボタンを使用した後にのみ、画像を保存します。

カメラが静止画モードで起動している場合は、「キャプチャ」ボタンを使用しない限り、SharpCapは画像を撮影しません。 SharpCapは、最初に、画像を撮影するために何をすべきかを説明するメッセージを表示しますが、これは最初の画像が撮影された後、カメラの画像に置き換えられます。

以下の方法で画像を移動することができます。

· ツールバーの「拡大」ドロップダウンを使って、画像の拡大レベルを調整する

· 画像の上にマウスを置いて、<CTRL>キーを押しながら、マウスのスクロールホイールを使って、 画像の拡大レベルを調整してください。

· 画像の特定のポイントにマウスカーソルを置き、<CTRL>を押しながら、マウスのスクロールホイールを使って、 そのポイントを拡大することができます。画像が一杯になると、マウスカーソルの下にある画像のポイントは、ズームイン／アウトしても変わりません。

· 画像全体を見渡せないレベルまで拡大している場合は、次のいずれかの方法で画像を移動することができます。

o   水平・垂直方向のスクロールバー（下図）

o   縦方向はマウスホイール、横方向は<SHIFT>を押しながらのマウスホイール

カメラコントロールパネル

カメラコントロールパネルには、現在使用しているカメラの機能と使用可能なコントロールが表示されます。 これらのコントロールは、露出、解像度、カラーバランスなどのカメラ設定の調整に使用されます。表示されるグループとコントロールは、以下の条件によって異なります。

· 付属カメラのメーカー。

· カメラの機種（同じメーカーでも可）

詳しい説明は、 カメラコントロール をご覧ください。 コントロールは論理的にグループ化されており、各グループは必要に応じて拡張 / 閉鎖することができます。

グループ名の左にある下矢印ボタンをクリックすると、グランドが展開されます。右側の「ハンバーガー」アイコンを使って、グループをドラッグして順番を変更します。

作業領域

作業領域は、以下のような様々なツールを表示する領域です。

· ライブスタック

· ヒストグラム

· 極軸合わせ

· フォーカス スコア

各ツールとも、パネルのタイトルバーを使って、パネルをSharpCapのメインフォームからドラッグして、セカンドモニターに配置するなどの操作が可能です。

状態バー

画面下の状態バーには、常に最新の情報が表示されています。

· 撮影したフレーム

· 失われたフレーム

· 撮影期間

· 撮影速度、フレーム / 秒（fps）

· 使用可能なメモリと使用中のメモリ

· クーラーの状態（冷却型カメラの場合）

· GPSの状態（GPS対応カメラの場合）

フレームの進行状況

露出時間を1秒以上に設定すると、右側に各フレームの進行状況を示す進行バーが表示されます。

進行バーの右側の数字は、フレーム内のこれまでの経過時間と残り時間です（いずれもMM:SS）。

カメラによっては、完成したフレームをパソコンにダウンロードするのに時間がかかるものがあり、ダウンロード中にフレームの残り時間がマイナスの値で表示されることがあります。 また、カメラが正常に応答しなくなり、SharpCapが未到着のフレームを待っている場合にも、マイナスの値が表示されることがあります。

撮影の進行状況

画像の取り込みが開始されると、右の表示部に進行バーが表示されます。

· 完成したフレーム

· 残りのフレーム

· 終了予定時刻

SharpCapの言語

SharpCapは、少数の英語以外の言語に部分的に翻訳されています。

言語 | 状態 | 言語コード
日本語 | 現在のところ、メニュー、ツールバー、カメラコントロール、設定画面、キャプチャ開始画面、最初の実行（SharpCap について）画面、インストーラーが翻訳されています。 それ以外の部分は英語で表示されます。 | ja
中国語（簡体字） | 現在のところ、メニュー、ツールバー、カメラコントロール、設定画面、キャプチャ開始画面、最初の実行（SharpCap について）画面が翻訳されています。 それ以外の部分は英語で表示されます。 | zh-CN
フランス語 | 現在のところ、メニュー、ツールバー、カメラコントロール、設定画面、キャプチャ開始画面、最初の実行（SharpCap について）画面が翻訳されています。 それ以外の部分は英語で表示されます。 | fr
ドイツ語 | 現在のところ、メニュー、ツールバー、カメラコントロール、設定画面、キャプチャ開始画面、最初の実行（SharpCap について）画面が翻訳されています。 それ以外の部分は英語で表示されます。 | De
スペイン語 | 現在のところ、メニュー、ツールバー、カメラコントロール、設定画面、キャプチャ開始画面、最初の実行（SharpCap について）画面が翻訳されています。 それ以外の部分は英語で表示されます。 | es
ロシア語 | 現在のところ、メニュー、ツールバー、カメラコントロール、設定画面、キャプチャ開始画面、最初の実行（SharpCap について）画面が翻訳されています。 それ以外の部分は英語で表示されます。 | ru

Windowsの表示言語に上記の言語を使用している場合、SharpCapは自動的にその翻訳を使用します。

SharpCapを常に英語で表示する を適用することで、SharpCapを強制的に英語で表示させることができます。 SharpCapを他のサポートされている言語で表示させるには、次の方法があります。 言語コマンドライン引数


メニューバー

ファイル

ファイルメニューには以下のオプションがあります。

SharpCapの設定

SharpCap設定のデフォルトは、インストール後の設定を最小限に抑えてアプリケーションを簡単に使用できるように選択されていますが、 必要に応じてここで設定を調整することができます。

それぞれのタブの詳細については、 SharpCapの設定 を参照してください。

終了

「終了」または「Alt+F4」を選択すると、SharpCapが順番にシャットダウンされます。なお、設定の内容によっては、 カメラを開いている場合や撮影中にシャットダウンの確認を求められることがあります。

カメラ

「カメラ」メニューでは、接続されている画像機器の選択と解除ができます。 カメラやビデオ撮影機器（フレームグラバー）などがあります。

カメラの種類は、メニューの異なる章に分類されています。各章には、「Altair カメラ」、「DirectShow カメラ」、「ZWO カメラ」など、その章に含まれるカメラの種類の説明があります。

通常は、新しいカメラをコンピュータに接続すると自動的に検出されますが、場合によっては、新しく追加されたカメラを検出するために、 「カメラの再スキャン」オプションを使用する必要があります。

2つの「内蔵」カメラが用意されています。

1. オリオン座のM42星雲を撮影したシミュレーション「テストカメラ1（ディープスカイ）」。

2. テストカメラ2（高速）、木星の撮影シミュレーション（左下の暗点は衛星の影）。

この2つのテストカメラは、望遠鏡とカメラを必要とせず、SharpCapの機能を学ぶために使用することができます。

また、「仮想」フォルダ監視カメラが表示されます。このカメラを使うと、すでにフォルダに保存されている（または保存中の）画像ファイルをSharpCapが自動的に読み込んで処理できるようになります。 SharpCapが検出できないカメラがあっても、このカメラを使って画像を撮影し、フォルダに保存できる他のソフトウェアがあれば、 この選択肢を使ってSharpCapがそれらの画像を処理できるようにすることができます。

注意：一部のカメラ（特にASCOMおよびDirectShowカメラ）は、コンピュータに接続されていなくても機器リストに表示されることがあります。 これらのカメラのうち、現在接続されていないカメラを選択すると、エラーメッセージが表示されます。

カメラを再スキャン

カメラの接続が切れたり、SharpCapを開いている間にカメラが差し込まれたりした場合は、「再スキャン」オプションを使って機器を探します。

SharpCapは、USB機器がコンピュータに追加されたり、コンピュータから取り外されたりすると、自動的に再スキャンを行います。 再スキャンボタンは、ネットワークに接続されたカメラ（BaslerまたはPoint Grey Gig-Eカメラなど）を検出する際に主に役立ちますが、 これらのカメラがネットワークに追加されてもSharpCapは検出できません。

カメラを切断

これにより、現在開いているカメラが閉じられます。カメラを閉じるには、「カメラ」メニューで有効なカメラをもう一度選択する必要があります。 また、別のカメラが選択された場合や、現在選択されているカメラがコンピューターから切断されたことをSharpCapが検出した場合も、カメラは自動的に閉じられます。

カメラを再接続

これにより、現在接続されているカメラが停止し、再起動します。状況によっては、カメラが動かなくなったり、反応しなくなったりした場合に、正常な動作に戻ることがあります。 カメラを再接続しても問題が解決しない場合は、SharpCapを一度閉じて再度開くか、カメラのUSBケーブルを一度外して再接続する必要があります。

使用可能なカメラ

使用するカメラをドロップダウンリストから選択します。

使用可能なカメラのリストに、1台のカメラが2回表示されることがあります。 どのカメラを選択すべきか迷った場合は、リストの上位にあるカメラを使用してください （SharpCapは、最も管理しやすいカメラをリストの上位に表示しようとするため）。 下の図のSVBony SV305を見てください。

別のカメラを開くことなく、現在使用中のカメラを閉じることができる場合があります。 これには、「カメラ」メニューに戻り、メニューから選択したカメラを再度選択するか、 「カメラを切断」メニュー項目を使用します。

キャプチャ

「キャプチャ」メニューには以下のオプションがあります。

キャプチャでは、以下のコントロールが可能です。

· 撮影の処理。

· ダークフレームの作成。

· フラットフレームの作成。

これらのメニューの詳細については、 動画と画像の撮影 をご覧ください。

表示

「表示」メニューには以下の項目があります。

全画面表示

「全画面表示」オプションを選択すると、SharpCapが全画面表示モードに切り替わります。 この場合、表示されるのは「撮影表示領域」と「カメラコントロールパネル」のみで、 メニューやツールバーはありません。 この状態を解除するには、マウスポインタを画面上部に移動させると、メニューが表示されます。 「全画面表示」のチェックを外すことができます。 また、F11キーを押すことで、全画面表示のオン・オフを切り替えることができます。

パネル配置をリセット

カメラコントロールパネルでは、各コントロールグループの右上にハンドルが付いています。 このハンドルをマウスでつかんで、 コントロールをカメラコントロールパネル内の別の場所に移動させることができますので、お好みに合わせてご利用ください。 「パネル配置をリセット」を選択すると、コントロールグループをデフォルトの順序に戻すことができます。

ナイトビジョンカラー

このメニューオプションを選択すると、SharpCapは標準的な配色とナイトビジョンに適したダークカラーの配色に切り替えます。また、F12キーでも2つの配色を切り替えることができます。

ツインモニタービュー

このオプションを選択すると、SharpCapは標準のシングルモニター表示と、カメラからのメイン画像をセカンドモニターに表示するツインモニター表示モードを切り替えます。 なお、ツインモニターモードはSharpCap Proの機能です。

ツール

「ツール」メニューでは、画像の撮影や望遠鏡の位置合わせに役立つ特定の機能にアクセスできます。

なお、各ツールは、カメラを選択してからでないと選択できません。また、一部のツールでは、GOTOマウントや電子フォーカサーなどのハードウェアの設定が必要になります。

ヒストグラム

このオプションは、SharpCap のメインのヒストグラム機能にアクセスするためのものです。このツールの詳細については、 ヒストグラム を参照してください。

ライブスタック

このオプションは、ツールバーにある「ライブスタック」ボタンと同じ機能を提供します。 ツールの詳細については、 ライブスタック を参照してください。

<ALT> < L> は、ライブスタックを開始するホットキーの組み合わせとして使用できます。

極軸合わせ

「極軸合わせ」を選択すると、アライメント処理を管理するための一連の画面が表示されます。 詳細は、 極軸合わせ を参照してください。

プレートソルブ(ソルブのみ)

このツールは、現在の画像の天球座標を決定するために、プレートソルブ検索を開始します。このオプションは、互換性のあるプレートソルブツールが自動検出されているか、 SharpCapの設定で設定されている場合にのみ有効になります。プレートソルブ操作の進行状況と結果は、通知バーに表示されます。 対応するプレートソルブツールや設定の詳細については、 プレートソルブタブ を参照してください。ASCOMマウントが接続されている場合、SharpCapはマウントからの現在の座標を検索開始点として使用し、 操作を高速化する可能性があることに注意してください。

プレートソルブ後再同期

このツールは、現在の画像に対してプレートソルブを実行し、プレートソルブの結果にマウントの位置を再同期させた後、GOTOを元の天体座標に調整します。 これにより、天体が中心から外れていたり、完全に視野から外れていたとしても、天体を視野の中心に置くことができます。 なお、このアクションで実行される操作は、SharpCap設定の「プレートソルブ」タブで設定できます。

センサー解析

このツールは、SharpCapのセンサー解析を起動し、カメラセンサーの特性を測定します。 一度測定したセンサーデータは保存され、将来的にSharpCapのスマートヒストグラム機能に使用することができます。詳細については、 センサー解析 および スマートヒストグラム を参照してください。 なお、スマートヒストグラムは、SharpCap Proの機能です。

ADC調整

このツールは、カラー画像の赤、緑、青のチャンネル間のオフセットを表示することで、ADC（大気分散補正器）の最適なアライメント設定を見つけることができます。詳しくは、 ADC調整 をご覧ください。

ピクセル値の読み出し

このツールは、画像内の任意のピクセルをクリックすることで、そのピクセルの輝度値を読み取ることができます。 ピクセルの輝度値だけでなく、座標（X,Y）も表示され、カメラが RAWモード の場合は、ピクセルのカラーチャンネル情報も表示されます。詳しくは、 ピクセル値の読み出し をご覧ください。

ピクセル位置 / クリックして最近に

このツールは、SharpCapにASCOM GOTOマウントが接続されていて、最近のプレートソルブ操作が行われた場合に、 画像内の任意のピクセルの天空座標（RA/Dec, Alt/Az）を確認することができます。

画像内の任意の点の空の座標を表示するだけでなく、±RA、赤緯、高度、方位角座標の方向が表示され、 その点をダブルクリックすることでSharpCapに任意の点について画像を再構成させることができます。これは、画像のフレーミングに非常に便利です。 詳細は、ピクセル位置 / クリックして最近に を参照してください。

フォーカスアシスタント

ここのサブオプションでは、さまざまな フォーカス ツールを選択できます。

シーイングモニター

これで シーイングモニター が起動し、シーイングが最も良い時に月・太陽・惑星の画像を撮影することができます。

コリメーション(テスト実装)

これにより、ニュートン望遠鏡のコリメーションに役立つと思われる実験的な コリメーション 補助が起動します。

フィーチャートラッキング(テスト実装)

これは、月・太陽・惑星の撮影時に、天体が視野から外れないようにマウントを誘導することができる実験的な フィーチャートラッキング ツールです。

シーケンサー

「シーケンサー」メニューでは、SharpCapが自動で無人のイメージングを行うためのツールにアクセスできます。

ディープスカイ シーケンスプランナー

このメニューオプションは、カメラが選択されると有効になり、ディープスカイ画像に必要な最も一般的な手順を含む画像操作のシーケンスをすばやく構築し、実行することができます。 詳細は ディープスカイシーケンスプランナー を参照してください。

シーケンスエディター

このオプションを選択すると、完全なシーケンス編集ツールが表示されます。これは、ディープスカイシーケンスプランナーよりも柔軟性が高く、より幅広い画像作業に使用できますが、 より複雑です。詳しくは、 シーケンスエディター をご覧ください。

保存済のシーケンスを実行

このオプションでは、以前に保存したSharpCap シーケンス (*.scs)を参照し、実行を開始することができます。

現在のシーケンスを実行

このオプションは、現在シーケンスエディターツールに読み込まれているシーケンスを実行します。

以前のシーケンスを実行

最近読み込まれて実行されたシーケンスを選択すると、そのシーケンスが読み込まれて実行されます。

スクリプト

「スクリプト」メニューでは、スクリプトコンソールにアクセスして、既存のスクリプトを実行したり、新しいスクリプトを書いたりすることができます。 スクリプトは「Python」をベースにしています。 SharpCapの機能は、内蔵のプログラミング言語としてスクリプトを使用することで拡張できます。

スクリプトは高度なテーマであり、SharpCapを効果的に使用するためにスクリプトの知識は必須ではありません。

詳しい説明は スクリプト をご覧ください。

ヘルプ

「ヘルプ」メニュー項目には以下のオプションがあります。

ヘルプ

「ヘルプ」は、SharpCapソフトウェアの一部としてインストールされています、Windowsヘルプファイル形式のドキュメントを表示します。

SharpCap Proのライセンス

SharpCap Pro のライセンスを入力・確認することができます。

アップデートを確認

「アップデートを確認」を選択すると、インストールされているバージョンと最新バージョンの間で、SharpCapのWebサイトでバージョンチェックが行われます。 アップデートがない場合は、以下のようなメッセージが表示されます。

アップデートが可能な場合は、ダウンロードとインストールが提供されます。

SharpCapの新バージョンは、この自動更新メカニズムによって利用可能になるまでに時間がかかることに注意してください。このチェックで新しいアップデートがないと表示されていても、 ダウンロードページ で新しいバージョンがダウンロードできる場合があります。

バグを報告

このオプションは、SharpCapフォーラムの「バグレポート」エリアに直接リンクします。フォーラムに新しいバグレポートを投稿する前に、 お客様がSharpCapの最新バージョンを使用しているかどうかを確認し、お客様が抱えている問題が既に議論されていないかどうかをフォーラムで検索してください！

ログを表示

SharpCapはバックグラウンドで、プログラムに関するイベントを常に記録しています。

「Copy to Clipboard」ボタンをクリックすると、ログの内容がコピーされます。 メモ帳などのテキストエディターを使って、ログの内容を貼り付けてファイルを保存することができます。 ログファイルの送信方法については、 http://forums.sharpcap.co.uk/を参照してください。

SharpCapのログはすべてディスクに保存されているので、必要に応じて以前のSharpCapのログファイルを探し出すことができます。ログファイルの保存先は以下です。

%LOCALAPPDATA%\SharpCap\logs

以下は、フォルダのフルネームへのショートカットです。

C:\Users\<あなたのWindowsユーザー名>\AppData\Local\SharpCap\logs

ログフォルダーにアクセスする最も簡単な方法は、ログ画面の 「 Locate on Disk 」 ボタンを押すことです。 このボタンを押すと、Windowsエクスプローラーにログフォルダーが表示されます。

ログファイルの名前は、SharpCapが起動した時間に基づいて、以下のような形式で付けられます。

Log_YYYY-MM-DDTHH_MM_SS-XXXXX.log

YYYY,MM,DD,HH,MM,SSはSharpCapが起動した日時を表し、XXXXは別の数字を表します。

SharpCapが保存するログファイルは単なるプレーンテキストファイルであり、Windowsのメモ帳（または他のテキストエディタ）で開くことができます。

サポートフォーラム

これにより、SharpCapフォーラムがWebブラウザで起動します。フォーラムでは、SharpCapの使い方や天文学全般に関するヒント、ガイド、ディスカッションなどが行われています。

このソフトについて

「このソフトについて」画面では、以下の情報を提供します。

· SharpCapのWebサイトへのリンク。

· SharpCap Proライセンスへのアップグレードをお知らせするメッセージが表示されます。

· 謝辞。

· ライセンス情報へのリンク。

· SharpCapのFacebookページへのリンク。

· バージョンと変更履歴。


ツールバー

カメラが「ライブビュー」モードで開かれているか、「静止カメラ」モードで開かれているかによって、ツールバーの表示が若干変わります。

「静止カメラ」モードでカメラを開いているときのツールバーの左半分です。

カメラを「ライブビュー」モードで開いているときのツールバーの左半分です。

ツールバーの右半分です。

1. ライブビュー

「ライブビュー（動画）」モードと「静止カメラ」モードを切り替えるボタンです。カメラが「ライブビュー」モードになっているときは、このボタンがハイライト表示されます。 カメラによっては、静止カメラモードで動作しないものもあり、その場合はこのボタンは無効になります。

なお、カメラを開く前にこのボタンを適切な状態に切り替えると、カメラを開く際のモードが設定されます。ライブモードと静止画モードの違いについては、 ライブモードと静止画モード を参照ください。

2. 撮影開始

撮影開始ボタンは、新規ファイルへのビデオ撮影を開始します。 この機能は、メニューから「キャプチャ」→「撮影開始」を選択するのと同じです。 詳細は、動画と画像の撮影 を参照してください。

3. クイック撮影

「クイック撮影」ボタンをクリックすると、新規ファイルへのビデオ撮影が開始されますが、あらかじめ設定されたフレーム数または秒数が使用されます。

事前に選択した値を変更するには、下矢印をクリックして新しい値を選択します。 この値は将来のクイック撮影のために記憶されます。

<ALT> < Q> は、クイック撮影を開始するホットキーの組み合わせとして使用できます。

4. 撮影停止

撮影が進行中の場合、「撮影停止」ボタンが利用可能になり、現在の撮影を停止します。

5. 一時停止

撮影が進行中の場合、「一時停止」ボタンが表示され、撮影を一時停止します。 この機能は、天体の上を雲が通過している場合に有効です。 撮影を一時停止しても、ファイルへのフレームの保存が停止するだけで、画面に表示される画像は更新され続けます。

一時停止は、カメラが「静止カメラ」モードのときには表示されません。

6. スナップショット

スナップショットボタンは、表示範囲に表示されている現在の画像を、PNG、TIFF、JPG、FITSのいずれかの静止画ファイルに撮影します。 撮影されたファイルの場所は、ツールバーの下の通知バーに表示されます（以下は例）。

<ALT> <A> は、スナップショットを開始するためのホットキーの組み合わせとして使用できます。

7. フレーミング撮影

このボタンは、カメラが「静止カメラ」モードのときにのみ表示され、カメラが画像を撮影して画面に表示します。画像は保存されません。

使用しているカメラに調整可能なゲインコントロールがある場合、「クイック撮影」オプションが利用できます。 このボタンを押すと、SharpCapはゲインを上げ、露出を下げて補正し、画像を撮影・表示した後、露出とゲインのコントロールを元に戻します。 ディープスカイの被写体のフレーミングやピントを確認するのに便利です。

8. 2つのモニターモード

このボタンは、2 台以上のモニターが接続されている PC でのみ表示されます（モニターは「ミラー」ではなく「拡張」に使用されている必要があります）。 このボタンを押すと、1台のモニターに表示される通常の表示と、2台のモニターに表示されるカメラの画像が2台目のモニターに転送され、 すべてのコントロールが最初のモニターに残る2モニター表示とが切り替わります。この機能は、ライブスタックを行う際に特に便利で、 ライブスタックのコントロールは、最初のモニターに多くのスペースを割り当てることができます。

9. ライブスタック

このボタンを押すと、ライブスタック処理が開始されます。 機能的には、「ツール」 → 「ライブスタック」と同じです。 このツールの詳しい説明は ライブスタック をご覧ください。

<ALT> < L> は、ライブスタックを開始するホットキーの組み合わせとして使用できます。

10. 天体名

メインツールバーの「天体名」を選択すると、あらかじめ定義された天体が選択され、画像フォルダ階層の一部として使用されます。

また、M42やオリオン大星雲のように、現在の対象を表す新しい名前を入力することもできます。

以降の撮影は、デフォルトの撮影フォルダーの下のM42（またはオリオン星雲）というサブフォルダに保存されます。 ここで追加された天体は、SharpCapが再起動しても永続しません。 永続化させるには、「ファイル」→「SharpCapの設定」→ 全般タブ で天体を追加する必要があります。

このツールは、撮影時に自己記録の目的で（撮影フォルダー名の階層で）使用すると便利です。 例えば、「M42 CLSフィルター」や「M42 F6.3レデューサー」など、 撮影に使用した機材を識別するための名前を作成することができます。

11. フレームタイプ

ここで撮影するフレームのタイプを選択すると、保存されたファイルのファイル名テンプレートにその種類が代入されます。 フレームタイプはシーケンサーおよびシーケンスプランナーツールでも使用されます。 フレームタイプの変更は、保存されたファイル名にのみ影響しますのでご注意してください。

12. 効果

「効果」ドロップダウンには、以下のオプションがあります。 ここで表示されるオプションによって 画像に適用される効果は、画面上にのみ表示され、ファイルに保存された画像には影響しないことに注意してください。

特定の効果オプションを選択すると、ツールバーの選択ツールが有効になります。

画像上には、ドラッグして大きさを変えられる赤い四角形が表示されます。 このようにして、選択した領域にのみ特殊効果を適用することができます。

効果は表示のみに適用され、撮影したデータには影響しません。

このツールは、「画像ヒストグラム」、「ADC調整」、「フォーカススコア」ツールと一緒に使うことで、画像の一部分に限定して作業を行うことができます。

なし

画像には何の効果も適用されません。

露出オーバーをハイライト表示

露出がオーバーしていると思われる部分は赤で強調されています。 この図では、赤く強調されている部分に注目してください。

下は月を使ったより極端な例で、赤い強調部分を取り除くためには、カメラの露出設定を下げる必要があります。

イメージブースト

「イメージブースト」は、より暗い天体を探すときに有効です。 ノイズが入るため、画像は若干粗くなります。なお、ミニヒストグラムの ストレッチ を使えば、より柔軟に微弱な天体を明るくすることができます。

イメージブースト（強）

「イメージブースト(強)」では、画像をより強力に強調することで、より暗い天体も浮かび上がらせることができます。 ただし、粒状性が増すことが予想されます。

フレームスタック（3）

フレームスタック（3）では、3枚の画像を重ねて表示します。 この効果は、より暗い天体を探す際に役立ちます。 このオプションが適用されたときのスタックでは、新しい画像とスタック内の前の画像との位置合わせは行われません。

フレームスタック（5）

フレームスタック(5)では、5枚の画像を重ねて表示します。 これにより、暗い天体を探すときの明るさがさらにアップします。

フレームスタック （10）

フレームスタック（10）では、10枚の画像を重ねて表示します。

RGBの位置調整

RGBの位置調整は、惑星の撮影において、大気の状態によって撮影天体の端に色の歪みがある場合に使用することができます。 この極端な例では、片側が赤、もう片側が青になっていますが、これは光の色が大気中で屈折して変化するために起こります。

このオプションを使用して、赤 / 青の値を調整し、画面上で良好な画像が得られるようにして、撮影準備時に最適なフォーカスを確保します。 右側の画像は、カラーチャンネルを調整した同じ木星の写真です。

RGBの位置調整は、プレビュー画像にのみ適用され、撮影データには影響しません。 Registaxのような他のプログラムでは、最終的な撮影画像のRGBチャンネルの再調整が可能です。

RGBの位置調整は、画面に表示される画像にしか影響しないため、主な用途としては、RGBのズレを補正してピントの良し悪しを判断したり、 惑星撮影のライブ中継を行ったりします。

赤 / 緑 / 青チャンネルを選択

これらの効果は、カラーカメラでのみ有効です。特定のチャンネルを選択すると、各画像から他の2色が取り除かれ、それぞれ赤、緑、青の共有色で画像が表示されます。

赤 / 緑 / 青チャンネルを白黒表示

これらの効果は、カラーカメラでのみ有効です。これらのオプションを選択すると、該当するカラーチャンネルデータが白黒画像として表示されます。

ストップモーションビデオ撮影

このオプションは、進行中のビデオ撮影を終了します。 SharpCapでサポートされているすべてのカメラからストップモーションフレームを撮影するための基本的なツールです。

13. 領域の選択

領域の選択ツールは、画像上に赤い選択用の四角形を作成し、ドラッグしてサイズを変更することができます。 この領域の選択は、特殊効果（FX）を適用したり、「フォーカススコア」や「センサー分析」ツールを使用する際に使用されます。

また、領域の選択ツールは、「画像ヒストグラム」ツールを使って縮小した領域のヒストグラムを調べたり、 「センサー解析」ツールなどの他の操作で処理する画像の領域を指定したりするのにも使えます。

領域選択が非常に小さい場合、それが容易に見えないことがあります。SharpCapは、領域選択が非常に小さい場合、それを示す2つの赤い矢印を表示します。

非常に小さな領域選択を大きくしたい場合は、拡大機能を使って領域選択を調整できるまで画面を拡大するか、画像内の任意の場所をダブルクリックすると、 領域選択がダブルクリックした場所を中心とした範囲にリセットされます。

14. レチクル重ね

レチクル重ねツールには4つのオプションがあります。

ツールバーにあるアイコンを繰り返しクリックすると、表示範囲にレチクルのオプションが表示されます。 また、ボタンの右にあるドロップダウンメニューを使って、レチクルを直接選択することもできます。

· このレチクルは、マウスで「つかむ」ことができ、表示領域内を移動させることができます。

· レチクルを表示しているときに、プレビュー表示のどこかをクリックすると、中心点を移動することができます。

· マウスの右ボタンでドラッグしたりクリックしたりすると、レチクルの向きや大きさが調整されます。

また、レチクルの中心付近には、各レチクルの回転角度が表示されています。同心円では、各円の近くに、そのサークルの半径を示す数字がピクセル単位で表示されます。

なお、「ピクセル値の読み出し」または「ピクセル位置 ／ クリックして最近に」を選択すると、現在選択されているレチクルが無効になります。 レチクルを選択すると、現在選択されているこれらの2つのツールが無効になります。

レチクルなし

グラフィックは画像から消去されます、 これがデフォルトです。

十字線(二重線)

表示範囲の画像の上に十字のグラフィックが表示されます。 これにより、接眼レンズではなくカメラを使って正確なマウント調整を行うことができます。

同心円

表示領域の画像の上に円形のグラフィックが表示されます。 これにより、接眼レンズではなくカメラを使って正確なマウント調整を行うことができます。 また、この円はコリメーションの補助にも使用できます。

十字線（一重）

シンプルな1本の十字線（各方向に1本だけの線）です。

15. 拡大

拡大ツールは、「撮影表示領域」の画像を拡大／縮小する機能です。 また、CTRLキーを押しながらマウスホイールを使ってズームを調整することもできます。 また、タッチパネルを搭載したノートパソコンをお使いの場合は、「ピンチ」ジェスチャーでズームを調整することもできます。

この機能を使うと

· 暗い天体を探すときにはズームアップします。

· フォーカススコアのツールを使用して、効果領域選択を単一の星の上に配置しようとすると、ズームインします。

· フォーカススコアのツールで黒レベル％を正確に設定しようとすると、ズームインしてしまいます。

· 「ライブスタック」や「画像ヒストグラム」を使用しているときに、ズームアウトして画像を縮小します。

· カメラの高解像度で撮影したときに表示される画像サイズを小さくするには、ズームアウトします。

· 拡大は16%～800%の範囲で設定できます。

· オート拡大は、ほとんどの目的に適した設定で、画面のスペースに合わせて画像を表示します。

注意：非常に大きな画像を画面に描画する方法の制限により、非常に高解像度のカメラでは、最大拡大レベルが800％以下に制限される場合があります。

16. 画像ヒストグラム

ヒストグラムが正しく形成されていることは、高品質な画像を作成するための重要な条件です。

ツールバーの「画像ヒストグラム」アイコンをクリックします。

アイコンをクリックすると、メイン画面の作業領域に画像ヒストグラムが表示されます。

対数スケールと線形スケール、太陽／月／惑星／ディープスカイ／ ROI がヒストグラムの形状に与える影響など、詳しい説明と例については、 ヒストグラム を参照してください。

17. フォーカススコア

SharpCapには、天体写真撮影で最も難しいとされる天体へのピント合わせを支援するいくつかのオプションが用意されています。 SharpCapにASCOMフォーカサーが設定されている場合、このツールは特に強力です。

フォーカス補助は、ツールバーの「フォーカスアシスタンスツール」アイコンを選択して開始します。

惑星または表面の焦点合わせ向き

· コントラスト（エッジ）検出

· ヒストグラムレンジ検出（輝度範囲）

· フーリエ解析ディテール検出

星の焦点合わせ向き

· マルチスター FWHM（半値全幅） 測定

· バーティノフマスク

· FWHM（半値全幅）測定

入門書や実例を含む詳しい説明は フォーカス をご覧ください。


カメラコントロールパネル

カメラコントロールパネルには、有効なカメラの機能と使用可能なコントロールが表示されます。 表示されるグループとコントロールは、以下の条件によって異なります。

· カメラのメーカー。

· カメラの機種（同じメーカーでも可）。

詳しい説明は、 カメラコントロール をご覧ください。 最初に一般的なカメラコントロールの説明があり、次にメーカー固有のカメラコントロールの説明があります。

· コントロールはグループ化されており、各グループは必要に応じて拡張/閉鎖することができます。 各グループにはそれぞれ見出しの色がついているので、特定のコントロールを探すときに正しいグループをすぐに見つけることができます。

グループ名の左にある下矢印を押すと、グループが展開され、その中のコントロールが表示されます。 グループが展開されると、下矢印が上矢印に変わり、これを押すと再びグループが折りたたまれます。

コントロールのグループを展開すると、そのグループ内の個々のコントロールが表示され、調整できるようになります。

· コントロールグループをマウスでつかみ、ユーザーの好みに合わせて順序を変更することができます。 順番をデフォルトに戻すには、メインメニューの「表示」→「パネル配置をリセット」を使います。

· パネルのタイトルバーを使って、パネルをSharpCapのメインフォームからドラッグして、例えばセカンドモニターに配置することができます。

· ピンのアイコンを使うと、カメラコントロールパネルを自動で隠し、横にドッキングした状態にすることができます。

· スライダーを左右にドラッグすることで、数値コントロールの値を調整することができます。また、現在のスライダの位置の左または右をクリックすると、スライダーが1目盛り分移動します。 下の例では、左右にクリックすると、ゲインが50減少または増加します。

· 多くのコントロールに新しい値を入力することができます。 数値が表示されているカメラのコントロール（ゲイン、露出、明るさなど）は、表示ボックスに新しい値を入力し、 <Enter>または<Tab>を押すことで変更できます。 入力された値が範囲外の場合、その値は無視されます。

· コントロールの中には、数値を持たない代わりに、選択できる範囲があるものがあります。コントロールの値をクリックすると、選択可能なリストが表示されますので、 必要な選択肢をクリックしてください。

· いくつかの操作部には、押すと動作を実行するボタンがあります。その動作とは、より多くの選択肢を表示したり、カメラのホワイトバランス設定を調整したりすることです。

· コントロールの中には、読み取り専用のものがあります。これは、コントロールの値は表示されるが、調整はできないことを意味します。 これらのコントロールのスライダーと数値は薄いグレーで表示され、キーボードやマウスを使って移動したり変更したりすることはできません。

コントロールは、自動モードに設定されている場合や、他のコントロールの値に基づいて読み取り専用になることがあります。 下の温度表示のように、常に読み取り専用のコントロールもあります。読み取り専用のコントロールは、表示されている値が変化すると自動的に更新されることが多い。

プロファイル

プロファイルは、テキストファイルに保存されたカメラ設定の集まりです。 さまざまなプロファイルを読み込むことで、さまざまな天体やカメラの設定情報を瞬時に得ることができます。

· 開く - ドロップダウンで現在選択されているプロファイルから値を読み込み、カメラコントロールに適用します。

· 保存 - カメラコントロールの現在の値を取得し、ドロップダウンで現在選択されているプロファイルに書き込みます（プロファイルを上書きします）。

· 別名で保存 - 現在のカメラコントロール値から新しいプロファイルを作成します。

· 管理 - プロファイル管理画面が表示され、プロファイルの名前変更、削除、デフォルト設定ができます。

「別名で保存 」をクリックして、意味のあるプロファイル名を入力し、「OK」をクリックすると、新しいプロファイルが作成されます。

保存されているプロファイルは、ドロップダウンからアクセスできます。

現在選択されているカメラで作成されたプロファイルは、太字で表示されます。他のカメラで作成されたプロファイルは、プロファイル名の後にカメラ名を括弧で囲んで表示されます。 別のカメラで作成されたプロファイルを読み込むことは可能ですが、結果が正しくない場合があります。

なお、プロファイル名のドロップダウンで選択されている項目を変更しても、それだけでは何の効果もなく、保存または開くを押したときに使用されるプロファイルが変更されるだけです。

カメラにデフォルトのプロファイルが設定されている場合は、カメラを開くたびにそのプロファイルが自動的に読み込まれます。

プロファイル管理

プロファイルの管理は、プロファイルの「管理」ボタンを押して行います。プロファイル管理画面が表示されます。

既存のプロファイルは、カメラごとに分類されて左側に表示されます。プロファイルをクリックすると、そのプロファイルに含まれる設定が表示されます。 右側のボタンを使って、プロファイルを管理することができます。

· Load ー 選択されたプロファイルを読み込み、現在開いているカメラに設定を適用します。

· Delete ー 現在選択されているプロファイルを削除します。 プロファイルの削除を元に戻すことはできませんのでご注意ください。

· Make Default ー 現在選択されているプロファイルを、作成されたカメラのデフォルトプロファイルにします。 デフォルトのプロファイルは、カメラを開くたびに読み込まれます。

· Clear Default ー 現在選択されているプロファイルがカメラのデフォルトプロファイルである場合に使用可能 - そのプロファイルのデフォルトフラグを削除します。

· Show on Disk ー をクリックすると、Windowsエクスプローラが起動し、選択したプロファイルを含むファイルがハイライト表示されます。 この機能を使って、プロファイルを別のコンピューターに転送したり、手動で編集したり、名前を変更したりすることができます。

フォーマット

このコントロールでは、カメラの解像度、 ビット深度 、 カラーモード 、 ビニング のほか、撮影した画像の保存形式を管理できます。

必要に応じて、別のモードを選択することもできます。

出力形式を「自動」に設定すると、カラーモードや露出時間に応じて、撮影ファイルに最適な保存形式を選択します。

· 5秒以下の露出は動画形式で保存されます。

· 5秒以上の露出は、個別のフレームとして保存されます。

· SharpCapは、 SharpCapの設定 で指定された優先的な動画および静止画ファイルフォーマットに従うようにします。

· RAW画像を WMV やJPGで保存することはありません。 これらのフォーマットは「不可逆」であり、RAW画像のベイヤーパターンデータに大きなダメージを与えるからです。

· 16ビットの画像は、 AVI 、WMV、JPGなどのフォーマットでは高いビット深度をサポートしていないため、保存できません。

カメラコントロール

ここでは、露出やゲインなど、主にハードウェアに関連するカメラの機能を管理します。

画像情報

ここでは、カメラで撮影された画像に、明るさ、ガンマ、コントラストなどの基本的な画像処理を施すためのコントロールを紹介します。 使用できるコントロールの範囲は、カメラメーカー／カメラドライバーによって決定されます。

SharpCapでは、仮想フォルダーモニターカメラ以外のすべてのカメラの撮影したフレームに、日付と時刻を示す タイムスタンプ を追加することができます。 タイムスタンプに使用される時刻は、SharpCapがフレームを受信した時刻を基準としており、フレームの撮影が終了した後になりますのでご注意ください。 フレームが撮影されてからSharpCapがフレームを受信するまでの時間差は、使用しているカメラの機種やカメラの設定によって異なります。

前処理

ここでは、ダーク減算やフラットフレーム補正など、画質向上のための前処理を設定することができます。 ここでの調整は、画面に表示される画像と、ファイルに保存される画像データの両方に影響します（ただし、ライブスタック時に処理されていないフレームを「生」で保存する場合は、 これらの調整を行わずに保存されます）。 詳細は 前処理コントロール の項を参照してください。

SharpCapのフラットフレーム補正コードは、USB3カメラからの画像を高速で処理できるように設計されており、月・太陽・惑星の画像ビデオを撮影する際に、 ちりの影などの人工物をライブで除去することができます。 詳細は、 ダークフレームの撮影 および フラットフレームの撮影 を参照してください。

ミニヒストグラムストレッチ

このコントロールは、現在の画像のミニヒストグラムを常時表示し、撮影時にファイルに保存されるデータに影響を与えることなく、画面に表示される画像を「引き伸ばす」ことができます。 表示されている画像を引き伸ばすことで、明るさやコントラストを向上させたり、かすかな細部を簡単に明るくしたりすることができます。 ストレッチ機能は、「効果」ドロップダウンの「イメージブースト」オプションと同様の効果が得られますが、より詳細なコントロールが可能です。

ここで表示の明るさを調整しても、保存ファイルには影響しません（ただし、ミニヒストグラムエリア内の「保存」 [image] アイコンを使って保存したファイルは、画面上と同じ状態で保存されます）。

詳細は、ミニヒストグラムとストレッチ画面 を参照してください。

望遠鏡制御

望遠鏡制御には、GOTOマウント、電子フォーカサー、フィルターホイールなどの画像ハードウェアを操作するためのコントロールがあります。 これらのオプションは、SharpCapの ハードウェア設定 でこれらのデバイスを使用するように設定されている場合にのみ表示されます。

これらの制御方法の詳細については、 望遠鏡のハードウェア制御 の項を参照してください。

ここには、メモ欄があります。メモ欄に任意のテキストを入力すると、撮影した画像やビデオと一緒に保存されるCaptureSettings.txtファイルに記載されます。

なお、CaptureSettings.txtファイルは撮影の開始時に保存されるため、撮影の開始後にメモ欄に加えた変更は、その撮影のCaptureSettings.txtファイルには反映されません。

テストカメラコントロール

テストコントロールグループは、SharpCapに同梱されている2台のテストカメラに特化しています。 このコントロールでは、大気条件のシミュレーション、ダークノイズやダストのシミュレーション、ST4ガイディングポートのシミュレーションを行うことができます。

その他のコントロール

これらはメーカーによって異なりますが、例えば以下のようなものがあります。

· 望遠鏡の制御。

· ファンやクーラーのオン / オフなどの温度制御。

· GPS設定。

· USB関連の設定で、カメラがUSB接続でデータを転送する際の速度を制御します。


動画と画像の撮影

動画および画像の撮影は、キャプチャメニューまたはツールバーの同等のボタンから開始できます。

撮影開始

撮影開始メニューやツールバーボタンを使うと、フレーム数や時間を制限したカスタム撮影を開始することができます。

天体名ボックスに天体名を入力すると、それが保存ファイル名の天体名として使用されます。

撮影制限の説明

· 1フレームのPNG、 FITS などの静止画形式と、カメラ設定の TXT の2つのファイルが作成されます。

· 撮影が完了すると、通知バーに情報が表示されます。

· ファイルはデフォルトの撮影フォルダーに保存されます。

· AVI または SER と、カメラ設定のTXTの2つのファイルが作成されます。

· なお、「出力形式」コントロールで静止画ファイルの形式を選択した場合、1つの動画ファイルではなく、複数の静止画ファイルが1つのフォルダーに作成されます。

· 撮影が完了すると、通知バーに情報が表示されます。

· ファイルはデフォルトの撮影フォルダーに保存されます。

· 撮影は、ツールバーの「撮影停止」ボタンをクリックするまで続きます。

· AVIまたはSERと、カメラ設定のTXTの2つのファイルが作成されます。

· なお、「出力形式」コントロールで静止画ファイルの形式を選択した場合、1つの動画ファイルではなく、 複数の静止画ファイルが1つのフォルダーに作成されます。

· 撮影が完了すると、通知バーに情報が表示されます。

· この例では、撮影ファイルには5つのフレームが含まれます。

· ファイルはデフォルトの撮影フォルダーに保存されます。

· 制限時間はHH:MM:SSで設定できます。 この例では、30秒が撮影に設定された制限です。

· AVIまたはSERと、カメラ設定のTXTの2つのファイルが作成されます。

· なお、「出力形式」コントロールで静止画ファイルの形式を選択した場合、1つの動画ファイルではなく、複数の静止画ファイルが1つのフォルダーに作成されます。

· 撮影が完了すると、通知バーに情報が表示されます。

· この例では、撮影ファイルは30秒の動画になります。

· ファイルはデフォルトの撮影フォルダーに保存されます。

単純なシーケンスの実行

· これは、上記の「撮影制限」で定義された撮影を繰り返すものです。

· なお、このオプションは、上記で設定した撮影制限が 「無制限」の場合には有効になりません。

· 間隔を空けて一連の撮影を開始することができます。

· この例では、10秒の間隔を空けて、3回の撮影を行います。

· AVIまたはSERを3枚、カメラ設定のTXTを3枚、計6枚のファイルが作成されます。

· 撮影が完了すると、通知バーに情報が表示されます。

· この例では、撮影ファイルは3×10秒の動画になります。

· ファイルはデフォルトの撮影フォルダーに保存されます。

ディープスカイ撮影の計画

アドバンスドシーケンスプランナーの「ディープスカイ」ボタンをクリックすると、自動化されたディープスカイ撮影を計画するための、より豊富なツールにアクセスできます。このボタンをクリックすると、 ディープスカイシーケンスプランナー が起動します。

撮影の開始

撮影オプションの設定が完了したら、スタートボタンを押して撮影を開始するか、キャンセルボタンを押して中止します。

フレーム数が多い場合や長時間の連続撮影を行う場合は、ガイド付き望遠鏡を使用することをお勧めします。

撮影中は、ステータスバー（画面右下）の右端に進捗状況が表示されます。

撮影中は、実際のフレーム数と合計フレーム数、終了予定時刻（ETA）が表示されます。

撮影が完了すると、ツールバーの下にある通知バーに、撮影したファイルの状態、場所、名前などの情報が表示されます。

通知バーの青い文字はクリックできます。ファイル名の部分（上記の例では「20_42_24.avi」）をクリックすると、SharpCapは撮影した画像や動画を、 そのファイルタイプに対応したデフォルトの表示アプリケーションを使って開こうとします。フォルダ名の部分をクリックすると、SharpCapはそのフォルダをWindowsエクスプローラで開き、 その中のファイルを見ることができます。

撮影停止

撮影が開始されると、 撮影停止 オプションが利用可能になり、現在の撮影を直ちに停止します。 一連の撮影が進行中の場合は、現在の撮影を停止するだけで、一連の撮影をキャンセルすることはできません。 シーケンス全体をキャンセルするには、シーケンスの次の撮影を待っている間に表示される通知バーのボタンを使用します。

最後に撮影した画像を削除

撮影が完了すると、 最後の撮影した画像を削除 というオプションが利用可能になります。 確認のためのダイアログが表示されるので、誤って撮影を取ってしまった場合や、 撮影中に何か問題が発生した場合に便利です。

画像フォルダを開く

画像フォルダを開く では、現在撮影が保存されている場所にファイルエクスプローラーのウィンドウを開きます。 デフォルトの設定では、通常これは：

Desktop\SharpCap Captures\YYYY-MM-DD

ダークフレームキャプチャ

この ダークフレームキャプチャ メニューでは、SharpCapのダークフレーム撮影アシスタントが起動します ー ダークフレームの撮影 を参照してください。

フラットフレームキャプチャ

この フラットフレームキャプチャ メニューでは、SharpCapのフラットフレーム撮影アシスタントが起動します ー フラットフレームの撮影 を参照してください。


カメラの基本知識

ライブモード と 静止画モード

SharpCapのバージョン3.2までは、カメラを常に「ビデオカメラ」モードで動作させていました。つまり、カメラは常に画面に表示される画像を撮影していましたが、 画像は「撮影開始」、「クイック撮影」、「スナップショット」のいずれかのボタンを使用したときにのみ保存されます。これは、最新のCMOSカメラには適していますが、 物理的なシャッターを持つカメラ（デジタル一眼レフカメラなど）や、フレームをPCにダウンロードするのに時間がかかるカメラ（高解像度のCCDカメラなど）には適していません。

SharpCap 4.0では、「ライブモード」と「静止画モード」を選択できるようになりました。

ライブモードは、旧バージョンのSharpCapの動作に相当するもので、デフォルトでは、カメラが連続して画像を撮影し、 画面に表示します。すべてのカメラがライブモードに対応しています。

静止画モードは、SharpCapがサポートしているほとんどの種類のカメラで利用できます。静止画モードでは、SharpCapは要求された場合にのみカメラに画像の撮影を要求し、 それ以外の場合はカメラはアイドル状態になります。

ライブモードと静止画モードの切り替えは、ツールバーの ライブビュー ボタンを切り替えることで行うことができます。 ボタンが選択されている（ハイライトされている）場合、カメラはライブモードになり、ボタンがハイライトされていない場合、カメラは静止画モードになります。 ボタンが有効になっていない場合は、現在のカメラが静止画モードに対応していないことを意味し、モード間の切り替え機能はありません。 以下の種類のカメラは静止画モードに対応していません。

· Basler社製 カメラ

· セレストロン / 画像ソースカメラ

· iNova社製 カメラ

· Point Grey カメラ (現在のFLIR)

· Webカメラとフレームグラバー

· フォルダーモニターカメラ ー このカメラには独自のコントロールがあり、 静止画モードのように要求されたフレームだけを処理することができます。

また、カメラが開いていないときにライブビューボタンを選択／解除することもできます。これは、次のカメラを開くときにどのモードを使用するかを制御するもので、 必要に応じて、カメラを正しいモードで直接開くことができます。

SharpCapの機能の中には、ライブモードを必要とするものがあり、それらを選択するとカメラは自動的にライブモードに切り替わります。

· 極軸合わせ

· ライブスタック

· ADC 調整

· 「効果」ドロップダウンのオプションの一部。

例えば、シーケンサーやシーケンスプランナーを使って撮影する際の ディザリング など、一部の機能は静止画モードでのみ使用可能です。

静止画モードの長所

· 物理的なシャッターを持つカメラのシャッター作動の低減。

· フレームのPCへのダウンロードに時間がかかるカメラを使用している場合、SharpCapの反応が良くなることがあります。

· 画像の露出開始時間を選択できます。

· カメラの設定を変更した場合、通常は次の静止画で反応しますが、ライブモードではカメラの設定変更が反映されるまでに数フレームかかる場合があります。

静止画モードの短所

· 例えば、0.5秒の露出を行った場合、ライブモードでは2fpsになりますが、 静止画モードではそれよりも低い フレームレート になります。

· 全てのカメラタイプに対応しているわけではありません。

· SharpCapの全ての機能には対応していません。

静止画モードでの撮影

カメラが静止画モードのときに撮影する方法はいくつかあります。

· スナップショットボタン ー 1枚の画像を撮影して保存します。

· 撮影開始ボタン ー 通常通り、撮影する画像数や撮影時間の入力を求められます。

· クイック撮影ボタン ー 指定した時間、または指定したフレーム数の画像を撮影します。

· フレーミング撮影ボタン ー カメラから画像を取得して画面に表示しますが、画像は保存されません。

SharpCapの機能の中には、カメラが静止画モードになっているときに、自動的にカメラから画像を取得するものがあります。 例えば、センサー解析 や スマートヒストグラム空の明るさを測定 では、このようにして測定を行います。

モードの説明

モード（カラースペース）とは、カメラで撮影した各フレームの画像データをどのように保存するかを示すものです。 モードの詳細は以下の通りです。

· 画像データがカラーなのかモノクロか。

· 輝度を何段階で測定するか。

· 画像データを圧縮するかどうか。

画像の輝度レベルの数は、しばしば ビット深度 という言葉で表現されます。 例えば、以下のような画像があります。

· 輝度レベルが256の場合、ビット深度は8

· 輝度レベルが1024の場合、ビット深度は10

· 輝度レベルが4096の場合、ビット深度は12

· 輝度レベルが65536の場合、ビット深度は16

非圧縮のモード

この章に掲載されているモードは、非圧縮で無損失、つまり撮影された画像の品質を落とさないものです。 天文用カメラやウェブカメラの中には、非圧縮のモードを選択できるものがあります。

RGB24

これは、カラー画像のデフォルトのモードで、各ピクセルに3バイト（赤、緑、青の各チャンネルに1バイト）が使用されます。 各チャンネルに1バイト使用するということは、各色に256の値（0〜255）が存在することになります。

長所 | · 操作と後処理が簡単。 · 画像はどのアプリケーションで見ても正しく表示されます。 · ホワイトバランス、ガンマ、明るさ、コントラストなどのカメラベースの調整が可能です（ただし、これらは通常PC上のソフトウェアで行います）。
短所 | · ファイルは通常1ピクセルあたり3バイトであるため、大きくなります。 · ビット深度 は8ビットに制限されています。 · ディベイヤリング は、カメラドライバーがシンプルで高速なアルゴリズムを用いて行います。 · ガンマや明るさ、コントラストなどの調整は、デジタルスペースでそのまま行うとデータの損失につながります。

RGB32

これは、標準的なカラー画像の代替オプションです。 1ピクセルあたり、3バイトの代わりに4バイトのスペースが使用されますが、そのうち1バイトは未使用です。 このフォーマットで保存されたファイルは、RGB24で保存された同じファイルよりも大きくなりますが、画質には全く差がありません。

長所 | · 操作と後処理が簡単。 · 画像はどのアプリケーションで見ても正しく表示されます。 · ホワイトバランス、ガンマ、明るさ、コントラストなどのカメラベースの調整が可能です（ただし、これらは通常PC上のソフトウェアで行います）。
短所 | · ファイルは通常1ピクセルあたり4バイトであるため、大きくなります。 · ビット深度は8ビットに制限されています。 · ディベイヤリングは、 カメラドライバーがシンプルで高速なアルゴリズムを用いて行います。 · ガンマや明るさ、コントラストなどの調整は、デジタルスペースでそのまま行うとデータの損失につながります。

MONO8（一部のウェブカメラではY800にも対応）

これは基本的なモノクロのモードで、1ピクセルに1バイトを使用し、0から255までの単一の輝度値を格納します。

長所 | · ファイルサイズが小さく（1ピクセルあたり1バイト）、モノクロの天体（ナローバンドフィルター、月）に最適。
短所 | 以下の点は、カラーカメラでMONOで撮影した場合のみ適用されます。 · カラーカメラでモノラルを生成するための処理は、 ディベイヤリング 処理でカラー画像を生成し、それをモノクロにするため、以下のRGBの注意点が適用されます。 o ディベイヤリングは、カメラドライバーがシンプルで高速なアルゴリズムを用いて行います。 o ガンマや明るさ、コントラストなどの調整は、デジタルスペースのままで行うとデータの損失につながります。RAW8 / 12で撮影して、最終的にモノクロにしたほうがいいかもしれません。

MONO16

1ピクセルあたり2バイトで構成されるモノクロのモードで、1ピクセルあたり65536通りの輝度値を設定できます。 ただし、このモードを採用しているカメラの多くは、65536通りの値を作り出すことができません。 例えば、1024通りの値（10ビット）または4096通りの値（12ビット）しか作り出すことができないカメラもあります。 このような場合、カメラが生成する値は、すべての範囲を満たすように引き伸ばされます。

長所 | · 出力レベルの幅が大きく、一枚の画像の中でより広い範囲の明るさを表現することができます。
短所 | · ファイルサイズが大きい（1ピクセルあたり2バイト） · 撮影したフレームに目に見えてノイズがあっても、実際の画質は向上しない（ノイズをより詳細に記録するだけ） 以下の点は、カラーカメラでMONOで撮影した場合のみ適用されます。 · モノラルにするための処理では、ディベイヤーでカラー画像を作成し、それをモノクロにするため、以下のようなRGBの注意点があります。 o デベイヤリングは、カメラドライバーがシンプルで高速なアルゴリズムを用いて行います。 o ガンマや明るさ、コントラストなどの調整は、デジタル空間のままで行うとデータの損失につながります。RAW8 / 12で撮影して、最終的にモノクロにしたほうがいいかもしれません。

RAW8

カラーカメラでは、各ピクセルで3つの色チャンネル（赤、緑、青）すべてを検出しているわけではなく、実際には各ピクセルは1つの色の光しか検出していません。 色は、通常ベイヤーマトリックスと呼ばれる格子状に配置されており、次のような形をしています（図はGRBGベイヤーマトリックス）。

Image result for bayer matrix

ほとんどのカラーカメラは、この方法でカラーデータを取り込んでいます。 「 ディベイヤリング 」と呼ばれる技術を用いて、各画素に赤、緑、青のすべての値を生成し、 フルカラーの画像を得ることができます。RGBのモードを使用する場合、このディベイヤリング処理は、カメラ側またはドライバーソフトウェア側で行われます。

RAW8などの生のモードで撮影した場合、赤、緑、青の各ピクセルの元の値がSharpCapに取り込まれます。 SharpCapは独自のディベイヤリングコードを持っているので、画面上の画像はカラーのままだが、保存されたファイルは、ディベイヤリングが可能なソフトウェアで開かない限り、 ピクセルレベルでわずかなグリッドパターンが見えるモノクロになります。 「PIPP」「Registax」「AutoStakkert」「Deep Sky Stacker」などがこれにあたります。

RAW8形式で保存されたファイルは、1ピクセルあたり1バイトしか消費しないため、RGBファイルよりもはるかに小さいという大きなメリットがあります。 また、RAW形式で保存されたファイルは、適切な処理ソフトウェアによって、一般的なカメラドライバーよりも低速で高品質なアルゴリズムを使用してディベイヤリング処理を行うことができます。

RAW8のモードには、カメラセンサーの左上のピクセルが緑 / 赤 / 青のグリッドのどこから始まるかによって、4つの種類があります。 これらのバリエーションは、カメラセンサーの左上4つのピクセルにちなんで名付けられています。

· RGGB

· BGGR

· GRBG

· GBRG

例えば、RGGBとは、最上段の左2ピクセルが赤と緑、2段目の左2ピクセルが緑と青にそれぞれ対応することを意味します。

通常、SharpCapは、カメラがRAWモードで使用するパターンを認識し、正しいパターンを自動的に選択しますが、間違ったパターンが自動的に選択された場合は、 ディベイヤーモード コントロールの値を調整して、正しいパターンを手動で選択します。 正しいパターンを見つける最も簡単な方法は、カメラで赤い物体や光を見ることです。正しいパターンでなければ、赤い画像は表示されません。

なお、SharpCapが画面上の画像をディベイヤリングしていても、撮影ファイルに保存された画像はRAW形式のままです。

長所 | · カメラのセンサーから出てくる正確なデータで、後処理は一切なし。 · 後処理（ディベイヤリングを含む）は、後でより高い品質で行うことができます。 · ファイルサイズが小さい（1ピクセルあたり1バイト）
短所 | · 出力ファイルを扱うことのできるアプリケーションの範囲が狭い。 · 後処理はより複雑です。 · RAW形式を理解できないアプリケーションで開くと、出力ファイルが「チェスボード」のように見えることがあります。 · ビット深度は8ビットに制限されます。

SharpCapではカラー表示されているのに、保存されたファイルを見ると細かい格子状のモノクロになっている場合（下記サンプル）、 保存された画像の色情報を復元するためには、ディベイヤリングを行う必要があります。 詳細はこちら を参照ください。

RAW16

RAW16のモードは、1ピクセルあたり16ビットまでのビット深度に対応する生のモードです。 カメラによっては、RAW10やRAW12と表示されているものもありますが、これはカメラで利用できる本当のビット深度をより正確に表しています。 RAW16のモードで保存されたファイルは、1ピクセルあたり2バイトを使用します。

長所 | · カメラのセンサーから出てくる正確なデータで、後処理は一切なし。 · 後処理（ディベイヤリングを含む）は、後でより高い品質で行うことができます。 · ビット深度が大きいほど情報量が多くなり、ノイズの少ない画像であれば ダイナミックレンジ も広くなります。
短所 | · 出力ファイルを扱うことのできるアプリケーションの範囲が狭い。 · 後処理はより複雑です。 · RAW形式を理解できないアプリケーションで開くと、出力ファイルが「チェスボード」のように見えることがあります。 · ファイルのサイズが大きくなる（1ピクセルあたり2バイト）。

圧縮されたモード

ウェブカメラの多くは、圧縮されたモードしか提供していません。 圧縮されたモードを使用すると、PCに転送するデータ量を減らすことができますが、 画像の細部が失われることになります。 SharpCapでは、モードに基づいてウェブカメラから圧縮されたAVIファイルを保存することはできません。 ウェブカメラから保存されるすべてのAVIファイルは、RGB24、RGB32、またはMONO8形式（モノラルカメラの場合）になります。

ビデオのファイルサイズを小さくしたい場合、ファイル圧縮のために多少の画質の劣化があっても構わない場合は、 WMV ファイル形式での保存を検討ください。

YUY2 / YUV

これらは同じモードに対する2つの名称に過ぎません。 これらのモードでは、輝度情報はすべてのピクセルに格納されていますが、 色情報は水平方向に隣接する2つのピクセルで共有されています。 色情報は2バイトの情報（色相と彩度）で構成されているので、 このモードでは1ピクセルあたり全体で2バイト使用されることになります。 (http://www.fourcc.org/yuv.php)

I420

このモードでは、明るさは1ピクセルごとに保存されますが、色情報は4つのピクセルのブロック（2x2）で共有されます。 つまり、このモードでは、1ピクセルあたり合計1.5バイトを使用することになります。

MJPEG

このモードでは、各フレームは圧縮されたJPEG画像として保存されます。 これにより、フレームサイズは大幅に小さくなりますが、画像に著しい 圧縮アーティファクト が発生する可能性があります。 圧縮のレベルは、カメラまたはカメラドライバーによって設定され、調整することはできません。

正しいモードの選択

一般的には、以下のガイドラインが正しいモードの選択に役立ちます。

· カラーカメラの場合、RGBのモードよりもRAWのモードがあればそちらを選ぶ。

· RAWモードがない場合は、圧縮されたモードよりも非圧縮のRGBを優先します。

より高いビット深度（RAW10,12,16またはMONO16）を選択できる場合は、比較的長い時間露出する場合にのみ選択してください。 短時間露出で高ビット深度の画像を撮影しても、通常、画質上のメリットはありません。 詳しくは、スマートヒストグラム をご覧ください。

撮影形式の説明

AVI

AVIファイル形式は、ビデオファイル形式の一つです。 AVIファイル形式は、一般的に使用されており、さまざまなアプリケーションで読み取ることができますが、 残念ながら、ビデオデータをさまざまな方法で保存できる複雑なファイル形式です。 このため、特定のアプリケーションでは特定のAVIファイルの読み取りが困難な場合がありますが、他のアプリケーションやコンピューターでは同じファイルが正常に動作する場合があります。 しかし、一般的には、MONOまたはRGBのモードを持つAVIファイルは、どのようなシステムのどのようなソフトウェアでも正しく動作します。

AVIファイルは、1色チャンネルあたり8ビットまでのビット深度のビデオ形式しか保存できないため、それ以上のビット深度モードのカメラを使用している場合、AVIへの撮影はできません。

RAW形式で撮影を保存するためにAVIファイルを使用することができますが、処理ソフトウェアはこれを自動的に認識せず、適切なベイヤーパターンが手動で指定されていない場合は、 一般的にピクセルグリッドが見えるモノクロ画像が表示されます。

PIPP - Planetary Imaging Pre-processor (通称PIPP) は、 面倒なAVIファイルを処理したり、スタックソフトでは処理できないような飛び飛びの動画のフレームを安定させたりするのに便利なソフトウェアです。

なお、SharpCapでは、マイク付きのWebカメラを使用していても、音声をAVIファイルに記録することはありません。

長所 | · ほとんどの動画再生ソフトで見ることができます。
短所 | · ファイル形式は複雑で、多くのサブフォーマットがあります。 · 本機にインストールされている他のソフトウェアや コーデック によっては、正常に再生できない場合があります。 · エラーの内容は微妙で、解決が難しい場合もあります。 · 8ビットのみ。 · AVIで保存されたMonoやRAWは、ファイル形式の制限により上下逆に表示されることがあります。

SER

SERファイル形式は、天文学の撮影に特化して設計された別のビデオファイル形式です。 SERファイルは、AVIファイルのように多くのアプリケーションで読み取り、表示、または処理することはできませんが、 ファイル形式がAVIファイル形式よりもはるかに単純であるため、非互換性によるランダムな問題がはるかに少ない傾向にあります。

SER形式は、RGB、Mono、RAW形式の動画を保存することができ、1ピクセルあたり8ビット、最大16ビットのビット深度で撮影することができます。

RAW形式で撮影すると、センサーのベイヤーパターンの詳細がSERファイルに保存されるため、ほとんどの処理・表示ソフトウェアはこの情報を自動的に読み取り、 RAW画像データを正しくカラー画像にでディベイヤーすることができます。

また、撮影した各フレームの タイムスタンプ がSERファイルに保存されるので、後の画像処理にも役立ちます。

SER Player アプリケーション(v1.7.3.2)は、ここから 圧縮フォルダー(.zip)をダウンロードして解凍し、インストールしてください。日本語を含む8ヵ国語で使うことができます。

長所 | · バリエーションの少ないシンプルなファイル形式で、アプリケーションが正常に動作するかどうかは別として、全く動作しないこともあります。 · SERファイルはカメラのベイヤーパターンで書き込まれるため、RAW撮影の後処理が容易になります。 · ビット深度は8ビット / ピクセル、最大16ビット / ピクセルをサポート。 · ファイルの各フレームには正確なタイムスタンプが打たれています。 · Mono、RAW、RGBの撮影に対応します。
短所 | · SER形式をサポートしている後処理アプリケーションは少ないが、最も使用されている以下のアプリケーションはすべてSER形式をサポートしています。 o AutoStakkert AS2 (スタック)。 o Registax 5と6（スタックとウェーブレットシャープネス処理）。 o PIPP（ビデオファイルを処理するための準備）。 · SER規格の解釈は多少異なるため、自動的に認識されない場合、プログラムが正しいモードを選択する手助けが必要になることもある。

WMV

WMVは圧縮されたビデオ形式で、ウェブカメラや全天球カメラなどから長時間のビデオシーケンスを撮影する際に、完璧な画像の再現が重要ではなく、 ファイルサイズの縮小が必要な場合に最適です。

WMVビデオは、ほとんどのコンピューターやデバイスのビデオプレーヤーで再生できますが、WMVビデオをさらに処理するツールを見つけるのは難しいかもしれません。

長所 | · 他のビデオ形式に比べてファイルサイズが非常に小さい。 · 1ピクセルあたり8ビットのビット深度に対応 。 · MonoとRGBの撮影に対応。 · 視聴や共有を目的とした、後処理を必要としない長い動画の撮影に最適です。
短所 | · 圧縮により画質が損なわれる · RAWデータおよび1ピクセルあたりのビット深度が8ビットを超えるデータの保存には使用できません。 · 画像データの後処理には、天体写真の後処理ツールではなく、動画編集ツールが必要になります。

ADV

ADV形式（Astro Digital Video）は、天文現象を動画で撮影し、撮影に使用した機材や設定だけでなく、各フレームの正確な時刻を含む大量のデータを保存できるように設計されています。 掩蔽 (えんぺい) などの時間的制約のある観測に適しています。

ADVビデオを処理して表示するには、特別なツールが必要です。この形式を使用する前に、ADV形式と使用可能なツールについてよく理解しておく必要があります。 http://www.astrodigitalvideoformat.org/ をご覧ください。

長所 | · 8ビット以上のビット深度のMONOおよびRAWデータに対応。 · カメラの設定やフレームのタイムスタンプなどのリッチデータがファイルに保存される。 · 掩蔽 (えんぺい) などの専門的な撮影に適しています。
短所 | · 専用の処理ソフトが必要。 · 一般的な画像処理には適していません。

PNG

PNGファイルは、1つのフレームを撮影するための標準的な画像ファイルです。 ほとんどの画像処理や表示ソフトでPNGファイルを開くことができるので、簡単に扱うことができます。

PNGファイルは、ビット深度8ビット、16ビット、カラー、モノクロ、RAWなど、あらゆる形式の静止画を格納することができます。 ただし、多くの画像処理アプリケーションでは、ビット深度が16ビットのPNGファイルを正しく扱えない場合があります。

RAW画像をPNGファイルに保存すると、モノクロのPNGファイルとして保存されるため、画像処理ソフトや閲覧ソフトでは、正しくディベイヤーの設定をしない限り、 ピクセルの格子状のパターンを示すモノクロで表示されます。

長所 | · ほとんどのグラフィックアプリケーションに読み込むことができます。 · 8ビットから16ビットの深度、モノラルまたはカラーの画像を扱うことができます。
短所 | · 多くの画像処理アプリケーションでは、16ビットのPNGファイルを読み込む際に、細部が破棄される場合があります。 · PNG形式で保存されたRAW画像は、モノクロで市松模様のように見えるため、正しくディベイヤリングするためには、後処理で手動設定が必要になる場合があります。

FITS

FITSファイル形式は、柔軟性の高い特殊な形式で、高ビット深度の静止画を保存するためによく使われます。 FITS形式は、8ビットのビット深度の画像を保存することができますが、ソフトウェアによっては8ビットのFITSファイルを正しく読めないものもあるので、 その場合はPNGを選択した方がよいでしょう。

FITSは特殊なファイル形式であるため、FITSファイルを処理できるアプリケーションの数は少なく、 PNGファイルを快適に扱える画像表示 ー 編集アプリケーションのほとんどは、FITSファイルを開くことができません。 しかし、 Deep Sky Stacker や FITS Liberator のように、 FITSファイルを処理・閲覧することができるアプリケーションもあります。

長所 | · 8ビット以上のビット深度に対応。 · モノラル、カラー、RAW画像に対応。 · 露出などの画像データはファイルに保存され、アプリケーションによってはこのデータを読み取ることができます。 · SharpCapでは、ダークフレームを読み込む際に、FITSファイルから16ビットのデータを読み込むことができます。
短所 | · 限られたアプリケーションでしか開くことができません。 · 一部のアプリケーションでは、このファイルタイプを開くために追加のプラグインが必要です。 · ファイル形式は非常に複雑で柔軟性に富んでいるため、アプリケーションによってはファイルが正しく表示されない場合がありますが、他のアプリケーションでは正しく表示されます。 · 他のファイル形式に比べて保存速度が遅いため、 高い フレームレート には向きません。 · アプリケーションによっては、FITSファイルの8ビットデータを正しく扱えない場合があります。

TIFF

TIFFファイル形式は、広くサポートされている画像ファイル形式で、ほとんどの画像処理アプリケーションで開くことができます。 TIFFファイルは大きく圧縮されていないため、一般的にサイズが大きくなりますが、同じ画像であればFITSファイルよりも小さくなることがあります。

長所 | · 8ビット以上のビット深度に対応。 · モノラル、カラー、RAW画像に対応。 · SharpCapでは、ダークフレームを読み込む際に、TIFFファイルから16ビットのデータを読み込むことができます。
短所 | · PNGなどの他のファイル形式に比べてファイルが大きくなる場合があります。 · FITSに比べてファイルヘッダーに格納される情報が少ない · 他のファイル形式に比べて保存速度が遅いため、高いフレームレートには向きません。

SharpCapには、TIFFファイルを圧縮する機能がありますが、一般的な処理ツールの多くが圧縮されたTIFFファイルを正しく読めないため、このオプションはデフォルトで無効になっています。 TIFF圧縮を有効にしたい場合は、SharpCapが作成した圧縮されたTIFFファイルを画像処理ソフトが読めるかどうかを確認してください。

JPEG

JPEGファイル形式は、デジタル画像のための画像形式として非常に広く使用されています。ほとんどの画像処理アプリケーションは、JPEGファイルを読み込み、操作し、保存することができます。 JPEGファイル形式は、8ビットのビット深度で静止画を保存することができます。

JPEG形式は圧縮方式を採用しているため、保存時に画像の細かい部分が失われ、後で復元することができないことに注意してください。 人の目では気づかないような明るさや色などの細かい部分が失われるのは、他のファイル形式に比べてファイルサイズを大幅に小さくできるからです。

JPEGファイル形式の限界を考えると、特定の使用例にしか適していないと思われます。 例えば、非常に多くのフレームが自動的に撮影され、各フレームで完璧な画質を得ることがファイルサイズの小ささよりも重要でない全天球カメラなどです。

長所 | · ファイルサイズが小さい。 · ほとんどの画像処理アプリケーションで開くことができます。
短所 | · 保存時に画像の細部が失われる · 8ビットの限られた深度のみ


カメラコントロール

カメラのコントロールを正しく調整することは、あらゆる種類の画像に不可欠であり、どのような調整が必要かを理解するために、各種コントロールの機能を理解することも同様に重要です。

さまざまなカメラに搭載されているカメラコントロールについては、以下の「カメラの共通コントロール」で説明しています。

以降では、各カメラメーカー固有の機能について説明します。 同じ機能でも、メーカーによって名称が異なる場合があります。 また、同じメーカーのモデルでも、機能が異なる場合があります。 メーカー名はアルファベット順に記載しています。

カメラの共通コントロール

以下のコントロールは、一般的に、さまざまなメーカーのさまざまなカメラで利用できると思われますが、 すべてのカメラにこの章に記載されているすべてのコントロールが搭載されているわけではありません。 これらのコントロールは、カメラコントロールパネル（デフォルトでは、カメラのメイン画像の右側に表示されています）にあります。

フォーマット

これらのコントロールでは、撮影する画像の解像度（撮像範囲）や、撮影する画像の種類（モード：モノラル、RGBなど）をコントロールすることができます。 さらに、画像を保存する際に作成されるビデオファイルの種類を選択したり、その他の関連オプションを調整することもできます。

フォーマット

モード

· モードコントロールは、各フレームがどのような画像形式で撮影されるかを決定します。 一般的に、モードには次の4つのカテゴリーがあります。

o   モノクロ

o   カラー

o   Raw

o   圧縮

· 選択すべきモードとその意味については、 モードの説明 をご覧ください。

撮像範囲

· これは、撮影された各フレームのサイズ（ピクセル単位）を制御します。

· 多くのカメラでは、撮像範囲を小さくすることで、センサーの全範囲の中の一部の範囲を撮影することになりますが、 これを「ROI（Region of Interest）撮影」と呼びます。

· 保存ファイルのサイズが小さくなるだけでなく、撮像範囲を小さくすることで フレームレート が高くなることもあります。

ROIの位置（パン／チルト）

· より小さな撮像範囲を選択した場合、通常、センサーのどの範囲を使用するかを選択することも可能です（適切な関心領域（ROI）の選択）。

· 撮像範囲が最大値より小さい場合のみ表示されます。

ビニング

詳細は、 ビニング を参照してください。

出力形式

· 出力形式では、撮影したファイルを保存する形式を選択できます。 撮影形式のオプションについては、 撮影形式の説明 を参照してください。 以下のルールが適用されます。

· 「スナップショット」（単一フレーム）の撮影では、出力形式がビデオ形式（AVIまたはSER）であっても、静止画撮影形式（PNG、FITS、TIFF、JPEG）のいずれかが常に使用されます。 出力形式が静止画の場合は、選択された形式が使用されます。

· マルチフレーム撮影の場合、選択された形式が常に使用されます。 静止画ファイルの形式を選択した場合、各フレームは別々のファイルに保存されます。

· カメラが静止画モードの場合は、このコントロールのオプションに動画ファイル形式は表示されません。

出力形式が「自動」に設定されている場合、現在の露出時間が5秒未満の場合は互換性のあるビデオ形式が選択され、現在の露出時間が5秒以上の場合は互換性のある静止画形式が選択されます。 設定ダイアログで指定された出力形式が使用されます（例えば、16ビット深度の画像をAVI形式で保存できないなど、撮影する画像の種類に応じた形式であることが条件です）。

[注意：設定の 保存タブ で「自動出力形式でカメラを起動」 オプションがチェックされている場合、カメラは常にこのコントロールを「自動」モードで起動します。]

ディベイヤーモード

· RAWモードの場合のみ表示されます。

· RAW画像を表示する際に、ディベイヤー（色変換）するかしないかを選択できます。

· ファイルに保存された画像データには影響を与えません（ただし、SER、ADV、FITS形式のファイルのメタデータには影響を与えます。 正しいディベイヤーモード設定を行うことで、互換性のある処理アプリケーションが保存されたRAWファイルを自動的に正しくディベイヤーすることができます）。

· ディベイヤー機能のオン / オフはもちろんのこと、何らかの理由で間違ったパターンが自動的に選択されてしまった場合に、使用するベイヤーパターンを上書きすることも可能です。

ビニング

ビニングについての解説は、 用語集 を参照して下さい。

例えば、1280x960のセンサーの場合、2x2ビニングで640x480の画像を出力することができます。4x4ビニングの場合は320x240の出力画像となります。

ビニング値が「1」または「1x1」の場合は、ビニングが適用されないことを意味します。

カメラによっては、ビニング時にピクセル値を追加するもの（ビニングをオンにすると画像が明るくなる）と、値を平均化するもの （画像は明るくならず、代わりにノイズが減少する）があることに注意してください。 どちらの場合も、最終的な画像のS / N比は同じように向上します。 より明るい画像が必要でカメラが平均化する場合は、ゲインを上げるだけで、カメラが画素を追加したのと同じ結果になります。

ビニング加算

ビニングなし（幅2x、高さ2y） | ビニングあり2x2（幅x、高さy）

ビニング加算 ー ビニングなしの画像とビニングありの画像の間で、カメラの設定に他の変更は加えていない。 2x2ビニングを適用すると、撮影した画像のサイズが半分になり、画像が4倍に明るくなります。 両方のフレームで、画像の明るい右部分にかなりのレベルのノイズが見られることに注意してください。

ビニング平均化

ビニングなし（幅2x、高さ2y） | ビニングあり2x2 （幅x、高さy） | 2x2のビニングでゲインを追加 （幅x、高さy）

平均化されたビニング ー ビニングされていない画像とビニングされた画像の間で、カメラの設定に他の変更はありませんでした。 2x2ビニングを適用すると、撮影画像のサイズは半分になりますが、この場合、画像は明るくなりません。 しかし、画像の右側の明るい部分をよく見ると、ビニングを適用したことで、この部分（およびフレームの他の部分）のノイズが大幅に減少していることがわかる。 ゲインをさらに上げると、ビニング化された画像が明るくなり、画像の明るさとノイズレベルの両方において、ビニング加算の結果と同様の画像が得られます。

カメラコントロール

カメラコントロールは、カメラを設定するための主要なコントロールで、露出の長さやカメラゲインなどの主要なコントロールが含まれます。

カメラコントロール
露出時間 | · 露出時間は、カメラが1フレームごとに光子を集める時間の長さを制御します。 · 露出時間が長いほど、より多くの光子を集めることができ、より明るい画像が得られます。 · ほとんどのカメラでは、より長い露出を選択すると、 フレームレート が制限されます。 例えば、100ms（1/10s）の露出を設定すると、 ほとんどのカメラのフレームレートは10フレーム/秒に制限されます。 · カメラにはそれぞれ露出時間の制限があります。 · 一部のカメラ（特にウェブカメラ）では、許容露出量の範囲が正しくないとSharpCapに報告されることがあります。 · 露出コントロールの「長秒モード」チェックボックスの効果は1つだけで、露出スライダーの範囲を、最小露出から5秒（長秒チェックなし）、 最大露出から0.5秒（長秒チェックあり）に変更することです。 これは、露出可能な範囲が非常に広いカメラの場合、0.01msから1000sまでのスライダーの範囲では、正確な露出調整が困難になるためです。
ゲイン (アナログゲインと呼ばれることもあります) | · ゲインコントロールは、センサーが受信した信号の増幅器として機能します。 · ゲインを上げると、露出時間を増やさなくても画像の明るさを増すことができますが、その分、画像がノイズだらけになります。
フレームレート | · カメラがより高い静止画像数でフレームを作成している場合でも、SharpCapでフレームを処理する静止画像数を制限することができます。 · これは、フレームが撮影ファイルに保存される速度と、UIが更新される速度に影響します。なお、カメラのコントロールパネルやステータスなど、UIの他の部分の更新には影響しません。 · これは、全天球カメラの設定で、露出時間の短い日中のフレームレートと夜間のフレームレートが同じになるようにする場合に有効です。
反転 | · 画像の向きを修正するために、水平または垂直（または両方）の反転を適用します。 · カラーカメラをRAWモードで使用している場合、反転コントロールを調整すると、カメラのベイヤーパターンが効果的に変更されることに注意してください （例えば、垂直方向に反転するとRGGBがGBRGに変わり、その逆も同様です）。 · ダークフレームやフラットフレームを使用する場合は、ライトフレームと同じ反転設定で撮影しないと正しく動作しません。
温度 [読み取り専用] | · カメラセンサーの現在の温度。カメラに複雑な熱制御（ペルチェクーラーなど）が搭載されている場合は、熱制御の項目に現在の温度が表示されますのでご注意ください。

画像情報

上に示した画像情報は、さまざまなカメラに搭載されているコントロールの代表的なものです。カメラによっては、これらのコントロールがすべて利用できないものもあります。 実際、カメラによっては「タイムスタンプフレーム」オプションしかないものもあります。

画像情報

ガンマ

· ニュートラルガンマは1です。

· 正しくは、ガンマが1より小さいと陰影と中間色が強調され、ガンマが1より大きいと中間色とハイライトが強調されるという解釈です。

· アプリケーションやカメラによっては、ガンマを逆に扱うものもあり、ガンマを上げると陰影が強調されます。

· ガンマ、コントラスト、明るさの詳細については、 http://www.orpalis.com/blog/color-adjustments-brightness-contrast-and-gamma/ を参照してください。

· ほとんどの場合、ガンマコントロールは初期設定のままにしておくのがよいでしょう。

コントラスト

· コントラストを上げると、画像の暗い部分はより暗く、明るい部分はより明るくなります。

· これにより、画像の細部を引き出すことができる場合があります。

· ほとんどの場合、コントラストコントロールは初期設定のままにしておくのが良いでしょう。

輝度

· 明るさを上げると、通常、同じ量だけ画像が明るくなります。

· 明るさは、カメラによっては「オフセット」や「ブラックレベル」と呼ばれることもありますが、名称にかかわらず、すべてのコントロールは同じ効果を持ちます。

· ディープスカイの撮影では、明るさ/オフセット/ブラックレベルコントロールを調整して、画像の中に明るさが最小（ゼロ）の部分がないようにする必要があります。 これは、ヒストグラム機能で確認できます。

· 明るさを上げることで、画像の暗い部分の細部を引き出すことができます。

タイムスタンプ

· フレームの左上にUTC（協定世界時）の タイムスタンプを付けることができます。

· 目に見えるタイムスタンプだけでなく、機械で読めるタイムスタンプもフレームのピクセルデータの最初の8バイトに埋め込まれています。

機械読み取り可能なタイムスタンプは、0001年1月1日午前0時からの100ns間隔の数である64ビットの整数です。 (詳細は、 https://msdn.microsoft.com/enus/library/system.datetime.ticks(v=vs.110).aspx を参照してください)

ホワイトバランス

後述の「ホワイトバランス」を参照してください。

ホワイトバランス - カラーカメラで撮影した画像は、色が正しくないことがよくあります。 これには以下のような様々な理由があります。

· ある色（多くの場合、緑や赤）が他の色よりも光に対して敏感であること。

· 画像を撮影する際の照明の種類 - 例えば、アストロ以外の画像の場合はタングステン、LED、蛍光灯など。

カメラによっては、カラーバランスを調整して正しい色の画像を得ることができるようになっています。

これらのコントロールの詳細は異なりますが、いずれも効果的にカラーチャンネルの明るさを相対的に調整し、画像の「色かぶり」を補正することができます。

カメラによっては、オートホワイトバランスを選択できるものもありますが、通常の撮影では問題ありませんが、天体写真では混乱してしまうことがありますので、注意が必要です。

ホワイトバランスや、ガンマ、コントラスト、明るさなどの画像調整を行う際には、ヒストグラムコントロールを使用してください。 いずれかのカラーチャンネルのヒストグラムのトレースにギャップがある場合（ヒストグラムの中央にゼロカウントのレベルが表示される）、 ホワイトバランス（またはその他）の調整がカメラのハードウェアではなく、PCのソフトウェアで行われていることが考えられます。 下の図のようなヒストグラムは、データが失われていることを意味します。

このような場合は、ホワイトバランスをデフォルトに戻し（ヒストグラムの隙間をなくす）、重ね合わせた後にカラーバランスを補正するのがベストです。 これにより、SharpCapでデジタルホワイトバランス補正を行ったことによるデータ損失を防ぐことができます。

前処理

前処理

ダーク補正

· SharpCapで撮影した各フレームから、選択したダークフレーム画像を減算することで、 アンプグロー やダークノイズなどを低減することができます。詳細については、 ダークフレームの撮影 を参照してください。

[注意：ダークフレーム補正は、フレームの他の処理（ライブスタックや効果など）の前に減算され、ダークフレームの減算は保存されたファイルに影響を与える] 。

フラット補正

· ケラレ やほこりによる明るさの変化を、フレームごとに補正します。フラットフレーム補正コードは高度に最適化されており、 高速なPCであれば、USB3カメラを使った高速撮影でも、1フレームごとに補正を行うことができます。詳しくは、 フラットフレームの撮影 をご覧ください。

[注意：フラットフレーム補正は、ダーク減算の後、フレームの他の処理（ライブスタックや効果など）の前に適用され、フラットフレームの適用は保存されたファイルに影響します] 。

バンディング除去 と しきい値

· カメラによっては、画像の暗い部分に様々な横方向の帯が見られます（これらは、淡い物体を表示するために画像レベルを引き伸ばした後で初めて目に付くことがあります）。 下の画像は、このタイプのバンディング（横じま）の一例です。

· SharpCapのバンディング除去機能は、保存や処理を行う前に、カメラからの各フレームに発生するこの種のバンディングを取り除くことができます。

· 「バンディング除去」コントロールは、バンディング低減効果の強さを設定します。

· 「しきい値」コントロールは、バンディング抑制が適用されない輝度レベルを指定します。これにより、バンディングが最も目立つフレームの最も暗い部分にのみ調整が行われます。

· これらのコントロールの最適な調整方法は以下の通りです。

o   ダークフレームを撮影するようにカメラを設定する

o   必要に応じてストレッチ表示を使い、バンディングをより鮮明にする

o   最初にバンディングのしきい値を最大にする

o   バンディング除去コントロールを徐々に上げていき、バンディングの減少量に満足できるようにします。

o   しきい値コントロールを徐々に下げていきます。ある時点でバンディングが再び現れますが、これはしきい値の設定が低すぎたためです。 しきい値を少し戻して、バンディングが再び消えるようにすれば完了です。

· しきい値は、バンディング除去がゼロに設定されている場合には効果がありません。

· これらのコントロールを使用する場合は、 ダークフレームとライトフレームの両方の撮影に同じ設定を使用する必要があります。

自動位置合わせ (惑星/銀河)

· 惑星や太陽・月面全体を撮影する際にこのオプションを有効にすると、各フレームの画像がオフセットされ、フレームの中央に配置されます。

· 他のタイプの天体を撮影するときにこのオプションを有効にすると、予測できない結果になることがあります。

· 惑星を各フレームの中心に安定させることは、画面に表示される画像だけでなく、画像ファイルや動画ファイルに保存される画像データにも影響します。

· 画像が移動しているため、カメラの記録領域外の部分が表示されることがありますが、その場合は濃いグレーで表示されます。

· この機能は、ピント合わせの段階で最も有用であり、惑星を一定の位置に保つことで、 目視やSharpCapのフォーカスツールを使ってベストフォーカスのポイントを判断することが容易になります。

· 自動位置合わせは、ビット深度8ビットのライブビューモードで動作しているカメラでのみ利用可能です。カメラが静止画モードで動作している場合や、 高ビット深度のモードを使用している場合は、このコントロールは使用できません。

背景減算

· このオプションを有効にすると、自動検出された一定の背景レベルが各フレームから削除されます。これにより、光害による背景の明るさ（スカイグロー）を除去することができ、 特に光害による画像の背景へのカラーキャストを除去することができます。

· このオプションは、除去すべき光害の量が多い場合に使用するように設計されています。 空が非常に暗い場合や、ナローバンドフィルターを使用している場合、このオプションは、各カラーチャンネルの背景レベルをヒストグラムの5％ポイントに調整しようとするため、 画像の背景がわずかに明るくなることがあります。

· このオプションは、ダークフレーム補正とフラットフレーム補正に対応しており、理想的には両方（または少なくともダークフレーム補正）と一緒に使用することをお勧めします。 ダークフレームはカメラ自体に起因する不要な明るさを除去するもので、このオプションは光害に起因する不要な明るさを除去するものです。

· 画像の明るさに対する調整は、カラー画像の異なるカラーチャンネルに対して異なる場合があります（これにより、色付きの空の光を補正することができます）。 しかし、この補正は画像内の位置によって変化しないため、空の光のグラデーションは除去されません。

· このオプションを有効にすると、画面に表示される画像と、撮影時にファイルに保存される画像データの両方に影響します。

· このオプションを有効にすると、キャリブレーションフレーム（フラット、ダーク、バイアス、ダークフラットなど）を撮影しません。 このオプションは、ライトフレームを撮影するときにのみ使用してください。

· 「単純なオフセット」オプションを使用すると、画像内のすべてのピクセルに同じ補正値が適用されますが、例えば、オレンジや赤の空の輝きがある場合、 赤チャンネルに最大の補正値が適用されるため、明るい星の色に影響を与える可能性があります（青や緑の色合いになります）。

· 「ブレンドオフセット」オプションを使用すると、SharpCapは完全な明るさに近いピクセルの明るさに大きな調整を行わないようにします。 これにより、背景減算オプションによって生じる星の色のずれを軽減または排除することができます。このオプションは、ほとんどの場合、「単純なオフセット」よりも好ましいものです。

ミニヒストグラムとストレッチ画面

このコントロールは、現在の画像のミニヒストグラムを常時表示し、撮影時にファイルに保存されるデータに影響を与えることなく、画面に表示される画像を「引き伸ばす」ことができます。 表示されている画像を引き伸ばすことで、明るさやコントラストを向上させたり、かすかな細部を簡単に明るくしたりすることができます。 ストレッチ機能は、「効果」ドロップダウンの「イメージブースト」オプションと同様の効果が得られますが、より詳細なコントロールが可能です。

ヒストグラムストレッチの調整

ストレッチ調整の基本的な操作は、黄色の縦の破線3本の位置をマウスでドラッグすることです。 この3本の線は、それぞれ黒、中間グレー、白として表示されるヒストグラムのレベルを表しています。

通常、黒レベルラインと中間レベルラインの調整が最も有効です。中間レベルのラインを黒レベルと白レベルのラインの中間でなくなるように調整すると、 ヒストグラム上に黄色のカーブで示される伝達曲線が作成され、画像のピクセル値が画面の明るさにどのように変換されるかを制御します。

中間レベルのラインを左に移動させると、最初は急激に上昇し、その後フラットになるカーブを描きます。 これは、画像の暗い部分の輝度を上げ、かすかな細部を見やすくする効果があります。 中間レベルのラインを右に移動すると、最初は比較的フラットで、白レベルの近くで急激に上昇するカーブになります。 これは、画像の明るい部分を暗くする効果があり、その部分の細部がより見えやすくなります。

下はヒストグラムストレッチ（調整なしで表示される画像）の初期設定です。

中段のラインが左に移動し、かすかな細部の明るさが強調されます。

中段のラインが右に移動し、画像の明るい部分のコントラストが強調されます。

黒レベルラインを右に移動すると、画像全体が効果的に暗くなります。これは、背景をより黒くして、背景のノイズや光害を目立たなくするのに有効です。

ヒストグラムストレッチボタン

一番上の稲妻ボタンは、現在の画像のかすかな細部を引き出すために設計された自動ストレッチを実行します。 これは、画像の輝度レベルの分析に基づいて、黒、中間、白のレベルラインを自動的に調整します。このボタンを使用する際に適用されるストレッチの強さは、SharpCap設定の 全般タブ で調整できます。自動ストレッチ機能を使用するには、SharpCap Proのライセンスが必要です。

真ん中の丸い矢印のボタンは、黒、中間、白のレベルラインをデフォルトの位置に戻し、現在有効なストレッチを取り除きます。

一番下の「表示どおりに保存」ボタンを押すと、画面に表示されている画像をそのままPNGファイルとして保存することができます。 通常のSharpCapの画像保存機能とは異なり、この保存ファイルには、現在適用されているストレッチの効果が含まれています。 なお、保存された画像ファイルのビット深度は、現在のカメラのビット深度設定にかかわらず、8ビットになります。

ヒストグラムストレッチでの変更は、画面上での画像の表示にのみ影響し、 撮影ファイルに保存された画像には何の変更もありません（ヒストグラムストレッチコントロールの 「表示どおりに保存」ボタンを使って保存したものは除く）。

カメラ別コントロール

以下のコントロールは、上記の共通コントロールに加えて表示されます。

Altair カメラコントロール

SharpCapは、Altair Astro社製の現行モデルのカメラすべてに対応しています。 カメラリストに掲載されていない新機種の場合は、そのカメラに対応したSharpCapの最新版をご確認ください。

詳細については、Altair Astro のウェブサイトをご覧ください。 ドライバ、ソフトウェア、テクニカルノートは、Altair サポート のウェブサイトでご覧いただけます。

カメラコントロール
天体の自動露出 | 自動露出がどの程度の明るさのフレームを目指すかをコントロールします（有効な場合）。 低い値に設定すると、自動露出はハイライトの少ない露出不足のフレームになる傾向があります。 高い値に設定すると、自動露出は露出過多のフレームになる傾向があります。
USB 速度 | カメラが使用しようとするUSBバス速度の大きさをコントロールします。 通常、この値を高くすると フレームレート が高くなりますが、 高すぎるとフレームレートが非常に低くなったり、フレームが不規則になったり、フレームが全く表示されなくなることがあります。
フリップ | 画像の向きを、水平、垂直、またはその両方に反転させることができます。 RAWモードでは使用できません。
ファン | ファンが搭載されているカメラでは、ファンのオン / オフを切り替えられます。

画像情報
ホワイトバランス調整 | 画像のホワイトバランスの自動調整を1回だけ行います。
ネガティブ | 画像をネガティブな表現に変換します（黒が白に、白が黒に、色が逆になります）。
色合い | 画像のグリーン／マゼンタのカラーバランスを調整します。値が低いとマゼンタがかった色になり、値が高いとグリーンがかった色になります。
カラーバランス | 画像の赤と青のカラーバランスを調整します。この値を高く設定すると画像が赤くなり、低く設定すると青くなります。
デジタル処理 (On / Off) | Altair ドライバーでの画像のデジタル調整を有効／無効にします。 · これを「On」に切り替えると、ガンマ、輝度、色合いなどのコントロールが有効になります。 · 「Off」にすると、これらの制御が無効になります。この機能をOffにすると、パフォーマンスが若干向上する場合があります。

ASCOM カメラコントロール

ASCOMカメラは、SharpCapで利用できるコントロールが比較的少ない。 ドライバーや詳細情報は ASCOM規格 のウェブサイトでご覧いただけます。

すべてのASCOMカメラが以下の制御をすべて提供することを保証するものではありません。 例えば、ASCOMカメラの中には、クーラーを全く搭載していないものもありますし、 クーラーを搭載していても、クーラーの出力を直接制御できるものとできないものがあります。

カメラコントロール

オプション

カメラのASCOM設定ダイアログを表示します。 設定可能なカメラオプションが追加される場合があります。 ダイアログが表示されている間、カメラは一時的にクローズされ、クローズされると再起動します。

温度制御
実際の温度 | カメラセンサーの現在の温度（読み取り専用）
冷却装置の温度 | カメラ内の冷却装置（ある場合）の現在の温度（読み取り専用）
クーラー(ON / OFF) | カメラに搭載されているクーラーのON / OFFを設定します。 クーラーをONにすると、以下の2つのコントロールのうち1つを使って冷却レベルを制御できます。
クーラーパワー | クーラーの稼働率を設定することができます。
目標温度 | カメラが冷やそうとする温度（この温度になるように冷却装置のパワーを自動的に調整する）。

AstcamPan カメラコントロール

ドライバーのダウンロードなど、カメラに関する情報はサイトでご覧いただけます : こちら

カメラコントロール
オフセット | 黒レベルの調整を行います。 このコントロールは、ヒストグラムの黒レベルのピークの両側が見えて、ゼロレベルと区別されるように、カメラを覆った状態で調整する必要があり、 黒レベルのノイズをスタック時に正しく平均化することができます。 他の一部のカメラでは、オフセットまたはブライトネスと呼ばれています。
ターボ USB | カメラがUSBバスにデータを転送する際の速度を制御します。 高い値を設定すると、データをより速く移動させようとし、より高いフレームレートが得られますが、 高すぎる値を設定すると原因となります。 · フレームを落とす。 · フレームレート の崩れ。 · あるいは、フレームを一切使わないこともあります。 一般的に、この設定を「オート」のままにしておくと、ほとんどの状況でうまくいきますが、フレームがない、フレームが乱れる、フレームレートが低いなどの問題がある場合は、 このオプションを調整してみてください。
高速モード | 状況によってはフレームレートが向上する場合があります。 カメラに搭載されている12bit ADCを使用していたものを10bit ADCに変更します。 高速モードを有効にすると、ゲインを低く設定した場合に画像ノイズが増加する場合があります。
ハードウェアビニング | ビニング が有効な場合のみ適用されます。 カメラドライバーのソフトウェアではなく、カメラ自体でビニングを計算します。 ゲインとノイズが増え、フレームレートが上がります。

Atik カメラコントロール

SharpCapはAtik社のほとんどのカメラモデルに対応しています。 最新のAtik コアソフトウェア がインストールされていないと、 SharpCapがカメラを検知・制御できない場合があります。

カメラコントロール
プレビューモード | 一部のカメラで有効です。有効にすると、カメラの読み出し時間が短くなり、画質が低下する場合があります。 プレビューモードを有効にすると、フレーミングやピント合わせの際に便利ですが、画像を撮影する際には無効にしてください。
ダークフレームの撮影 | 物理的なシャッターを備えたカメラでのみ使用できます。この機能を有効にすると、画像撮影時にシャッターが開かなくなり、 望遠鏡の開口部を塞ぐことなく、暗いフレームを撮影することができます。
高速モード | 一部のCMOSカメラに搭載されています。カメラを高速モードにすると、 フレームレートが向上し、太陽・月・惑星の撮影に役立ちます。ディープスカイ画像やライブスタックを行う場合は、高速モードを無効にしてください。

画像情報

デジタルゲイン

アナログゲインコントロールを持たないCCDカメラで使用できます。デジタルゲインは、各ピクセルの明るさにデジタルゲイン係数をかけて、画像を人工的に明るくする機能です。 この機能は、ピント合わせやフレーミングなどのために、より短い露出を可能にするのに役立ちますが、画像を撮影する際には無効にしてください。

温度制御
温度 | カメラセンサーの現在の温度（読み取り専用）。
クーラーパワー | クーラーの稼働率を設定することができます。
目標温度 | カメラが冷やそうとする温度（この温度になるように冷却装置のパワーを自動的に調整する）。

Basler カメラコントロール

ドライバーや詳細情報は、 Basler社 のウェブサイトでご覧いただけます。

Basler特有のコントロール

フォーマット
モード | Baslerのカメラは、RAWモードに非標準のモード名を使用しています。 · BayerBG8 ー BGGRベイヤーパターンのRAW8に相当します。 · BayerRG12 ー RGGBのBayerパターンを持つRAW12に相当します。 · Bayer GB12Packed ー RAW12にGBBRベイヤーパターンを加えたもの。 パックされた12ビットモードでは、隣接する2つのピクセルが、パックされていないモードではそれぞれ2バイトを必要とするところ、3バイト（それぞれ1.5バイト）にパックされます。 これにより、カメラからコンピューターへのデータ転送量が減るため、状況によっては フレームレートが向上することがあります。
FPS (frames per second) | カメラがコンピューターに送信しようとする1秒あたりのフレーム数です。 オートのままでは、可能な限り最大のレートを目指します。 なお、マニュアルモードで設定したフレームレートは、露出時間が長すぎたり、 カメラとコンピューター間のデータレートが不足していたりして、実際には達成できないことがあります。 フレームレートを制限したい場合は、この値を高くして「フレームレートリミット」コントロールを設定するよりも、 低い値に設定した方が、撮影コンピューターのCPU負荷を軽減することができます。

カメラコントロール
黒レベル | 黒レベルの調整を行います。 このコントロールは、ヒストグラムの黒レベルのピークの両側が見えて、 ゼロレベルと区別されるように、カメラを覆った状態で調整する必要があり、黒レベルのノイズをスタック時に正しく平均化することができます。 他の一部のカメラでは、オフセットまたはブライトネスと呼ばれています。
デジタルゲイン | 画像に加えることのできる追加のゲインです。 0から1ステップ上がるごとに、画像の明るさは2倍になり、ノイズレベルも2倍になる。

処理コントロール（他のカメラとの整合性のために画像コントロールである必要があります）
自動ホワイトバランス | 「調整」ボタンを押したときに、画像のホワイトバランスを自動的に調整します。
ホワイトバランス（R）[カラーモードのみ] | カラー画像の赤チャンネルの相対的な強度をコントロールします。
ホワイトバランス (B) [カラーモードのみ] | カラー画像の青チャンネルの相対的な強度をコントロールします。
ホワイトバランス (G) [カラーモードのみ] | カラー画像の緑チャンネルの相対的な強度をコントロールします。

セレストロン / イメージングソース カメラコントロール

SharpCapは、セレストロンブランドのSkyrisおよびNexImageカメラ（The Imaging Source社製）、イメージングソースブランドのDMKおよびDFKカメラのすべてをサポートする必要があります。

ドライバーおよび詳細情報は、 Imaging Source社 のウェブサイトおよび セレストロン社 のウェブサイトでご覧いただけます。

カメラコントロール
フォーカス | 内蔵カメラのレンズのフォーカスをコントロールします（可能な場合）。
絞り | 内蔵カメラのレンズの絞りをコントロールします（可能な場合）。
パン、チルト、ロール | カメラをパン、チルト、ローリングするための物理的なコントロール（モータードライブを搭載している場合、リモートコントロールが可能）。
IRカットフィルター | 制御可能なフィルターを搭載したカメラのIRカットフィルターをON / OFFします。

画像情報
色強調 | 画像の色を強調します。
ハイライト削減 | 画像内のハイライト部分の相対的な明るさを下げます。
ノイズ除去 | 各フレームにノイズ除去フィルターを適用する（細部が減少する傾向がある）。
カラー 有効 | カラーカメラのカラーモードとモノクロモードの切り替え。
シャープネス | 各フレームにシャープネスフィルターを適用し、細部を強調する（ノイズが増える傾向にある）。

ホワイトバランス
ホワイトバランス (R) | カラー画像の赤チャンネルの相対的な強度をコントロールします。
ホワイトバランス (B) | 上記のホワイトバランス (R)と同様に、青のチャンネルをコントロールします。
ホワイトバランス (G) | 上記のホワイトバランス(R)と(B)と同様に、緑のチャンネルをコントロールします。

iNova カメラコントロール

SharpCapは、iNovaの各種カメラに対応しています。

ドライバーや詳細情報は、iNova のウェブサイトでご覧いただけます。

カメラコントロール
黒レベル | 理論的には、他のメーカーで説明されている黒レベルコントロールと同じですが（QHYのコピー？）、実際にはiNova SDKのバグにより何もしません。
ピクセル クロック | カメラの内部CPUの動作速度。 速度が高いほどフレームレートは高くなりますが、高すぎるとフレームが全く表示されないこともあります。
水平ブランク | カメラが画像の1つの走査線を読み取ってから次の走査線を読み取るまでに適用する遅延時間。 通常はオートのままにしておくのが最適ですが、手動で調整することでフレームレートが向上する場合があり、値が低いほどフレームレートが速くなります。 多くの速度コントロールと同様に、やりすぎるとフレームレートがゼロになってしまいます。

Moravian Instruments カメラコントロール

SharpCapはCMOS Moravian Instruments社製カメラに対応しています。CCDベースのカメラも使用可能です。

ドライバーや詳細情報は、Moravian Instruments のウェブサイトでご覧いただけます。

CMOSカメラでは、カラーモードの選択肢が追加されている場合があります。

· RAW8 低速

· RAW8 高速

· RAW12 低速

· RAW12 高速

高速モードでは、より高いフレームレートが得られる場合があります。カメラの機種によっては、その他の読み取りモードが利用できる場合があります。

Moravianカメラでは、カメラのファンや冷却を制御する機能が搭載されている場合、そのオプションが表示されることがあります。

Player One カメラコントロール

SharpCapは、Player Oneのすべてのカメラに対応しています。

ドライバーや詳細情報は Player One のウェブサイトでご覧いただけます。

Player Oneのカメラには、現在、専用のコントロールはありません。

Point Grey (現在のFLIR) カメラコントロール

SharpCapはFlyキャプチャベースのPoint Greyカメラをサポートしています。Spinnakerベースのカメラには対応していません。USB、GigE、Firewireの各モデルに対応しています。

ドライバーや詳細情報は次を参照してください。https://www.flir.com/iis/machine-vision/

なお、SharpCapの起動後にGigEカメラが接続された場合、検出するためにSharpCapの再起動が必要になることがあります。

カメラコントロール
自動露出 Auto Exp Target | この値は、「露出」と「ゲイン」の「自動」オプションを有効にした場合に、目標とする明るさを示します。 値が大きい（0より大きい）ほど露出が高く、負の値は露出が低いことを意味します。
実際の温度 Actual Temperature | 温度表示は (°C)

選択したモード（RAW、MONO、RGBなど）に応じて、以下のリストの中から異なる画像コントロールが利用できます。

画像情報
デジタル処理 Digital Processing | このコントロールを「On」にすると、以下の他の画像コントロールが有効になりますが、フレームレートが若干低下する可能性があります。 このコントロールを「Off」にすると、他の画像コントロールは無効になりますが、表示および保存される画像データは、 ソフトウェアで処理されずにカメラセンサーから読み取られたデータと一致します。
ガンマ | 画像のガンマを調整する
輝度 | 画像の明るさを調整する。 注意事項: これは、すべてのピクセルの値に一定のオフセットを加えるだけの単純な明るさコントロールではありません。 このコントロールの正確な実装は不明ですが、RGBモードでは、カラーチャンネルの相対的な強さに影響を与えるようです。
鮮明度 | 画像に簡単な鮮明度処理を施す（ノイズの多い画像ではノイズも増えるので注意が必要）。
色合い | 画像の色合いを調整する
飽和度 | RGB画像の色の強さをコントロールする
ホワイトバランス (赤) | カラー画像の赤成分の相対的な強さをコントロールする
ホワイトバランス (青) | カラー画像の青成分の相対的な強さをコントロールする

QHY カメラコントロール

SharpCapは、QHY5L-II、QHY5-III、QHY174、178、224、290、163、183など、さまざまなQHY CMOSカメラに対応しています。 QHY ColdMOSカメラの冷却機能は、QHY174-GPSのGPS機能と同様にサポートされています。

QHY のウェブサイトでは、ドライバーや詳細情報をご覧いただけます。

カメラコントロール
アンプノイズ除去 | 一部のカメラに搭載されているこのコントロールを有効にすると、長時間露出時にカメラが生成する アンプグロー の量を減らすことができます。 一般的には、このコントロールを「自動」設定にしておくと、適切な場合にアンプグローリダクションが適用されるので、最適です。 アンプグローリダクションを手動で有効にした場合、露出とゲインの組み合わせによっては正しくない画像になることがあります。
横縞ノイズ除去 | このコントロールは一部のカメラで利用可能で、カメラ列間の バンディング 効果を軽減するように調整できます。
オフセット | 黒レベルの調整ができます。 このコントロールは、ヒストグラムの黒レベルのピークの両側が見え、ゼロレベルと区別できるように、カメラを覆った状態で調整する必要があります。 これにより、スタック時に黒レベルのノイズを正しく平均化することができます。
速度 | カメラで使用される転送速度をコントロールします。 状況によっては フレームレート が上がることがあります。
USB負荷 | この値は、カメラがUSBバスにデータを送信する際の速度をコントロールします。低い値を設定すると、データをより速く移動させようとし、より高いフレームレートが得られます。 設定値が低すぎると、以下のような現象が発生します。 · フレームが落ちる · フレームレートの低下 · あるいは、フレームがない場合もあります。
DDRバッファを使用 | 一部のカメラで使用可能です。 カメラに内蔵されているDDRバッファの使用をOn / Offします。 DDRバッファを使用すると、フレームレートが向上し、フレームが落ちる問題が軽減される場合があります。
光量の最適化 | 暗い場所や明るい場所に合わせて、カメラのセンサーを最適化することができます。
フィルターホイール | カメラポートに接続されている QHY フィルターホイールをコントロールすることができます。 SharpCapでカメラを開いたときに初期化中の場合は、接続されたフィルターホイールが検出されないことがありますので注意してください。
ライブ配信 | SharpCapで表示されている画像を、QHYビデオ配信アプリケーションでライブ配信することができます。

GPS コントロール
GPS | 内蔵のGPS機能に対応しているカメラでは、その機能を有効または無効にすることができます。 GPS機能を使用すると、フレームにマイクロ/秒単位の正確なタイムスタンプを付けることができます。 GPS機能を使用するには、カメラに12V電源を供給する必要があります。 GPSを有効にして衛星をロックすると、GPSシステムから取得した各フレームのタイムスタンプが、 撮影設定ファイルおよびSERファイルのフレームタイムスタンプのタイムスタンプとして使用されます。 これ以上の調整をしないと、フレームタイムはミリ秒レベルの精度になりますが、マイクロ秒レベルの精度を得るためには以下のコントロールを正しく調整する必要があります。
GPS 調整用LED | 次の2つのコントロールを正しく調整するためには、GPS調整用LEDがOnになっている必要があります。 また、LEDの光が画像に映るようにカメラを覆う必要があります。 光が見えやすくなるようにゲインを上げてください。
開始位置調整 | GPS LEDが点灯している状態で、調整用の開始位置をゼロまで下げてから、調整用の光が画像の片側に光りとして現れるまで上げていきます。 その後、光が再び消えるまで値を少しずつ下げていきます。 このコントロールを設定することで、 カメラ回路がフレームスタートを要求してから実際に露出を開始するまでの時間差を利用して、GPSフレームスタート時間を補正することができます。
終了位置調整 | GPS LEDが点灯している状態で、この値を調整用の開始位置値のすぐ上に設定し、LEDの光が再び消えるまで値を上げます。その後、光が再び現れるまで値を少しずつ下げていきます。 これにより、カメラ回路がフレームの停止を要求してからフレームが終了するまでの時間差で、フレーム終了時間を調整することができます。 開始位置と終了位置の調整を行った後は、調整用LEDを再度OFFにすることを忘れないでください。 また、カメラの露出やカメラのモードを変更した後は、調整を繰り返す必要がありますのでご注意ください。

画像情報
ホワイトバランス（R） [カラーモード専用] | カラー画像の赤チャンネルの相対的な強さをコントロールします。
ホワイトバランス (B) [カラーモード専用] | 上記のホワイトバランス (R)と同様に、青のチャンネルをコントロールします。
ホワイトバランス (G) [カラーモード専用] | 上記のホワイトバランス (R)と(B)と同様に、緑のチャンネルをコントロールします。

温度制御
クーラーパワー | クーラーの動作電力の割合を設定できます。 自動に設定されている場合、クーラーは自動的にセンサーを目標温度コントロールで指定された温度まで冷却しようとします。
目標温度 | クーラーパワーが自動に設定されているときに使用する、センサーの目標温度を設定します。

Starlight Xpress カメラコントロール

SharpCapは、スターライトエクスプレス CCDカメラの全製品をサポートしています。ドライバや詳細については、 Starlight Xpress のWebサイトをご覧ください。

フォーマット

一部のスターライトエクスプレスカメラにはインターレースセンサーが搭載されており、センサー上のラインの半分だけを一度に読み取ることができます。 インターレースセンサーを搭載したカメラを使用している場合、SharpCapはインターレース処理コントロールを追加して、 インターレースカメラを処理するさまざまな方法を選択できるようにしています。

「インターレース処理 Interlace Handling 」のオプションは

· 「奇数行と偶数行の撮影 Capture Odd then Even 」ー このオプションは、SharpCapに表示される各フレームでカメラを2回露出し、 最初にセンサーの奇数ラインを、次に偶数ラインを撮影します。これは、センサーの解像度をフルに発揮できる唯一のオプションですが、 フレームレート は半分になります （例えば、2秒間の露出を選択した場合、画像は4秒間に1回しか更新されません）。

· 「奇数行からの補間 Interpolate from Odd 」ー このオプションでは、センサーの奇数列のみが露出されますが、 偶数行のデータを左右の奇数行のデータで平均化（補間）してフルサイズの画像を生成します。 フレームレートは通常通りですが、画像の細部は少なくなります。

· 「偶数行からの補間 Interpolate from Even 」 ー は「奇数行からの補間」と同じですが、ただし、センサーの偶数行のみを露出し、 奇数行は平均化によって生成されます。

· 「奇数行の撮影 Capture Odd 」 ー はセンサーの奇数行を露出して、通常の半分の高さ（上記のカメラでは290ピクセル）の画像を形成します。 フレームレートは通常通りですが、画像の高さが半分になることで画像が歪んでしまいます。

· 「偶数行の撮影 Capture Even 」 ー は「奇数行の撮影」と同じですが、偶数行のみを撮影します。

· 「すべての行を撮影（2倍の垂直方向ビン） Capture All (2x vertical bin) 」 ー このオプションは、センサー上のすべてのピクセルを露出し、センサーを読み込む前に2倍の 垂直 ビニング を適用します。 「奇数行の撮影」や「偶数行の撮影」と同様に、画像は通常の半分の高さになるため歪んでしまいますが、各フレームですべてのピクセルが露出・測定されるため、 センサーの感度が最大限に発揮されます。

画像情報

画像情報
デジタルゲイン | スターライトエクスプレス CCDカメラには、アナログのゲイン調整オプションはありませんが、ウェルの深さが深いため、 比較的低い彩度レベルでも使用可能な画像を生成することができます。残念ながら、このような画像は、各ピクセルの信号が最大信号に比べて低いため、非常に暗くなってしまいます。 デジタルゲインオプションは、センサーから読み込まれた後の画像全体を最大100倍にブーストすることで、この問題を補正する方法です。 デジタルゲインの使用は、フォーカスや極軸合せツールの使用時に特に有効です。
黒レベル | これは、ソフトウェアによる黒レベルの調整です。このコントロールを調整する必要があるのは、 「デジタルゲイン」オプションを使用する場合のみです（ヒストグラムの黒レベルを適度な範囲に抑えるため）。

SVBony カメラコントロール

SharpCapは、SV305とSV305-PROのカメラを直接対応しています。旧型のSVBonyカメラ(SV105, SV205)は、ウェブカメラドライバーで対応しています。

ドライバーのダウンロードや、カメラに関する情報は こちら からご覧いただけます。

カメラコントロール
黒レベル | 黒レベルの調整を行います。 このコントロールは、ヒストグラムの黒レベルのピークの両側が見えて、ゼロレベルと区別されるように、カメラを覆った状態で調整する必要があり、 黒レベルのノイズをスタック時に正しく平均化することができます。 他の一部のカメラでは、オフセットまたはブライトネスと呼ばれています。
USB 速度 | カメラが使用しようとするUSBバススピードの大きさをコントロールします。 通常、この値を高くするとフレームレートが高くなりますが、 高すぎるとフレームレートが非常に低くなったり、フレームが不規則になったり、フレームが全く表示されなくなることがあります。

画像情報
シャープネス | 画像に簡単なシャープネス処理を施す（ノイズの多い画像ではノイズも増えるので注意が必要）。
飽和 | RGB画像の色の強さをコントロール

ZWO カメラコントロール

SharpCapは、高解像度のASI1600カメラや冷却式カメラの対応を含む、ZWOカメラの全製品に対応しています。

ドライバーや詳細情報は、ZWO のウェブサイトでご覧いただけます。

カメラコントロール

カメラコントロール
ターボUSB | カメラがUSBバスにデータを転送する際の速度を制御します。 高い値を設定すると、データをより速く移動させようとし、より高い フレームレート が得られますが、高すぎる値を設定すると原因となります。 · フレームが落ちる。 · フレームレート の崩れ。 · あるいは、フレームを使わないこともあります。 一般的に、この設定を「自動」のままにしておくと、ほとんどの状況でうまくいきますが、フレームがない、フレームが乱れる、フレームレートが低いなどの問題がある場合は、 このオプションを調整してみてください。
高速モード | 状況によってはフレームレートが向上する場合があります。 カメラに搭載されている12bit ADCを使用していたものを10bit ADCに変更します。 高速モードを有効にすると、ゲインを低く設定した場合に画像ノイズが増加する場合があります。
ハードウェアビニング | ビニング が有効な場合のみ適用されます。 カメラドライバーのソフトウェアではなく、カメラ自体でビニングを計算します。 ゲインとノイズが増え、フレームレートが上がります。

画像情報

画像情報
ホワイトバランス (R) [カラーモードのみ] | カラー画像の赤チャンネルの相対的な強さをコントロールします。 ホワイトバランス（B）とともに、画像のホワイトバランスを補正するのに使用します。 なお、2つのZWOホワイトバランスコントロールのどちらかを自動に設定すると、両方とも自動になります。
ホワイトバランス (B) [カラーモードのみ] | 上のホワイトバランス (R) と同様に、青をコントロールします。 なお、緑チャンネルのコントロールはありませんが、 赤と青の両方に逆の変更を加えることで緑チャンネルの相対的な強さを増減させることができるので、その必要はありません。
モノクロビニング [カラーカメラのみ] | ビニングが選択されている場合のみ適用されます。カラービニング画像ではなく、モノクロビニング画像を作成します。

注意：ZWO社のカメラにはガンマコントロールがありません。ガンマを調整する機能は数年前にZWO社によって削除されました。

温度制御

温度制御
冷却 On/Off | カメラの冷却器の On/Off を切り替えます。 カメラクーラーを動作させるには、カメラに12V電源が接続されている必要があります。
目標温度 | クーラーをOnにした場合に、カメラが実現しようとする温度。
冷却パワー [読み取り専用] | クーラーが動作している現在の電力割合。

その他制御

カメラの自動露出や自動ゲイン機能を制御します。

その他制御
Auto Exp Max Brightness | ヒストグラムの最大輝度点の目標レベルを、50（約20％のレベルでヒストグラムのピークを狙う）から 150（約60％のレベルでヒストグラムのピークを狙う）の範囲で設定します。
Auto Exp Max Exp | 自動露出を有効にしたときに使用できる最大露出（秒単位）です。
Auto Exp Max Gain | 同様に最大許容ゲインを設定します。

DirectShow カメラ

マイクロソフト DirectShowは、マイクロソフトWindowsプラットフォーム上でメディアをストリーミングするための構成です。

市場には膨大な数のWebカメラやフレームグラバーがあります。 一般的には、SharpCapはそれらのいずれにも対応していますが、 一部のカメラ／グラバーにはバグのあるドライバーがあり、SharpCapで正しく動作しない場合があります。 SharpCapで利用できるコントロールは、ドライバーによって決定されます。 SharpCapは、ドライバーが利用可能なコントロールを表示します。 デバイスドライバーが提供する「ビデオ撮影 Pin」および「ビデオ撮影フィルター」ダイアログでは、 さらに多くの制御が可能な場合があります。 これらは、「フォーマット」および「画像情報」の「Pinオプション」および「フィルタオプション」コントロールを使用してアクセスできます。 それぞれのダイアログを表示するには、そのコントロールの［表示 Show ］ボタンを押します。

Pinダイアログとフィルターダイアログの例を以下に示します。

ビデオ撮影フィルタ | ビデオ撮影 Pin

なお、「ビデオ画像フィルタ」および「ビデオ画像 Pin」ダイアログで使用できるコントロールやそのデザインは、SharpCapではなく、 使用しているカメラのカメラドライバによって決定されます。

例えば、ライブスタックや極軸合せは、Webカメラやフレームグラバーからの画像でも使用可能で、細部や星が見え始めるのに十分な長時間露出を設定することができます。

Webカメラ

多くの低価格Webカメラは、画像処理に使用するために何らかの調整が必要です。 これには、レンズやオートフォーカサー（赤外線フィルターを含む）を取り外したり、 Webカメラ用の1.25インチアダプターや赤外線カットフィルターを追加したりする必要があります。

マイクロソフト ライフカメラ（Webカメラ）

マイクロソフト ライフカメラHDは、一般的なWebカメラを天体用に改造したもので、一般的には月や惑星の画像撮影に使用されるが、ディープスカイの天体撮影には使用されない。 その性能は、SharpCap ギャラリー の木星の画像で見ることができます。

これらのWebカメラはeBayで約15ポンドで入手でき、IRカットフィルター（eBayで約10ポンド）が必要です。 改造の詳細は、 http://dslrmodifications.com/lifecam/lifecam1.html に掲載されており、使われなくなった望遠鏡や廉価な望遠鏡の接眼部にカメラを取り付けています。

オリジナルのマイクロソフト ライフカメラ | 1.25インチのアイピースに改造して装着
IRカットフィルター | センサー表示

フレームグラバー

フレームグラバーは、アナログのビデオ信号からフレームを撮影することができる電子機器です。 フレームグラバーは、USBデバイスです。 アナログビデオ信号は、一般的にデイナイトCCTVスタイルのセキュリティカメラから供給される。 このタイプのカメラは、一般的にアストロビデオカメラと呼ばれ、LN300型のCCTVボディをベースに、 ビデオフレームの内部スタックを可能にするファームウェアや電子機器が強化されているのが一般的です。 カメラの出力は、フレームグラバーまたはアナログスクリーンになります。 この配置は、特にアウトリーチ型のシナリオにおいて、天体のライブ画像表示やインターネットビデオ放送によく使用されます。 この配置は、光害の激しい空の下でも満足のいく結果が得られることが証明されています。

典型的なビデオ撮影デバイスは、http://www.ezcap.tv/ の EzGrabber です。 [注意：ezcapと同じように見えるクローンデバイスはたくさんありますが、全く異なるハードウェアを搭載し、 異なるドライバーを使用している場合があります ー これらのドライバーには互換性の問題がある場合があります]。

アストロビデオタイプのカメラのメーカーとしては、Revolution Imager社 や Mallincam社 が有名です。

フレームグラバーとアストロビデオカメラで構成される典型的なセットアップを以下に示します。

アナログビデオカメラと、カメラの内部メニューにアクセスするためのBluetoothアダプター。 イーサーネットケーブルを接続するためのビデオ / パワーバルン（左側）。

USB2 ビデオフレーム撮影デバイス。 SharpCapではUSB2861デバイスとして表示されます。

左から、ビデオフレームグラバー、バルン、イーサーネットケーブル、バルン、アナログビデオカメラ。

SharpCapは、このUSBフレームグラバーをUSB2861（通常は28xx）デバイスとして認識します。 フレームグラバーに接続されているカメラの詳細は、SharpCapでは検出されません。 このカメラは独自の内部メニューシステムで制御されており、通常はUSBまたはBluetooth接続でアクセスします。 このタイプのカメラは、通常、最大解像度が720×576で、NTSCまたはPALになります。

SharpCapによるフレームグラバーの表示 | アストロビデオカメラ内部メニュー

改造Webカメラ

改造Webカメラとは、電子的に改造されたWebカメラのことです。 典型的な改造は、長時間露出（LX）とアンプグローの除去です。 SharpCap 3.1以降では、LX改造されたWebカメラはサポートされていません。これらのカメラを制御するには、SharpCapの旧バージョン（3.0以前）を使用する必要があります。

DirectShow コントロール

DirectShowカメラには、マイクロソフト社が定めた一定のコントロールがありますが、すべてのカメラがこれらのコントロールをすべて提供されるわけではありません。

フォーマット (ビデオフォーマット)

· モード

· フレームレート (FPS)

· 解像度

· フレームディバイダー

カメラコントロール

· パン

· ティルト

· Roll

· ズーム

· 露出

· Iris

· フォーカス

画像情報

· 輝度

· コントラスト

· 色合い

· 飽和

· シャープネス

· ガンマ

· カラー表示

· ホワイトバランス

· 逆光補正

· ゲイン

仮想カメラ

SharpCapは、さまざまな種類のカメラと直接対応することができ、さらにASCOMまたはDirectShowドライバを介して、より多くのカメラと対応することができます。 また、曇りの夜にプログラムの機能を試すために使用できるテスト用（シミュレート）カメラも用意されています。 仮想フォルダモニタカメラは、画像をSharpCapに取り込むためのもう一つの方法を提供します。既存または新規に追加された画像ファイルをディレクトリから読み込むことができ、 SharpCapの新しい使用方法を提供します。その例を挙げてみよう。

· SharpCapではサポートされていないカメラがあり、DirectShowやASCOMドライバを使用していても、そのカメラからフレームを撮影してフォルダに保存するアプリケーションがあります。 フォルダモニターのバーチャルカメラを使って、フォルダに保存された新しいフレームをそれぞれSharpCapに読み込み、 フォーカス測定やライブスタックなどのSharpCapのツールにアクセスすることができます。

· SharpCapまたは他のキャプチャアプリケーションで撮影した天体の一連の画像フレームがあります。 フォルダモニタの仮想カメラを使って、SharpCapでこれらのフレームをライブスタックすることができます（元々SharpCapで保存されたフレームであれば、 異なるパラメータでライブスタックを繰り返すことができます）。

保存されたファイルから画像が読み込まれているときに、露出、ゲイン、カラーバランスなどのカメラコントロールを調整することは当然できません！ 仮想フォルダモニタカメラでは、限られたコントロールしかできません。解像度やモードの値も、読み込まれた画像ファイルの内容に応じて決定されるため、変更することはできません。

作業したいファイルを含むフォルダを参照し、フォルダ内のファイルリストを自動で移動する（再生モード）か、一時停止モードで手動で進む／戻ることができます。 また、ダークサブトラクションやフラットフレーム補正の適用や、フレームレートの上限設定も可能です。

フォルダソースを選択するには、「参照」ボタンを押して、フォルダを選択するか（そのフォルダ内のすべての画像ファイルを処理します）、 単一の画像ファイル（PNG、TIF、FITS、JPGに対応）を選択すると、同じフォルダ内のその種類の画像ファイルをすべて処理します。新しいフォルダーを選択した場合は

· フォルダに画像ファイルが含まれている場合、選択されたファイルタイプの最初の画像ファイルがカメラに読み込まれて表示された後、 カメラは自動的に一時停止し、必要な調整を行ったり、ライブスタックなどのツールを選択したりしてから、「再生」ボタンを押してフォルダ内の他の画像の処理を開始します。

· フォルダに画像ファイルがない場合は、カメラは自動的に再生モードに入ります。つまり、選択したフォルダに保存された後、すぐに最初の画像が処理されて画面に表示されます。

再生コントロール（巻き戻し、ステップバック、一時停止、再生、ステップフォワード）により、フォルダ内に存在する画像ファイルを移動することができます。

画像ファイルは常に日付順（古いものから順に）に処理されます。解像度とモードの値は、最初に処理されたフレームから選択され、解像度やモードの設定が異なるファイルはスキップされます。 SharpCapがフォルダ内のファイルを使い果たした場合（またはフォルダ内に画像ファイルが最初から存在しない場合）、新しい画像ファイルが追加されるのを待ち、 追加された画像ファイルを読み込みます。

フォルダ内に複数の画像ファイルがある場合、「再生」機能を選択すると、画像と画像の間に間を置かずに次々と表示されます。

· フレームレートリミットコントロールは、フレームが表示される速度を制限したり

· ライブスタックを選択すると、前のフレームがライブスタックの計算を完了した後に新しいフレームがロードされるため、 ライブスタックによってスキップされるフレームがないことが保証されます。

仮想フォルダーモニターカメラは、SharpCap Proの機能です。

テストカメラ

テストカメラは、設定とその効果を試して理解するのに便利です。 このマニュアルの内容の多くは、テストカメラから得られたものです。 したがって、このマニュアルは、PC /ノートパソコンに望遠鏡やカメラを取り付けていない場合や、空が曇っている場合でも、学習教材として使用することができます。 適切なレンズ（数ポンドで購入可能）を使用すれば、晴れた空を待たずにアストロカメラをテストすることができます。

テストカメラ 1 （ディープスカイ）

一般的なカメラ／画像／表示コントロールの説明は、 カメラの共通コントロール を参照してください。 [注意：一般的なコントロールの中には、現在、ゲインなどの効果がないものもあります。]

· 画像 ー 「参照」ボタンをクリックすると、SampleFilesフォルダに保存されているPNGファイルが読み込まれます。 ユーザーが作成した他のPNG、JPG、FITSファイルをここに保存し、テストカメラからアクセスすることができます。

· ランダム回転 ー は、撮影表示範囲に表示される各フレームにランダムな小回転を適用します。 オン／オフ、デフォルトはオフ。

· ランダムオフセット ー は、撮影表示範囲に表示される画像に、ランダムなオフセット効果を適用します。 オン／オフ、デフォルトはオフ。

· ランダムシーイング ー は、撮影表示範囲に表示されている画像にランダムなシーイング効果を適用します。 オン/オフ、デフォルトはオフ。

· ランダムノイズ (On/Off) ー 撮影表示範囲に表示されている画像に、ランダムなノイズ効果をかけます。 デフォルトは10、範囲は0～50です。

· ダークノイズを追加 ー は、デフォルトでは、SampleFiles\1280x960x32RGB_dark.png を撮影画像に表示されている画像に適用します。 ダークノイズに使用する画像は、「参照」を押して変更できます。

テストカメラ 2（高速）

一般的なカメラ／画像／画面のコントロールについては、 カメラの共通コントロール を参照してください。 [注意：一般的なコントロールの中には、現在のところ効果がないものもあります（ゲイン、露出、ガンマなど）。]

· フォーカスオフセット ー は、フォーカサーの動きをシミュレートするもので、「フォーカススコア」→ グラフ で使用できます。 デフォルトは0で、範囲は-10〜+10です。 このフォーカスオフセットコントロールは、ハードウェア設定で選択されたフォーカサーが「None」に設定されている場合にのみ使用できることに注意してください。

· ランダムオフセット ー は、撮影表示範囲に表示される画像に、ランダムなオフセット効果を適用します。 オン／オフ、デフォルトはオフ。

· ランダムシーイング ー は、撮影表示範囲に表示されている画像にランダムなシーイング効果を適用します。 オン/オフ、デフォルトはオフ。

· ランダムノイズ ー は、撮影表示範囲に表示されている画像に、ランダムなノイズ効果をかけます。 デフォルトは10、範囲は0～50です。


ヒストグラム

画像のヒストグラムは、デジタル画像の輝度分布をグラフ化したものです。 輝度値ごとにピクセル数をプロットしています。 ヒストグラムは、露出アンダー、露出オーバー、カラーバランスの問題など、画像の問題点を素早く浮き彫りにし、可能な限り高品質のデータを撮影するために使用されます。

ツールバーの「画像のヒストグラムを表示」アイコン [image] をクリックすると、ヒストグラムが表示されます。

そうすると、メイン画面の作業領域に画像ヒストグラムが表示されます（下図）。

ツールバーの「領域の選択」アイコン [image] をクリックすると、画像上に赤い長方形が表示され、ドラッグしてサイズを変更することができます。 この選択領域の長方形が有効になっている間、ヒストグラムは長方形内にある画像の部分についてのみ計算されます。 これにより、画像の限られた領域や、その領域のヒストグラムの表示方法をより詳細に確認することができます。

上の2つのヒストグラムには違いがありますが、カメラの設定は変更していません。

ヒストグラムの詳細

· 「自動非表示 Auto Hide 」ー 右上の「ピン」アイコン [image] を使って、 マウスがヒストグラムから離れたときにヒストグラムを自動的に隠すことができます。 折りたたまれたヒストグラムタブの上にマウスを戻すと、再び表示されます。

· 「対数 / 線形選択 」ー この Logarithmic チェックボックスは、縦軸の表示を対数表示と線形表示に切り替えます。 対数表示は、ヒストグラムの他の部分に高いピークを表示する必要があるために見えない小さな値を見るのに適している傾向があります。 対数オプションを使用する場合は、各輝度レベルのピクセル数を確認するために、 縦軸に表示される値を常に参照することを忘れないでください。

· 「平均 Mean と 標準偏差 (SD) 」ー 各カラーチャンネルのピクセル値の平均と標準偏差を示す統計情報です。 これらはADU（Analogue to Digital Units）で測定され、8ビット画像では100％の時に最大255、10/12/14/16ビット画像では100％の時に最大65535の値を示します。

· 「十字線」ー これらは、ヒストグラム領域にマウスが移動したときに表示され、ヒストグラムグラフ上の任意のポイントのADU値とピクセル数を簡単に読み取ることができます。

· 「横軸」ー 最大ピクセル輝度の％（8ビットモードではピクセル輝度は0～255、16ビットモードでは0～65535）。 この値は0～100で表され、8ビット、12ビット、14ビット、16ビットのカメラに対応しており、均一な表示が可能です。

· 「縦軸」ー は、その明るさのピクセル数です。

· 「ヒストグラムの線」ー ヒストグラムの4本の線は、3つの原色チャンネル（赤、緑、青）のそれぞれの明るさの分布と、 各ピクセルの全体の明るさの分布（しばしば「輝度」と呼ばれる）を示しています。

· 「水平方向のカラーバー」ー 横軸の下にあるバーは、輝度, 赤, 緑, 青の各チャンネル（通称LRGB）の範囲を表しています。

下のヒストグラムは、次のような情報を伝えています。

· 約400kピクセルが最大ピクセルの明るさの3％を持っています。 これがヒストグラムのピークです。

· このケースでは、約15個のピクセルが「最大ピクセル輝度の100％」、つまり飽和しています。 これは画像の総数に比べて非常に少ないピクセルなので、右端のクリッピングはあまり意味がありません。

モノラルモードを使用している場合、グラフには白い横棒（ルミナンス）と線が1本だけ表示されます。

ヒストグラムの軸について

下の図は、横軸と縦軸の単位を定義したものです。

なお、SharpCapでは、横軸の目盛を％で表示しており、8、12、14、16ビットのカメラに対応した統一された表示方法になっています。

横軸の目盛は、カメラのビット深度の表現を使ってインターネットで調べることができます。 この表は、2n-1（n＝カメラの ビット深度 ） で表される横軸の目盛を示したもので、実際に使用することができます。

カメラのビット深度 | ヒストグラム横軸の目盛
8 | 0..255
12 | 0..4095
14 | 0..16383
16 | 0..65535

線形目盛と対数目盛

右上の「対数 Logarithmic 」チェックボックスの選択を外したり、選択したりすることで、SharpCapのヒストグラムの形を変えることができます。

縦方向の目盛が線形、チェックボックスが選択されていない | 縦方向の目盛が対数である場合、チェックボックスが選択されます

上のグラフでは、縦方向の目盛が異なっていることに気付きます。 ここでは、線形目盛と対数目盛の違いについて説明します。

注：～は計算上のおおよそを意味します。 わずかな不正確さは、画面に合わせて拡大する際の丸め誤差によるものです。

線形目盛 [image] は、「画像ヒストグラム」のチェックが外れています。

· 数字は統一されています。

· 刻み目は等間隔になっています。

· 刻み目は、その値の差が均一です。

· 値は、0、37k（1*37）、75k（～2*37）、113k（～3*37k）、150k（～4*37k）、188k（～5*37k）です。

· 1つの目盛りから次の目盛りまでの増分は～37k（37000）、つまり各値に37kを加えて次の値を得ることになります。

· グラフがある場所（例えば50％の明るさ）と別の場所（例えば25％の明るさ）で2倍の高さになっている場合、 50％の明るさのピクセルが25％の明るさのピクセルの2倍あることを意味します。

対数目盛 [image] は、画像ヒストグラムにチェックが入っています。

· 数字は不揃いです。

· 刻み目は等間隔になっています。

· 目盛りは、ある値から次の値に移るときに一律の差があるのではなく、ある量を掛け合わせたものになっています。 例えば、13、180（～13*13）、2400（～13*13*13）といった具合です。

· 基本的な代数を覚えている人は、130, 131, 132, 133といった具合に認識しているでしょう。

· 縦方向の目盛は、値が小さいところでは高さが増し、値が大きいところでは高さが減ります。

· 各レベルのピクセル数が大幅に減少したことで、グラフの一部が見やすくなりました。

· 対数目盛は、すべてのデータをチャート上に表示し、値を読みやすくするのに役立ちます。また、高い値を抑制し、低い値を強調します。

上記を読んだ上で、"画像ヒストグラムを使用する際、対数目盛と線形目盛のどちらを選択すべきか？"という質問があります。

答えは「天体の種類を考えて、最適な画像が得られる方を使う」ですが、以下の点に注意してください。

· 線形は、ヒストグラムを適用する領域の明るさがほぼ均一な場合などに有効です。

o   フレームがいっぱいになったときの月や太陽の画像。

o   惑星円盤内の領域を選択するために ROI を使用した場合の惑星画像。

· 対数は、ヒストグラム領域内に明らかに異なる領域がある場合などに有効です。

o   小さな星雲の領域を含むディープスカイのフルフレームです。

ディープスカイを直線的なヒストグラムで見ると、星雲や星々のピークは広大な黒レベルのピークに埋もれてしまい、見えなくなってしまいます。 しかし、対数目盛はこれを回避します。

次の2つの例では、どちらも対数目盛を使用していますが、撮像される天体の種類（ディープスカイや大きな惑星）によって、望ましいヒストグラムの形は全く異なります。

ディープスカイ | 大きな惑星

ヒストグラムで画質向上

良いヒストグラムの形は、以下の条件によって異なります。

· 選択されている対数または線形の縦方向目盛り。

· 表示されている天体。

o   ディープスカイ。

o   太陽・月・惑星。

o   太陽系／月系／惑星系の場合、ROI とは、ディスク内の領域を選択するためのものです。

線形 / 対数の縦方向の目盛りや被写体の種類に応じた「良い」ヒストグラムの形状のガイドラインを以下にまとめました。 これらのガイドラインに従うことで、画像を正しく露出することができます。

ディープスカイ - 線形

ディープスカイ - 対数

太陽／月／惑星 – 線形

太陽／月／惑星 - 対数

太陽/月/惑星のROIまたは天体がフレームを満たしている場合（黒い背景がない場合）– 線形

太陽/月/惑星とROI - 対数

これらのヒストグラムの形状が、なぜ特定の画像タイプに対応しているのかを理解するには、以下の情報を考慮するとよいでしょう。

· ディープスカイのヒストグラムは、背景が暗く、星雲の明るさも低いため、低い強度レベルにピークがあります。

· 太陽/月/惑星のヒストグラムは、通常、暗い背景のために黒レベル付近にピークがあり、天体の（比較的）大きくて明るい画像のために別のピークがあります。

· 太陽や月のヒストグラムでは、ROIが使用されていたり、太陽や月がフレーム全体に表示されている場合、黒い背景がないため、黒レベル付近にピークはありません。

次の2つの図は、ヒストグラムで発生する問題の種類と修正方法を示しています。

露出不足の画像 | ヒストグラムがこのようになっている（左にずれすぎている）場合、画像は露出不足または黒レベルクリップと言われています。 これにより、背景がざらざらした画像になってしまいます。 この背景のざらつきは、後処理ソフトで除去するのが難しい。 微妙な細部も出にくくなります。 修正するには、露光時間を長くしたり（望ましい）、ゲインを上げたり、明るさやオフセットを大きくしたりします。
露出オーバーの画像 | ヒストグラムがこのようになっている場合（右にずれすぎている場合）、その画像は「露出オーバー」と呼ばれます。 画像内のピクセルが飽和してしまい、細部が失われています。 修正するには、露出量を少なくしたり（好ましい）、ゲインを下げたりします。

ガイドライン

以下の2つの例では、これらのガイドライン（ルールではありません）に基づいて、ディープスカイの天体の「妥当な」ヒストグラムを、縦軸を対数スケールに設定しています。

· 横方向のLRGBバーが左軸に触れていない（そうでない場合は黒くクリップされている）。

· 横方向のLRGBバーが右軸に触れていない（それ以外は白飽和）。

· 赤と青の横棒が両端でほぼ水平になっている（カラーバランス）。

· LRGBのヒストグラムはグラフ上で非常に近い位置にあります。

· ヒストグラムのピークは、横軸の20％前後です。 光害によってピークが移動することがあります。

· ピークの左にはシャープな勾配があります。

· ピークの右手には緩やかな勾配があります。

ディープスカイのモノクロの例

以下の例では、M42を撮影するための準備を記録しています。 使用した機材は

· セレストロン C8 SCT。

· セレストロン CG5 赤道儀。

· Altairアストロ GPカメラ モノクロ V1は、MONO8のモードに設定されています。

· 0.5倍のフォーカルレデューサーとAstronomik CLSフィルター。

· イメージングノートPCはLenovo X61 ThinkPadで、CPUは1.8GHz Core 2 Duo、4Gb RAM、120Gb SSD、Windows 10 Pro 32-bitを搭載しています。

M42は、明るさの範囲が広い天体です。 画像全体の露出とゲインを設定するのではなく、「効果」ツールを使って、限定された領域のヒストグラムを設定し、 M42の明るい中核部分を計算から除外しました。 この選択により、中心部は露出オーバーになりましたが、星雲を捉えるチャンスが得られました。

縦軸を対数目盛にして、ディープスカイの天体を上記のガイドラインに照らし合わせます。

ガイドライン | 満足度
横方向のLRGBバーが左軸に触れていない（そうでない場合は黒くクリップされている）。 | はい、モノラルなのでRGBはありません。
横方向のLRGBバーが右軸に触れていない（それ以外は白飽和）。 | タッチしても、ログ目盛で見ると、～80ピクセルが飽和している。
赤と青の横棒が両端でほぼ水平になっている（カラーバランス）。 | モノラルとしては該当なし。
LRGBのヒストグラムはグラフ上で非常に近い位置にあります。 | モノラルとしては該当なし。
ヒストグラムのピークは横軸の約20％です。 | 10%ですが、形は良いです。
ピークの左にはシャープな勾配があります。 | はい。
ピークの右手には緩やかな勾配があります。 | はい。

スタックをクリアしてスタッキングを再開すると、ヒストグラムはまだ妥当なもので、1×30秒のフレームの後には星雲ができ始めていました。

各段階では、作業領域のヒストグラムに最も注意を払いました。

これは、FITS Liberatorに読み込まれたFITS撮影ファイルのコピーで、後処理はしていません。 ヒストグラムは「妥当な」形を保っており、後処理のために価値のあるデータが撮影されていることを示しています。

ディープスカイのカラーの例

この撮影は、AVS DSO-1アナログビデオカメラとUSB2ビデオ撮影デバイス（フレームグラバー）を使用して撮影されました。 ビデオグラバーはDirectShowデバイスとして分類されており、SharpCapではカメラのコントロールが表示されないため、カメラの内部メニューを使って調整しています。

上記のガイドラインに照らし合わせてみると...

ガイドライン | 満足度
横方向のLRGBバーが左軸に触れていない（そうでない場合は黒くクリップされている）。 | はい。
横方向のLRGBバーが右軸に触れていない（それ以外は白飽和）。 | はい。
赤と青の横棒が両端でほぼ水平になっている（カラーバランス）。 | 適正。
LRGBのヒストグラムはグラフ上で非常に近い位置にある。 | はい。
ヒストグラムのピークは横軸の約20％。 | はい。
ピークの左にはシャープな勾配がある。 | はい。
ピークの右手には緩やかな勾配がある。 | はい。

M42の核となる4つのトラペジウム星が見えています。 露出、ゲイン、明るさを調整して、ヒストグラムをもっと右に伸ばすようにするとよいでしょう。

ライブスタック数を293とした場合のPNGファイルの表示結果を以下に示します（表示したまま保存＝後処理なし）。 コアは吹き飛んでいますが、星雲が写っています。

AVS DSO-1 camera settings

· AGC = 36

· Colour = Red 63, Blue 101

· INTG = X8

· Brightness = 60

· Gamma = 0.3

· INTMUL = 5


スマート ヒストグラム

ディープスカイを撮影するとき、正しいゲインや露出で撮影しているか気になったことはありませんか？ 10分×6回の露出の方が、5分×12回の露出よりも、本当に細部が出るのか？ SharpCap Proのスマートヒストグラム機能を使えば、もう迷う必要はありません。 センサー解析 の結果と合わせて, SharpCapは空の背景の明るさを測定し、 異なるゲインと露出の組み合わせによる最終的な積層画像の品質への影響を数学的にシミュレーションします。 また、提案されたよりも長いまたは短い露出（または低いまたは高いゲイン）を使用した場合の影響を示すグラフも表示されます。

これを最新の低ノイズCMOSセンサーで試してみると、最適な露出時間が想像していたほど長くないことに気付き、複雑なガイドが過去のものになるかもしれません （従来のディープスカイイメージングで5～10分、あるいはそれ以上の長時間露出を行うのは、暗い天体を見るためではなく、 CCDセンサーの典型的な高い読み取りノイズに対処するために必要なのです。最適な露出時間は読み取りノイズの二乗に比例し、 CMOSの読み取りノイズは8～10電子ではなく1～3電子であるため、品質を落とさずに露出時間を大幅に短縮できることが多いのです。)

スマートヒストグラムを使用するには、SharpCap Proのライセンスが必要で、SharpCapには、使用するカメラの機種ごとのセンサー解析データが必要です。 SharpCapには、150機種以上の一般的な天文カメラのセンサーデータが同梱されていますので、すぐにスマートヒストグラムをお使いいただけると思います。

SharpCapがセンサーデータを持っていないカメラを使用する場合は、使用する予定のカメラのモデルごとにセンサー解析を行う必要があります。 最良の結果を得るためには、8ビットと高ビット深度（12/14/16）の両方のモードでセンサー解析を行う必要があります。

なお、スマートヒストグラム機能は、一部のカメラでのみ利用可能です。

· スマートヒストグラムは、DirectShow（ウェブカメラ）ドライバーを使用したカメラでは使用できません。

· スマートヒストグラムは、 センサー解析 ツールを使用して解析されたカメラでのみ使用できます。SharpCapには、一般的な天文カメラのカメラ解析データが収録されていますが、 スマートヒストグラムの機能を利用するには、それぞれのカメラでセンサー解析を実行する必要があります。

スマートヒストグラムバー

スマートヒストグラムの基本的な形は、ヒストグラム領域の上部に2本のカラーバーが表示されています。

赤、こはく、緑色の部分がある一番上のバーは、その明るさのレベルでの画像全体のノイズに対するカメラの読み取りノイズの影響を示しています。 ヒストグラムの赤いハイライト領域の画像では、カメラの読み取りノイズが全体のノイズの50％以上を占めています。 こはく色の領域では、読み取りノイズが全体のノイズに大きく寄与しています（10％～50％）。緑の領域では、読み取りノイズの寄与は小さい（10％未満）。

赤色とオレンジ色のゾーンの大きさは、カメラのゲインとオフセットのコントロールを変えることで変化します。 これらのコントロールの値を決めたら、空の背景に対応するヒストグラムのピークがオレンジゾーンのすぐ右側にくるように露出を調整します。 これにより、露出時間を長くしてもリターンが少なくなる（ゼロになる）ゾーンに入ることなく、最適な画質が得られます。

下側のバーは、撮影した画像の品質に対する ビット深度 の影響を示しています。 高ビット深度モード（12、14、16ビット）では、バーは緑と薄緑に分かれています（上図参照）。 薄緑の部分は、総ピクセルノイズが8ビットモードのADUレベル間の距離と同じかそれ以上になるため、ビット深度の増加が役に立たない範囲を示しています。 薄緑の領域では、高ビット深度の使用は、単にピクセルノイズをより詳細に記録していることを意味します。

8ビットモードでは、下のバーがこはく色と緑色になります。

こはく色の部分は、ヒストグラムの8ビットモードでデータを浪費している部分を示している （つまり、このヒストグラム領域の画像の一部を10/12/14/16ビットに変更した方が画質が向上する）。 この こはく色の領域は、カメラのゲインレベルを上げると左に縮小し、惑星撮影で使用される高いゲインでは全く見えなくなることもあります。 これは、惑星の ラッキーイメージング に高ビット深度モードを使用する必要がないことを示しています （また、スマートヒストグラムはディープスカイにのみ有効なわけではありません！）。

ヒストグラムの上部にあるカラーバーは、スマートヒストグラムの機能を簡単に利用するためのもので、露出時間やビット深度に関する基本的なガイダンスを示しています。 ゲイン、オフセット、露出、ビット深度の推奨値を示す、より詳細な計算を行うには、 カラーバーの隣にある「脳」ボタンを押して、脳ウィンドウを表示します。

スマートヒストグラム 脳ウィンドウ

「脳」ウィンドウはかなり複雑に見えますが、上から下まで順を追って見ていけば、使いこなすのは難しくないでしょう。

脳の目的は、最高のディープスカイ画像を得るために適切なカメラ設定を選択するのを助けることです。 脳は、素晴らしい品質のサブエクスポージャー画像を得ることを目的としているわけではなく、 一定期間（デフォルトでは1時間）に撮影されたすべてのフレームを重ねたときに、どのようにすれば最高の最終画像が得られるかを計算していることに注意してください。 この計算では、360×10秒の画像を撮るのが良いのか、10×360秒の画像を撮るのが良いのか、あるいはその他の組み合わせが良いのかが計算されます。 なお、デフォルト値の60分よりも長い時間、または短い時間を選択しても、主要な結果（推奨露出時間とゲイン）は変わりません。

空の明るさを測定

最初のステップは、空の明るさを測定（または入力）することです。これは、毎秒1ピクセルあたりの電子数で測定され、光害や熱雑音などの不要な光源から、 毎秒どれだけの信号がカメラの各ピクセルに到達しているかを示しています。 「 測定 Measure 」ボタンを押すと、 SharpCapはゲインを最大に設定し、露出時間を長くしてこの値を測定します。

カラーカメラの場合、どのチャンネル（赤、緑、青、暗部）を測定するかを選択することができます。 多くの場合、青のチャンネルが最も暗くなるため、長時間の露出が推奨されることになります。

撮像時にフィルターを使用している場合は、フィルターを装着した状態で空の明るさを測定する必要があります。 フィルターは、背景の空の明るさを低減するように設計されていることが多く、SharpCapではその効果を考慮することが重要です。 複数のフィルターを使用している場合は、各フィルターの空の明るさを個別に測定するか、最も暗いフィルターの値から計算するとよいでしょう。

画像のエッジ/コーナー付近で ケラレ が発生する場合は、 「 画像のエッジ/コーナーを無視 Ignore Image Edges/Corners 」オプションの選択を検討してください。 このオプションを選択すると、SharpCapは画像のエッジ/コーナー部分を考慮して測定を行わず、画像の中央部分に最適な計算を行います。

なお、空の明るさは、天体の高度、空の透明度、明るい月の近さなど、さまざまな要因で変化します。

何度も脳ウィンドウを使っているうちに、自分の観測地での天空の明るさの代表的な値に慣れてきて、 測定ではなくマニュアル調整でおおよその天空の明るさを e/pixel/s で指定して直接入力できるようになるかもしれません。

制限と目標の設定

次のステップは、計算の制限と目標を設定することです。考慮すべき最小および最大露出を設定することができます （通常、最大露出はマウントのトラッキング / ガイドの品質によって決まり、最小露出は非常に短いフレームでどれだけデータを保存しなければならないか、 またはライブスタックのためのスタック速度によって決まります）。また、撮像時間（この値の設定は重要ではなく、変更しても推奨値は変わりません）や、 最終的な画像のノイズレベルにセンサーの読み取りノイズがどの程度寄与するかを設定することができます。 「 読み取りノイズ制限 Read Noise Limit 」に10％を選択した場合、最終的な積層画像のノイズレベルの合計が、 達成可能な最小のノイズレベルよりも10％増加することを計算で許容することを意味します（例えば、任意のスケールで10から11になるように）。

この最後の選択は、ゲインの選択方法を決定します。2つのオプションは、ADUあたり1電子（または可能な限りそれに近い）を目指す 「ユニティゲイン Unity Gain 」と 「 最大ダイナミックレンジ Max Dynamic Range 」です。 「最大 ダイナミックレンジ 」は、最終的なスタック画像で、飽和していない最も明るい部分とノイズレベルの比率が最大となるゲインを求めます。 最大ダイナミックレンジは、多くの場合（常にではありませんが）、最小のゲイン値を選択します。

「最大ダイナミックレンジ」を選択した場合、（推奨露出量に基づいて）撮影可能なフレーム数を考慮して計算されます。 「最大ダイナミックレンジ」を選択した後、推奨露出量よりも長い露出量を使用した場合、より良いカメラ設定の選択肢を逃してしまう可能性があります。 この場合、「 最小露出 Min Exposure 」の設定値を大きくして、より長い露出を考慮するようにしたほうが、正しい推奨値になります。

その結果

空の背景が測定され、制限と目標が設定されると、結果を調べることができます。 上の画像では、空の明るさが5e/pixel/s（かなりひどい光害）の場合、計算ではゲイン値398、露出9.4秒、 ブラックレベル0が推奨されていることがわかります（空の明るさがヒストグラムの左側をクリアするのに十分であるため）。 下のグラフは、結果を理解し、必要に応じて値を微調整するのに役立つ計算の詳細を示しています。

「最適露出 Optimal Exposures 」チャートは、ゲイン別に 「 読み取りノイズ制限 Read Noise Limit 」の基準を満たすために必要な露出時間を示しています。 また、最小および最大の露出限界がグラフの範囲内にある場合は、赤い水平線で表示されます。 このグラフから、この場合の推奨露光量は398ゲインで46.9秒ですが、230ゲインでは60秒、約1400ゲインでは30秒の露光量でもよく似た結果が得られることがわかります。 少なくともこのグラフに示されている露光時間を目標としますが、より長い露光を選択しても、 「しきい値検出シミュレーション Detection Threshold Simulation 」チャートで見るように、あまり改善されません。

なお、ここでの計算は、撮影した画像のノイズレベル以上の微弱な細部の見え方のみを考慮しています。 その他の要素も、使用したい露出 / ゲインに影響を与える可能性があります - 例えば...

· 撮影フレーム数や撮影画像ファイルのサイズを制限したい場合は、露出を上げるように促すことができます。

· このとき、十分な明るさの星が写っていることを確認すると、重ね合わせがうまくいくかもしれません。

· 光害の影響により、長時間露出ではバックグラウンドレベルが非常に高くなる可能性があり、露出時間を制限する必要があります。

例えば、撮影フレーム数を制限したい場合は、最小露出量を60秒に設定するなどです。このようにすることで、状況に応じた最適な推奨値を得ることができます。 最低露出時間を60秒に設定すると、状況によっては最低露出時間を15秒に設定した場合とは異なるゲインや黒レベルの推奨値が得られる場合があります。

「相対スタックダイナミックレンジ Relative Stack Dynamic Range 」チャートでは、ゲインを変更した場合に、最終的なスタック画像の ダイナミックレンジ がどのように変化するかを示しています（各ゲイン値の推奨露出時間に従うと仮定した場合）。 このチャートは、必要なセンサー解析データがある場合、異なる ビット深度 の情報を示します。 この場合、8ビットラインのスタックダイナミックレンジは約450以下のゲインでゼロになります。 これは、選択したすべての制限に適合する露出時間の有効なソリューションがない場合に起こります。 例えば、このケースでは、リードノイズの制限が10%の場合、ゲインが450未満の8ビットモードでは、最大露出値の5分よりも長い露出が必要になります。 この場合（多くのカメラに共通することですが）、ゲイン値を低くすることで、最終的なスタック画像のダイナミックレンジをわずかに広げることができます。

3つ目のグラフは、露出時間の違いによる最終的な積層画像の最も暗い可視天体の変化を示しています。 このグラフを見ると、推奨露出時間を超えることで得られる最終的な感度の向上がいかに少ないかがよくわかります。 このケースでは、推奨値（ゲイン=398、露出=47s）では、予想される最も暗い検出可能な天体は0.0176e/pixel/sです。 露出時間を47秒から300秒に増やすと、0.0168e/pixel/sに下がり、約5%の改善が見られます。また、この時点でカーブは基本的にフラットになっていることがわかります。 これ以上露出を増やしても、最終的なスタック画像での微弱な天体の見え方はほとんど改善されません。

スマートヒストグラム機能が推奨する数値は、撮影に最適な設定を微調整するための出発点として使用するとよいでしょう。 例えば、ガイドが良好で、スマートヒストグラムが30秒の露出を推奨している場合、やや長めの露出を使用するとよいでしょう。

「しきい値検出シミュレーション Detection Threshold Simulation 」では、最終的なスタック画像で見ることのできる最も暗い天体が、その画像のノイズレベルと同じ明るさであると仮定しています。 実際には、多くのピクセルをカバーする天体の場合、小さな天体よりも大きなかすかな天体の方が見やすいため、それよりも少し良い結果になるかもしれませんが、カーブの形は変わりません。 特に、推奨される露出レベルを超えて、さらに露出を上げてもかすかな細部に対する最終画像の感度は実質的に改善されないという事実は変わりません。

要約すると、脳ウィンドウを使用すると、SharpCapは、画像に使用する可能性のあるゲインと露出のすべての組み合わせを一瞬でシミュレートし、 各パラメータのセットが最終的なスタック画像にどのような影響を与えるかを計算します。 これは、センサー解析の結果から、SharpCapがゲインと露出のあらゆる組み合わせに対するセンサーの動作を計算することができるからである。


ライブスタック

ライブスタックは、従来のように高精度なガイド付き赤道儀や長時間のサブフレーム露出を必要とせずに、SharpCap内でディープスカイ画像の撮影を可能にする機能である。 より多くの短時間の露出を行い、フレーム間の視野のドリフトや回転をSharpCap内でソフトウェアにより補正することで、 より多くの人がより低コストでディープスカイの天体写真を撮影できるようになります。

長時間露出と正確なガイド付きマウントが従来から求められているのは、ディープスカイの天体写真撮影に使われる従来のCCDカメラが高い読み取りノイズを持っているからです。 フレームを撮影するたびに高い読み取りノイズが発生する場合、読み取りノイズレベル以上の微弱なディープスカイの天体を見るためには、長時間の露出が必要となります。 長時間露出を行うためには、正確な追尾が可能な赤道儀やオートガイドが必要となります。

しかし、CCDカメラではなく、低ノイズのCMOSカメラを使うことで、その状況は一変します。 読み取りノイズが少ないということは、はるかに短い露出で微弱な天体を検出できるということです（さらに、短い露出を何度も重ねることで、読み取りノイズが少ないとできない）。 露出が十分に短ければ（多くの場合、30秒以下）、マウントの精度はそれほど重要ではありません。30秒の露出でのドリフト量は、300秒の露出でのドリフト量よりもはるかに小さいからです。 また、天頂から離れた場所では、ALT / AZマウントの使用によるフィールドローテーションは、通常、1回の30秒の露出では大きな影響を与えません。 SharpCapは、画像内の最も明るい星の動きを追跡することで、連続したフレーム間の緩やかなドリフトや回転を補正する。 撮影枚数が増えるにつれて、最初は見えていたノイズレベルが減少していくので、手間をかけずに驚異的なディープスカイ画像を得ることができます。

ライブスタックは、別のスタッキングプログラムを使わなくても、ディープスカイの画像がリアルタイムで表示されるというシンプルな満足感が得られるため、 特にアウトリーチでの使用に適しています。

ライブスタックは、「ツール」メニューから「ライブスタック」を選択するか、ツールバーの「ライブスタック」ボタンを選択して起動します。

選択すると、ライブスタックは直ちにフレームの取り込み、位置合わせ、スタックを開始します。 アライメントを行うためには、各フレームで最低 3 つの星が検出されなければなりません。 ライブスタックの作業領域に表示される保存ボタンを使って、任意の時点でスタック画像を保存することができます。 保存は必要に応じて繰り返すことができ、例えば、50フレーム後、100フレーム後などに保存することができます。

なお、惑星、太陽、月の画像にはライブスタックを使用しないでください。

ライブスタックのユーザーインターフェース

ライブスタックを制御するUIは、カメラ画像の下の作業領域に表示され、常に表示されている左パネルと、右にある一連のタブに分かれています。

左側のパネルは、スタック処理の最も重要な側面をコントロールし、レポートしますが、ライブスタック中は常に表示されています。 右側のパネルには10個のタブがあり、ライブスタック処理の詳細を監視・制御することができます。

左側パネル

概要

· 「 スタックフレーム Frames Stacked 」ー スタック上のフレームの現在の数です。

· 「 無視されたフレーム Frames Ignored 」ー 無視された（スタックされなかった）フレームの数です。 これは、アライメントの問題、SharpCapが十分な星を見ていない、フレームがフォーカススコアの基準を達成できないなどの理由で起こります。

· 「 露出トータル Total Exposure 」ー 現在のスタックが実行されている時間の長さです。 カメラによっては、SharpCapに露出値を報告できないものがあります（DirectShowフレームグラバーなど）。 そのような場合、SharpCapは、後続のフレーム間の時間に基づいて露出を推定します。

コントロールグループ

· 「 フレームアライメント Align Frames 」ー アライメントとデローテーションのオン／オフを切り替えます（デフォルトはオン）。 詳細は、右パネルの アライメントタブ を参照してください。

· 「 FWHMフィルター FWHM Filter 」ー FWHM（半値全幅） の平均値による各フレームのフィルタリングを有効／無効にします。 FWHM値の高いフレームは、ピント／見え方／透明度／雲の状態が悪いものとして破棄されます。 フィルタータブ 参照。

· 「 フィルター輝度 Brightness Filter 」ー フレーム内で検出された星の明るさで、各フレームのフィルタリングを行うかどうかを設定します。 星の明るさが低下するのは、薄い雲が原因であることが多い。

· 「 クリア / リセット時の自動保存 Auto Save on Clear / Close 」ー クリアボタンを押したときや、他の操作でスタックがリセットされたときに、 自動的にスタックを保存するかどうかを設定します。

· 「 Rawフレーム Raw Frames 」ー これらのオプションは、Raw（処理されていないフレーム）も保存するかどうかを制御します。 使用できるオプションは次のとおりです。

o 「保存なし Save None 」ー Rawフレーム（生のフレーム）が保存されない。

o   「スタック Rawフレーム保存 Save Stacked 」ー スタックに追加されたRawフレームは保存され、スタックに追加されなかったフレームは保存されません （フレームが追加されない理由はいくつかあります：アライメントの失敗、FWHMまたはフィルター輝度、スタックの一時停止、 ディザリング などです）

o   「一時停止 / ディザリング時以外の保存 Save except when Paused/Dithering 」ー 積層が一時停止している場合やディザ操作を行っている場合を除き、Rawフレームが保存される。

o   「全て保存 Save All 」ー すべてのRawフレームが保存されます。

なお、保存されたRAWフレームには、前処理（ダーク補正、フラット補正、 バンディング除去 、背景減算）が一切行われていません。 つまり、後から別のアプリケーションで処理することができます。

なお、優先静止画形式 の設定により、Rawフレームの保存形式が決定され、 Rawフレームは「YYYY-MM-DDCapture\HH_MM_SSrawframes」のようなフォルダに保存されることになります。

· 「 ビュー View 」下記のいずれかを選択して表示することができます。

o   「スタック Stack 」(これまでのスタックを表示する - デフォルト)

o   「個々のフレーム Individual Frames 」(カメラで撮影されている個々のフレームを表示する）。これは、ライブスタックに問題がある場合に有効です。 個々のフレームを見ることで、どんな星が見えているのか、条件が変わったのかなどがわかります。

· 「 スタッキング Stacking 」ー 積層のアルゴリズムを、 「デフォルト Default 」のアルゴリズムと 「シグマクリップ Sigma-Clipping 」アルゴリズムから選択できます。詳細は、 スタックタブ を参照してください。スタックアルゴリズムを変更すると、スタックがリセットされますのでご注意ください。

アクショングループ

クリアボタンを押すと、スタックがリセットされ、最初からやり直しになります。 カメラ、解像度、モードの変更など、他の操作によってもスタックがリセットされることがありますのでご注意ください。 露出、ゲイン、明るさ、ダーク／フラットの適用などを変更してもスタックはリセットされませんが、 スタックの進行中にこのような変更を行うことは、結果が悪くなる可能性があるため、通常は避けるべきです。

保存ボタンには4つのサブオプションがあります。

· 「16ビットスタックとして保存 Save as 16 Bit Stack 」ー 積層データを 0 と最大ピクセルの間で 0～65535 の範囲で線形に変更し、16 ビットの FITS ファイルとして保存します。 16ビットFITSオプションはデフォルトで、画像の全範囲を使用した高い ビット深度 の画像を得ることができます（例：最も明るいピクセルは65535）。

· 「Raw形式で保存（32ビット） Save as Raw (32-bit) Stack 」ー 全32ビットスタックデータを32ビットFITSファイルとして保存します。 このデータは、32ビットデータの利用可能な範囲のほとんどを埋めるようにビットシフトされます（ビットシフト量は、fitsファイルのBITSHIFTヘッダーに格納されます）。 注意：シグマクリップスタックを使用した場合、32ビットの値は最大値 231-1まで引き伸ばされます。

· 「調整して保存 Save with Adjustments 」ー ライブスタック調整を行った画像（ヒストグラム調整とカラー調整を行った後の画像）を、 8ビットまたは16ビットのPNGファイル（使用するカメラのビット深度に応じて）として保存します。

· 「見たままを保存 Save exactly as seen 」ー 画面に表示されている通りの画像を、8ビットのPNGファイルとして保存します。 これには、ライブスタックのヒストグラムとカラー調整、および画面ストレッチが適用されている場合はその効果が含まれます。

「一時停止/再開 Pause/Resume 」ボタンは、スタックを一時的に停止または再開します。 ライブスタック画面を閉じたり、ヒストグラムなど他のツールに切り替えたりすると、スタックは自動的に一時停止します。 ライブスタックに戻ると、スタックがリセットされるような操作（解像度やモードの変更など）が行われていなければ、スタックを再開することができます。 これにより、ライブスタックを閉じる可能性のあるSharpCapの他の機能を誤って選択しても、スタックデータが失われることはありません。

最後に、 「詳細 Advanced 」では、選択可能な間隔の後にスタックを自動的に保存してリセットすることができます。 これは、航空機の往来が激しい地域に住んでいる場合、短いスタックを大量に撮影することで、1組の航空機のライトで長いスタックが台無しになるのを防ぐことができるので便利です。

ステータスタブ

ステータスタブには、スタック処理とこれまでのスタックに関するより詳細な情報が表示されます。 注目すべきは、各フレームに必要なアライメントとスタック計算の処理にかかる時間である 「スタック時間 Stacking Time 」です。 この時間が露出時間よりも長い場合、フレームはスタックから脱落します（次のフレームが到着したときに、前のフレームがまだスタックされているため）。 「レンダリング時間 Render Time 」は、画面上の画像を再描画するための計算が完了するまでの時間を表します。 ノイズリダクションやシャープネスなどのライブスタック機能によっては、レンダリング時間が長くなることがあります。 レンダリング時間が長いと、ライブスタックのヒストグラムやカラー設定を変更しても、プログラムの反応は遅くなります。

右側の情報パネルには、現在のステータスや、スタッキングエラーが発生している場合は警告やエラーメッセージが表示されます。

ヒストグラムタブ

ヒストグラムタブには、ライブスタックデータのヒストグラムが表示されるだけでなく、「白レベル」「黒レベル」「中間レベル」を表す3本の黄色の垂直破線を動かすことで、 画像のレベルを引き伸ばすことができます。黄色い線は、ヒストグラムのレベルに応じて表示される画像の明るさを決定する「転送曲線」を示しています。 黒レベルのピクセル（およびそれ以下）では、表示される画像は黒になります。中間レベルポイントのピクセルでは、表示される画像は中間（50％）グレーになります。 ホワイトレベルポイントにある（またはそれ以上の）ピクセルでは、表示される画像は最大（100％）の強度になります。

· 黒レベル、白レベル、中間レベルを調整することで、画面上での画像の表示方法や、 調整して保存 または 見たままを保存 を選択した場合の保存方法が変わります。

· この変更は、スタック内の実際の値や、16ビットまたは32ビットのスタックとして保存する場合の結果には影響しません。

· ここでレベルを変更しても、「ライブスタック」パネルに表示されるヒストグラムの形や位置には影響しませんが、 右の「カメラコントロールパネル」の「ミニヒストグラム」には表示されます。

· また、カメラコントロールパネルにある「ヒストグラムストレッチコントロール」は、画面上での画像の見え方にのみ影響し、 「保存」ボタン の 「 表示された通りに画像を保存 Save image exactly as shown 」オプションを使用した場合を除き、保存データには影響しません。

白レベルの調整

· 白レベルはヒストグラムの横軸に適用されるので、左が0％、右が100％となります。通常、このラインを調整する必要はありません。

黒レベルの調整

· 黒レベルはヒストグラムの横軸に適用されるので、左が0％、右が100％となります。

· 空の光やチップノイズを抑えたり、画像の背景を暗くしたりするには、黒レベルを少しだけ上げます（スライダーを右に動かします）。 黒レベルを上げすぎると、画像が不自然になったり、かすかな部分が消えてしまうことがあります。

中間レベルの調整

· 中間レベルの線は、ヒストグラムの水平軸にも適用され、中間（50％）のグレーレベルとして表示されるヒストグラム上のレベルを指定します。 中間レベルは、黒レベルと白レベルの間になるように制限されています。

· 中間レベルコントロールを左に動かすと、画像の暗い部分の明るさが増します。中間レベルコントロールを白レベルに向かって右に動かすと、画像の暗い部分は暗くなりますが、 画像の明るい部分のコントラストが強調されます。

転送曲線

· 黄色の転送曲線は、黒点と白点の間のレベルが画面上でどのように表示されるかを示しています。 この線の形状は、黒レベル、白レベル、中間レベルの各コントロールの位置によって決定され、多くの画像処理アプリケーションに見られるカーブ調整と同じように機能します。 この線のグラフの縦軸は、黒（下）から白（上）までの表示の明るさを表しています。 表示された画像のピクセルの明るさは、ヒストグラム上のピクセルの横方向の位置を取り、赤い転送曲線のラインまで移動し、 その時点でのラインの縦方向の位置をそのピクセルの表示された明るさとすることで計算されます。

自動ストレッチとリセットボタン

これらのボタンは、メインのヒストグラム領域の右上にあります。「自動ストレッチ」ボタン は、 黒、中間、白の各レベルを自動的に適切な値に設定し、スタックされている画像の見え方を向上させます。 リセットボタン は、レベルをデフォルト値に戻します。 なお、自動ストレッチボタンを使用するには、SharpCap Proのライセンスが必要です。

少し強めに伸ばしたい場合は、CTRLキーを押しながら「自動ストレッチ」ボタンをクリックしてください。SHIFTキーを押しながらだと、通常のストレッチよりも若干弱くなります。 デフォルトのストレッチの強さは、 画面設定 で調整することもできます。

カラー調整

カラー調整スライダーは、メインのヒストグラム領域の右側にあり、カラーカメラの場合のみ表示されます。4つのスライダーは、左から右の順に並んでいます。

o   赤色調整

o   緑色調整

o   青色調整

o   彩度の調整

3つのカラースライダーを使って、画像のカラーバランスを調整できます。彩度スライダーは、表示される色の量を増やしたり減らしたりします。 ここでの調整は、画面に表示されている画像と、「調整して保存」または「見たままを保存」を選択して保存した画像に影響します。

色調整スライダーは、各色チャンネルに-10db（0.32倍）から+10db（3.2倍）の調整を加えることができます。

色スライダーの下には、左から右に向かって3つのボタンがあります。

o   画像のヒストグラムのピークを合わせて、自動カラーバランスをとることができます。

o   星カラーを基準にした自動カラーバランス

o   色調整のリセットボタン

ヒストグラムの微調整

希望の効果を得るために、ヒストグラムのストレッチレベルやカラーバランスのスライダーを微調整する必要がある場合もあります。

· <SHIFT>キーを押しながら黒/中/白のレベルラインをドラッグすると、ラインの移動速度が遅くなり、調整がしやすくなります。

· 黒/中/白のレベルラインのドラッグを開始し、ドラッグを続けながらマウスポインターを画面上部に移動します。 マウスポインターをヒストグラム領域から遠ざけるほど、ラインの左右へのドラッグは遅くなります。

· カラーバランスバーの一つをクリックし、キーボードの上下矢印キーで微調整したり、ライブスタック領域の高さを変えたりします。

· 「対数の水平軸］チェックボックスをオンにすると、ヒストグラムの水平方向のスケールが調整され、シャドー部とミッドレンジ部のスペースが大きくなり、ハイライト部のスペースが小さくなります。なお、ヒストグラムの垂直方向のスケールは常に対数です。

アライメントタブ

アライメントタブは、FWHM フィルタと同様に、各画像内の星の検出に依存するアライメント処理を制御します。 SharpCap は、星が検出された画像のみをアライメントできます。

· アライメント付きライブスタックの動作には、最低3つの星が必要です。 ただし、信頼性やアライメントを考慮すると、星の数は10～15個以上が望ましい。

· また、検出される星の数が多すぎると、アライメントの誤一致や、星の検出段階でスタック処理が遅くなるなどの問題が発生します。100〜200個の星で十分です。

アライメントグループ Alignment

· 「 フレームのアライメント Align Frames 」ー フレームのアライメントを有効または無効にします。 アライメントを有効にすると、 スタックの最初のフレームが基準フレームとなり、他のすべてのフレームがそのフレームに合わせられます。 SharpCap は、最初のフレームで検出した星を使用して、以降のすべてのフレームをスタックに合わせます。 スタック内の星は、星の検出パラメータが変更されると再検出される。 星が3つ検出されることが絶対的な条件ですが、3つの星が近接していたり、直線に近い場合などは、アライメントが機能することを保証するものではありません。 理想的には10〜20個以上の星が検出され、フレーム全体にうまく分布していることが望ましい。

· 「 アライメントに使う星の数 Align using 」ー で星の数を選択します。 星の数は10個、15個、20個、25個のいずれかです。 星の数を多くすると、スタック処理が遅くなることがありますが、アライメントの結果が良くなることがあります。 たくさんの星を検出してもアライメントが難しい場合にのみ、この値を増やしてください。

星検出グループ Star Detection

· 「 感度 Sensitivity 」ー この値を大きくするとより多くの星を検出しようとし、小さくすると検出される星の数が少なくなります。 以下の点に注意してください。

o   感度を高く設定すると、星の検出に時間がかかり、積み上げ作業が遅くなる可能性があります。

o   SharpCapは、200個以上の星が検出された場合は感度を下げ（最低75）、25個以下の星が検出された場合は感度を上げ（最高75）、自動調整してくれます。

· 「 ノイズ低減 Noise Reduction 」ー 有効にすると、SharpCapが低レベルのノイズやホットピクセルを無視できるように ガウスぼかし を適用します。 これを増やすことで、ノイズの多い画像でも星を正しく検出できるようになるかもしれません。

· 「 ホットピクセルの抑制 Suppress Hot Pixels 」ー このオプションを有効にすると、画像内の単一のホットピクセルから星を検出しないように、星の検出処理を調整します。 大きなピクセルのカメラと短焦点の望遠鏡を使用している場合（つまり、星が非常に小さい場合）は、このオプションをオフにする必要があります。

· 「 微光星の最適化 Optimize for Faint Stars 」ー アライメントに問題があるが、画像内に検出されない微光星が見える場合は、このオプションを使用します。

· 「 検出された星をハイライトする Highlight Detected Stars 」ー これをチェックすると、検出された星の周りにボックスが表示され、黄色の星はアライメントに使用され、 赤の星はアライメントに使用されません。 これは、星の検出やアライメントに問題がある場合、その原因を究明するのに非常に役立ちます。

なお、検出された星は、 Stack の場合はスタックの星、 「 個々のフレーム Individual Frames 」の場合はカメラのRawフレームの星となります。

· 「 全てリセット Reset All 」ー このボタンは、星の検出に関する全てのオプションをデフォルト値に戻します。

ステータスグループ Status

· スタックからのフレームの 「オフセット Offset 」、 「回転 Rotation 」、 「検出された星 Star Detection 」の数などの各種データを表示します。

スタックタブ

スタックタブでは、「スタックアルゴリズム Stacking Algorithm 」 を 「デフォルト Default 」 または 「シグマクリップ Sigma Clipped 」のどちらかを選択でき、シグマクリップアルゴリズムの設定を調整することもできます。

デフォルトのスタック

デフォルトのスタックアルゴリズムでは、各フレームのピクセル値をスタックデータに追加します。スタックされたフレームからのフレームデータはすべてスタックに含まれます。 デフォルトのスタックアルゴリズムには、調整可能なコントロールはありません。

シグマクリップのスタック

シグマクリップ スタックアルゴリズムは、スタックしたフレームを平均化してスタックデータを作成します。 このアルゴリズムでは、小数のピクセル値を追跡することで、スタックの品質を維持しています。 また、新しいフレームの各ピクセルの値と、スタック内のこれまでのピクセルの値を比較し、両者の差が大きすぎる場合は、 そのフレームではそのピクセルのデータは無視されます。

シグマクリップスタックの利点は、衛星や飛行機の軌跡など、個々のフレームに見られる異常な特徴がスタックデータに残らないことです。

SharpCapは、スタック内の各ピクセルの平均値と、各ピクセル値の変動量を記録しています。各ピクセルの変動量は、各ピクセルの標準偏差またはシグマ値として知られています。

あるフレームのあるピクセルのデータをスタックに含めるかどうかの判断は、そのフレームのピクセル値と、そのピクセルのこれまでのスタックの平均ピクセル値との差に基づいて行われます。 この差の大きさを、そのピクセルのシグマ値にシグマしきい値をかけた値と比較します。差が大きければ、そのピクセルデータは無視されます。

シグマクリップアルゴリズムの動作を調整するために、以下のコントロールが用意されています。

· 「初期フレーム数 Initial Frame Count 」ー これは、アルゴリズムが、異常な値を拒否することなく、 各ピクセルに期待される値を学習するための初期フレームの数を制御します。通常は5〜10程度の値で十分です。

· 「シグマしきい値 Sigma Threshold 」ー ここでは、フレームのピクセル値が現在のスタックのピクセル値とどれだけ異なっていれば拒否されるかを制御します。 高い値を設定すると、廃棄されるピクセルデータが少なくなりますが、異常なピクセルデータを排除するアルゴリズムの効果は低下します。 このコントロールは、各フレームで拒否されたピクセルの割合を示すステータス情報を見ながら調整する必要があります。

· 「シグマ下限 Sigma Low Limit (%) 」ー このコントロールは、スタック内の任意のピクセルに対して計算されるシグマ値の下限を指定します。 これは、個々のフレームにノイズがほとんどない場合に、画像データが誤って除去されるのを防ぐために必要です。

なお、「シグマクリップスタック」にはSharpCap Proのライセンスが必要です。

拡張タブ Enhancement

拡張タブのコントロールは、画像のノイズを低減したり、画像をシャープにしたり、またはその両方を行うことで、ライブスタック画像を改善する方法を提供します。 拡張タブのツールは、 ガウスぼかし によるノイズ除去を除き、 SharpCap Proのライセンスが必要です。

· 「ガウスぼかし Gaussian Blur 」 は、画像の各ピクセルを隣り合うピクセルと一緒にぼかす、シンプルなノイズ除去ツールです。 これにより、イメージ内のノイズを軽減することができますが、同時にイメージを多少ぼかす効果もあります。 「半径 Radius 」コントロールは、各ピクセルがぼかされる領域の大きさを決定します。この値を大きくすると、 ノイズ低減効果が強くなりますが、同時に画像がよりぼやけます。

· 「バイラテラル フィルター Bilateral Filter 」 は、より洗練されたノイズ低減ツールで、ガウスぼかしノイズ低減ツールのように細部をぼかすことなく、 同系色の領域のノイズを低減することができます。この場合も、「半径」コントロールは、ノイズ除去を行う領域を決定します。 輝度の許容範囲は、明るさの変化をどの程度まで許容すれば、その特徴が維持されるかを決定します。 バイラテラル フィルターのアルゴリズムは、ガウスぼかしのアルゴリズムよりもはるかに多くの計算を必要とするため、 高解像度のカメラを使用している場合や低速のコンピューターを使用している場合は、ライブスタックの速度が低下する可能性があります。

· 「アンシャープマスク Unsharp Mask 」は、画像のシャープな部分とそうでない部分を相対的に強化し、よりシャープな画像を作成するシンプルな画像鮮鋭化ツールです 。半径コントロールは、画像のシャープな成分とシャープでない成分の間の分割を調整します。設定値が高いほど、シャープな成分の一部とみなされる部分の目盛りが大きくなります。 「量 Amount 」コントロールは、画像のシャープな部分に適用されるブーストの量を決定します。 アンシャープマスクによるシャープネスを適用すると、残念ながら画像のノイズが増えるという副作用があります。量 コントロールの値を大きくしすぎると、 画像が不自然になってしまうことがあります。

· 「ウィーナーデコンボリューション Weiner Deconvolution 」は、スタック画像内の星の形をスタック画像のぼかしの性質を示すものとして判断し、 このぼかしを元に戻してシャープな画像を生成することを目的とした、高度な画像鮮鋭化ツールです。この鮮鋭化アルゴリズムを調整する唯一のコントロールは、S/N比です。 これは、スタック内の画像信号がノイズよりもどれだけ明るいかを示すものです。 信号対雑音比（S/N比） のコントロールは、 画像に自然な印象を与える最も高い値に設定する必要があります（値を高く設定しすぎると、画像が「オレンジピール」のような不自然な印象になります）。 ウィーナーデコンボリューション アルゴリズムは大量の計算を必要とするため、高解像度のカメラを使用している場合や低速のコンピューターを使用している場合は、 ライブスタックの速度が低下することがあります。

なお、ウィーナーデコンボリューションは、シーイングや光学系などによって画像がどのようにぼやけたかを示す 点像分布関数 の推定値として平均的な星の形状を使用するため、星検出が有効であり、画像内の星を見つける必要があることに注意してください。 星が検出されていない場合、デコンボリューションオプションは効果がありません。

シャープネスとノイズ減少のアルゴリズムは、画面に表示されている画像と、 調整して保存 または 見たままを保存 で保存された画像の両方に影響を与えます。シャープネスとノイズ減少は、画面上の画像が更新されるたびに適用されるため、 これらのツールを使用すると、カラー調整やヒストグラムの変更など、他のコントロールの変更に対するライブスタックの応答性が低下する場合があります。

ガイディング タブ

SharpCapは、人気の高いフリーウェアのガイディングアプリケーション PHD2 やMGEN3 オートガイダーと連携して、ライブスタック中のガイドや ディザリング を監視・制御することができます。 また、SharpCapは、ガイディングアプリケーションを使用せずに、接続されたASCOMマウントを使用してディザリングを行うことができます。 古いバージョンのSharpCapでは、このタブにあったディザリング設定を含め、ガイディング／ディザリングオプションの設定については、 ガイディング設定 を参照してください。

ライブスタック中にガイディングやディザリングを開始する前に、ガイディング設定 でガイドの設定を行ってください。

「ガイディングアプリケーションを監視する Monitor Guiding Application 」がチェックされている場合、ライブスタックの開始時に、 SharpCapは選択されたガイディングアプリケーション／デバイスへの接続を試みます。 接続が成功したか失敗したかを通知するメッセージが表示され、接続が成功した場合は、ステータス情報が定期的に更新されます。

SharpCapがガイディングアプリケーション／デバイスに正常に接続している場合は、右のステータスボックスに「ガイディング」、「キャリブレーション」、「停止」などのステータスが表示されます。 ガイドモニタリングが無効な場合や、SharpCapがガイディングアプリケーション／デバイスに接続できない場合は、 「ガイドに接続されていません Not connected to guiding 」と表示されます。

接続を再試行するには（PHD2が最初に起動していなかったり、MGEN3デバイスが接続されていなかったりした場合）、 Monitor Guiding Application チェックボックスのチェックを外してから再チェックしてください。

ガイドモニタリング

一般的なガイドモニタリングは、2つのオプションで管理されます。

「 ガイドが失われた場合スタックを一時停止 Pause stacking if guiding lost 」ー このオプションを有効にすると、ガイドのステータスが「ガイディング」から他のステータスに変更された場合、 SharpCapは進行中のライブスタックを一時停止します。なお、このオプションを設定した場合、ガイドしていない（または接続していない）状態でもスタックを開始することができます。 また、一時停止したスタックを手動で再開した場合、SharpCapはステータスが再び「ガイド」から非ガイド状態にならない限り、 再度一時停止することはありませんのでご注意ください。

「 ガイドをしていない場合はスタックを開始しない Do not start stacking if not guiding 」ー 有効にすると、ガイド状態が「ガイディング」になっていない（または実行されていない、接続されていない）場合、 SharpCapは開始された新しいスタックを一時停止します。

ガイドの開始や停止時には、SharpCapの通知バーに通知メッセージが表示されます。

ディザリング

SharpCap Proをお使いの方は、ライブスタック中にガイドアプリケーション／デバイスを使ってディザリングを有効にすることもできます。ディザリングを有効にするには、 「 自動ディザ Automatically Dither 」チェックボックスをチェックし、必要に応じてディザリングの間隔を設定します。

SharpCapは、一定時間ごとにディザの指示を出します。キャプチャー中にディザのタイミングが来た場合、SharpCapはフレームが終了するまで待ってからディザを開始します。 ディザ動作中、SharpCapはライブスタックを一時停止し、ディザ動作によってぼやける可能性のあるフレームがスタックに含まれないようにします。 スタックは、ディザの沈降が終了した後、最初のフレームの終了後に再開されます。

「 ディザー間隔 Dither interval 」ー これは、SharpCapが1つのディザの終了から次のディザを開始するまでに待機する最小時間です。 上述のように、ディザ操作は進行中のフレームの最後まで遅延します。ディザ間隔は、カメラの露出時間よりもかなり長い時間に設定する必要があります。 そうしないと、ディザリングによって失われるフレームの割合が許容できないほど高くなります。

「 ディザリング中に露出を減らす Reduce Exposure while Dithering 」ー このオプションが選択されている場合、SharpCapはディザリング操作中にカメラの露出を1秒に下げ、 ディザリング操作が完了すると、通常選択されている露出時間に戻します。これにより、各ディザでの撮像時間のロスが少なくなるため、通常はチェックしたままにしておきます。 縮小露光（1秒）フレームはスタックに追加されず、Rawフレームの保存に 「 全て保存 Save All 」オプションが選択されていない限り、Rawフレームとして保存されません。このオプションの使用を推奨します。

フィルター（FWHM）タブ

このフィルターは、品質の悪いフレーム（大気の状態が悪い、雲がある）をスタックから除外することができます。 フレームの品質は、フレーム内のフォーカス品質の FWHM（半値全幅） 推定値によってのみ判断されます。

· 「FWHMのフィルター Filter on FWHM 」ー チェックを入れると、FWHM（フォーカススコア）のフィルターが有効になります。

· 「最大FWHM Maximum FWHM 」ー スライダーを使って、使用するフレームの最大FWHM値を指定します。 最近のフレームの履歴を表示します。 使用されたフレームは緑、フィルターによって破棄されたフレームは赤で表示されます。

· フィルターは、どのスタックの最初のフレームにも適用されません。

フィルター（輝度）タブ

このフィルターは、雲の通過によるフレームの明るさの低下を検出し、雲によって損なわれたフレームがスタックに追加されるのを防ぐことができます。 フレームの明るさは、フレーム内に検出された星の明るさに基づいて判断されるため、このフィルターはフレーム内に十分な星が検出された場合にのみ正しく動作します。

グラフは、最近のフレームの明るさを、右側に最新のフレーム、左側に最古のフレームを表示しています。 拒否されたフレームは赤い四角で、スタックされたフレームは緑の四角で表示されます。

使用できるコントロールは ...

· 「輝度のフィルター Filter on Brightness 」ー チェックすると、明るさのフィルタリングが有効になります。

· 「最小の輝度 Minimum Brightness 」ー それ以下の明るさのフレームが拒否されるレベルを調整します。 このレベルは、最近スタックしたフレームの平均的な明るさを基準にして測定されます。

· 「自動 Auto 」ー SharpCapが最近のフレームの統計に基づいて最小輝度の しきい値 を自動的に設定するには、このボックスをチェックします。 最小輝度を手動で設定する場合は、このボックスをオフにします。

ドリフトグラフ タブ

ドリフトグラフは、現在のライブスタック中の画像の移動や回転の履歴を表示します。

左側のグラフは、画像の移動量を散布図（X,Y）で表したものです。 緑の十字はスタックに追加されたフレーム、赤の十字は何らかの理由（フィルタリング、スタックの一時停止など）でスタックに追加されなかったフレームを表しています。 最近のフレームほど十字が大きくなり、最新のフレームは青い十字になります。

右側のグラフは、縦軸に回転量、横軸に時間（最新のフレームを右に表示）をとって、スタックの回転の履歴を示しています。 赤道儀では回転量は非常に少ないが、Alt-Az儀では大きくなる可能性があります。

いずれのグラフにもマウスを重ねると拡大表示されます。

ログタブ

ライブスタックのログ情報を、SharpCapのメインログに保存されているものよりも詳細に表示します。 何かがうまくいかないときには、ここを見るといいでしょう。

また、ログタブには、便利な2つのコントロールがあります。

· 「全設定のリセット Reset All Settings 」ー このボタンを押すと、全てのライブスタックの設定がデフォルト値にリセットされます。

· 「無視された X フレームの後に警告する Warn After X Ignored Frames 」ー この設定を調整することで、連続してフレームを無視した場合に、 SharpCapが警告の表示を開始するまでのフレーム数を変更することができます。

ライブスタック リファレンス

デフォルトのスタックでは、SharpCapはスタックの各ピクセルに32ビットの整数値を保持し、各フレームの値がピクセル値に加算されます。

· 16ビットカメラの場合、スタックの値がなくなるまで、最大32768（215）フレームまでスタックすることができます。

· 8ビットカメラの場合、スタックの値がなくなるまで、1600万フレーム（224）までスタックすることが可能です。

シグマクリップのスタック では、SharpCapは各ピクセルごとに2つの32ビット浮動小数点を保持し、 平均ピクセル値と平均ピクセル値の変動を表します。

スタック中に保存されたすべてのファイルは、1つのフォルダに保存されます（rawフレームと処理されたスタック画像はサブフォルダに保存されます）。 これにより、スタックからの保存内容をまとめておくことができます。 フォルダの名前は、スタックが開始された時間と選択された天体の名前に基づいて、 通常のファイル命名規則に従って付けられます。

ライブスタックの名前変更

ライブスタック中にツールバーの天体の名前が変更された場合、SharpCapは出力フォルダの名前を変更します。 これは、現在のスタックでまだ画像が保存されていない場合は、プロンプトなしで自動的に行われます。 画像が保存されている場合は、スタックの名前変更を確認するプロンプトが表示されます。

注意：名前変更確認の回答を待っている間、ライブスタックの処理は一時停止します。

注意：新しい名前は、「天体名」ボックスから離れてクリックするか、キーを使ってボックスからカーソルを移動させるまで適用されません。

ライブスタック利用の一例

SharpCapのライブスタック機能を使用した便利なビデオデモンストレーションが、Charles Copeland氏の好意により、 https://www.youtube.com/watch?v=zIlJHyVWei4 に掲載されています。

ビデオではSharpCap 2.7を使用していますが、新しいバージョンのSharpCapにも有効です。 このビデオは、NexStar 6SE望遠鏡、 アナログビデオカメラ 、0.5倍のフォーカルレデューサーを使用して、ビデオスタックソフトウェアで何ができるかを示す良いデモンストレーションです。


フォーカス

SharpCapには、天体写真撮影で最も難しいとされる天体のピントを合わせるためのオプションがいくつか用意されています。 SharpCapにASCOMフォーカサーが設定されている場合は、特に強力なツールとなります （ASCOMフォーカサーとは、ステッピングモーターまたはDCモーターを使用して望遠鏡のフォーカサーを動かす装置で、USBケーブルを介してコンピュータから制御できます）。

はじめに

フォーカススコアには6つのツールがあり、対象に応じて適切なツールを選択する必要があります。 それぞれのツールは、画像のフォーカスの質を測定し（ツールによってフォーカスの質の測定方法は異なります）、測定結果を数値とグラフでワークエリアに表示します。 グラフは次のようなものです。

緑のバーは常にフォーカスが良いことを示し、赤いバーは常にフォーカスが悪いことを示します。最新の測定値がグラフの右側に、古い測定値が左側に表示されています。 なお、ツールによっては、フォーカスが良いとスコアが低くなり（グラフの短いバー）、逆にフォーカスが良いとスコアが高くなる（グラフの高いバー）場合があります。

フォーカスツールを選択して、ベストスコアが出るまでフォーカサーを調整し、どちらに動かしてもスコアが上がらないようにすることも可能ですが、 処理の仕組みと調整方法を十分に理解していれば、より良い結果を得ることができます。

ピントの合っていない画像にフォーカスツールを使おうとしないでください。 フォーカスツールは、ピントが近い状態から完全にピントが合った状態にするために使用するものです。 ピントがかなりずれていて、なかなかピントが合わない場合は、以下のいずれかを試してみてください。

· 天体のピント位置に近い、昼間の200m以上離れた地上の物体にピントを合わせます（遠ければ遠いほど良い）。

· 月が見えている場合は、見つけやすく明るい月を使います。 望遠鏡のピントがずっとずれていると、どんなものでも見つけにくくなってしまうので助かります。 しかし、月は明るいので、ピントが非常に悪くても見逃すことはありません。

· 高ゲインで2秒程度の露出で、明るい星や惑星を狙う。 以下のいずれかの方法で、表示画像の輝度を上げる。

o   ストレッチ表示 やストレッチ自動表示を使用する際に、中間レベルの値を小さくする。

o   「効果」のドロップダウンから イメージブースト を選択。

o   「効果」のドロップダウンから イメージブースト（強） を選択。

明るい天体が視野内または近くにある場合、明るいドーナツ型（反射式／SCT）または明るい円盤型（屈折式）の光の全部または一部が見えますが、 これは高いゲインと明るさの向上によって見えるようになった、天体の非常にピンボケした視界です。 望遠鏡のフォーカサーを調整して、このドーナツ／円盤を小さくすると、正しい焦点に近づきます。

フォーカスツール

ツールバーの「フォーカスアシスタントツール」の下には、6つのフォーカスツールが用意されています。 目的のツールを選択して、フォーカス測定を開始します。 ツールには2つのグループがあり、1つは太陽、月、惑星、または表面に焦点を合わせるのに適したもの、もう1つは星に焦点を合わせるのに適したものです。

各フォーカスツールには、平均化の設定があります。この設定は、データポイントをグラフに追加する前に、いくつのフォーカス読み取り値を平均化するかを制御します。

「平均化 Averaging 」ー 記録される値として、 「平均値 Average Score 」または、 「ベスト値 Best Score 」のいずれかを選択します。

「平均値以上 Average Over 」ー フレーム数または時間のいずれかで指定できます。平均化は、高速撮影（月・太陽・惑星）の場合に有効です。 ディープスカイ撮影の場合は、通常、「Average Over」オプションを1フレームに設定するだけで十分です。

ツールには、フォーカス検出の計算を制御するための設定もありますが、これらはツールによって異なります。ほとんどのツールには次のようなオプションがあります。

「黒色しきい値 Black Threshold 」ー このレベル以下のものは計算から除外され、ダークレベルノイズが計算に含まれないようになっています。 レベルは、最大輝度に対する割合で表されます。

「ノイズ低減 Noise Reduction 」ー 測定を行う前に画像に ガウスぼかし をかけて、ピクセルノイズをカットします。ぼかしの量を調整することができます。 なお、この調整を行った場合、画面上の画像にはぼかしが表示されません。

また、各フォーカスツールには、わずかながら内蔵の簡易ヘルプが用意されており、「ヘルプ」リンクをクリックまたはマウスオーバーすると表示されます。 以降の各ツールのヘルプを参照してください。

コントラスト（エッジ）検出

惑星や表面の焦点に適しています。 画像内のコントラストの総量を測定します。フォーカスが良ければコントラストが高くなり、スコアが高くなります。

背の高い緑のバー（高い値）は、コントラストが高く、ピントが合っていることを意味します。短い赤いバー（値が低い）は、焦点が最も悪いことを示しています。

ヒストグラムレンジ検出（輝度範囲）

惑星や地表の焦点（特に高ノイズ）に適しています。 画像の最も明るい部分と最も暗い部分の間の範囲を測定するため、フォーカスが良ければ高いスコアが得られます。 ノイズの多い（ゲインの高い）画像に対しては、コントラスト（エッジ）検出よりも効果的です。

背の高い緑のバー（高い値）は、コントラストが高く、ピントが合っていることを意味します。短い赤いバー（値が低い）は、焦点が最も悪いことを示しています。

フーリエ解析ディテール検出

惑星や表面の焦点に適しています。 フーリエ変換 を用いて、画像中の小さなスケールの細部を調べ、フォーカスを測定します。 焦点が合っていれば、スコアは高くなります。 コントラスト検出方式に比べ、ノイズに弱い可能性があります。

背の高い緑のバー（高い値）は、コントラストが高く、ピントが合っていることを意味します。短い赤いバー（値が低い）は、焦点が最も悪いことを示しています。

マルチスターFWHM（半値全幅）測定

星や点光源に適しています。 フレーム内の適切な星の FWHM （星の幅の指標）を測定し、平均値を算出します。 ピントが合っていないフレームでは星が大きく見えるため、この測定値が大きくなり、値が小さいほどピントが合っていることになります。

マルチスターFWHMスコアには、星の検出を調整するためのいくつかのコントロールがあります。星の検出数が20個以上（数百個以下）になるように調整してみてください。 これらの調整方法については、以下を参照してください。

有効なスコアを生成するためには、少なくとも5つの適切な星が検出されなければなりません。検出された星が5つ未満の場合、プレースホルダースコアとして25が報告されます。

「ホットピクセルの抑制 Suppress Hot Pixels 」ー このオプションを有効にすると、画像内の単一のホットピクセルから星を検出しないように星の検出処理を調整します。 大きなピクセルのカメラと短焦点の望遠鏡を使用している場合（つまり、星が非常に小さい場合）は、このオプションをオフにする必要があります。

「ストレッチの使用 Use Display Stretch 」ー このオプションを選択すると、画像に適用された ストレッチ画面 が星検出にも使用され、暗い星の検出が容易になります。 一般的には、このオプションは選択しないでください。

「感度 Sensitivity 」ー この値を大きくするとより多くの星を検出しようとし、小さくすると検出される星の数が少なくなります。 以下の点に注意してください。

· 感度を高く設定すると、星の検出に時間がかかり、積み上げ作業が遅くなる可能性があります。

· SharpCapは、200個以上の星が検出された場合は感度を下げ（最低75）、25個以下の星が検出された場合は感度を上げ（最高75）、自動調整してくれます。

「最大輝度 Max Brightness 」ー FWHM測定の一部で考慮される星の最大輝度レベルです。 完全に飽和した星は、それらがどれほど飽和しているかを知ることができないため含まれていません。つまり、不正確な結果をもたらす可能性があります。

「ノイズ低減 Noise Reduction 」ー 有効にすると、SharpCapが低レベルのノイズやホットピクセルを無視できるように ガウスぼかし を適用します。 これを増やすと、ノイズの多い画像でも星を正しく検出できるようになります。

短い緑のバー（低い値）は、最高のフォーカスを示します。 赤いバー（高い値）は、最悪のフォーカスを示します。

このオプションでは、実際には「半値幅」を測定します。半値幅はFWHMと密接な関係がありますが、ノイズや形の悪い星の影響をそれほど受けない特性です。

バーティノフマスク

星などの点光源に適しています。 スコープの開口部にバーティノフマスクを置き、選択ツールを使って星と線の周辺を選択する必要があります。 3本のラインが同一点で交差し、スコア（プラスまたはマイナス）が最もゼロに近いとき、最高のフォーカスが得られます。

バーティノフツールを使用するには、適切な直径のバーティノフマスクを望遠鏡の先端に設置する必要があります。 0.1と0.1は同じくらい良く、0.0は完璧で、+3.9と-3.9は同じくらい悪いです。

「角度分解能」と「線幅」は、バーティノフのフォーカススコアにのみ見られるコントロールです。

「角度分解能 Angular Resolution 」ー デフォルトでは1度につき1回スキャンしますが、より細かく設定することも可能です。 設定可能な値は、0.20°、0.25°、0.33°、0.5°、1.0°です。

「線幅 Line width 」ー ピクセル単位で測定され、スクリーン上で見られるバーティノフスパイクの幅にほぼ一致するように設定する必要がある。 設定可能な値は1～40で、5刻みとなっています。

緑色の短いバー（低い値）が最適です。値はプラス、マイナス、ゼロのいずれかです。 値がゼロの場合、最高のフォーカスを示します。 赤いバーの値が大きい（プラスまたはマイナス）と最悪です。

FWHM（半値全幅）測定

星やその他の点光源に適しています。 単一の星の幅（FWHM）を測定します。領域選択ツールを使って選択する必要があります。 焦点が合うと星の幅が狭くなり、FWHMスコアが低くなります。

マルチスターFWHMは、通常、シングルスターよりも優れています。なぜなら、10個または100個のFWHM測定を行い、それらを平均化しているため、 測定値に含まれるノイズや系統的エラーが少ないはずだからです。

短い緑のバー（低い値）は、最高のフォーカスを示します。 赤いバー（高い値）は、最悪のフォーカスを示します。

どのフォーカスツールを使えばいいのか？

多くの星が見える視野の場合は、マルチスターFWHMを使用します。

単一星（または、まばらな）フィールドの場合は、FWHMまたはバーティノフマスクを使用します。

惑星や表面の焦点には、3つのツールが用意されています。

· コントラスト（エッジ）検出

· ヒストグラムレンジ検出（輝度範囲）

· フーリエ解析ディテール検出

惑星や地表に焦点を合わせようとするときは、次のことを考慮してください。

· フォーカススコアのアルゴリズムの違いは、「ピントが合っていることへの感度」と「ノイズへの感度」という相反する2つの要素間のより良いバランスを見つけようとする試みです。

· どれを使うかは、試行錯誤や個人的な好みの問題になるでしょう。 コントラスト（エッジ）検出ツールは、ほとんどの状況で（おそらく）良い出発点となります。

フォーカス手順

次の表は、望遠鏡の良好な焦点を得るために必要な様々な手順を示しています。

望遠鏡（ASCOMフォーカサーなし） | 望遠鏡（ASCOMフォーカサー付き）
準備 · 望遠鏡を使って遠くの天体に最初の視覚的焦点を合わせる。
設定 · 画像ヒストグラムツールを使って、天体が露出オーバーになっていないか確認します。 · 最適なフォーカススコアを得るために、適切なフォーカスアシスタントツールを選択し、黒レベル、天体検出パラメータ、ROI ボックスを調整します。 · グラフをリセットすると、スコア履歴が消去されます。
フォーカス調整 · 望遠鏡のフォーカサーを手動で調整し、フォーカススコアを見る。 ベストスコアが出たらストップ。 · 望遠鏡のピントが合う。 | フォーカス調整 · カメラコントロールパネルのフォーカサーコントロールを使って望遠鏡のフォーカサーを調整し、フォーカススコアを見る。 · グラフタブを使用。 ベストスコアが出たらストップ。 · 望遠鏡のピントが合う。

設定段階では、表示されるスコアは、望遠鏡の焦点を変えるのではなく、ソフトウェアのパラメータを変更することで変化するため、意味がありません。

設定段階の最後に、「グラフをリセット」してスコア履歴を消去します。

フォーカス段階では、望遠鏡のフォーカサーのみを調整し、SharpCap内の設定は一切行わないでください。 これは、フォーカススコアに見られる変化が、望遠鏡のフォーカスの変化の結果のみであり、他のものに影響されないようにするためです。 フォーカス段階でSharpCapの設定を変更した場合（例えば、惑星が視野内で移動し、 ROI を更新する必要がある場合など）、調整後にグラフをリセットし、事実上、フォーカス段階を再度開始します。

フォーカスは、次のような要因で変化する可能性があるため、作業を通じて確認する必要があります。

· 天体に薄い雲がかかっている。

· 大気環境の変化。

· 望遠鏡筒に影響を与える温度変化。

· 光学系に影響を与える温度変化。

以下の表は、ASCOMフォーカサーを搭載していない望遠鏡と搭載した望遠鏡に対して、 適切なフォーカスアシスタントツールを使用した場合にSharpCapで表示される内容を示しています。

望遠鏡（ASCOMフォーカサーなし） | 望遠鏡（ASCOMフォーカサー付き）
星のFWHM測定。このトレースでは、フォーカサーを適正な位置（初期の黄/緑のバー）から不良な位置（赤のバー）に移動させ、再び適正な位置（濃い緑のバー）に戻している。 [注：履歴タブのみ。] | 惑星のコントラスト（エッジ）検出。このケースでは、フォーカサーを最初の悪い位置から良い位置に移動させ、過去の良い位置から悪い位置に戻しています。 [注：履歴とグラフのタブ。]

画面の説明

フォーカスアシスタントツールのうち、ここでは「コントラスト（エッジ）検出」を選択すると、次のような画面が表示されます。 この画面レイアウトは、6つのフォーカスアシスタントツールすべてに共通しています。

コントラストフォーカス スコアツールを使用した場合、4つの異なる領域があります。

撮影表示領域

撮影表示領域には、赤い選択領域の長方形が表示されます。 この長方形は、マウスでドラッグしてサイズを変更できる。 長方形は、天体の端に移動したり、完全に表面上に移動したり、天体全体を囲むように拡大したりすることができます。

· 赤い四角の外にある部分は、フォーカススコアの計算から除外されます。

· 長方形内で影が付いていない部分（黒レベルより上）は、フォーカススコアの計算に含まれます。

· 長方形内で影が付いている部分（黒レベル以下）は、フォーカススコアの計算から除外されます。

コントロール表示部

· どのフォーカススコアが選択されているかによって、様々なコントロールが可能です。詳しくは フォーカスツール の項をご覧ください。

· 状況に応じた ヘルプ が用意されています。

グラフ表示部

· グラフ領域には、以下のようなグラフが表示されます。

フォーカススコアの履歴（履歴タブ）。

「フォーカススコア → フォーカス位置」のグラフ（グラフタブ）。 [注意：ASCOMフォーカサーが接続されている場合のみ表示されます] 。

· 黒い線はフォーカス位置（後述）を示すためのものです。

· 青い線はスコア平均、つまり過去10回のフォーカススコアの平均値です。

· 左側の縦軸は、フォーカススコアを示しています。

· 右側の縦軸はフォーカサーの位置を示しています。

スコア表示部

· パネルのタイトルバーを使って、パネルをSharpCapのメインフォームからドラッグして、例えばセカンドモニターに配置することができます。

· ピンのアイコンは、作業領域に表示されているフォーカスツールを自動で隠すことができます。

· 現在のスコア（Now）と、これまでに記録したベストスコア（Best）が表示されます。

· リセットボタンは、履歴とベストスコアを消去します。 選択領域の有効化、無効化、移動、黒レベルの変更を行った場合は、リセットボタンを使用してください。

グラフ表示部

「履歴 History 」タブは常に表示されます（下図1）。 追加の「グラフ」タブは、ASCOMフォーカサーが接続されている場合にのみ表示されます（下図2）。

履歴タブ

履歴タブでは、フォーカススコアの値の履歴が列グラフで表示され、左に最も古い測定値、右に追加される最新の測定値が表示されます。

履歴タブは、ASCOMフォーカサーを接続していないときのデフォルトのタブです。ASCOMフォーカサーとの併用も可能ですが、グラフタブの方がフォーカサーとの併用に適しています。

（図1）

ASCOMフォーカサーが接続されていない状態

· 青色の「平均 Average 」ラインが表示されます。 これは、過去10回のフォーカススコア測定の平均値で、ノイズの影響でフォーカス値がフレームごとに変化している場合に、その変化を確認するのに役立ちます。

· 新しい測定値は右に表示され、古い測定値はチャート領域が埋まると左から消えていきます。

（図2）

ASCOMフォーカサーが接続されている場合

· 右側にフォーカサー位置の軸が表示されます。

· 黒いフォーカサー位置の線が表示されます。

· 青色の平均線が段差のあるグラフに変化します。

· 平均線の各水平区分は、ASCOMフォーカサーがある特定の位置にあった期間に対応します。

· フォーカサーの位置が移動すると、新しい区分が始まります。

· 横方向の区分は、フォーカサーがその位置にあったときの全サンプルのフォーカススコアの平均値を示しています。

次の図は、赤（ピントが悪い）から緑（ピントが良い）までの、表示できる色の範囲です。

赤 ＞ オレンジ ＞ 黄色 ＞ ライトグリーン ＞ ダークグリーン

フォーカスグラフのバーの色と高さは、「良好なフォーカス」の絶対的な尺度ではなく、最近行われた他のフォーカス測定との相対的な尺度です。 最近得られた最高のフォーカススコアは、常に鮮やかな緑色のバーが表示され、グラフの中で最も高い（FWHMでは最も低い）ものになります。 これは完璧なフォーカスを意味するものではなく、フォーカスツールを開いてから（または最後にリセットしてから）達成された最高のフォーカスを意味します。 ただし、バーティノフマスクツールの場合は例外で、ゼロの値が完璧なフォーカスの絶対的な尺度となります。

グラフタブ

このグラフは、SharpCapでASCOMフォーカサーが設定され、接続されている場合にのみ表示されます。 その場合、このグラフはデフォルトのタブになります（ただし、必要に応じて「履歴」タブに戻すこともできます）。

グラフタブでは、フォーカススコアの測定値がフォーカサーの位置によってどのように変化するかを、フォーカサーの位置を横軸に、フォーカススコアを縦軸にとっています。

ベストフォーカスとは、グラフの一点にピーク（最大）がある場合（コントラストベースのフォーカススコア）と、 一点に谷（最小）がある場合（星ベースのフォーカススコア）を指します。

このグラフは、フォーカサーの位置を-3から+3まで以下の順序で段階的に変化させたものです。

-3 -2 -1 0 1 2 3

このグラフは、横軸にフォーカサーの位置を、縦軸にフォーカススコアをとっています。

· 緑色の上向きの三角形は、フォーカサーがプラス方向（外向き）に動いたときのデータポイントです。

· 赤い下向きの三角形は、フォーカサーがマイナス方向（内側）に移動している間に収集されたデータポイントです。

· 色が強いほど新しいデータであることを示しています。

· 色が薄くなっているものは、古いデータを示しています。

下の履歴グラフの黒い線と数字は、上のグラフで示したフォーカサーの位置に対応しています。

ASCOMフォーカサーがインストールされている場合は、「ヒストグラム」タブではなく「グラフ」タブで作業を行います。 フォーカススコア軸（グラフの左側）を使ってベストフォーカスのポイントを見つけるには、以下を参照してください。

· ピーク値 （コントラスト検出/フーリエ オプション Contrast Detection/Fourier options ）です。

· 最小値（FWHMオプション）。

· ゼロ（バーティノフオプション）。

注意：この機能は、2台のテストカメラに搭載されているフォーカスオフセットコントロールを使って試すことができます。 フォーカスオフセットコントロールは、カメラコントロールパネルの [ テストカメラコントロールパネル ] にあり、0以外の値に設定されている場合、任意の画像にぼかしを適用します。

履歴とグラフ操作

· マウス左ボタンでドラッグして移動する。

· マウスホイールで拡大する。

· マウスの中ボタンまたは右ボタンで領域を選択すると、その領域に拡大します。

· 紛失した場合は、ダブルクリックでデフォルトの表示に戻ります。

· グラフ領域で右クリックすると、ASCOMフォーカサーを右クリックした位置に移動させるオプションが表示されます。

青色のラインにマウスを合わせると、過去10サンプルのフォーカススコア履歴が表示されます。

フォーカサーのグラフにマウスを重ねると、フォーカサーの位置とスコアレポートが表示されます。

グラフ上で右クリックすると、クリックした位置にフォーカサーを移動させることができます。 移動には、 「直接移動 Move Focuser to - (Direct) 」する方法と、フォーカサーのバックラッシュに対応するための 「過去に移動して戻る Move Focuser to - (Past and Return) 」の移動があります。

適切な黒レベルの設定

ほとんどのフォーカスアシスタントツールでは、黒レベルの値を正しく設定することで、より信頼性の高いスコアを得ることができます。 黒レベルの明るさを下回る画像の部分は、フォーカススコアの計算に含まれません。 なお、マルチスターFWHMスコアでは、黒レベルを手動で設定する必要はなく、自動的に処理されます。

黒レベルを設定する前に、画像ヒストグラムで被写体が露出オーバーになっていないか確認してください（画像ヒストグラムが右端に来ないようにしてください）。

大きな惑星を撮影する場合、最適な黒レベルは、天体と暗部の間に薄い黒の領域がある状態です。 これでは見づらいので、ツールバーの拡大ツールを使って細部を改善します。

コントラスト検出（エッジ）のフォーカススコアを使用。

ここではズームは100%です。 この場合、黒レベルはたまたま6.5％でした。

実際の最適な黒レベルの割合は、カメラや設定によって異なります。 写真は、黒レベルが正しく設定されている場合の黒レベルの濃淡の見え方を示しています。

ROI（関心領域） が惑星の上にあり、ROI内のすべてが目的の画像の一部である場合。 必要なのは、そのすべてのフォーカスを測定することです。 したがって、この場合、黒レベルは「低」または「ゼロ」に設定されます。

星を目標にした場合、最適な黒レベルは、被写体と暗部の間に薄い黒の部分がある状態です。 この状態はわかりにくいので、ツールバーの拡大ツールを使ってください。

FWHMフォーカススコアを使用。

ここではズームは150%です。 この場合、黒レベルはたまたま21％でした。

実際の最適な黒レベルの割合は、カメラや設定によって異なります。 写真は、黒レベルが正しく設定されている場合の黒レベルの濃淡の見え方を示しています。

これは、正しい黒レベルがフォーカススコアに与える影響であり、黒レベルやその他のパラメータを調整した後は、 その結果が実際のフォーカス品質の変化と混同されないように、必ずグラフをリセットする必要があることを示しています。

バーティノフマスクの使用

「バーティノフマスク」フォーカスアシスタントツールが機能するためには、望遠鏡にバーティノフマスクが装着されている必要があります。 以下は、従来の方法でバーティノフマスクを使用して得られた回折パターンの例で、3つの回折スパイクが1つのポイントで交差していれば、良好なフォーカスであることを示しています。

良好 | 左側がオフ | 右側がオフ

バーティノフマスクは単一星に使用され、領域選択エリアで選択する必要があります。焦点が合っていることは、短い緑色のバーで示されます。 バーがない場合、またはスコアが0の場合は、完璧な焦点であることを示します。

バーティノフマスクツールを使用する場合は、黒レベルコントロールが、フォーカススコアの計算から回折スパイク周辺の背景領域を除外し、 可視の回折スパイク領域全体を含む値に設定されていることを確認してください。

SharpCapは、バーティノフマスクによって形成された回折線を検出し、それらがすべて一点に集まっているかどうか（焦点が合っているかどうか）を計算します。

時々、間違った線が検出されることがあり、その場合（右図参照）、フォーカススコアは正確ではありません。 誤った線が検出された場合、黒レベルやカメラのゲインや露出などのパラメータを調整することで、問題を解決できることがほとんどです。

回折スパイク

SharpCapのマスクを重ねる

結果のグラフィック

SharpCapのマスクで回折スパイクを重ねると、ピントの合ったグラフィックになる。

（ほぼ）オートフォーカス

ASCOM製フォーカサーを使用する場合、SharpCap Proのユーザーは、上記の手順の多くを自動化できる追加機能を有効にすることができます。自動化可能な機能は以下の通りです。

· フォーカサーの様々な位置をスキャンし、各位置でのフォーカススコアを測定し、フォーカスの質のグラフを自動的に作成します。

· ベストフォーカススコアを計測した位置に自動的に戻ります。

· 同じ範囲のフォーカス位置を自動的に再スキャンし、測定された最高のフォーカススコアに達すると自動的に停止します。

これらの機能はすべて、フォーカスグラフの右上にあるコントロールを使って作動させることができます。

なお、「Goto」と「Scan」グループのボタンは、マウスを移動させるまでは少しだけ透明になっていますが、これはボタンの裏側のグラフを見るためです。

オートフォーカススキャン

スキャンインボタンとスキャンアウトボタンを使って、フォーカサーの位置の範囲で自動スキャンを開始し、各位置でのフォーカスの質を測定することができます。 これは、スキャンが予想されるベストフォーカスの位置を通過するように、ベストフォーカスのポイントの片側から始めるのが最適です。

フォーカススキャンの詳細は、「オプション...」ボタンを押して、次のように設定します。

· 「スキャンステップサイズ Scan Step Size 」ー これは、各フォーカス測定の間のフォーカサーの動きの量です。

· 「最大ステップ数 Max Step Count 」ー フォーカススキャン中に行うスキャンステップサイズの総ステップ数です。

· 「各ステップで収集するサンプル Samples to collect at each Step 」ー 各ステップでのフォーカススコアの測定に使用するフォーカススコアサンプルの数を指定します。 なお、SharpCapは、各ステップで動きが落ち着くまで最低1フレーム待ってから測定を開始します。

なお、平均化オプション（5フレームなど）を設定していて、ここで3つのサンプルを設定した場合、各ポジションで15フレーム5*3が収集されます。

スキャンは継続され、次のいずれかが起こるまで、フォーカスグラフにデータが蓄積されます。

· 停止ボタンを押したとき

· フォーカサーが最大または最小の位置に達したとき

· または、オプションで設定したステップ数が完了しているとき

スキャン処理中は、通知バーに進行状況の情報が表示されます。

ベストフォーカス位置の検出

SharpCapは、オートフォーカスと手動フォーカスの両方の動作で蓄積されるフォーカスデータを監視し、データのパターンを見つけようとする。 特に、SharpCapはベストフォーカスのポイントを探しており、それはピーク（下図）または谷のいずれかを持つベストフィットカーブによって示される。 谷型のベストフィット曲線は、最低値が最適なフォーカススコア（星のFWHM測定など）に期待され、ピークは最高値が最適なスコア（コントラスト測定など）に期待されるべきである。

ベストフィットカーブは、2つの測定位置の間にあっても、ベストフォーカスが期待できる位置を示します。

フォーカスのベストフィットカーブを正しく検出するためには、 フォーカス測定にはベストフォーカスの位置の両側に少なくとも2～3回の測定が含まれていなければならないことに注意してください。 フォーカススキャンがこのポイントまたはその前で停止した場合（つまり、停止したポイントがこれまでで最高のスコアを持っている場合）、 スキャンボタンをもう一度押すと、ベストフォーカスのポイントを過ぎてもスキャンが継続されます。

ベストフィット曲線が表示されるのは、測定値に比較的強いパターンがあり、フォーカススコアにピークや谷がある場合のみです。 フォーカスの測定値が非常に変動的で、明確なパターンがない場合、曲線は表示されません。 この問題は多くの場合、フォーカサーの動きが「バックラッシュ」領域内にあり、モーターが回転していてもフォーカサー自体はカメラを動かしていないことが原因です。

ベストフィット曲線が表示され、明確な山や谷があれば、「Goto Best Position」や「Goto Best Score」オプションを使って、 フォーカサーをベストフォーカスが得られた位置に戻すことができます。

ベストフォーカスに戻る

SharpCapは、最高のフォーカススコアが得られたフォーカサーの位置に戻るか、2つの「Goto ...」ボタンを使って、 これまでに得られた最高のスコアと一致する位置にフォーカサーを戻そうとします。

これらのボタンにはそれぞれドロップダウンがあり、最適なデータを使用する動きの方向を、プラス（外向き）またはマエナス（内向き）から選択できます。 フォーカスグラフには、2本のベストフィットラインが表示されます（外向きの動きは緑、内向きの動きは赤）。 フォーカスハードウェアに大きなバックラッシュがある場合、これらの線は同じ位置でピークを迎えない可能性があるため、どちらかを選択できるようにしておくことが重要です。

「Goto」ボタンのデフォルトの動作は（ドロップダウンから選択せずにボタンを押した場合）、直近にスキャンされた方向を選択することになっています。

どのようなスキャン方向を選択しても、また「Goto Best Position」と「Goto Best Score」のどちらを使用するかに関わらず、 SharpCapは常に使用するスキャンデータと同じ方向のベストフォーカス位置に近づくようにフォーカサーを移動させ、 必要に応じて最初にベストフォーカス領域を通過させて正しい方向からのアプローチを可能にする。 これは、フォーカサー機構のバックラッシュの影響を最小限に抑えるために必要です。

最適なフォーカス位置を求める

「Goto Best Position」ボタンは、バックラッシュが少なく、前のフォーカス位置に正確に戻れるフォーカサーの場合に最適なオプションです。 ステッピングモーターを使用したフォーカサーがこれに該当します。

このボタンを押すと、SharpCapはベストフィットカーブ上の最適な位置のフォーカサー位置を計算し、 その位置にフォーカサーを移動させます（バックラッシュを最小限に抑えるため、カーブの測定と同じ方向から）。 これで、あなたの望遠鏡がベストフォーカスになるはずです。

最適なフォーカススコアを求める

「Goto Best Score」ボタンは、お使いのフォーカサーの精度が低く、同じフォーカサーのポジション番号を選択しても物理的に全く同じ位置に戻ることが難しい場合に最適なオプションです。 DCモーターを使用したフォーカサーは、一般的にこの部類に入ります。

このボタンを押すと、SharpCapはフォーカススコアが前回のフォーカススキャンで測定されたピーク値と一致する（もしくはそれに近い）位置を探そうとします。 SharpCapが達成しようとする目標スコアは、前回のフォーカススキャンで測定された2つのベストスコアの平均値です。 この手順では、同じ方向に2回目のフォーカススキャンを行い、目標とするフォーカス値に達した時点で停止するため、 「Goto Best Focus Position」ボタンを使用する場合よりも時間がかかります。

バーティノフマスクによるオートフォーカス

上記のオートフォーカス化の説明では、コントラスト検出やFWHM測定のように、ベストフォーカスの位置で最大値または最小値を与えるフォーカススコア方式を中心に説明しました。 バーティノフマスクのフォーカスツールでは、フォーカススコアがゼロになったところがベストフォーカスとなります。

ここで紹介するオートフォーカス調整手順は、バーティノフマスクツールに対応しており、焦点のスコアがゼロになるポイントに適切に戻ります。

ASCOMフォーカサーとバックラッシュ

フォーカサー機構のバックラッシュは、実際のフォーカサーには必ず存在し、フォーカサーの移動方向によってベストフォーカス位置が異なる位置に現れるという現象が起こります。 つまり、フォーカサーがプラス（＋V）方向に動いているときに、フォーカサーの20100の位置にフォーカススコアのピークがあるとすれば、 マイナス（-V）方向に動いているときには19900の位置にあるということです。 フォーカサーを最高スコアの位置に戻そうとするときは、バックラッシュによる誤差を避けるために、フォーカスを測定したときと同じ方向からアプローチしてください。

フォーカサーのバックラッシュ量（プラス方向とマイナス方向の最適なフォーカス位置の差）を計算し、そのバックラッシュ量を補正するようにSharpCapを設定するのが理想的です。 フォーカサーの設定 を参照ください。

フル自動フォーカス

フル自動フォーカス（ディープスカイイメージ用）は、 シーケンサー と シーケンスプランナー で利用できます。 フル自動フォーカスは、上述のスキャンとベスト位置への復帰のステップをベースにしているため、フル自動フォーカスを使用する前に、 これらのステップが機能することを確認するのが最善です。


極軸合せ

SharpCap 極軸合せは、天文家が優れた極軸合せを素早く、簡単に、確実に実現できるように設計されています。 このアイデアは、Themos Tsikas氏が作成した PhotoPolarAlign アプリケーションに触発されたものです。 Themosは、SharpCapの極軸合せ機能の開発において、テストや提案に協力してくれています。

「極軸合せ」は、「ツール」メニューから起動できます。

その仕組みは？

極軸合せは、極付近を撮影した2枚の写真を解析することで行われる。 1枚の写真を撮影し、SharpCapで解析した後、赤経軸を中心にマウントを約90度回転させて2枚目の写真を撮影する。 それぞれの写真に写っている星を認識して、SharpCapは2つのことを計算します。

1. 各画像に表現されている正確な空の領域 ー この処理はプレートソルブと呼ばれています。 SharpCapには、プレートソルブのアルゴリズムが組み込まれており、インターネット接続や他のプログラムやデータベースのインストールは必要ありません。 SharpCapのプレートソルブは、北極から6〜7度の範囲（NまたはS）でのみ機能します。

2. 1枚目の画像から2番目の画像に移動するときに、星が回転しているように見える回転の中心。

SharpCapは、各画像において望遠鏡がどの赤経と赤緯を指していたかを正確に把握しているため、 画像内のどの位置（あるいは画像からどのくらい離れているか）に天球があるかを把握しています。 また、SharpCapは、星が回転しているように見える位置、つまりマウントの赤経軸が現在どこを指しているかを知っています。 この2つの位置が同じであれば、極軸合せは完璧です。 もし同じでない場合は、マウントの高度調整器と方位調整器を同じ位置になるように調整すれば、極軸合せが完了することになります。

SharpCapは、この処理を画面上で指示し、完璧なアライメントを得るために各方向にどれだけマウントを移動させる必要があるかをライブで表示してくれます。

必要なものは？

· 赤道儀。

· SharpCapに対応したカメラと望遠鏡、ファインダーを組み合わせてマウントしたもの。

· カメラの視野角が約0.5度から約2.5度の間であること。

· 天の極がはっきり見えること。

· 視野内に15個以上の星が見えること。

· すでに極から約5度以内に位置していること。

極軸合せの調整は、このようなズレには影響されないため、ガイダースコープやメインスコープを完全に合わせておく必要はありません。

SharpCapは、少なくとも赤経が30〜45度回転して天球が見えていないと、位置合わせができません。

ステップ バイ ステップ

導入

「極軸合せ」ツールを最初に選択すると、極軸合せを動作させるために必要なものを思い出させる導入画面が表示されます。 必要なものがすべて揃っていることを確認したら、緑色の「Next」ボタンを押して次に進むことができます。

「Next」を押すと、SharpCapは1枚目の画像の撮影に移ります。

1枚目の画像

この段階でSharpCapは、カメラから送られてくる各フレームのプレートソルブを試み、極軸合せの調整を開始します。

そのタイミングで、星が十分に見えるようにカメラの設定を調整するとよいでしょう。露出を2秒に設定し、ゲインを比較的高めに設定するのがよいでしょう （正確な値はカメラによって異なりますが、範囲の上半分から始めてください）。

十分な数の星が検出され、視野が適切な大きさであり、極に近ければ、下のような光景が見られるはずです。

SharpCapがプレートソルブに使用している星は黄色、その他の星は赤で表示されています。 北極点（または南極点）が表示され、その周りに異なる半径の円が表示されています。 天球が見えない場合がありますが、気にせず次の段階に進んでください。

[ 注意：「Next」ボタンは、SharpCapが次の段階に進む準備ができ、ユーザーがボタンを押す必要があるときに緑色に変わります ] 。

プレートソルブに失敗し、[Next]ボタンが有効にならない場合は、次の3つの原因が考えられます。

1. 検出される星の数が少ない。

2. 極から遠すぎる。

3. 視野角が大きすぎる、または小さすぎる。

最後の2つは物理的に設定を変更する必要がありますが、最初の1つは、画面下部の 「星検出 Star Detection 」パラメータを調整するか、 使用するカメラの露出やゲインを調整することで解決できる可能性があります。 星が淡い場合は、露出やゲイン、星の検出感度を上げてみてください。 また、ヒストグラムストレッチ機能を使って星の明るさを上げてみると、SharpCapの星の検出がしやすくなります。

解決したら、「NEXT」ボタンを押して次の段階に進みます。

2枚目の画像

「NEXT」を押した後、赤経軸を約90度回転させます。 RAクラッチのロックを解除するか、マウントにGOTOシステムがある場合はそれを利用して行います。

SharpCapは、引き続き各フレームのプレートソルブを試み続け、十分に回転したフレームを解決できたら、調整段階に進むためのオプションを提供しますが、これは次のようなります。

この時点で、SharpCapは、赤経軸が指し示す画像内の位置を計算している。これは、画像が回転しているように見える位置であり、赤い十字とRAラベルでマークされている。 赤経軸の位置は視界に入らないかもしれないので、表示されなくても「Next」ボタンが有効になっていれば心配ありません。

「Next」ボタンが有効になっていない場合は、回転量を変えてみてください（あるいは逆方向に回転させてみてください）。 それでもうまくいかない場合は、回転した位置で十分な星が検出されていない可能性があります。 この問題を解決する最善の方法は、マウントを回転した位置に置き、「Restart」ボタンを押してアライメント調整の最初に戻ることです。 これにより、回転した位置のビューが残り、星の検出コントロールを調整して、その方向でプレートソルブができるようになります。

次のボタンが押されるまで、高度や方位の調整をしないでください。

調整

ボタンを押して調整段階に移ると、画面上の明るい星のひとつがハイライトされ、次のように目標を示す矢印が表示されます。

極軸合せを整えるために必要なことは、指示された星を目標に移動させることです。そうすることで、NCPと赤経軸が整い、極軸合せが完了します。 画面下の Polar Align Error の下には、マウントを移動させる方向を示すガイドラインが表示されます。 このガイドラインは、カメラ画像に重ねて大きな文字で表示されています。

移動方向は以下のように解釈してください。

· 望遠鏡やマウントを天球の方向に向けて見て立つ。

· 望遠鏡の遠端（空を向いている方）が指示された方向に移動するようにマウントを動かしてください。

· つまり、方向が左と下を示しているならば、（北半球では）マウントを動かして、スコープがさらに西を向くようにし（極に向かって左を向くように）、 さらに下を水平線に向ける必要があります。

方向の提案は、あなたの緯度と経度に基づいて計算されます。あなたがこれらを正確に入力していない場合、移動する方向（上下左右）の情報はおおよそのものにすぎません。

調整段階では、ハイライトされている星が別の星に変わるかもしれませんが、心配する必要はありません、調整を続けてください。 これが近づいてくると、矢印と目標は一対の平行線に変わり、最終的にはそれらを合わせて調整を行う必要があります。

問題を無視して星を目標に入れるか、あるいは星の検出とプレートソルブがより確実に機能するように、ゲイン、露出、星の検出感度をさらに調整してください。直近のフレームの状態を確認してください。 頻繁に「解決できませんでした Could not solve 」と表示される場合は、星検出やカメラの設定を確認する必要があります。

アライメント誤差が2分角以下であれば良好、1分角以下であればより良好です。 アライメントエラーをゼロまで下げようとして時間を無駄にしないでください。

ヒント

· ガイドカメラ（ZWO120MC、QHY5LII、Altair GPCAMなど）に、 焦点距離200mm程度のファインダー/ガイダーを使用してみてください。

· 画面に表示される説明を読み、手順を確認してください。

· SharpCapが十分に星を見ることができるように、高いゲインと2～4秒の露出を選択します。

· マウントが三脚に設置されている場合、三脚のマウントプレートのボルトで、 マウント自身の高度・方位調整器よりも細かい調整ができることがあります。

· スコープやファインダーがマウントに正しく装着されていれば、ずれていても結果に影響はありません。

· SharpCapは、マウントをどの方向（上下左右）に移動させるかを判断するために、おおよその経度を知る必要があります。 タイムゾーンの設定が間違っていると、間違った方向が表示されることがあります。

極軸合せの設定

極軸合わせ処理をするために使用できるいくつかのオプションがあります。

今後はこの導入部をスキップする

導入ページで、このオプション= 「今後はこの導入部をスキップする Skip this introduction in future 」 をチェックすると、次回から極軸合わせを実行したときに導入ページが表示されず、最初の画像ステージに直接進みます。

位置情報と屈折補正 Location & Refraction Correction

SharpCapは、極軸合わせ処理の2つの側面に現在地を使用できます。

· 調整手引きするときに、上/下/左/右の方向を決定する

· アライメント時に大気の屈折を補正する

デフォルトでは、SharpCapはコンピュータのタイムゾーンから経度を推定します（例：ESTは75Wと推定）。 SharpCapは、最初の画像段階で北半球/南半球の入力を求め、45Nまたは45Sのいずれかの緯度を想定します。

これらのデフォルトの位置推定値は、上下左右の誘導方向が精度よく機能するのに十分なものですが、屈折補正を有効にすることはできません。

屈折補正を有効にするには、SharpCap設定の 極軸合わせタブ で、正確な位置を直接入力するか、SharpCapにASCOMマウントから位置を取得するように設定する必要があります。 これにより、極軸合わせツールが更新され、真の位置と適用される屈折補正量が表示されます。

なお、緯度40度以上であれば、屈折の補正をする意味はないでしょう。緯度が低いほど極の屈折が大きくなるので、赤道に近いところで観測する場合は補正が重要になります。

自動進行と小回転モード

他にも、有効にしておきたいオプションが2つあります。

「自動進行 Auto Advance 」ー このオプションを有効にすると、SharpCapは、次の段階が利用可能になったときに自動的に次の段階に移動し、「Next」ボタンを押す必要がなくなります。

「回転角度を小さくする Allow smaller rotation angles 」ー これを有効にすると、2つの画像間の回転を小さくして調整することができます。 これは、スカイトラッカーのように回転が制限されているマウントには便利ですが、精度が落ちる可能性があります。

星の検出設定

これらの設定は、極軸合せ処理による星の検出に影響を与えます。理想的には、1枚の画像（そのうち15枚）に30〜50個程度の星が検出されれば、最良の結果が得られます。

「感度 Sensitivity 」ー この値を大きくするとより多くの星を検出しようとし、小さくすると検出される星の数が少なくなります。 以下の点に注意してください。

· 感度を高く設定すると、星の検出に時間がかかり、積み上げ作業が遅くなる可能性があります。

· SharpCapは、200個以上の星が検出された場合は感度を下げ（最小75）、15個以下の星が検出された場合は感度を上げ（最大75）、自動調整してくれます。

「ノイズ低減 Noise Reduction 」ー 有効にすると、 ガウスぼかし を適用して、 SharpCap が低レベルのノイズやホットピクセルを無視できるようにします。 これを増やすことで、ノイズの多い画像でも星を正しく検出できるようになり、 カメラからの新しいフレームごとに異なる値にジャンプする極誤差の問題を減らすのに役立つ場合があります。

「ホットピクセルを抑える Suppress Hot Pixels 」ー このオプションを有効にすると、画像内の単一のホットピクセルから星を検出しないように、星の検出処理を調整します。 大きなピクセルのカメラと短焦点の望遠鏡を使用している場合（つまり、星が非常に小さい場合）は、このオプションをオフにする必要があります。

「ストレッチを使用 Use Display Stretch 」ー このオプションを選択すると、画像に適用された ストレッチ画面 が星検出にも使用され、暗い星の検出が容易になります。一般的には、このオプションは選択しないでください。

調整オプション

これらのオプションは調整段階で利用可能で、マウントの高度や方位を物理的に調整している間、 SharpCapを実行しているコンピューターが容易に見えない状況で役立つように設計されています。

「画像の位置合わせエラーを表示する Show align error on image 」ー このオプションは、カメラの画像上に位置合わせエラーと移動方向の情報を大きくはっきりとした文字で表示します。 この情報は、画像の下に表示される通常の調整用テキストよりも、より遠くからでも視認でき、読み取ることができます。

「調整時に音を出す Play sounds during adjustment 」ー SharpCapを有効にすると、カメラからの調整フレームが処理されるたびに、 コンピューターのサウンドシステムからビープ音を鳴らします。極座標の誤差が小さくなると、ビープ音のピッチが大きくなり、位置合わせ処理の音声フィードバックが提供されます。

極軸合せのトラブルシューティング

以下の情報は、「極軸合せ」ツールでよく遭遇する問題を解決するのに役立つでしょう。

いくら調整しても、誤差をゼロにすることはできません

極軸合せの誤差を正確にゼロにする必要はありませんし、それをしようとするとクリアスカイの時間を無駄にしてしまいます。 極座標が1分以内に収まっていれば、長時間露出の撮影には十分だと考えてよいでしょう。

最初の段階で立ち往生,「Next」ボタンが有効にならない？

この段階で詰まってしまうということは、SharpCapがカメラからの視点をプレートソルブできず、カメラが極の近くを指しているかどうかを判断できないということです。 最新のフレームステータスは常に赤で 「解決できませんでした Could Not Solve 」と表示され、最初のフレームステータスは 「作業中 Working 」と表示されます。 時々、カメラからのフレームが他のフレームよりも少し良く、プレートソルブが行われた場合、最終的にこの段階を通過することができます。

この問題の原因として考えられることは...

検出される星の数が少ない

もし、検出された星の数が少ない（10個以下）場合は、この原因が最も考えられます。この問題を解決するための提案は以下の通りです。

· カメラの露出を最大2～4sまで上げる

· カメラにゲインコントロールがある場合は、カメラのゲインを上げます。約1/2のゲインから始めて、最大値まで上げてください。

· 星の検出感度を初期値の75から上げる

· 星の検出が正しく行われるように、ストレッチ画面機能を使って星の輝度を上げてみてください。

· ピントが合っているかどうかを確認してください。ピントの合っていない星は、ピントの合っている星よりも検出しにくくなります。

カメラ / 望遠鏡が極から5～6度以上離れたところに向けられている

多くの星が検出されているにもかかわらず、プレートソルブが失敗する場合は、極から離れすぎている可能性があります。

SharpCapには、北極から7度までの星のデータベースがあります。これよりも極から離れた場所の画像を撮影した場合、プレートソルブは失敗します。 SharpCapにプレートソルブアプリケーションがインストールされ、設定されている場合は、 プレートソルブ（ソルブのみ） メニュー項目を使用して、望遠鏡がどこを向いているかを正確にチェックすることができます。 また、プレートソルブアプリケーションがなくても、フレームを保存し（「スナップショット」ボタンを押す）、 それを nova.astroptrometry.net にアップロードしてプレートソルブを行うことで、 このチェックを行うことができます。

ホットピクセルが星として検出される

カメラによっては、ホットピクセル（光が当たっていないのに最大値を示すピクセル）が発生することがあります。 星検出の設定によっては、単一のホットピクセルが星として検出されることがあります。 このようなホットピクセルが十分に存在し、検出されると、プレートソルブアルゴリズムが混乱する可能性があります。 この問題が発生した場合は、 「 ホットピクセルを抑える Suppress Hot Pixels 」オプションがチェックされていることを確認し、 必要に応じて「ノイズ低減 Noise Reduction 」の設定を増やしてください。

視野角が小さすぎる、または大きすぎる

SharpCapの星のデータベースは13等星まであるので、各半球に16000個以上の星があり、プレートソルブの計算が可能です。

視野が非常に狭い場合、カメラから見える範囲に13等星以上の星がほとんどないため、プレートソルブに失敗することがあります。 これは、視野角が0.5°以下になると頻繁に発生します（左右いずれかの方向）。視野がこれより小さい場合は、プレートソルブが断続的に行われることがあります。 プレートソルブ作業ができるほどの星が見えることもあれば、偶然にも星が少ない場所に行ってしまい、プレートソルブ作業ができないこともあります。

視野角が非常に大きい場合、SharpCapの星データベースでカバーされている範囲以外の明るい星が検出され、プレートソルブの操作が混乱することがあります。 カメラを ROI モードにして、視野を狭くしてみてはいかがでしょうか。

ステップ2またはステップ3で動かない場合、何も更新されないか、すべてに非常に長い時間がかかります

望遠鏡を調整したり、SharpCapを極軸合せ調整の新しいステップに移動させた後、結果が表示されるまで、またはSharpCapが解決策を見つけるまで、長く待つ必要はありません。 通常は数秒程度です。最も一般的な原因は、SharpCapがカメラから送られてくるすべてのフレームソルブをできていないことで、 実際には10フレームに1フレーム、あるいは100フレームに1フレームしか解決できていないかもしれません。

この問題は簡単に見つけることができます。というのも、 「最新のフレーム Most Recent Frame 」の状態は、ほとんどの場合、 赤で「解決できませんでした Could not solve 」と表示されますが、時々、 緑の「解決しました Solved 」に変わるからです。

この問題は、上記の最初の段階で止まってしまう問題と全く同じ原因です。 上記の「検出される星の数が少ない」を参考に、星が十分に検出されているか、すべてのフレームが解決されているかを確認してください。

これは、赤経軸を中心とした回転により、プレートソルブが困難な空の領域（おそらく明るい星が少ない）にカメラが移動したためと考えられます。 この問題を解決する良い方法は、赤経軸を回転させたまま、SharpCap 極軸合せ手順を最初の段階に戻し、カメラの設定と星の検出設定を調整して、 回転した位置で良いプレートソルブが得られるようにしてから、ホームポジションに回転して調整を続行することです。

誤った結果が出る – SharpCapは、調整後の極軸合わせは素晴らしいとのことですが、そうではありません

まず確認すべきことは、マウントのAlt / Azを調整する前に、「Next」ボタンを押して調整段階に移行したかどうかです。 調整段階に移行していないと、正しくない極軸合わせになってしまいます。

最も一般的な原因は、マウントが赤経軸を中心に回転しているときに何かがずれていることです。 ガイドスコープ / カメラを使用している場合は、スコープがしっかりと取り付けられていないか、 ケーブルが引っ張られている（あるいは単にぶら下がっている）ことでカメラがわずかにずれている可能性があります。 この問題は、赤経軸のベアリングに問題がある人も経験しています。

この問題が疑われる場合には、まず問題があることを確認する必要があります。 SharpCapの極軸合わせを通常通り実行し（ホームポジションからスタートして90度回転）、通常通り調整します。 調整が終わったら、スコープを90度の位置に置いたまま、SharpCapで極軸合わせを再度実行します（今回は、回転を促されたらホームポジションに戻します）。 2回目の極軸合わせ実行時の測定値が1回目の測定値と一致していれば、おそらくこの問題はありません。 大幅に一致しない場合は、回転時の屈曲／移動が原因であると考えられます。

この問題をテストするには、マウントを約15度ずつ段階的に回転させることで簡単にできます。 SharpCapは、回転の各段階において、回転の中心（赤経軸が向いている場所）と計算される位置に暗赤色の十字をプロットします。 これらは、屈曲がない場合、画面上で緊密なグループを形成するはずです。 下のスクリーンショットでは、左に示した極軸合わせの実行時に、ガイドカメラへのケーブルを意図的に緩めています。 ここでは、カメラを引っ張るケーブルの重さのために、さらに回転させると、測定された赤経軸の位置がずれているのがわかります。 ケーブルをしっかりと固定すると、赤経軸の位置ははるかに緊密なグループになります。

緩いケーブル ー 赤い縦のクロスは、赤い斜めのクロス（最終的な結果）から離れたラインに広がっていることに注意してください。

固定されたケーブル ー 赤い縦のクロスが、赤い斜めのクロスの周りに密集していることに注目してください。

回転時のたわみに問題があることがわかったら、すべての接続部を締め、すべてのケーブルを固定するという通常のハードウェアの修正を試してみることができます。 また、2ステップ時の極軸合わせを、ホームポジションから左に30〜40度、右に30〜40度の位置で行うことも有効な手段です。 機器の構成にもよりますが、回転後に「上」から「横」になるのではなく、穴あけ作業中にスコープの大部分が「上」になるため、 この方法を使用した場合には、たわみが少なくなります。

SharpCapが言うマウントの移動指示の意味

ここで示されている指示は、あなたがマウントを見ていて、極の方向を向いている（つまり、望遠鏡が極のあなたから離れた方向を向いている）ことを前提としていることを忘れないでください。 「上に移動 move up 」という指示は、「望遠鏡の対物レンズがより上を向くように、マウントの高度を移動する」ことを意味し、 「右に移動 move right 」という指示は、「望遠鏡の対物レンズがより右（NHの場合は東、SHの場合は西）を向くように、 マウントの方位を移動する」ことを意味しています。

家/木/障害物の上に北極星が見えるだけ

極の視界が限られている場合、マウントがホームポジション（スコープが上、ウェイトが下）にあるときには極周辺の領域が見えていても、90度回転したときには見えないことがあります。 このような場合には、望遠鏡を垂直方向の左側に30～40度傾けた状態からスタートして、垂直方向の反対側に30～40度回転させてみてください（合計60～80度の回転）。 こうすることで、スコープを高い位置に保つことができ、うまくいけば、必要な回転を達成しつつ、極の視界を維持することができます。


センサー解析

カメラメーカーでは、センサーゲイン、リードノイズ、 ダイナミックレンジ などのチャートを作成しています。 これらのチャートは、センサーの特性を比較したり、撮影状況に応じてカメラの設定を最適化するのに役立ちます。 しかし、これらのチャートを作成するには、何十回もの測定と緻密な計算が必要であり、熱心なアマチュア天文家以外には手の届かないものでした。

SharpCapは、ほぼすべてのカメラでこの分析を行うために必要な測定と計算を自動化しています （DirectShowカメラは、SharpCapが調整できるような細かな露出制御がないため、分析できません）。

SharpCapのセンサー解析の結果は、画像時のゲイン、露出、 ビット深度 の選択をサポートする スマートヒストグラム 機能に使用されます。

センサー解析の準備

SharpCapの「センサー解析」ツールを実行する前に必要な手順は以下です。

· SharpCapでカメラを使いこなす

· カメラを最高ビット深度モードに設定し、カラーカメラの場合は、RGBモードではなくRAWモードに設定します。

· 常時点灯している光源を探す。

o   晴天や曇天の日の自然光が理想的ですが、雲が点在する日は明るさが変わるのでNGです。

o   人工光でも効果はありますが、多くの人工光では50/60Hzのちらつきが発生するため、短時間の露出では画像に線が見えることがあります。 このような場合は、背の高い細い領域を選んで測定し、領域内の複数のちらつきバンドを含めるようにします。

· カメラの視野内に均等に照明された領域が表示されるように配置します。視野全体が均一に照らされている必要はなく、少なくとも100×100ピクセルの範囲であればよい。 これには以下の方法があります。

o   望遠鏡を使って、ピントを外して曇り空や青空に向けたり、白いTシャツなどをレンズにかぶせたりします。

o   カメラのノーズピースに半透明の1.25インチダストキャップを使用する

o   CSまたはCスレッドレンズを使用して、均一に照らされた特徴のない物体（紙など）にカメラを向ける。

o   レンズやカバーを外した状態での使用（ただし、センサーへのゴミの付着に注意）。

· センサーの照明の明るさを変えられるようにしてください。調整を正常に完了させるためには、このようにする必要があるかもしれません （注：実行中に照明の明るさを変えないようにしてください - 開始時に適切な明るさになるように処理する必要があるかもしれません）。

· 暗所での測定が可能なように、センサーを覆うことができるように準備する。

· カメラのカラーバランス、ガンマ、コントラストのコントロールを「ニュートラル」に設定してください。

· 物理的なシャッターを持つカメラ（デジタル一眼レフ）や、フレームをダウンロードするのに時間がかかるカメラ（大型CCD）の場合は、静止画モードにしてください。

センサー解析の実行

処理を開始するには、「ツール」メニューから「センサー解析」を選択します。 既存のツール（ヒストグラムやライブスタックなど）が閉じて、「センサー解析」が開きます。選択範囲の四角形は、画像表示領域にも表示されます。

基本的な指示と小さな画像ヒストグラムがセンサー解析ツールウィンドウに表示されます。 「ビニング測定をスキップする Skip Binning Measurements 」 チェックボックスは、センサー解析が失敗した場合や、前回の実行で ビニング の効果を測定する最終段階で行き詰まった場合にのみチェックします。 準備ができたことを確認したら、「スタート」ボタンを押します。

測定領域の選択

開始ボタンを押すと、SharpCapは自動的にカメラの最低ゲインレベルを選択します。また、カメラの露出を自動的に調整して、選択正方形内の領域を正しく露光します。

この時点で、移動量を調整したり、選択正方形のサイズを変更したりして、明るさと色が均一な画像の領域を選択します。 画像の適切な領域には、下の図のようなヒストグラムが表示され、右端に1つの対称的なピークが見られます。 また、照明の明るさを調整して、推奨される範囲の露出時間を確保する必要があります。 SharpCapは、カメラの特性に基づいて必要な範囲を計算し、2秒以下の露出からカメラの最小露出を超える露出まで、すべての解析手順を実行できるようにしています。

露出値は、照明レベルの変更や選択領域の調整に応じて自動的に調整されるので、自分で調整しないでください。

選択された領域が均一でない場合、ヒストグラムには複数のピークや非対称のピークが現れます。 露出時間が長すぎたり短すぎたりすると、警告メッセージが赤で表示され、変更すべき点が指示されます。下の図はその両方を表しています。

光量が正しく調整され、選択領域が選ばれたら、「続行 Proceed 」ボタンを押して実際の測定を開始します。

測定中は、以下の点に注意してください。

· 測定中のカメラの邪魔をすること

· カメラの前に移動すること（これにより、測定される光のレベルが変わります）

· カメラに到達する光の光量が変化するのを待ちます（センサーをカバー / カバー解除するように求められた場合を除く）。

· カメラのコントロールを手動で調整すると、不正確または無効な結果になる可能性が高くなります。

ビット深度と e/ADUの測定

センサー測定の最初の段階では、カメラが生成する画像の真のビット深度と、最小ゲイン時のカメラの e/ADU を測定します。 e/ADUの測定を行っている間、ヒストグラムの右側に散布図が描かれ、様々な露出で測定されたフレームノイズと測定された平均ADUの関係を示します。 緑のクロスは直線に近いはずです。

この後、センサーに光が当たらないようにカバーをかけて暗所での測定を行う必要があります。

直線性とゲインレンジの測定

次の段階では、露出時間の変化に対するセンサーの応答の直線性を測定し、カメラのゲインコントロールの影響についても大まかに測定します。 この測定では、光量を変化させないことが特に重要です。最終的な結果でセンサーの直線性の限界が低くなる最も可能性の高い原因は、測定中の光量の変化です。

ダーク測定

SharpCapは、暗所での測定を可能にするために、センサーを覆うように促します。

SharpCapは、高ゲインと100ミリ秒の露出を設定します。これにより、この時点で画面に白い画像が表示される可能性があります。 センサーを覆うと、カメラの画像が暗くなり、 「続行 Proceed 」ボタンが有効になります。 センサーが完全に覆われたら、[続行]ボタンを押します。

大量の暗部の測定を行う必要がありますが、 フレームレート が非常に低くない限り、通常はかなり早く進みます。 最初の測定では、ゲインとオフセットコントロールにさまざまな値を設定して、画像の明るさを測定します（オフセットはブラックレベルまたは明るさとしても知られています）。 続いて、さまざまなゲイン値でダークフレームに存在するノイズの量を測定します。

暗部の測定が終了したら、最終的なゲインとビニングの測定を行うために、センサーのカバーを外さなければなりません。

ゲインとビニングの測定

SharpCapは、センサーのカバーを外すように促します。

センサーのカバーを外すと、SharpCapは選択領域を正しく露出するために露出の調整を開始します。 この時点で、（必要に応じて）最初に行ったように、照明の明るさや選択領域を調整して、測定領域が均一になるようにし、露出が推奨範囲内になるようにします。 必要な調整が終わったら、「続行」ボタンを押します。このボタンは、センサーのカバーが外れたときに有効になります。 「続行」ボタンを押した後は、それ以上の調整は行わないでください。

「続行」ボタンを押すと、センサー測定の最終段階に入ります。この段階では、カメラのゲインを徐々に調整し、ゲインの変化に対応するための露出の変化量を測定します。 このとき、カメラの照明の明るさが変わらないようにすることが重要で、そうしないと正しくない結果が出てしまいます。

最後に、カメラのビニング設定を簡単に調整して、カメラがビニングをどのように扱うかを判断した後、結果を表示します。

センサー解析結果

測定作業の主な結果は以下の通りです。

· 結果表の上に表示されているセンサーの 「ビット深度 Bit Depth 」は12ビットで、センサーは 212 (4096) 種類のADU値（異なる明るさのレベル）を生成することができます。

· ゲインの設定を変えた場合の e/ADU値を、グラフと表の緑のクロスで示しています。 この数値は、カメラで測定した明るさを 1ADU増加させるために、1ピクセルあたりに必要な電子の数です。

· ゲイン設定を変えた場合のカメラのノイズ読み取り（グラフと結果表では赤い十字で表示）。 これは、カメラの電子回路が各ピクセルの明るさを完璧に読み取れないために、各画像に付加されるノイズの量（電子換算値）を表しています。

表に示された他の結果

· ピクセルが飽和するまでに保持できる電子の数（100％の白信号が得られる）。

· 各ゲイン設定の相対的なゲイン（最小ゲインの乗数またはdBで測定）

· 各ゲイン設定のダイナミックレンジ ー 正しく測定できる最も明るい信号（最良信号）と最も暗い信号（読み取りノイズ）の比率です。 この値は、写真のストップ（事実上の2の累乗）で測定されます。

通常、グラフには2つの滑らかな曲線が表示され、e/ADUゲインと読み取りノイズの両方の最大値が左側に表示されます。 上の例では、ゲイン値が約200のときに読み取りノイズが急激に低下しています。 この場合、カメラセンサーはゲインが200よりも高くなると、より高感度で低ノイズのモードに切り替わり、それが測定値に反映されています。

SharpCapは、完了したセンサー解析の結果をコンピュータに保存し、 解析したカメラの スマートヒストグラム 機能を提供するために使用します。分析を再実行すると、保存されていた前のバージョンは上書きされます。 以前に保存されたセンサーデータは、センサー分析ツールを再度選択しても表示されません。 ただし、スマートヒストグラム 脳ウィンドウ のタブでは表示されます。

スマートヒストグラムの機能をフルに活用するためには、カメラの最大ビット深度（RAW12/RAW16/MONO16モード）と8ビット深度（RAW8/MONO8モード） の両方で分析する必要があります。

センサー分析は無料の機能で、SharpCap Proのライセンスは必要ありませんが、SharpCap Proのライセンスをお持ちのユーザーは、 必要に応じて結果から値の表をコピーすることができます。

なお、センサー解析は、カメラを静止画モードにして実行することができます。 これは、物理的なシャッターを持つカメラ（デジタル一眼レフカメラなど）や、フレームのダウンロードに時間がかかる高解像度のCCDカメラにお勧めです。

センサー解析のデータファイル

センサー解析データは、フォルダ内に保存されたファイルに格納されます。

%APPDATA%\SharpCap\SensorCharacteristics

このフォルダの代わりに

C:\Users\<your windows user name>\AppData\Roaming\SharpCap\SensorCharacteristics

あるコンピューターのセンサー解析ファイルを別のコンピューターの同じフォルダーの場所にコピーすれば、それぞれのコンピューターで解析を実行する必要はありません。

SharpCap Proのライセンスをお持ちの方は、これらのファイルをテキストエディタで開き、保存されているデータを確認することができます。 SharpCap Proのライセンスをお持ちでない場合は、これらのファイルは暗号化されており、SharpCapのみが読むことができます （解析結果のデータをコピーしたり、データファイル経由でデータにアクセスすることはSharpCap Proの機能です）。


ADC調整

大気拡散について

水面に出入りする光線が表面で曲がって、水中のものが実際よりも深くないように見えるのと同じように、 星や惑星からの光は、真空の宇宙空間から私たちの大気圏に入るときにわずかに曲げられます。 光はごくわずかに垂直方向に曲げられ、大気がない場合に比べて光源が空の少し上（地平線の上）に見えるようになります。 それだけではなく、青の光は緑の光よりも曲がり、赤の光よりも曲がります。 この効果は、光源が地平線に近づくほど強くなります（曲がる量の合計と、赤から青への変化の量の両方において）。

この影響は、明るい天体の両側にカラーフリンジとして現れ、天体の上には青、下には赤のフリンジが現れます。 例えば、地平線近くで撮影した三日月型の金星の画像では、その極端な例を以下に示します。

この効果は、特に高解像度の惑星撮影を行う際に、画質の低下をもたらします。 ソフトウェアを使って、赤、緑、青の色チャンネルを再調整することで、この影響をある程度元に戻すことは可能ですが、 この方法では、それぞれの色チャンネル自体がこの影響でぼやけてしまうという問題を解決することはできません。 例えば、深い青の色は、青チャンネルの緑に近い色よりも曲がってしまいます。

この問題を解決するには、カメラと望遠鏡の間に設置された大気分散補正器（ADC）と呼ばれる装置を使用するのが良いでしょう。 この装置は通常、1対の調整可能なプリズムを使用して、光に色に応じた曲げを加えます。 正しく調整することで、ADCの効果が大気の影響を打ち消し、画質へのダメージを取り除く（あるいは少なくとも大幅に減らす）ことができます。 ADCとその仕組みについては、次のWebページで詳しく紹介されています。 スカイ インスペクターADCページ

SharpCap ADC調整ツール

SharpCapの「ADC調整」ツールは、最適な画質を得るためにADCを調整するのに役立つように設計されています。 このツールは、カメラ画像の3つのカラーチャンネルがどの程度ずれているかを見やすく表示し、ADCの調整作業の指針となります。

上図の金星の高分散画像にこのツールを適用すると、次のような結果が得られます。

このことから、次のことに気付いてください。

· これは、ADC調整パネル（下図）の 「黒のしきい値 Black Threshold 」コントロールを調整することで実現しています。 SharpCapの計算では、赤い影付き領域は無視されます。黒しきい値を調整して、目標周辺の暗い領域をすべて影付きにしますが、 目標の一部（エッジのカラーフリンジを含む）を影付きで覆わないようにしてください。

· 緑の点は、画像の緑チャンネルの輝度の中心を示しています。

· 青と赤の線は、青と赤のチャンネルの輝度の中心が、緑のチャンネルの中心からどのくらい（どの方向に）ずれているかを示しています。 見やすくするために、線の長さを長くしています。

· 線に隣接する数字は、緑と赤のチャンネルの中心（赤）と緑と青のチャンネルの中心（青）の間のオフセットの大きさ（ピクセル）を示しています。

· ADCの調整とは、簡単に言うと、赤と青のオフセットが最小になるように、ADCの回転と補正の大きさを調整することです。

ADCを調整するために、いくつかのコントロールが用意されています。

· 「黒のしきい値 Black Threshold 」ー これは、暗い背景（無視される）と明るいターゲット（計算に含まれる）を分ける画像の明るさの割合を指定します。 赤い影が背景をすべて覆い、目標を囲む（ただし覆わない）ように調整します。

· 「フレーム全体の平均 Average Over Frames 」ー 新しいデータ位置でグラフを更新する前に、何フレーム分の測定を行うか。 画像にノイズが多い場合は、この数値を大きくするとよいでしょう。

· 「リセット」ー グラフから過去のオフセットデータを消去します。

· 「領域選択を利用した天体の追跡 Track object using selection area 」ー 領域選択 ツールを使用して画像の特定の領域に測定を制限した場合、このボックスをチェックすると、 SharpCapは領域選択内の明るい天体の中心を自動的に維持します（天体が移動した場合も同様です）。

調整の履歴グラフは、分散の測定値が時間の経過とともにどのように変化したかを示しています（ADCの調整による）。

画面に表示されている赤い線の長さ（赤 - 緑のオフセット）は、ゼロより上に表示されている赤い列で追跡され、 青い線の長さ（青 - 緑のオフセット）は、ゼロより下に表示されている青い列で追跡されます。矢印は、各測定時の各線の方向と相対的な長さを示しています。

新しい測定値は、グラフの右側に継続的に追加されます。グラフがいっぱいになると、古い測定値が徐々に左側に移動し、最新のデータが右側に表示されるようになります。

調整手順

ADC調整は、2段階の手順で行われます。まず、ADCの回転を補正し、次にADCが適用する補正量を調整して、赤と青のオフセット線に可能な限り小さな値を与えます。調整の手順については、 スカイ インスペクターADCページ をご覧いただくか、以下の手順を試しください。

回転調整

この段階では、ADCの補正の大きさを最大に設定します。この設定とSharpCapのADC調整ツールの準備ができたら、ADC（カメラも回転可能）を徐々に360度回転させます。 回転中は、オフセットラインの大きさに注意してください。このとき、ADCと大気が同じ方向に色を曲げようとするため、分散量とオフセットラインの長さが最大になる。 その最大値から180度離れたところで、分散量とオフセットラインの長さが最小値になるはずです。この時点でADCは大気の分散を補正しているが、過剰に補正していることになる。 この調整段階では、オフセットラインの方向は重要ではありません。オフセットラインの長さと、回転中のどの位置でその長さが最大と最小になるかを気にすればよいのです。

この2つの位置を確認したら、分散が最も小さく、分散が大きい場所のほぼ反対側になるようにADCを配置し、補正の大きさの調整に移ります。

微調整

上記の回転調整を終えた時点で、ADCは正しい方向に調整されていることがわかっているので、あとは2本のオフセットラインの長さが最小になるまで、 ADCが適用する補正量を徐々に減らしていくだけです。この位置が決まれば、回転の微調整でさらにオフセットを減らすことができるかどうかを確認することができます。


ピクセル値の読み出し

メニューの「ツール」メニューで ピクセル値の読み出し ツールを使うと、画像内の任意のピクセルの詳細な輝度情報を表示することができます。 このツールを選択すると、画像上に赤い十字線が表示され、十字線の中心にあるピクセルの明るさに関する情報が表示されます。

画像内の任意の場所をクリックすると、その位置に十字線が移動します。また、左ボタンを押しながら画像上でマウスを動かすと、十字線はマウスの位置に追従します。 十字線を必要なピクセルの上に正確に置くのが難しい場合は、ツールバーのズーム機能を使って対象領域を拡大し、ピクセルを大きくして選択しやすくすることができます。

十字線の隣に表示される情報は、カラーカメラかモノクロカメラかによって異なります。

モノクロカメラの場合、以下のような情報になります。

· X： 十字線の中心となるカメラ画像内のX座標。

· Y： 十字線の中心となるカメラ画像内のY座標。

· LUM： 十字線の中心にあるピクセルの輝度（明るさ）の値。

RAWモードのカラーカメラの場合、X位置とY位置が一緒に表示されます

· RAW： ピクセルのRAW輝度

· CHN： ピクセルに対応するカラーチャンネル（R(ed)、G(reen)、B(lue)のいずれか）。

· R, G, B： 画像をフルカラーに デバイヤリング した後の、そのピクセルの3つのカラーチャンネルの輝度値です。

RGBモードのカラーカメラの場合、X位置とY位置が一緒に表示されます

· R, G, B： 画像をフルカラーにデバイヤリングした後の、そのピクセルの3つのカラーチャンネルの輝度値です。

ピクセルの値は、0～255の範囲（8ビットモードの場合）、または0～65535の範囲（10、12、14、16ビットモードの場合）で測定されます。

「ピクセル値の読み出し」ツールを無効にするには、ツールメニューから「ピクセル値の読み出し」ツールを再度選択します。

なお、このツールを選択すると、現在表示されている レチクル が無効になり、逆にレチクルを選択すると、このツールが無効になります。


ピクセル位置/クリックして最近に

「ピクセル位置／クリックして最近に」ツールは、画像の任意の部分の天球上の位置を確認したり、選択した任意の点で画像の中心を再設定したりするための使いやすい方法です。 この機能を使用するには、GOTOマウントが設定されており、SharpCapに接続されていること、およびSharpCapで使用するために設定されたプレートソルブツールがあることが必要です。 これらの条件が満たされていない場合、このツールのメニュー項目は有効になりません。

もし、最近プレートソルブを行ったことがあれば（現在の位置から数度以内）、すぐに方向キーが表示されます（以下参照）。 それ以外の場合は、十字線と 「利用可能なプレートソルブ情報がありません No Plate Solving information available 」という情報メッセージが表示されます。

この時点で、このツールの機能を有効にするためにプレートソルブ操作を実行する必要があります。

· 画像内の任意の場所を指示通りにダブルクリックします。これにより、現在のマウントポインティング座標から15度以内の範囲に限定して、プレートソルブ操作が行われます。

· 「プレートソルブ後再同期」メニュー項目またはマウントコントロールの「GPS」ボタンを使用します。 これらのオプションは、上記のようにプレートソルブ操作を実行し、さらに元の目標座標の周りでマウントを再同期および再最近にします （詳細については、 プレートソルブ後再同期 を参照）。

· プレートソルブ(ソルブのみ) メニューを使って、プレートソルブを実行する。これは、有効な解決策を求めて空全体をスキャンするため、 上記の2つのオプションに比べてかなり遅くなることに注意してください。

プレートソルブ操作が成功すると、カメラ画像に十字線の座標と方向が重ねて表示されます。

この重なりには多くの情報が含まれています。

· 赤い十字線は、画像内の選択された位置を示しています。この位置は、画像内の任意の場所をクリックすることで移動できます。

· 黄色い文字は、選択された位置の赤経と赤緯の座標を示しています。 JNOW と J2000 の両方の値が表示されています。 この座標を使って星座早見表などで特徴を確認する場合には、J2000の座標値を使うことになるでしょう。

· 緑色の矢印は、画像内の赤経と赤緯の増加と減少の方向を示しています。例えば、+RAは赤経が大きくなる方向を、-Decは赤緯が小さくなる方向を示しています。

· 緑の矢印の上にある目盛りは、基準点（赤い十字線）から目盛りまでの赤経と赤緯の変化の大きさを示しています。 例えば上図では、＋と-の赤緯方向ともに15分、赤経は1分のところに目盛りがついています。

· シアンの矢印は、肉眼でターゲットを見た場合に適用される方向、つまり、下は地平線を指し、上は天頂を指し、左は方位座標が小さくなる方向、 右は方位座標が大きくなる方向を示しています。

方向指示器が表示されたら、目標範囲をクリックすることで、画像の任意の部分に再配置することができます。

SharpCapは、選択された位置を画像の中央に配置するために必要なマウント座標を計算します。この計算には、プレートソルブで検出されたマウントのポインティングの不正確さと、 プレートソルブ操作以降の動きが考慮されます。

ポイントをダブルクリックすると、SharpCapが動作確認を促します。動作を確認するプロンプトが表示されます。

「はい」をクリックすると移動が行われ、「いいえ」をクリックすると何も行われません。

一部の操作では、プレートソルブ情報が無効になり、方向が表示されなくなります。 この現象が発生した場合は、別のプレートソルブ操作を行って、方向を再び有効にしてください。この現象が発生する原因としては、以下のようなものがあります。

· カメラの解像度、ビニング、パン／チルト（ROI）の設定変更

· プレートソルブが発生したマウント位置から10度以上離れた場所に移動したため。

「ピクセル位置／クリックして最近に」ツールを無効にするには、ツールメニューからこのツールを再度選択します。

なお、このツールを選択すると、現在表示されている レチクル が無効になり、逆にレチクルを選択すると、このツールが無効になります。

注意：赤経と赤緯矢印が間違った方向を指している可能性があり、クリックして再中心化する操作が天の極の非常に近くで不正確になる可能性があります。 特にカメラの視野内に天球が入っている場合は、注意が必要です。

注意：天頂に近い場所では、上下左右の矢印が正しくない方向を向くことがあります（特に天頂がカメラの視野内にある場合）。


シーイングモニター

シーイングモニターは、SharpCapが以前から提供しているフォーカス支援のための画質測定技術を新たに応用したものである。 これまでのようにピントの合う位置を探すのではなく、画像の鮮明度を測定することで、目の疲れを感じることなく、クリアな視界の瞬間を捉えることができるようになります。

シーイングモニターはツールメニューから起動され、最新の値が強調表示された最新の画質範囲のグラフを表示します。 これにより、シーイングが最高の状態であることを客観的に測定できます。

すべての新しいフレームは、鮮明度（コントラスト）について分析され、その結果は画像の下に表示されるグラフに追加されます。 結果の品質は、 領域選択ツール を使用して関心のある領域を選択することで向上します（例えば、黒点、プロミネンス、クレーターなど）。 フォーカス測定の標準的なカラースキームを使用すると、シャープなフレームはグラフの右側に緑で、不良なフレームは左側に赤で表示されます。

シーイングが比較的一定であれば、グラフは上の図のように1つのピークを持つことになります。 シーイングが良くなったり悪くなったりすると、下の図のように新しいピークができ始めます（シーイングが良くなると右に、悪くなると左に）。 なお、薄い雲の通過によって明るくなったり暗くなったりするなど、他の要因によってもスコアが変化し、新たなピークが発生することがあります。

どちらのグラフにも、いくつもの縦線が見えます。

· Mean というラベルの付いた破線 ー これまでに測定した全サンプルの平均画質値

· Mean + 2S.D. というラベルの付いた破線 ー 平均値に2つの標準偏差を加えたものに相当する画質の値です。 シーイングが安定している場合、小さなランダムな変動により、このレベルを超えるフレームは約2％しかないと考えられます。

· 赤の実線で「最新の値 Latest Value 」と表示 ー これは、記録された最新のフレームの品質を示しています。 この線がMean + 2SDの線よりも右に移動している時間が長ければ、シーイングが改善されていると考えられます。

また、他の操作によっても画質が変化することがあることを覚えておく必要があります。

· フォーカス調整

· ゲインや露出などのカメラパラメータの調整

· 領域選択の正方形の移動

· 何らかの原因で画像が動いてしまう（トラッキング不良、マウント調整）。

これらが発生した場合、リセットボタンを押してグラフを消去し、新たなシーイングデータの蓄積を開始しないと、データが誤解を招く可能性があります。

シーイングモニターの設定

左側には、シーイングモニターの設定を調整するためのコントロールが表示されています。

· 「サンプル率 Sample Rate 」ー SharpCapがフレーム品質を測定する頻度を示します

· 「<X> フレームの平均 Average Over <X> frames 」ー グラフ上に新しいデータポイントをプロットする前に、いくつのフレーム測定値を平均化するかを制御します。 一般的には、毎秒数個の新しいデータポイントが追加されるように、サンプル率の半分から5分の1の間の値に設定する必要があります。

· 「黒レベル Black Level 」ー それ以下の明るさではすべての部分が無視される画像の明るさレベルを選択します。 この値を適切に設定することで、暗い部分のノイズが画質測定に寄与しないようになります。

· 「ノイズ低減 Noise Reduction 」ー フレーム内の細かいスケールのノイズが画質測定に影響しないように抑えることができます。

最後に、 「キャプチャの長さ Capture Length 」の設定は、「トリガーされたキャプチャ表示」の開始時に何フレームを撮影するかを制御します。

トリガーキャプチャとフィルターキャプチャの機能

SharpCap Proのライセンスを取得すると、 「トリガーキャプチャ Trigger Capture 」と 「フィルターキャプチャ Filter Capture 」という2つの機能が追加されます。 これらの機能は、シーイングモニターのグラフを常に見ていなくても、シーイングが改善されたときに画像をキャプチャするのに役立ちます。

どちらの機能も、シーイングモニターのグラフに 「 しきい値 Threshold 」を設定する必要があり、グラフの任意の位置をクリックして設定・調整することができます。

どちらのモードも、グラフの右端にあるボタンで起動できます。

トリガー付きキャプチャを見ると、 「最新値 Latest Value 」が 「しきい値 Threshold 」を超えたときに自動的にキャプチャを開始し、左側のコントロール領域にある 「 キャプチャの長さ Capture Length 」の設定で指定されたフレーム数をキャプチャします。画質がしきい値を下回った場合でも、 指定されたフレーム数がキャプチャされることに注意してください。

フィルタ付きキャプチャは、別の方法で動作します。「スタート」ボタンが押されると、SharpCapは直ちにキャプチャを開始しますが、 フレーム画像品質がしきい値レベルを下回るすべてのフレームを意図的に破棄します。 これは、ステータスバーに表示されるドロップフレーム数が急激に増加することで反映されます。 しきい値レベルを満たした、あるいは超えたフレームのみがキャプチャファイルに保存されます。 キャプチャは、ツールバーの［撮影停止］ボタンまたは［停止］ボタンが押されるまで続けられます。

注意：「フィルタ付きキャプチャ表示」が有効な場合、すべてのフレームが破棄されるときに、 ステータスバーに表示されるキャプチャフレーム数がわずかに変動しているように見えることがあります。これは正常な動作です。

注意：グラフの「最新値」の線が「しきい値」の線より下にあるときでも、いくつかのフレームが出力ファイルに保存されることがあります。 これは、「最新値」ラインの位置が、多数のフレームの画質の平均値であるためです。 平均値はしきい値を下回っていても、平均値を構成する個々のフレームの中には、しきい値を上回る画質を持つものもあります。


フィーチャートラッキング

フィーチャートラッキングは、太陽・月・惑星の撮像を支援するために設計されたツールで、望遠鏡のトラッキングが完璧でなくても、天体が視野から外れてしまうのを防ぐことができます。 長時間露光のディープスカイ画像では、PHD2ガイディングなどのツールを使ってガイドを行うことができます。

必要なハードウェア

フィーチャートラッキングを使用するには、以下のいずれかを使用する必要があります。

· ASCOM互換のGOTOマウント ー SharpCapの設定の ハードウェアタブ でマウントが選択され、接続されている必要があります。

または

· パルスガイド対応のマウントに接続されたST4パルスガイドポートを持つ対応カメラ。 このオプションを使用するには、ハードウェアタブのマウントオプションで「On Camera ST4」を選択してください。

または

· ROIモードのカメラでは、天体を追跡するために ROI （関心領域） の位置を調整することができます。 このモードでは、トラッキングには制限があり、天体が大きく動くと、SharpCapのROI調整スペースがなくなってしまうことに注意してください。

どちらを選んでもSharpCapは4方向にマウントを動かすことができるが、ST4オプションでは単一の移動速度しか得られないため、 利用可能であればASCOMオプションを選択すべきです。

この機能のために、ガイドスコープやガイドカメラを別途用意する必要はありません。 SharpCapは、通常の撮影機能に影響を与えることなく、メインの撮像カメラの画像を使って動きを追跡します。

フィーチャートラッキングの設定

フィーチャートラッキングは、ツールメニューから選択して起動し、ウィンドウが表示されます。 このウィンドウは独立しているので、フィーチャートラッキングは、フォーカスアシスタンス、シーイングモニター、ヒストグラムなどの他の機能と同時に使用することができます。

フィーチャートラッキング画面の左上には、ガイドに使用するハードウェアが表示され、 ASCOM GOTOマウントを使用する場合は、マウントの 「移動速度 Movement Speed 」を選択することができます。 適切なガイドハードウェアが選択されていなかったり、接続されていない場合は、ここに警告が表示され、ガイド機能が利用できなくなります。 Use Camera ROI オプションは、カメラの撮影領域が最大値よりも小さい値に設定されている場合にのみ有効となり、 ROIの位置を移動することができることに注意してください。

画像の動きを追跡するには、画像の特徴を自動的に検出する方法と、画像の明るさの「重心」を利用する方法の2種類があります。

惑星が唯一の明るいものとして映っている場合には、 「重心 Centre of Mass 」を選択します。月の撮影には 「フィーチャートラッキング Feature Tracking 」を選択します。 その他の天体については、両方を試してみて、どちらが最適かを判断するとよいでしょう。

画像ドリフトの監視開始

「モニター」ボタンを押すと、画像のドリフトの監視が始まります。SharpCapは、画像上の識別可能な特徴点の範囲を自動的に見つけ、画面上に小さな円で強調表示します。 画像が移動すると、これらの位置が画像上の特徴を追いかけ、SharpCapが画像の移動距離と方向を追跡することができます。

画像が非常に低コントラストであったり、非常にピンボケであったりすると、SharpCapは正確に追跡するのに十分な画像の特徴を見つけることができないかもしれません。

以下の場合、追跡が失われる可能性があります。

· 画像の動きが非常に速い

· 画像が大きく移動するため、追跡対象のほとんどが見えなくなってしまう

· 画像の明るさを大幅に変更する

画像監視が有効な場合、「監視状況 Monitoring Status 」 エリアは定期的に更新されます。

「最後の移動 Last Movement 」の値は、最新の測定フレームと前回の測定フレームの間で画像がどれだけ移動したかを示します。 「累積移動量 Accumulated Movement 」は、モニタリングを開始してから検出された画像の移動量の合計を示します。 これらの測定値の単位はピクセルです。

「追跡数 Tracking Points 」の値は、 SharpCapが現在追跡している画像上の特徴の数を示します。追跡されている特徴の数が減少した場合は、 Re-Initialize ボタンを使用して、監視が有効な間、追跡する新しい特徴のセットを見つけることができます。

追跡が正常に機能しているかどうかを、マウントを少し動かして確認してみてはいかがでしょうか。

キャリブレーション

SharpCapは、マウントを4つの異なる方向（RA +/-、Dec +/-またはAlt +/-、Az +/-）に動かしたときに、画像がどの方向に（どのくらい）動くかを計算する必要があります。 これは、カメラの向き、望遠鏡の焦点距離、望遠鏡の光学構成、使用しているレデューサーやバーローレンズなど、さまざまな要素に影響されます。SharpCapでは、 上記の情報をすべて入力する手間を省くために、マウントを各方向に動かして画像の動きを測定することで、この情報を算出しています。

適切な数の追跡数で画像モニターが正常に動作している状態で、 Calibration ボタンを押して較正処理を開始します。

較正中、SharpCapはマウントを4つの方向にそれぞれ移動させます。SharpCapは、合計50ピクセルの画像シフトが測定されるまでマウントを動かし続けます （この値は較正設定で設定できます）。各方向の較正処理では、X軸上の全マウントの動きに対するY軸上の測定された画像の動きのグラフが描かれます。

グラフは概ね直線になるはずですが、この図のように、マウントの初期動作では画像があまり動かないのが一般的です。 これはマウント機構のバックラッシュによるもので、バックラッシュ量が過大でない限り、通常は問題になりません。

較正処理の4つの段階では、4つのマウント移動方向のそれぞれに対応して画像がどのように移動したかを示すグラフが、 「 散布 Scatter 」タブに表示されます。 このグラフは、「X」または十字の形をしているはずです。2つのアームはほぼまっすぐで、お互いに直角に近い状態になっているはずです。

散布図が上図のようにならない場合は、較正に失敗している可能性があります。較正の失敗の原因としては、以下のようなものが考えられます。

· SharpCapがマウントを4方向に動かしても、画像が動かない

· マウントを反対方向に動かすと、画像の移動速度が大きく異なる

· マウントを反対方向に動かすと、画像が反対方向に動かない

· マウントをRA（またはAz）軸方向に移動させたときの画像の移動方向と、マウントをDec（またはAlt）軸方向に移動させたときの画像の移動方向が、ほぼ直角ではない場合

上記のいずれの場合も、マウントの動きに過剰なバックラッシュがあることが一番の原因と考えられます。 バックラッシュの影響を少なくするために、可能であれば移動量を多く設定することが有効です。 また、初期ステップサイズや必要移動量を大きく設定することも有効です。較正に失敗した場合、その理由はキャリブレーションコントロールの「ステータス」に表示され、 詳細は 通常のSharpCapのログファイル と同じフォルダにあるSharpCapの「ガイドログ」に記載されています。

較正が正常に完了すると、「ガイディング」ボタンが有効になります。

注意：較正が成功すると、SharpCapは較正結果を保存し、後で再利用できるようにします。 SharpCapを再起動した後にフィーチャートラッキングに戻った場合、「Calibrate」ボタンの右側にあるドロップダウンを使用して、 保存された較正をロードすることを選択できます。

保存された較正は、カメラの調整や回転を行わず、同じ空の領域を撮影している場合にのみ有効です。

ガイド実行

較正を行った後、または以前に保存した較正を読み込んだ後、「ガイディング」ボタンを押してガイドを開始します。 SharpCapは、天体が画像内でほぼ固定されるようにマウントを移動させようとします。 SharpCapは、天体を「ピクセルパーフェクト」なレベルで静止させようとはせず、天体がゆっくりと視界から外れないようにするだけです。

ガイドの状態は、「累積移動量 Accumulated Movement 」の情報で確認することができます。 ガイドが有効な場合、累積移動量はX=0、Y=0に近い値になります。また、移動量のグラフでは、画像の移動の履歴と修正が表示されます。

動向グラフの赤い十字は、目標位置に対する画像の位置の測定値を表しています（X軸とY軸の単位はピクセルです）。 最新の測定値は赤い十字が大きく、古い測定値は小さく表示されます。青色の矢印は、画像を目標位置に戻すためのガイド補正を表している。

ガイドの手順をコントロールするために、3つの調整があります。

· 「デッドゾーンサイズ Dead Zone Size 」ー 目標位置の周囲で、ガイド補正を一切行わない領域の大きさ（ピクセル単位）を指定します。 デフォルトでは5ピクセルです。

· 「最大移動時間 Max Move Duration 」ー ガイド補正の一部として発行される移動コマンドの最大長（秒単位）です。 実際の移動量は、この長さと選択したガイド率の両方に依存します。

· 「スケーリング補正 Correction Scaling 」ー ガイドコマンドを発行する際に適用する、計算された補正の割合。 一般的には50～70％に設定することで、較正データが100％正確でなくても、過補正や目標の片側からもう片側への振動などの問題が発生しないようにします。


コリメーション

SharpCapのコリメーション（テスト実装）ツールは、視野内の星の大きさを測定することで、ニュートン望遠鏡のコリメーションの問題を発見できるように設計されています。

星雲が少なく、焦点の合った星を撮影した場合、正しくコリメートされたニュートン望遠鏡では、最もシャープな星がフレームの中央にあるはずですが、 端の方や特に隅の方の星は、コマや（潜在的な）他の収差の影響で大きくなります。

コリメーションツールを起動すると、SharpCapはフレーム全体の星のサイズを検出・測定し、検出された星をハイライト表示します。 また、フレーム内の星の大きさにパターンを見つけ出し、画像上に星の大きさの等高線を描きます。

小さくて焦点の合った星は緑から黄色に、大きくて焦点の合っていない星はオレンジから赤にハイライトされます。 上の例では、確かに小さな星の領域があり、それを囲むように焦点の合っていない星の領域がありますが、 そのパターンの中心はフレームの中心のすぐ下にあり、円形ではなくわずかに楕円形になっています。 このズレは、コリメーションが正確でないことを示しています。

パターンの中心からのズレは、主鏡のコリメーションが正しくないことが主な原因です。 楕円形のパターン（非円形）は、主に二次側のコリメーションが正しくないか、カメラが傾いていることが原因です。 フレームの中央に円形（またはほぼ円形）のパターンがある場合は、コリメーションが良好であることを示しています。

左側には、通常の星検出などのコントロールがあります。これらについては、 フォーカスツールコントロール のドキュメントで詳しく説明されています。 コリメーションツールには、フレーム全体の小さな空間スケールでの星の大きさの変化を無視する機能もありますが、 これにより大きなスケールでの星の大きさの変化のパターンを浮かび上がらせることができる場合があります。

コリメーション状態情報

· 「強度パターン Pattern Strength 」ー これは、星の大きさの変化がパターンによってどの程度説明されるかを示すものです。 強度の高いパターンは、強度の低いパターンよりも信頼性が高い。

· 「形状パターン Pattern Shape 」ー 他のパターンでは中心点がないため、コリメーションのガイドには使用できません。

· 「離心率 Eccentricity 」ー これは、楕円形のパターンがどれだけ円形から離れているかを示しています。離心率が0の場合は円形を意味します。

· 「位置ずれ Misalignment 」ー これは、楕円や円形のパターンの中心が、フレームの中心からどれだけ離れているかを示すものです。

· 「 FWHM (半値全幅) の最大/最小 Max/Min FWHM 」ー フレームで測定された星の幅の最小値と最大値を示しています。

注意：このツールはコリメーションエラーを検出することができますが、表示された測定値に基づいてうまく調整することはまだ難しいかもしれません。

なお、コマ補正器を使用すると、視野の中心から離れた星のコマを劇的に減らすことができます。 これにより、画像は劇的に改善されますが、このツールでコリメーションを正確に読み取ることは非常に困難または不可能になります。


ディープスカイ シーケンスプランナー

ディープスカイシーケンスプランナーは、SharpCap シーケンスエディターの複雑な機能に煩わされることなく、ディープスカイイメージング作業を計画し、 自動的に実行するための使いやすい方法を提供します。ディープスカイイメージングに必要なオプションのほとんどは、プランナーが対応しています。

· カメラ設定

· 冷却されたカメラの準備開始

· 天体の選択とフレーミング

· ガイドと ディザリング

· 自動フォーカス

· フィルター交換

シーケンスプランナーで設定できる動作のほとんどは、「テスト」ボタンを使って個別にテストすることができます。 さらに、日中または夜間のテストランモードで、計画したシーケンス全体を実行することもできます。 このようなテストができることで、実際に実行したときに、計画通りにシーケンスが実行されることを確信することができます。

ディープスカイシーケンスプランナーで思うような結果が得られない場合は、より自由度の高い SharpCap シーケンスエディター で実現できる可能性があります。シーケンスプランナーでシーケンスの概要を計画し、 「詳細な編集 Advanced Edit 」ボタンを押して、シーケンスエディターでさらにカスタマイズすることもできます。

なお、SharpCapでシーケンス計画を開始するには、カメラが選択されている必要があります。 カメラが選択されていると、SharpCapは、カメラやその他のハードウェアの性能に合わせてオプションを調整することができます。 また、撮像シーケンスを計画する際には、ASCOMハードウェア（フォーカサー、マウント、フィルターホイール）を接続しておくことをお勧めします。 ASCOMハードウェアが選択されているにもかかわらず接続されていない場合、 シーケンスプランナー画面では、オートフォーカスやフィルター変更などのハードウェア関連の計画機能を有効にするために、接続を促すメッセージが表示されます。

注意：静止画モードで動作しないカメラでは、シーケンスプランナーは使用できません。 現在のところ、以下のタイプのカメラはディープスカイシーケンスプランナーでは使用できません。

· Basler

· セレストロン / 画像ソース

· iNova

· Point Grey (現在のFLIR)

· SharpCapフォルダーモニターカメラ

· Direct Showドライバ経由で使用されるウェブカメラやUSBフレームグラバー

シーケンスプランナーの画面は、以下のスクリーンショットのように4つのエリアに分かれています。

1. 「撮影前 Before Capturing 」では、カメラのパラメータや撮像対象に関する情報を指定したり、 ガイディング、ディザリング、冷却などに関する選択を行います。

2. 「撮影リスト Capture List 」では、イメージング操作中に実行されるすべての異なるキャプチャーを指定します。 ダークフレーム、フラットフレーム、ライトフレームの撮影や、フィルターの変更を行い、LRGBやナローバンドの撮影を連続して行うこともできます。

3. 「撮影完了後 After Capture Complete 」では、カメラの準備やマウントの固定など、画像を撮影した後に行う操作を指定するものです。

4. 「操作ボタン」ー ここにあるボタンを使って、シーケンスの保存、読み込み、実行を行うことができます。 また、テストを実行したり、計画したシーケンスをフルシーケンスエディタに転送して、さらにカスタマイズすることもできます。

ディープスカイの撮影シーケンスを構築するには、まず「撮影前」項目で有効にしたいオプションを選択し、 次にダークフレーム、フラットフレーム、ライトフレームなどの適切な選択で「撮影リスト」を構築します。 最後に、「撮影完了後」に実行するオプションを選択します。詳細については、以下の項目を参照してください。

なお、SharpCapは、シーケンスプランナーに加えた変更を自動的に保存し、次回シーケンスプランナーのウィンドウを開いたときに、最新の設定を復元します。 また、計画を保存して、将来的に再利用することもできます。

撮影前のオプション

「 撮影前 Before Capturing 」項目の各タブでは、イメージングの特定の側面を設定することができます。

撮影設定 Capture Setup

この操作では、すべての画像に使用されるカメラの カラーモード と、保存された画像を書き込むファイル形式を選択できます。

シーケンス中の撮影は、すべてカメラを静止画モードにして撮影します。 このシーケンスはディープスカイイメージングを目的としているため、 カメラの最高ビット深度（RAW16、RAW14、RAW12またはMONO16、MONO14、MONO12）を使用することを強くお勧めします。

撮影した画像をどのような形式で保存するかは、撮影した画像を処理するソフトウェアによって異なりますが、ほとんどの場合、 FITS 形式を選択するのが最適です。

カメラ設定 Camera Settings

この操作では、露出、ゲイン、オフセットなどの最も重要なカメラ設定を行うことができます。 ここで設定されたデフォルトゲインとデフォルトの露出は、特定の初期化段階や撮影ステップで上書きされる場合を除き、撮影シーケンス全体で使用されることに注意してください。 ここで選択されたオフセット／明るさ／黒レベルは、全体を通して使用され、変更することはできません。

これらのパラメータを設定する方法は3つあります。

· 各パラメーターを手動で設定。 Set the default exposure/gain manually

· あらかじめ保存しておいたカメラの設定を含む撮影プロファイルを読み込む Load a capture profile （この方法は、露出／ゲイン／オフセット以外のカメラの設定にも使用できます）。

· SharpCapのスマートヒストグラム機能を使って、空の背景を測定し、最適な値を算出します。 Measure the sky background and set exposure/gain/offset automatically これは、 スマートヒストグラム 脳ウィンドウ を使って空の背景を測定し、推奨される設定を行うのと同じです。 このオプションは、お使いのカメラでセンサー解析データが利用可能な場合にのみ使用できます。

天体情報設定 Target

この操作では、撮影を行う天体に関する情報を設定します。ここで利用できるオプションは、SharpCapでGOTOマウントを設定・接続しているかどうかによって異なります。

GOTOマウントを行わない場合は、シーケンスの実行中に作成される撮影ファイル名の一部として使用される天体名の設定に関するオプションしかありません。

SharpCapでGOTOマウントが設定されていても、接続されていない場合は、 「今すぐハードウェアを接続 Connect Hardware Now 」ボタンを押してマウントに接続し、追加オプションを有効にするよう促されます。

GOTOマウントを利用すると、以下のような追加オプションが利用できます。

· 必要に応じて、最初のステップとして 「マウントの解除 Unpark the mount 」にします。

· 望遠鏡はすでに天体を向いているので、天体名を設定する。 The telescope is already pointing at the target, just set the target name to

· SharpCapに搭載されているディープスカイ天体のデータベース（現在はメシエカタログとコールドウェルカタログ）から天体を選び、その天体に移動します。 GOTO a target from the catalog

o   なお、SharpCapでは、天体の名前だけでなく、現在の高度や方向も表示されるので、現在地平線から離れた天体を簡単に選択することができます。

· 画像化したい天体の座標と名前を入力します。 GOTO target at RA/Dec ..... and set target name to

o   座標はRA/Dec表記で、様々な形式が受け入れられます。例えば、オリオン大星雲の座標は以下のような形式として受け入れられます。

05 35 17.3 -05 23 28 | 05 32 49.8 -05 25 21
RA 5h 35m 17s | Dec -5° 23′ 28″ | 5h35m 17s -5° 23′ 28″
5h35m17.39s/Dec-5°23'28.24" | RA=5h 35.4m, Dec= -05° 27´
RA:05h 35m 24.0s Dec: -05°27'00" | 5h RA, -5° DEC
RA 05h 35.4m | Dec. -05° 27″ | RA 05h 35.4m, dec. –05º 27’
{RA=05:35:16,Dec=-05:23:28} | 5.58805-5.391
(05:35:20.556, -05:18:32.593) | (83.84, -5.309)

いずれの場合も、値が24未満の場合、RA座標は（度ではなく）時単位であるとみなされます。

· 天体名が他の方法で設定されていない場合、シーケンスの実行時に天体名の入力を促します。 Prompt for target name if it is still not set

最後に、プレートソルブアプリケーションを設定し、GOTOマウントを接続している場合は、 プレートソルブ機能を使用して、天体が視野の中心にあることを確認してから撮像を開始することができます。 Use plate solving to center the target, Use an exposure of ..... s and gain これは プレートソルブ後再同期 ツールの使用と同じです。

冷却 Cooling

温度調節機能付きの冷却システムが搭載されているカメラでは、画像撮影前にカメラを特定の目標温度まで冷却することができます。

ガイディング Guiding

撮影時にガイドやディザリングを使用したい場合は、ここで設定することができます。この操作を使用する前に、SharpCap設定の ガイディング設定 でガイド／ディザリングの設定を行ってください。

「ライトフレームの撮影時にガイドが必要（ガイドがなくなったら一時停止） Require guiding while capturing Light Frames (pause if giding lost) 」オプションが設定されている場合、SharpCapはガイドが失われた場合に撮影を一時停止するだけでなく、 画像を継続できるようにガイドの再開を何度も試みることに注意してください。

「撮影中のディザ 300/秒ごとのライトフレーム Dither while capturing Light Frames every (300/seconds.) 」ー ディザリングの動作は、時間間隔が経過した後に終了する次のフレームの終わりに発生します。 例えば、40秒の露光で300秒ごとにディザリングを行うように設定した場合、8thごとにディザリングが行われます （7フレームで280秒かかり、300秒のディザリング間隔が終了する前に終了するため、8th目が開始され、320秒後に終了します）。

フォーカス Focus

ASCOM製フォーカサーを接続している場合は、撮像開始前にオートフォーカスを行うようにSharpCapを設定することができます。

オートフォーカス ステップでは、（ほぼ）オートフォーカス に マルチスターFWHM（半値全幅）測定 ツールを使用しますので、オートフォーカスオプションを使用する前に、手動でそのツールを試し、 必要な設定を行っていることを確認してください。オートフォーカス機能は、カメラの位置がすでにフォーカスに近い状態からベストフォーカスになるように設計されており、 カメラの位置がかなり離れている場合はフォーカスを見つけることができません。

オートフォーカスのステップを設定するために、以下のパラメーターを設定することができます。

· 「スキャンするフォーカサー位置の範囲 Autofocus within +/- <X> of current position before starting captures 」ー これは、現在のフォーカサーの位置からの各方向のオフセット（+/-）として指定され、 最適フォーカスの位置がこの範囲内にあることを保証するのに十分な大きさでなければなりません。

· 「フォーカス用のフレームを撮影する際に使用する露出とゲイン Use Exposure of<X> s and gain <X> while focusing 」ー 一般的には、ピント合わせのステップが極端に遅くなるのを防ぐために、 ゲインを高めに設定し、露出を短めにします。

· 「スキャンする方向 Scan in the <X> direction 」ー この方向は、最終的な最適フォーカス位置までのフォーカサーの動きにも使われます。

· スキャンされるフォーカサーの最小位置と最大位置の間で、フォーカスをテストするための測定点の数です。 using <X> steps

· 「バックラッシュ許容値 Allow for backlash of up to <X> 」ー この値は、バックラッシュによってオートフォーカスのステップが台無しにならないように、 フォーカサーのバックラッシュ量よりも大きな値に設定する必要があります。バックラッシュ補正を設定している場合には、この値を小さく設定することができます。

例えば、現在のフォーカス位置が13200で、以下のようなパラメータを使用した場合、SharpCapは12950から13550の間をスキャンし、 15箇所（位置間のフォーカス ステップ数は約33）を測定することになります。

SharpCapは、スキャンを開始する前に、まず13550の位置に移動し、次に12750の位置に移動し、さらに12950の位置に移動する。 これらの移動により、フォーカシングの動きのバックラッシュが解消される。

最後に、 「フィルター交換時の再フォーカス Refocus when filter is changed 」ー フィルターを交換した後、オートフォーカスのステップを繰り返すオプションを選択することができます。 この機能は、フィルターホイールのフィルターに フォーカスオフセットを設定 する代わりに使用することもできます。

撮影リスト

典型的な 「 撮影リスト Capture List 」を以下に示します。このリストでは、SharpCapがシーケンスの一部として実行する撮影画像の種類と順序を指定します。 右側のボタンを使用して、撮影リスト内のステップを追加、削除、順序変更して、ユーザーのイメージング要件に合わせて調整することができます。

撮影リストの各ステップには、調整可能な以下のプロパティがあります。

· 「フレームタイプ Frame Type 」ー フレームタイプ は、「ライト」、「ダーク」、「フラット」、「ダークフラット」、「バイアス」、「その他」のいずれかに設定できます。 フレームタイプは、撮影した画像を保存する際のファイル名やディレクトリ名に使用されます。

· 「フィルター Filter 」ー 電子フィルターホイールが接続されている場合は、各ステップでホイール内のフィルターを1つ選択することができます。 SharpCapは、そのステップのフレームを撮影する前に、ホイールをその位置に移動させます。 なお、フィルター欄が空欄の場合は、そのステップの前にフィルターホイールを移動させないことを意味します。

· 「フレームの数 Number of Frames 」ー そのステップで撮影するフレーム数

· 「露出の上書き Override Exposure 」ー このチェックボックスをオンにすると、この撮影ステップでは、 カメラ設定 タブで設定されたデフォルトの露出が、指定された値に変更されます。 後続のステップは、この変更の影響を受けません（「露出の上書き」を設定していない限り、デフォルトの露出を使用します）。

· 「ゲインの上書き Override Gain 」ー 「露出の上書き」については、チェックボックスにチェックを入れて値を設定すると、 この撮影ステップで使用する異なるゲインが設定されます。特定のフレームタイプ （フラット、ダークフラット、バイアス）は、ライトフレームやダークフレームと同じ露出／ゲイン値で撮影されないため、 通常、露出の上書きとゲインの上書きを使用します。

· 「前に一時停止、後に一時停止 Pause Before, Pause After 」ー これらのオプションのいずれかまたは両方にチェックを入れると、 ステップ内の画像を撮影する前または後にシーケンスが一時停止します。 一時停止中、SharpCapにはプロンプトが表示され、シーケンスを続行するには「OK」をクリックする必要があります。 この一時停止を利用して、フラットフレームの照明を設定したり、ダークフレームの絞りをカバーしたりすることができます。 また、一時停止中にカメラの設定を調整することもでき、フラットフレームを適切に露光するのに役立つ場合があります。

· 「テスト Test 」ー テストボタンを押すと、ステップがテストされます。 テストでは、ステップに関連するすべての動作が実行されますが、より大きなフレーム数が指定されていても、1フレームしか撮影されません。

例えば、各フィルターで60分の撮影をする代わりに、各フィルターで15分の撮影ステップを設定し、これを4回繰り返すことができます。 2時間後に雲が出てきても、各フィルターのデータが残っているので、安心して撮影できます。

撮影完了後のオプション

これらのオプションは、撮影ステップが完了した後に実行できるステップです。 「マウントをホームポジションに固定 Park the mount 」したり、（冷却されたカメラを使用している場合）徐々に暖めていくことを選択できます。

シーケンスのテストと実行

各ステップのテスト

シーケンスツールを使用して画像処理を自動化することは、画像処理の生産性を向上させる素晴らしい方法ですが （少なくとも、コンピュータが画像処理を行っている間の快適さを向上させることができます）、画像処理シーケンスが適切に動作せず、 エラーのために早期に停止してしまうと、晴天の時間を無駄にしてしまうという現実的なリスクがあります。

実際に実行する前にシーケンスのすべての部分をテストすることは、トラブルの可能性を最小限に抑えるための最良の方法です。 SharpCapのシーケンスプランナーは、シーケンスのテストを簡単に行えるように設計されています。

シーケンスプランナーのオプションの多くの部分に隣接している「テスト」ボタンを使って、個々のセットアップや撮影ステップをテストすることができます。 テストボタンを押すと、選択したオプションの動作確認に必要な最低限のコンテンツを含む短縮シーケンスが作成されます。 テストするオプションの内容によっては、昼間にテストすれば十分な場合もあれば（マウントの固定解除やカメラのオプション設定のテストなど）、 夜空を見ながらテストする必要がある場合もあります（オートフォーカスのテスト）。

個々のステップに対して［テスト］ボタンを使用すると、 「シーケンサー進捗状況 Sequencer progress 」画面が表示されます。 SharpCapは、テストが必要なステップ（およびそれらをテストするために必要な設定ステップ）のみを含む短縮シーケンスを作成することで、テストを実行します。

テストの完了には、数秒から数分かかる場合があります。進行状況画面のログエリアでテストの進行状況を確認するとよいでしょう。 ログに「Error」と表示されている場合は、テストが失敗していることを示しています。 例えば、上のスクリーンショットでは、マウントをターゲット座標に移動させるテストが行われていますが、 ASCOMマウントがすでにトラッキングしていないためにスロー操作を許可しなかったために失敗しました。

進行状況画面に表示されるログがエラーなく完了すれば、テストは成功している可能性が高いですが、それでも確認する価値はあります。 例えば、オートフォーカスのステップをテストしている場合は、検出されたフォーカスが本当にカメラにとって最適なフォーカスであるかどうかを確認してください。

シーケンス全体のテスト

個々のステップが正しく動作していることが確認できたら、最初から最後までのシーケンス全体をテストすることをお勧めします。 そのためには、シーケンスプランナー画面の一番下 「テストラン Test Run 」ボタンをクリックします。

テストランとは、シーケンス内のすべてのステップが問題なく動作するかどうかを確認するための手っ取り早い方法です。 テストランには2つのタイプがあり、どちらかを選ぶことができます。

· 「夜間のテスト Night time test run 」ー これらは、実際のシーケンスの実行に最も近いものです。 唯一の変更点は、露光時間が30秒に制限されていること、すべての撮影が1フレームのみの撮影に縮小されていること、撮影ステップの繰り返しが無視されることです。 カメラの冷却、ピント合わせ、マウントを動かして天体に向けるなど、すべてのセットアップとクリーンアップが実行されます。

· 「日中のテスト Day time test run 」ー これらのテストは、晴天でなくても実行できるように設計されており、 その制限の下で可能な限り多くのシーケンスをテストします。夜間テストでは、上記の変更点に加えて、以下の追加変更点が適用されます。

o   マウントの動きやオートフォーカスのステップは無視される

o   空の明るさの測定が省略される

o   ガイドとディザリングの設定は無視される

各ステップのテストと同様に、テスト実行中にシーケンサー進行状況画面のログに表示される出力を見て、問題が発生していないかどうかを確認してください。 また、保存された撮影ファイル（特に夜間のテストの場合）が正しいフォーマットであり、期待される品質の画像データが含まれていることを確認してください。

シーケンスの実行

シーケンスの実行は非常に簡単で、 「実行 Run 」ボタンを押すだけです。実行ボタンを押すと、SharpCapのシーケンサーエンジンが選択したステップを実行し、 シーケンサー進行状況画面が表示され、撮影シーケンスの進行状況を確認することができます。

シーケンサー進行状況画面

「シーケンサー進行状況 Sequencer Progress 」画面は、シーケンスが実行されているときに表示されます（メインシーケンスエディターがすでに表示されている場合を除く）。 この画面では、進行中のシーケンスをモニターしてコントロールしたり、必要に応じて一時停止やキャンセルをしたり、状況に応じて緊急停止をしたりすることができます。

シーケンス進行状況画面のコントロールには以下のものがあります。

· 「停止 Stop 」ー 現在実行中のシーケンスが停止します。 なお、シーケンスはすぐには止まらないかもしれませんが（現在行われている動作によっては）、通常はボタンを押してから数秒以内に止まるはずです。

· 「一時停止／再開 Pause/Resume 」ー これにより、シーケンスを一時停止し、一時停止後に再び実行を再開することができます。 シーケンスを一時停止すると、停止するよりも効果が出るまでに時間がかかる場合があります。 例えば、シーケンスが60枚の露光を行っている場合、シーケンスを停止すると、その露光がキャンセルされ、かなり早く停止します。 シーケンスを一時停止すると、その露光が終了するまで待ってから一時停止します。

· 「再実行 Run 」ー これにより、シーケンスが終了した後や、エラーや手動で停止した後に、 最初からシーケンスを再実行することができます。

· 「編集 Edit 」ー SharpCap シーケンスエディター 画面が表示され、実行中のシーケンスに変更を加えることができます。

· 「緊急停止 Emergency Stop 」ー このボタンは、実行中のシーケンスでコマンドが実行されて機器が破損する恐れがある場合に使用します。 このボタンを押すと、Stopボタンが押されたかのようにシーケンスが停止するだけでなく、 接続されているASCOMマウントやフォーカサーに動作停止コマンドが送信されます。

· 「進行状況を可視化 Keep Progress Visible 」ー このボックスにチェックを入れると、SharpCapが最小化されたり、 他のアプリケーションが前面に出てきたりしても、シーケンサーの進行状況画面は他のアプリケーションの上に表示されます。

進行状況画面の「ステータス Status 」には、以下の情報が表示されます。

· 「シーケンス名 Sequence Name 」ー これは、シーケンスがファイルから読み込まれた場合はファイル名、その他の記述的な名前になります。

· 「現在の段階 Current Step 」ー これは、シーケンスの中で現在実行中の段階を表しています。

· ETA ー ここでは、シーケンスが完了すると予想される時間と、完了が予想される時刻を示します。 一部のステップ（たとえば、空の明るさの測定）が完了するまでにさまざまな時間がかかる場合があるため、これは単なる推定値であることに注意してください。 一部の高度なシーケンスでは、SharpCapがシーケンスの実行にかかる時間を計算できない場合があります。

· 「進行バー Progress 」ー これは、一連の作業がどれだけ進んでいて、どれだけ残っているかを目に見える形で表したものです。

進行状況画面のログには、シーケンスの進行状況を把握するのに便利な情報が表示されます。 シーケンサーの各ステップの開始と終了がログに入力され、特定のステップの進行に関するその他の情報や、エラーが発生した場合にはエラー情報も表示されます。

シーケンサー進行状況ログに表示される情報は、SharpCapのメインログにも含まれますのでご注意ください。 シーケンスを実行した際に実行されるステップの完全なリストもSharpCapのメインログに保存されるため、問題が発生した場合の追跡に役立ちます。

保存 / 読み込み / 詳細な編集

ディープスカイのシーケンス計画は、「Save=保存」および「Load=読み込み」ボタンを使って保存し、後で再読み込みすることができます。 シーケンス計画は、「.ssp」（SharpCap Sequence Plan）という拡張子で保存されます。

以前に別のカメラ用に保存された計画を読み込むことは可能ですが、カメラの性能が異なる場合、 保存された計画の設定の一部が新しいカメラに適用できない場合は無視される可能性があるため、注意が必要です。

最後に、「詳細な編集 Advanced Edit 」ボタンを押すと、計画をSharpCap シーケンスエディターに転送して、さらに詳細に検討することができます。 これにより、シーケンスプランナー画面が閉じ、シーケンスエディター画面が開き、現在のシーケンスとして読み込まれた計画が表示されます。 シーケンスプランナー画面で設定した設定は自動保存され、次回シーケンスプランナーに戻ったときに復元されます。


シーケンスエディター

SharpCapシーケンスエディターは、前述のディープスカイシーケンスプランナーよりもはるかに柔軟にSharpCapのシーケンス操作を設定することができます。 ディープスカイシーケンスプランナーでは設定できない自動撮像作業の多くは、シーケンスエディターで設定でき、例えば、以下のようなものです。

· 月・太陽・惑星の撮影を自動化。

· ライブスタックの自動化。

· 複数の目標物を連続して撮影する際の自動化。

· モザイク画像の撮影を自動化。

これらの作業は、個々の比較的単純なステップを順番に実行することで、画像シーケンスを構築することで達成されます。 これらのステップは、シーケンス全体を構成する要素と考えることができます。 使用可能な構成要素のステップの全リストは以下の通りですが、ステップによって以下のようなことが可能です。

· カメラの選択

· カメラの設定変更

· フレームを静止画や動画として撮影

· ハードウェアにコマンドを送信する ー GOTOマウント、電子フォーカサー、フィルターホイール

· プレートソルブやオートフォーカスの操作

· 一定の間隔で待つか、時刻またはイベント（日没など）まで待つ

· 他のステップのグループを繰り返す

· その他にも様々な機能がありますが、 利用可能なステップ を参照してください。

コンピュータープログラミングに詳しい方なら、SharpCapシーケンサーが非常にシンプルなプログラミング言語であることにお気づきかもしれません。 シーケンサーには、複雑になりすぎないように、プログラミング言語にありがちな変数や条件文などは、あえて省いてあります。

シーケンスエディターによるパワーと柔軟性の向上により、本質的には無意味なシーケンスを設計することが可能であることを認識しておくことが重要です。 例えば、次のようなシーケンスを考えてみましょう。

最初のステップでは、現在開いているカメラをすべて閉じ、2番目のステップでは10フレームの撮影を試みます。フレームの撮影を試みると、常にエラーが発生します。

独自のシーケンスを設計する際には、SharpCapを手動で使用する場合の順序を考えて、同じ順序でステップを配置してください。

なお、SharpCap の手動操作に慣れるまでは、シーケンスエディターを使用しないでください。

シーケンスエディターのユーザーインターフェース

シーケンスエディターは、SharpCapのメイン画面とは別の画面で表示されます。 エディター画面は、いつでも表示でき、作業した最新のシーケンスが自動的に表示されます。 エディター画面を開いたまま、SharpCapのメイン画面に切り替えて、シーケンスに関連しない作業を行うことができ、 エディター画面を閉じる必要はありません。

エディター画面の最初の表示（シーケンスがロードされていない状態）は以下のようになります。

エディター画面は、以下のように9つの主要なエリアに分かれています。

1. 「メニュー」ー シーケンスの読み込みと保存、切り替え / コピー / 貼り付けなどの標準的な編集操作、シーケンスの実行 / 停止 / テストコマンドなどにアクセスできます。

2. 「利用可能なステップ Available Steps 」ー このエリアには、独自のシーケンスを構築するために使用できるシーケンサーのステップのリストが表示されます。 マウスを使って、このエリアから使用したいステップをメインのシーケンスリストにドラッグすることができます。

3. 「シーケンス Sequence 」リスト ー このエリアには、シーケンスのステップのリストが表示されます。 ここに表示されている各ステップは、シーケンスを実行したときに、上から下へと順番に実行されます。

4. 「操作ボタン」ー これらのボタンは、 「元に戻す Undo 」、 「やり直し Redo 」、 テスト、「実行 Run 」、停止などの一般的な操作に素早くアクセスできます。

5. 「選択されたステップのプロパティ Selected Step Properties 」ー シーケンスリストのステップをクリックすると、そのステップの調整可能なプロパティが表示され、 ここで調整することができます。

6. 「ごみ箱」ー シーケンスリストからここにステップをドラッグして削除します。

7. 「進行状況 Progress 」ー エディターでシーケンスを実行すると、シーケンスの進行状況と「ETA」が表示されます。

8. 「シーケンス一覧」ー このエリアには、シーケンスの現在の状態がコード形式で表示されます。 なお、このエリアで変更を加えてシーケンスを編集することはできません。

9. 「シーケンス ログ」ー エディターからシーケンスを実行すると、シーケンス関連のログ情報がここに表示されます。

1. メニュー

ファイルメニュー

ファイルメニューでは、シーケンスファイルの保存と読み込みに関する操作を行います。選択できる項目は以下のとおりです。

· 「新規 New 」ー 現在のシーケンスからすべてのステップを削除して、新しいシーケンスの設計を始めることができます。 なお、前回のシーケンスを保存せずに、誤って「ファイル」→「新規」を実行してしまった場合は、 「元に戻す Undo 」ボタンで前回のシーケンスに戻ることができます。

· 「開く Open 」ー 以前に保存したシーケンスを 「*.scs 」ファイルから読み込みます。現在のシーケンスは破棄されます。

· 「保存 Save 」ー このオプションは、現在のシーケンスがすでに保存されているか、 ファイルから読み込まれている場合にのみ利用できます。保存すると、前回保存したバージョンのシーケンスが上書きされます。

· 「名前を付けて保存 Save As… 」ー 現在のシーケンスを新しい「*.scs」ファイルに保存します。 新しい「*.scs」ファイルのファイル名を入力するプロンプトが表示されます。

編集メニュー

編集メニューには、シーケンスの編集に役立つ操作が用意されています。 キーボードショートカットは各メニュー項目の横に表示されているので、キーボードショートカットを使うためにメニューを開く必要はありません。

· 「元に戻す Undo 」ー 編集中のシーケンスに加えられた最新の変更を取り消すことができます。 ステップの追加、削除、並び替え、ステップのプロパティの変更は、すべて「Undo」ボタンで取り消すことができます。

· 「やり直し Redo 」ー 元に戻された最新の変更をやり直します。 ただし、「Undo」ボタンを使用した後にシーケンスに別の変更を加えると、やり直しはできなくなります。

· 「切り取り/コピー/貼り付け Cut/Copy/Paste 」ー これらは標準的なクリップボード操作で、シーケンスのステップを削除、複製、再配置することができます。 これらのオプションは、シーケンスリスト内で少なくとも1つのステップが選択されている場合に利用できます。

· 「削除 Delete 」ー 現在選択されているステップを編集中のシーケンスから削除します。

シーケンスメニュー

シーケンスメニューでは、シーケンスの実行、停止、テストとそのステップに関する操作を行います。

· 「実行 Run 」ー 現在のシーケンスを最初から実行します。

· 「停止 Stop 」ー 現在実行中のシーケンスを停止します。なお、シーケンスはすぐには停止できない場合があります。

· 「単一ステップのテスト Test Single Step 」ー シーケンスの単一ステップの実行をテストする。 このオプションを使うと、編集中のシーケンスで現在選択されているステップが実行され、正しく動作するかどうかを確認できます。

2. 利用可能なステップのエリア

このエリアには、シーケンスを構築するために 「利用可能なステップ Available Steps 」が表示されます。 利用可能なステップの数が多いため、「カメラ」「ガイディング」「フォーカサー」などのカテゴリに分類されています。

このエリアのステップをシーケンスに追加するには、2つの方法があります。

1) 「利用可能なステップ」エリアから、ステップをシーケンス内の必要な位置にドラッグします。

2) 「利用可能なステップ」エリアで、必要なステップをダブルクリックします。これにより、現在選択されているステップのすぐ後に、そのステップが挿入されます。

なお、「利用可能なステップの検索 Search Available Steps 」ボックスに検索したいステップの名前の一部を入力することで、利用可能なステップを検索することができます。 検索ボックスにテキストを入力すると、検索テキストを含まないステップはすべて非表示になり、表示するステップがなくなったステップ区分も非表示になります。

検索テキストボックスの右にある「X」ボタンをクリックするか、入力したテキストを削除することで、検索テキストを消去して、すべてのステップを再表示することができます。

3. シーケンスリスト

シーケンスリストには、現在シーケンスの一部となっているステップが表示されます。シーケンスを実行すると、これらのステップが上から下へと順番に実行されます。 各ステップは、上のステップが完了した後に開始されます。

いくつかのステップ（例えば、以下に示すRepeat 2 timesステップ）は、その中に他のステップを置くことができます。 Repeat 2 timesステップは、この文脈では親ステップであり、それに含まれるステップはサブステップです。 このケースでは、シーケンスの実行中にサブステップが2回実行されることになります。

マウスでステップをドラッグすると、シーケンスリスト内でステップを移動させて順序を変えることができます。 また、ステップを親ステップの中に入れたり、親ステップの外に出したり、異なる親ステップの間にドラッグすることもできます。

シーケンスリストの中の1つのステップをクリックすると、そのステップの調整可能なプロパティが 選択されたステップのプロパティ エリア に表示されます。ステップのプロパティの値を調整することができます。 例えば、何フレームを撮影するか、露出をどのように設定するか、特定のサブステップのセットを何回繰り返すかなどを変更することができます。

不要になったステップは、ゴミ箱にドラッグするか、選択してから編集メニューの「削除」を選ぶか、キーボードの＜Delete＞キーを押すことで削除できます。

また、標準の切り取り/コピー/貼り付け機能を使って、シーケンスリストのステップを操作することもできます。 1つまたは複数のステップを選択した後、適切なメニュー項目またはキーボードショートカットを使用して、ステップの切り取りまたはコピーを行うことができます。 ステップの切り取りまたはコピー後に貼り付けを選択すると、シーケンスリストで現在選択されているステップの後にステップが追加されます。

4. 操作ボタン

操作ボタンは、ファイル 、 編集 、 シーケンス の各メニューで利用できるいくつかの項目のショートカットです。

さらに、実行中のシーケンスを一時停止（再開）するための 「一時停止 Pause 」ボタンもあります。

「緊急停止 Emergency Stop 」ボタンは、実行中のシーケンスでコマンドが実行されて機器が破損する危険性がある場合に使用できます。 このボタンを押すと、 「停止 Stop 」ボタンが押されたかのようにシーケンスが停止するだけでなく、 接続されているAscomのマウントやフォーカサーに動作停止コマンドが送信されます。

5. 選択されたステップのプロパティエリア

多くのステップには、そのステップが行うことを正確に設定する調整可能なプロパティがあります。 例えば、下の画像は「カメラのウォームアップ」ステップのプロパティを示しています。 このステップでは、ウォームアップ率やタイムリミットなどのプロパティの値を選択します。

シーケンスを編集する際には、シーケンスの実行に使用する予定のカメラを開いておき、使用する予定のASCOMハードウェアを接続しておくのが最善の方法です。 例えば、カメラの露出やゲインを設定するステップを構成する場合、カメラが接続されていれば、正しい最小値と最大値が適用されます。

ステップのプロパティに加えた変更は、[元に戻す]ボタンまたは[編集]メニューの[元に戻す]項目で元に戻すことができます。

ステップのプロパティを設定する際には、特にSharpCapがデバイスやカメラに接続されていないときに調整する場合には、注意が必要です。 例えば、フィルター名のスペルを間違えると、SharpCapはフィルターホイールを存在しないフィルター（おそらく「Grene」）に移動させようとし、エラーが発生します。

6. ゴミ箱

シーケンスで不要になったステップは、 シーケンスリスト から「ゴミ箱」にドラッグして削除することができます。

7. 進行状況エリア

「進行状況 」エリアには、実行中のシーケンスの現在の進行状況が表示されます。

· 「ETA」は、シーケンスが完了するまでの時間と、完了すると予想される時間を示しています。 一部のステップ（空の明るさの測定など）では、完了までにかかる時間が変わることがあるため、これは推定値であることに注意してください。 詳細なシーケンスでは、SharpCapがシーケンスの実行にかかる時間を計算できない場合があります。

· 「進行状況」バーは、一連の作業がどれだけ進んでいて、どれだけ残っているかを目に見える形で表したものです。

8. シーケンス一覧

シーケンス一覧エリアには、シーケンスの現在の状態がコード形式で表示されます。 実際に表示されているテキストは、シーケンスを保存したときに「.SCS」ファイルに保存されたテキストです。 コンピュータプログラミングに精通している人の中には、このシーケンスのビューが役立つと思う人もいるかもしれません。

なお、このリストエリアに表示されているテキストを編集して、シーケンスを変更することはできません。

技術的には、シーケンスを 「.SCS 」ファイルに保存し、テキスト エディタで SCS ファイルを編集してから再読み込みすることで編集することができますが、これは推奨されません。 シーケンスファイルの編集に誤りがあった場合、SharpCapが再読み込みしようとするとエラーが発生することがあります。

9. シーケンス ログ

シーケンスログには、シーケンス実行中にシーケンサーが現在行っていることや、すでに完了したステップの情報が表示されます。

各ステップの開始と終了がログに表示され、一部のステップでは追加情報（例えば、これまでに撮影した静止画の数など）も表示されます。

シーケンスの実行中にエラーが発生した場合、ログに「エラー」が記録され、エラーの理由が説明されます（以下が一例）

21:07:02 Error : 'No camera selected.' while running step Capture 10 live view frames

シーケンスの実行中に問題が発生した場合は、必ず「シーケンスログ」を確認して、有用な情報を得てください。 また、 SharpCapメインログ をチェックして、追加情報を得るのもよいでしょう。

シーケンスエディターの操作

この章の残りの部分で説明するガイドラインに従うことで、できるだけ問題なく、迅速かつ正確に撮影シーケンスを設計することができます。

· シーケンスエディタに用意されている手順の多くは、SharpCapのUIで実行できる手動操作を反映しており、 それらがどのように機能し、どのような順序で使用されるのかを理解しておくことは、シーケンスをデザインする際に役立ちます。

· 撮像したいカメラをSharpCapで開いた状態でシーケンスを設計します。また、SharpCapにASCOMのハードウェアを接続します。 SharpCapは、接続されたカメラとASCOMのハードウェアからの情報を使用して、ステップのプロパティに適切な最小値と最大値、 および利用可能なオプションを設定することができます。

· シーケンスの実行を開始する前に、何をするかを考えてみましょう。 カメラがすでにセットアップされていて、望遠鏡が天体に向いているときにのみ実行するシーケンスを設計することができます。 このシーケンスは、フレームを撮影することから始まる、非常にシンプルなものになるでしょう。 カメラを開き、カメラの設定を行い、マウントを回転させて天体に向けるなど、すべての設定手順を含む別バージョンを設計することもできます。 最初にシンプルなバージョンから始めて、後からより複雑なバージョンに移行するのが良いでしょう。

· シーケンスを設計しているときには、「テスト」ボタンを頻繁に使用して、個々のステップをテストし、期待通りの動作をしているかどうかを確認します。 複数のステップをテストしたい場合は、それらのステップを一時的に親ステップの中に置くことができます。

· 特に無人でシーケンスを実行する場合は、シーケンス全体を実行する前に、シーケンス内のすべての異なるステップを個別にテストしてください。

· いきなり複雑なシーケンスを設計しようとしないでください。 まずは簡単なものから始めて、期待通りに確実に動作することを確認してから、徐々に複雑なステップを追加していきましょう。

· シーケンスを設計する際には、SharpCapは、選択したステップが意味をなさないものであっても、単純に実行しようとすることを忘れないでください。 SharpCapを手動で使用している場合、カメラが開いていないときに画像を撮影しようとしても、キャプチャボタンはすべて無効になっているのでできません。 シーケンスエディタを使用して撮像シーケンスを設計している場合は、そのような保護はありません。 カメラが閉じているときに撮影を開始しようとするステップがあった場合、SharpCapはそのステップを実行しようとし、シーケンスはエラーで終了してしまいます。

シーケンスの実行

操作ボタン の「実行 Run 」ボタン、または シーケンスメニュー の「実行 Run 」メニュー項目を使用して、シーケンスを実行することができます。 進行状況は「進行状況」エリアと「シーケンスログ」に表示されます。

シーケンスの実行中にシーケンスエディター画面を閉じると、 シーケンサー進行状況画面 が自動的に表示され、シーケンスの進行状況を確認したり、実行をコントロールしたりすることができます。

注意：シーケンスの実行中は、SharpCapのメニューとカメラコントロールが無効になります。 これは、コントロールに対する不注意な操作や変更が、シーケンスの適切な操作を妨げるのを防ぐためです。 また、シーケンスの実行中にSharpCapを閉じることもできません。 SharpCapを閉じたり、メニューやツールバーにアクセスするには、実行中のシーケンスを停止する必要があります。

「 プロンプトを表示 Show a prompt 」ステップでは、プロンプトがユーザーの［OK］クリックを待っている間に、 カメラコントロールの調整をオプションで再度有効にすることができます。 これは、シーケンス内の適切な位置でコントロールを手動で調整できるようにするためのものです（フラットフレームキャプチャのために適切な露出を設定する場合など）。

利用可能なステップ

この章では、シーケンスを構築するために使用できるシーケンサーのすべてのステップをリストアップして説明します。

カメラ

ステップ名 | 説明
Open Camera '<Camera Name>' | 指定したカメラを開き、すでに開いていた他のカメラを閉じます。
Close Camera | 開いているカメラを閉じます。
カメラをライブモードにする Put Camera in Live Mode | 現在開いているカメラをライブモードにする（ビデオ撮影用）
カメラを静止画モードにする Put Camera in Still Mode | 現在開いているカメラを静止画モデルにする（ディープスカイの撮影など）ことができます。ただし、すべてのカメラが静止画モードに対応しているわけではありません。
フレームの撮影開始 Start capturing frames | 現在のカメラ設定を使用してフレームの撮影を開始します。 フレームは無期限に（またはフレームの撮影の停止まで）ステップが実行され続けることに注意してください。
フレームの撮影停止 Stop capturing frames | 選択したカメラの撮影を停止します。
今から撮影を開始し、＜天文現象＞が発生したら停止する Start capturing now and then stop when <Astronomical Event> occurs | すぐに撮影を開始し、指定した天文時間になると撮影を停止します。 指定する時間帯は、次のいずれかです。天文深夜(Astronomical Midnight)、天文夜明(Astronomical Dawn)け、海上夜明け(Nautical Dawn)、市中夜明け(Civil Dawn)、 日の出(Sunrise)、太陽正午(Solar Noon)、日没(Sunset)、市中夕暮れ(Civil Dusk)、海上夕暮れ(Nautical Dusk)、天文夕暮れ(Astronomical Darkness)。 なお、緯度や時期によっては、発生しない現象もあります。選択した現象が24時間以内に発生しない場合はエラーになります。
ライブビューのフレームを<フレーム数>で撮影 Capture<Frame Count> live view frames | ライブモードで指定したフレーム数を撮影する。カメラが静止画モードになっている場合は、ライブモードになります。
<フレーム数>の静止画を撮影する（ガイドが必要：<撮影中にガイドを要求する>） Capture<Frame Count> still frames (guiding required : <Require guiding active while capturing>) | 静止画モードで指定したコマ数を撮影する。カメラがライブモードになっている場合は、静止画モードになります。 「ガイドが必要 = Require guiding」オプションが設定されている場合、SharpCapは以下の追加手順を行います。 · ガイディングアプリケーションがモニターされていない場合、エラーが発生します。 （「 ガイディングアプリケーションのモニター Monitor Guiding Application 」のステップを参照） · ガイドが作動していない場合、撮影は一時停止します。 · SharpCapはガイドの再開を試み、ガイドが再開された場合には撮影を再開します。 · SharpCapは、ガイドが失われたときに95％未満のフレームは破棄されます。 （補償のために余分なフレームが撮影されます）
カメラプロファイルの読み込み '<プロファイル名>' Load Camera Profile '<Profile Name>' | 名前付きの撮影プロファイルに保存されているすべての撮影設定を読み込みます。
出力形式を<ファイル保存形式>に設定 Set Output Format to <File Save Format> | 保存した画像 / 動画の出力形式を指定した形式に設定します。
解像度を<値>に設定 Set Resolution to <Value> | カメラの解像度を指定した値に設定する
カラーモードを<値>に設定 Set Colour Space to <Value> | カメラの カラーモード を指定した値に設定する
ビニングを<ビニング値>に設定 Set Binning to <Binning Value> | カメラの ビニング を指定値にする
露出を<露出時間>(s)に設定 Set Exposure to <Exposure time>(s) | カメラの露出時間を指定した長さに設定する。なお、1秒未満の露出も設定可能で、例えば30msの場合は0.030sとなります。
ゲインを<ゲイン値>に設定 Set Gain to <Gain Value> | カメラのゲインを指定した値に設定します。
オフセットを<オフセット / 輝度値>に設定 Set offset to <Offset/Brightness Value> | カメラのオフセット / ブラックレベル / 輝度を指定した値にする
<コントロール名>を<コントロール値>に設定 Set<Control Name> to <Control Value> | 別のカメラコントロールを指定された値に設定します。 このステップは、より具体的なステップがないコントロール（ガンマ、ホワイトバランスコントロールなど）を設定する場合に使用します。

クーラー

カメラを<目標温度>℃まで最大<冷却速度>℃/分で冷却する Cool the camera down to <Target Temperature>°C at up to <Cooling Rate>°C/minute | カメラを指定された目標温度まで冷却します。冷却速度や許容範囲（カメラが目標温度にどれだけ近づけばステップが終了したと判断するか）を制限することができます。 カメラのクーラーがオンになり（必要な場合）、必要に応じてクーラーも自動（温度制御モード）になります。 カメラにクーラーがない場合、またはクーラーが温度制御されていない場合、エラーが発生します。 設定された目標温度が周囲温度よりも高い場合や、カメラの冷却装置が達成できる最も低い温度よりも低い場合は、 カメラの温度が目標に到達しないため、このステップが終了しないことがあります。
目標温度を＜目標温度＞℃に設定 Set the target temperature to <Target Temperature>°C | カメラクーラーの目標温度を指定した温度に変更します。
カメラの冷却を切る Turn the camera cooler off | 次の3つの手段で、カメラの冷却装置をオフにします。 · カメラに冷却のON / OFFコントロールがある場合は、OFFに設定してください。 · カメラに手動で冷却能力を調整する機能がある場合は、冷却能力を0％に設定してください。 · カメラに温度調節機能付きのクーラーがある場合は、目標温度を最大値に設定してください。 なお、冷却したカメラでこの手順を行うと、センサーの温度が急激に上昇することがあります。
カメラを<目標温度>℃まで最大<温暖化速度>℃/分で温める Warm the camera up to <Target Temperature>°C at up to <Warming Rate> °C/minute | カメラを指定された目標温度まで温めます。 このステップは、冷却のステップと同様に、暖める速度と完了の許容範囲を指定することができます。 また、このステップには制限時間を設定することができ、ウォーミングアップの手順が完了していなくても、制限時間が経過するとステップが完了します。

マウント

マウントの選択「<マウント名>」 Select Mount '<Mount Name>' | 名前付きマウントを選択したマウントにします。これは、SharpCapがハードウェア設定で使用するマウントを変更することと同じです。
現在選択されているマウントの接続 Connect the currently selected mount | 現在選択されているマウントがまだ接続されていない場合に、そのマウントへの接続を試みます。 マウントがコンピューターに接続されていない場合や、正しく設定されていない場合は、エラーが発生する可能性があります。
現在選択されているマウントの切断 Disconnect the currently selected mount | 現在選択されているマウントとの接続を切断します。この時点以降、マウントが再び接続されるまで、マウントに関する他の操作はできなくなります。
マウントの固定解除 Unpark the mount | マウントがホームポジションに固定されている場合は、固定解除する
マウントを固定する Park the mount | マウントをデフォルトのホームポジションにする
マウントを（RA, Dec）＜RA/Dec座標＞に移動する Move the mount to (RA, Dec) <RA/Dec co-ordinates> | マウントを指定された座標に旋回させます。RA/Dec座標で受け入れられるフォーマットの詳細については、 シーケンサーの座標 を参照してください。
Alt=<高度>、Az=<方位>にマウントを移動させる Move the mount to Alt=<Altitude>, Az=<Azimuth> | 指定された高度 / 方位座標にマウントを旋回させます。すべてのマウントが高度 / 方位座標に対応しているわけではないことに注意してください。
RA=<赤経オフセット>, Dec=<赤緯オフセット>でマウント位置をオフセットする Offset the mount position by RA=<Right Ascension Offset>, Dec=<Declination Offset> | 現在のマウント位置を、赤経と赤緯で指定されたオフセット分だけオフセットします。これは、天体を視野の中心からわずかにずらしたい場合に有効です。
プレートは単一のフレームソルブをし、マウントを同期して、目標座標に再移動します Plate solve a single frame, sync the mount and re-GOTO the target co-ordinates | プレートソルブを使用して目標の中心を再設定します。 これは、プレートソルブ後再同期 ツールの使用と同じで、そのツールと同じ設定オプションに従います。
マウントの追跡レートを<追跡レート名>に設定 Set mount tracking rate to <Tracking Rate Name> | マウントの追跡レートを設定します。設定可能なオプションは、None（追跡停止）、Sidereal（恒星）、Lunar（月）、Solar（太陽）、Kingです。

フォーカサー

フォーカサー「＜フォーカサー名＞」を選択

Select Focuser '<Focuser Name>'

名前付フォーカサーを選択されたフォーカサーにする。これは、ハードウェア設定でSharpCapが使用するフォーカサーを変更することと同じです。

現在選択されているフォーカサーを接続

Connect the currently selected focuser

現在選択されているフォーカサーがまだ接続されていない場合に、その接続を試みます。 フォーカサーがコンピューターに接続されていない場合や、正しく設定されていない場合は、エラーが発生する可能性があります。

現在選択されているフォーカサーの切断

Disconnect the currently selected focuser

現在選択されているフォーカサーとの接続を解除します。この時点以降、再びフォーカサーを接続するまで、フォーカサーに関する他の操作はできなくなります。

フォーカサーを所定の位置に移動<フォーカサーの位置>

Move focuser to position <Focuser Position>

フォーカサーを指定された位置に直接移動させます。（例えば、フォーカサーを11950の位置に移動させます）

フォーカサーを<フォーカサーオフセット>で移動させる

Move the focuser by <Focuser Offset>

フォーカサーを現在の位置からオフセット分だけ移動させます。オフセットをマイナスにすると小さい位置の値に移動し、プラスにすると大きい位置の値に移動します。

<フォーカス開始位置>と<フォーカス終了位置>の間で、バックラッシュを考慮した<スキャンステップ数>を<バックラッシュ許容量>まで設定して オートフォーカスを行う

Autofocus between <Start Focuser Position> and <End Focuser Position> with<Scan Step Count> steps allowing for backlash up to <Backlash Allowance>

指定された2つのフォーカサー位置の間で、 マルチスターFWHM（半値全幅） によるオートフォーカスを行います。

詳細は、シーケンスプランナーのフォーカス に関する記事を参照してください。

＜開始フォーカサー位置（オフセット）＞から＜終了フォーカサー位置（オフセット）＞までを、＜スキャンステップ数＞のステップでオートフォーカスし、 ＜バックラッシュ許容量＞までのバックラッシュを許容する

Autofocus from offset <Start Focuser Position (Offset)> to <End Focuser Position (Offset)> with <Scan Step Count> steps allowing for backlash up to <Backlash Allowance>

開始点と終了点が絶対的なフォーカサー位置の値ではなく、現在のフォーカサー位置を基準にして定義されることを除いて、上記のオートフォーカスステップと同じです。

ホイール

フィルタホイールを選択 「<フィルタホイール名>」 Select Filter Wheel '<Filter Wheel Name>' | 指定したホイールを選択したフィルターホイールにする。これは、SharpCapが「ハードウェア設定」で使用しているフィルターホイールを変更するのと同じです。
現在選択されているフィルターホイールの接続 Connect the currently selected filter wheel | 現在選択されているフィルターホイールがまだ接続されていない場合に、その接続を試みます。 フィルターホイールがコンピューターに接続されていない場合や、正しく設定されていない場合は、エラーが発生することがあります。
現在選択されているフィルターホイールの接続を解除 Disconnect the currently selected filter wheel | 現在選択されているフィルターホイールの接続を解除します。これ以降、再びフィルターホイールを接続するまで、フィルターホイールに関する他の操作はできなくなります。
フィルターホイールを <フィルター名>の位置に移動 Move filter wheel to position <Filter Name> | フィルターホイールを移動させる（移動先のフィルター名を指定する）ことができます。
フィルターホイールを所定の位置に移動させる<フィルターホイール位置> Move filter wheel to position <Filter Wheel Position> | フィルターホイールを新しい位置に移動させる（移動先のフィルター位置番号を指定する。これらの番号は1からホイール上のフィルターの数までカウントアップされる）。

繰り返し

各繰り返しタイプのステップには、サブステップとして1つまたは複数の他のステップを配置することができます。 これらのサブステップは、繰り返しステップで指定された繰り返しの種類に応じて、1回または複数回実行されます。

繰り返し<繰り返し回数> Repeat<Repeat Count> times | サブステップを一定回数繰り返します。
<天文現象>が発生するまで繰り返す Repeat until <Astronomical Event> occurs | <天文現象>で指定された時刻になるまで、サブステップを繰り返します。 指定する時間帯は、次のいずれかです。天文深夜(Astronomical Midnight)、天文夜明け(Astronomical Dawn)、海上夜明け(Nautical Dawn)、 市中夜明け(Civil Dawn)、 日の出(Sunrise)、太陽正午(Solar Noon)、日没(Sunset)、市中夕暮れ(Civil Dusk)、海上夕暮れ(Nautical Dusk)。 なお、緯度や時期によっては、発生しない現象もあります。選択した現象が24時間以内に発生しない場合はエラーになります。 なお、指定した時間以降、サブステップの新たな実行は開始されませんが、指定した時間に実行中のサブステップは、 サブステップのリストの最後に到達するまで実行され続けます。
<フィルターリスト>の各フィルターについて繰り返す Repeat for each filter in <Filter List> | フィルターリストで指定したフィルターごとに、サブステップを1回繰り返します。
＜座標一覧ファイル＞のAlt / Az座標ごとに繰り返す Repeat for each Alt/Az co-ordinate in <Co-ordinate list file> | テキストファイルに記載されている高度 / 方位座標のセットごとに、サブステップを1回繰り返します。テキストファイルには、1行に1組の座標が記載されています。
＜座標一覧ファイル＞の赤経 / 赤緯座標ごとに繰り返す Repeat for each RA/Dec co-ordinate in <Co-ordinate list file> | テキストファイルに記載されている赤経 / 赤緯座標の各セットに対して、サブステップを1回繰り返します。テキストファイルには、1行に1組の座標が記述されています。 これらの座標値に必要なフォーマットの詳細については、 シーケンサーの座標 を参照してください。 SharpCapは、この名前を観測目標として、ファイル名を付けたり、その行の座標値を使用したりします。 天体名は、座標とコンマで区切ってください。例えば、以下のようになります。 M42, 05 35 17.3 -05 23 28

その他

現在選択されている全てのハードウェアを接続

Connect the all currently selected hardware

現在選択されているすべてのハードウェアを接続します。これは、フォーカサー、マウント、フィルターホイールを個別に接続するためのショートカットです。 なお、選択されていないハードウェアのカテゴリーがあっても、エラーにはなりません。

現在選択されている全てのハードウェアを切断

Disconnect all currently selected hardware

現在選択されている全てのハードウェアを切断します。マウント、フォーカサー、フィルターホイールを個別に切り離すためのショートカットです。

<再生する音>を鳴らす

Play the<Sound to Play> sound

コンピュータの標準サウンドデバイスでWindowsの音を再生します。アラートとエラーの2種類の音を選択できます。 この2つのオプションで再生される音は、Windowsコントロールパネルの「システムサウンドの変更」で設定できます。

パラメータ 「<引数>」と<コマンドが終了するのを待ちますか？>を指定して '<実行するプログラム>'を実行。

Run '<Program to run>' with parameters '<Arguments>' and <Wait for command to exit?>

別のWindowsアプリケーションまたはコマンドラインアプリケーションを実行し、オプションとして他のプログラムの終了を待ってから続行します。

実行するプログラムは、フルパスで指定する（または、「参照」ボタンで選択する）のがベストです。

また、実行中のプログラムに渡すコマンドラインパラメーターを指定することもできます。

このステップを使ってバッチファイルやPowerShellスクリプトを実行し、より複雑な操作を行うことも可能です。

カメラの設定を保存し、このブロックが終了したときに復元する

Save the camera settings and restore them when this block finishes

このステップには、複数のサブステップを追加することができます。ステップ開始時のカメラ設定が保存され、サブステップ終了後にカメラに再適用されます。

このステップを使用すると、カメラを元の設定に戻す前に、特定のタスク（フォーカスなど）に使用される代替のカメラ設定を許可するのに役立ちます。

<残り>秒数のカウントダウンを<メッセージテキスト>のメッセージとともに表示

Show a countdown for <Delay> seconds with message <Message Text>

このステップでは、一定の秒数だけ画面にメッセージを表示します（残りの秒数をカウントダウンで表示）。

<通知の色>に通知を表示する： 「<通知メッセージ>」

Show a notification in <Notification Colour>: '<Notification Message>'

このステップでは、SharpCapの通知バーに通知が表示され、表示されるテキストと通知バーの色を選択することができます。

プロンプト「<メッセージテキスト>」を表示して、OKが押されるのを待ちます。カメラコントロールを有効にする：＜カメラコントロールを有効にする＞

Show a prompt '<Message Text>' and wait for OK to be pressed. Camera controls enabled : <Enable Camera Controls>

メッセージを含むプロンプト画面を表示し、ユーザーがOKボタンを押すのを待ってから続行します。

オプションで、プロンプトが表示されている間、カメラコントロールを再度有効にすることができます。 これにより、フラットフレームの露出レベルを正しくするなどの調整が可能になります。

<指定した> 秒間待つ

Wait for<Delay> seconds

指定した秒数だけシーケンスを一時停止してから続行します。

<指定された時間>まで待つ

Wait until<Time of Day>

指定された時間まで待ってから続行してください。指定された時間は現地時間であることに注意してください。

<天文現象>が起こるまで待つ

Wait until<Astronomical Event> occurs

<天文現象>で指定された時刻になるまで待ってからシーケンスを続行する

指定する時間帯は、次のいずれかです。天文深夜(Astronomical Midnight)、天文夜明け(Astronomical Dawn)、海上夜明け(Nautical Dawn)、 市中夜明け(Civil Dawn)、 日の出(Sunrise)、太陽正午(Solar Noon)、日没(Sunset)、市中夕暮れ(Civil Dusk)、海上夕暮れ(Nautical Dusk)。 なお、緯度や時期によっては、発生しないイベントもあります。選択したイベントが24時間以内に発生しない場合はエラーになります。

SharpCapログに「<ログテキスト>」を書き込む

Write '<Log Text>' to the SharpCap Log

指定されたテキストをSharpCapのメインログに追加する。これはシーケンスの進行状況を把握するのに役立ちます。

処理

<ファイルパス>をダークフレームとして使用

Use <File Path> as a dark frame

指定された画像ファイルを読み込み、ダークフレームとして使用します。ファイルは、SharpCapが読み取れる静止画形式で、 かつ現在のカメラ設定でダークフレームとして有効（サイズ、ビット深度など）である必要があります。詳細は、 ダークフレームの撮影 を参照してください。

<ファイルパス>をフラットフレームとして使用

Use <File Path> as a flat frame

指定された画像ファイルを読み込み、フラットフレームとして使用します。ファイルは、SharpCapが読み取れる静止画形式で、 かつ現在のカメラ設定でフラットフレームとして有効（サイズ、ビット深度など）である必要があります。詳細は、 フラットフレームの撮影 を参照してください。

ライブスタックの開始

Start Live Stacking

ライブスタックを開始します（すでにライブスタックが行われている場合は何もしません）。 なお、定期的な ディザリング が有効な状態でシーケンサーからライブスタックを行うとエラーになることに注意してください。

ライブスタックの停止

Stop Live Stacking

ライブスタックを停止します。これにより、ライブスタックが無効になり、スタック UI が非表示になります。画像は保存されません。ライブスタックを停止する前に、 「 現在のライブスタックを保存 Save Current Live Stack 」の手順で保存してください。

ライブスタックの一時停止

Pause Live Stacking

ライブスタックが行われている場合、それを一時停止します。

ライブスタックの再開

Resume Live Stacking

ライブスタックが現在有効で一時停止している場合、それを再開します。

ライブスタックのリセット

Reset Live Stacking

ライブスタックをリセットします（現在のスタックをクリアして新しいスタックを開始します）。 リセット時に自動保存するオプションが有効になっている場合は、現在のスタックが保存されますが、そうでない場合は、リセットする前に 「現在のライブスタックを保存 Save Current Live Stack 」を使用します。

ライブスタック 自動ストレッチの適用

Live Stacking Apply Auto Stretch

ライブスタックのヒストグラムに自動ストレッチを適用します。

ライブスタック 自動ホワイトバランス

Live Stacking Auto White Balance

現在のライブスタックに自動ホワイトバランスを適用します。

星カラーからのライブスタック 自動ホワイトバランス

Live Stacking Auto White Balance from star colours

現在のライブスタックに自動ホワイトバランスを適用し、星カラーをベースにしたバランスをとる。

ライブスタック ストレッチをリセット

Live Stacking Reset Stretch

ライブスタックヒストグラムのストレッチをデフォルトに戻します。

ライブスタック ホワイトバランスのリセット

Live Stacking Reset White Balance

ライブスタックのカラーバランスをデフォルトに戻します。

現在のライブスタックを保存(<保存タイプ>)

Save current live stack (<Save Type>)

現在のライブスタックを以下のいずれかの方法で保存します。

· FITSRawStack16Bit ー 16ビットスタックとして保存 する場合と同じです。

· FITSRawStack32Bit ー RAW形式で保存（32ビット） のスタックに相当します。

· PNGWithStretch ー 調整して保存 に相当します。

· PNGAsShownOnScreen ー 見たままの状態で保存 と同じです。

· AllFormats ー 上記のすべての形式で保存します。

<フレームカウント>のフレームをライブスタックし、<保存タイプ>として保存

Live Stack for <Frame Count> frames then save as <Save Type>

ライブスタックを有効にして（すでに有効な場合はリセットして）、指定したフレーム数だけスタックしてから保存するショートカットステップです。

ファイル名

ファイル名やフォルダ名を整理して、シーケンスキャプチャをまとめる Arrange file and folder names to keep sequence captures together | 撮影が行われる前に、このステップをシーケンス内に置くと、ファイル名のパターンが変更され、シーケンスからのすべての撮影がグループ化されます。 シーケンスで開始された個別の撮影には、それぞれ独自のサブフォルダが割り当てられます。たとえば、 以下のように #1 – 25 light frames of M42
天体画像名を'<天体名>に設定する Set imaging target name to '<Target Object Name>' | 天体名を設定します（保存された画像や動画ファイルの名前に影響します）。
天体名を入力するプロンプトが表示される Prompt to enter the target name | 天体名の入力が促され、天体名が入力されるまでシーケンスは進行しません。
フレームタイプを「<タイプ>」に設定 Set frame type to '<Type>' | 撮影するフレームタイプをライト、ダーク、フラット、ダークフラット、バイアス、またはその他のいずれかに設定します。 なお、ここで指定したフレームタイプは、ファイル名にのみ影響します。

ガイディング

ガイディングアプリケーションのモニター Monitor Guiding Application | ガイディング設定 で設定したガイディングアプリケーション／デバイスへの接続を試みます。 選択したガイドアプリケーション／デバイスに接続できない場合は、エラーになります。 このステップは、他のガイド / ディザリング関連のステップの前に実行する必要があります。
ガイディングアプリケーションからの接続解除 Disconnect from Guiding Application | 現在接続されているガイディングアプリケーション／デバイスとの接続を解除します。このステップが実行された後は、他のガイド / ディザリングの手順を実行しないでください。
必要に応じてガイドを開始 Start guiding if necessary | 接続されたガイディングアプリケーションにガイドの開始を要求します。 この操作には、ガイドハードウェアの自動接続、露出ループの開始、星の選択、キャリブレーション、最終的なガイドが含まれます。 ガイドがすでに有効になっている場合は、何も実行されません。 ガイドが開始できない場合はエラーになります。
ガイドが有効になるまで待機 Wait until guiding is active | このステップでは、接続されているガイディングアプリケーション/デバイスが「ガイド」ステータスを報告するまで、シーケンスを続行することはできません。 この時点でガイドを開始するには、手動での操作が必要な場合があります。
ガイド停止 Stop guiding | ガイディングデバイス/アプリケーションにガイド停止要求を送信します。
アクティブな場合はガイドを一時停止し、このブロックが終了したら再起動する Pause guiding if active and restart when this block finishes | このステップのサブステップが実行されている間、ガイドを一時的に停止します。 この機能は、ガイドに邪魔されずにマウントを移動したり、プレートソルブを実行したりするのに役立ちます。
ガイディングアプリケーションから単一のディザリングを要求する Request a single dither from Guiding Application | 接続されたガイディングアプリケーションから単一のディザリング操作を要求します。 ガイド設定で指定された設定により、ディザリング操作の詳細が決まります。
<ディザリング間隔>秒単位でのディザリング Dither every <Dithering Interval> seconds | この時点からシーケンス内で（［周期的ディザリングの停止］ステップが実行されるまで）、SharpCapは定期的にディザリング操作を実行します。 ディザリング操作は、シーケンス内の特定のポイント（ステップ間または静止画画像ステップのフレーム間）でのみ実行できます。 このため、指定された間隔は、2つの ディザリング操作の間の最小の間隔です。通常、間隔が切れた後、 SharpCapが次の適切なディザポイントを待つため、間隔は長くなります。
周期的ディザリングの停止 Stop periodic dithering | 周期的ディザリングを取り消します。「<ディザリング間隔>秒単位でのディザリング 」ステップで再開できます。

高度な

<実行するシーケンス>にある一連のステップを実行する。

Run the sequence of steps in <Sequence to run>

このステップでは、別のシーケンスファイルを指定することができます。このステップが実行されると、他のシーケンスファイルのすべてのステップが実行されます。

'<「サブルーチン名>」というサブルーチンを定義します

Define a subroutine called '<Subroutine Name>'

指定された名前のサブルーチンを定義します。サブルーチンはサブルーチンステップ内に配置された一連のステップで構成されています。 このサブルーチンは、含まれるステップを何度も複製することなく、複数回呼び出すことで、一連の流れの中で繰り返し使用することができます。

先に定義された「<サブルーチン名>」というサブルーチンを呼び出します

Call a previously defined subroutine called '<Subroutine Name>'

先に定義したサブルーチンを呼び出し、シーケンスのこの時点でその中のステップを実行します。

サブルーチンを使うことで、複雑なシーケンスの設計やメンテナンスが容易になります。

<インポートするシーケンスファイル>にサブルーチンをインポート

Import subroutines in <Sequence file to import>

このステップでは、指定されたシーケンスファイルを読み込み、そのファイル内にあるすべてのサブルーチン定義を読み込みます。 これらのサブルーチン定義は、現在のシーケンスで使用することができます。

なお、読み込まれたシーケンスファイルの中で、サブルーチン定義やサブルーチン定義の一部ではないステップは無視されることに注意してください。

空の背景を測定し、最適なディープスカイの設定を＜最小露出（s）＞～＜最大露出（s）＞の間で設定する

Measure the sky background to set optimum deep sky settings between <Minimum Exposure (s)>s and <Maximum Exposure (s)>s

スマートヒストグラム脳の測定 を行い、カメラの最適な露出／ゲイン／黒レベルの設定を行います。 測定が完了すると、推奨されるカメラパラメータが適用され、次のステップへと進みます。

なお、この測定は、使用する予定のフィルターを装着した状態で行う必要があります。

調整できるパラメータは以下の通りです。

「 測定するチャンネル Channel to Measure 」ー 輝度を測定するカラーチャンネル。モノラルカメラの場合は明度に設定されます。

「フレームのコーナーやエッジを避ける Avoid frame corners/edges 」ー このオプションは、画像のコーナーやエッジ付近でケラレ（暗くなる）が発生する場合にチェックします。 このオプションを選択すると、SharpCapはこれらの領域を考慮しなくなり、より長時間の露光を推奨することになります。

「最小露出と最大露出 Minimum Exposure & Maximum Exposure 」ー 最大露出は、トラッキング / ガイド設定の制限によって決まります。 例えば、2分間の露出までは良い画像が得られるが、それ以上になると星の追跡に悩まされるという場合は、最大120秒に設定します。 最小露光量は、作成する画像ファイルの数や、位置合わせのために十分な明るさの星が必要であることなどを考慮して設定してください。

「統一感のあるゲインを目指す Aim for Unity Gain 」ー チェックした場合、SharpCap は統一感のあるゲインに近いゲイン値を選ぼうとします。 チェックを外した場合、SharpCapは、結果として得られるスタック画像の ダイナミックレンジ を見つけようとします。 なお、ディープスカイの画像にはノイズがつきものなので、統一感のあるゲインが他のゲイン値よりも優れているとは考えられません。

「ノイズ増加の許容範囲 (%) % Noiseincrease allowed 」ー これを、最終的なスタック画像に許容できる追加のノイズ量（理論上の最小値を超える量）に設定します。 少量の追加ノイズを許容することで、サブ露光の時間を短くすることができ、その結果、トラッキングやガイドの問題が少なくなります。 これが非常に低い値（5％未満）に設定されている場合、特に暗い空がある場合や狭帯域フィルターを使用している場合は、例外的に長時間露光を行うことができます。

<Pythonスクリプトファイル>にあるPythonスクリプトを実行する

Run the python script in <Python script file>

指定されたPythonファイルにあるSharpCapのPythonスクリプトコードを実行します。 これにより、他のシーケンサーステップでは得られない結果を得ることができるかもしれません。

pythonスクリプトの実行が終了するまで、シーケンスは続行されません。

「<タスク名>」という名前の定期的な操作を<間隔>秒ごとに実行する

Run a periodic task called '<Task Name>' every <Interval> seconds

このステップ内に配置されたステップは、周期的な操作を形成し、シーケンスの次の部分の実行中に周期的に実行されます。

この操作は、シーケンスの主要部分の他のシーケンサーステップの間、またはキャプチャ静止フレームステップの露出間でのみ実行されます。

つまり、操作を連続して実行する際の時間は、ほとんどの場合、定義された間隔よりも長くなり、その間隔よりも短くなることはありません。

P周期的なディザリングは、この方法で実現されます。

「<タスク名>」という名前の定期的な作業の実行を停止します

Stop running a periodic task called '<Task Name>'

以前に開始された定期的な作業をキャンセルします。 キャンセル後、作業は再度実行されません。

画面

画面を自動でストレッチ Auto stretch the display | 画面のストレッチパラメーター を調整すると、画像が自動的にストレッチされ、かすかな部分が最もよく見えるようになります。
画面ストレッチのリセット Reset the display stretch | 画面のストレッチパラメーターをデフォルト（未ストレッチ）の状態に戻します。
画面の拡大レベルの設定 Set the display Zoom level | SharpCapの画像表示の拡大レベルを変更します。なお、2モニター表示を有効にしている場合は、 プライマリモニター（SharpCapのメニューやコントロールが表示されているモニター）の拡大レベルにのみ影響します。

シーケンサーの座標

座標はRA / Dec表記である必要があり、さまざまな形式が受け入れられます。たとえば、次の形式のいずれかがオリオン大星雲の座標として受け入れられます。

05 35 17.3 -05 23 28 | 05 32 49.8 -05 25 21
RA 5h 35m 17s | Dec -5° 23′ 28″ | 5h35m 17s -5° 23′ 28″
5h35m17.39s/Dec-5°23'28.24" | RA=5h 35.4m, Dec= -05° 27´
RA: 05h 35m 24.0s Dec: -05°27'00" | 5h RA, -5° DEC
RA 05h 35.4m |Dec. -05° 27″ | RA 05h 35.4m, dec. –05º 27’
{RA=05:35:16,Dec=-05:23:28} | 5.58805 -5.391
(05:35:20.556, -05:18:32.593) | (83.84, -5.309)

いずれの場合も、値が24未満の場合、RA座標は（度ではなく）時間単位であると見なされます。


望遠鏡のハードウェア制御

SharpCapは、コンピューターに接続された様々なフォーカサー、フィルターホイール、GOTOマウントを制御できます。ほとんどのデバイスは、 ASCOM ドライバーを介してアクセスする必要があります。 適切なASCOMドライバー（おそらくデバイスメーカーから提供されている）であるASCOMプラットフォームをインストールし、 デバイスを使用するためにSharpCapを構成する必要があります。詳細については、SharpCapの設定の ハードウェアの設定 を参照してください。

正しいドライバーのインストールと設定が完了すると、カメラコントロールパネルの「望遠鏡制御」にデバイスが表示されます。

ハードウェア設定で選択した内容によっては、デバイスが接続されていない状態で始まることがあります（上図参照）。 デバイスが接続されていない場合は、各「接続済み」チェックボックスにチェックを入れるだけで、そのデバイスが接続され、その機能が利用できるようになります。

フォーカサー制御

フォーカサーの操作は、 「イン」ボタンと「アウト」ボタンで行います。 それぞれのボタン（粗いボタンと細かいボタン）の間には、ステップサイズ調整コントロールがあり、ボタンを押したときの移動量を調整することができます。 フォーカサーの現在の位置が表示され、このコントロールに新しい位置の値を直接入力することも可能です（新しい値を入力した後、<Tab>または<Enter>を押すと、 入力した値にフォーカサーが移動します）。 「逆行する」チェックボックスは、「イン」ボタンと「アウト」ボタンの意味を入れ替えるもので、「アウト」ボタンを押すとフォーカサーが内側に移動する場合に便利です。

お使いのフォーカサーに温度補正機能がある場合は、 「T.コンプ」のチェックボックスがあり、チェックを入れると温度補正機能がオンになり、チェックを外すとオフになります。

SharpCapの中でフォーカス位置を手動で変更するには、上図のフォーカサー調整コントロールを使用することができますが、SharpCapで電子フォーカサーを使用することの利点は、 フォーカスアシスタントツール との連携にあります。

フィルターホイール制御

フィルターホイールはSharpCapで簡単に制御できます。ボタンには使用可能なフィルターのリストが表示され、適切なボタンを押して目的のフィルターを選択することだけです。 ホイールがまだ動いている間は、フィルターを再度交換しようとしないことをお勧めします。 SharpCapによって表示されるフィルターの名前は、通常、フィルターホイールのASCOMドライバー設定ダイアログで構成できます。

SharpCapの他のASCOMハードウェアと同様に、「接続済み」チェックボックスをオフにすることで、一時的にデバイスから切り離すことができ、 「セットアップ」ボタンを押すことでASCOMドライバーの設定を表示することがでます。

フォーカサー制御に関しては、SharpCap内からフィルターを変更するのが便利ですが、電子フィルターホイールを使用することで、 SharpCapの他の部分との連携が可能になります。例えば、ファイル名に使用するフィルター名を設定したり (ファイル名の設定 参照) 、 シーケンサー または シーケンスプランナー を使用してイメージングを自動化したりすることができます。

SharpCapには、手動で操作するフィルターホイールの設定とコントロールを表示するオプションも含まれています。 手動ホイールを使用すると、SharpCapで現在選択されているフィルターを選択することができ、フィルター名をカスタムファイル名テンプレートで使用することができます。

GOTOマウント制御

SharpCapは、ほとんどのASCOMマウントに接続して制御できますが、機能量はASCOMドライバーの機能によって異なります （残念ながら、マウントがASCOM MoveAxis機能をサポートしていない場合、SharpCapは限られた機能しか提供しません）。

パソコンに接続できるGOTOマウントをお持ちでない方でも、以下のような場合には、SharpCapで限定的にマウントを制御できる可能性があります。

· カメラとマウントの両方にST4（ガイド）ポートがある場合。

· SharpCapは、カメラ（Altair、PlayerOne、QHY、SVBony、およびZWOカメラ）のST4制御をサポートします。

· カメラとマウントのST4ポートをST4ケーブルで接続する。

· SharpCapハードウェア設定でマウントに <On Camera ST4>を選択します。

これにより、方向ボタンを使ってガイドレートでマウントを微調整する機能や、 ディザリングのみのガイド を使用することができます。

座標読み出し

コントロールの左側には、現在の方位(Az)、高度(Alt)、赤経(RA)、赤緯(Dec)、時角(HA)が表示されます。 これらはマウントから定期的に更新されるため、プラネタリウムプログラムなど別のアプリケーションを使用して移動する場合は更新する必要があります。

時角は、次の範囲になります。12:00:00（マウントが真北の東を向いているとき）から00:00:00（マウントが子午線上にあるとき）を経て、 +12:00:00（西から真北に近づいているとき）まで。負の時角は、マウントが子午線に向かっていることを意味し、 （赤道儀の場合）子午線を越えて撮像を続けるためには方向反転が必要になることがあります。 例えば、時角が -00:25:00の場合、マウントは25分後に子午線に到達することを意味します。

移動ボタン

コントロールの中央部には移動ボタンがあり、SharpCap内でマウントを移動させることができる。 上下左右のボタンは、押している間、指定された方向にマウントを移動させます。 赤道儀の場合、上下は赤緯方向に、左右は赤経方向に移動します。 マウントは、コントロールの右上にある 「割合」ドロップダウンで選択できる速度で移動します。 このドロップダウンには、マウントが利用可能な移動速度がリストアップされています （このドロップダウンには、遅い移動速度は恒星時の倍数（1x、2x、8x）で、速い移動速度は1秒あたりの度数で表示されます）。 方向ボタンの間にある「停止」ボタンは、マウントの現在の動きを止めますが、方向ボタンを離すと動きが止まるので、通常は必要ありません。

また、以下のキーボードショートカットを使って望遠鏡を動かすことができます。

<CTRL>+J, <CTRL>+NUMPAD 4 | マウントを左に移動
<CTRL>+L, <CTRL>+NUMPAD 6 | マウントを右に移動
<CTRL>+I, <CTRL>+NUMPAD 2 | マウントを上に移動
<CTRL>+K, <CTRL>+NUMPAD 8 | マウントを下に移動

なお、移動ボタンやキーボードショートカットに反応してマウントが動く方向は、 ハードウェア設定 を調整することで（必要に応じて）逆転させることができます。

「スパイラル検索」ボタン [image] は、 押している間、スタート地点を中心に四角いスパイラルを描くようにマウントを移動させるボタンです。 惑星など、フレームからはみ出している天体を探すのに便利です。 なお、「スパイラル検索」の移動速度は、移動ボタンと同様に ドロップダウンで設定します。 「スパイラル検索」ボタンを離すと、スパイラルの動きが止まります。 再度ボタンを押すと、現在地を中心とした新しいスパイラルが始まりますが、以前のスパイラルパターンは再開しません。

「プレートソルブ」ボタン [image] は、現在の画像に対してプレートソルブを実行し、 マウントの位置をプレートソルブの結果に再同期させ、元の目標座標を元に戻します。 これにより、目標が中心から外れていたり、完全に視野から外れていたとしても、目標を視野の中心に置くことができます。 このボタンは、互換性のあるプレートソルバーが検出または設定された場合にのみ有効になります。詳細については、 プレートソルブタブ を参照してください。 このボタンからプレートソルバーを起動すると、ASCOMマウントから報告された現在の位置から15度以内の空の位置に検索が制限されることに注意してください。 これにより、プレートソルブの速度が飛躍的に向上しますが、現在のマウントの位置が非常に不正確な場合は、プレートソルブが失敗します。

その他の制御

「パーク」チェックボックスは、マウントの駐機または駐機解除に使用します。

最後に、「追跡」ボタン（右下）で、マウントの恒星時追跡度のオン／オフを切り替えることができます。 追跡をオフにすると、星やその他の天体が視野内を漂っているように見えます。 「追跡」ボタンの右側には、現在の追跡度を表示するドロップダウンがあり、変更することができます。 恒星(Sidereal)、太陽(Solar)、月(Lunar)の追跡度を選択できます。選択された追跡度がカスタム度の場合、「？」アイコンが表示されます。

SharpCapの他のASCOMハードウェアと同様に、 「接続済み」チェックボックスをオフにすることで、一時的にデバイスから切り離すことができ、 「セットアップ」ボタンを押すことでASCOMドライバーの設定を表示できます。


ダークフレームの撮影

デジタルカメラで撮影した画像には、カメラのセンサーや電子機器から発生するノイズがあります。 このノイズによる画質への影響を抑えるために、ダークフレームを使用することができます。 ダークフレームは、カメラのレンズ（または望遠鏡）を覆って光が入らないようにして撮影します。つまり、ダークフレーム内の信号はノイズによるものです。 ダークフレームを作成した後、各画像フレームからダークフレームを差し引くことで、ノイズの多くを取り除くことができます。 ノイズを正しく除去するためには、ダークフレームを画像フレームと同じ条件（露出、ゲイン、解像度、温度など）で撮影する必要があります。

最良の結果を得るためには、ダークフレームの撮影時に、カメラのセンサーがライトフレームの撮影時と同じ温度になっている必要があります。 多くのカメラには温度センサーが搭載されており（その値はSharpCapのカメラコントロールに表示される）、これを判断するのに役立つ。 長時間露光の熱によるノイズ対策として、ペルチェ式サーモエレクトリッククーラー（カメラの背面にある冷却器）を搭載しているカメラもありますが、 通常はカメラセンサーの温度をコントロールできるので、暗いフレームの撮影に最適です。

カメラのノイズ

以下は、カメラのノイズの例です。

右下の アンプグロー ー Webカメラで撮影した画像。このアンプグローは、ダークフレーム減算によって画像から取り除くことができます。

熱雑音 (Thermal noise) ー カラーアストロビデオカメラで撮影した画像。 この熱雑音は、ダークフレーム減算を使用して画像から除去できます。

最も明るいドットがホットピクセルで、これはモノクロカメラでゲインを高く設定した場合に生じる。 カラーカメラでは、このホットピクセルが異なる色で表示されます。 これらのホットピクセルは、ダークフレーム減算によって画像から取り除くことができます。

暗いフレームを撮影して後のフレームから差し引くことで、カメラのノイズを可能な限り除去します。

ダークフレームの説明

SharpCapはダークフレームを撮影することができ、その結果はデフォルトのキャプチャフォルダーの「darks」に保存されます。

ダークフレームは、これから撮影する画像と同じ解像度、同じ カラーモード で撮影する必要があります。 ダークフレームのノイズがライトフレームのノイズと可能な限り同じになるように、ダークフレームには撮影画像と同じ露出とゲインの値を使用し、 カメラセンサーの温度も同じにするのが理想的です。

SharpCapは、撮影したフレームから暗いフレームを差し引いてから、積み重ねたり保存したりできます。 この差し引きは、カメラのコントロールパネルで実行されます。 暗いフレームを個別に保存して、後で後処理ソフトウェアで使用することもできます。 以下は、ダークフレーム減算処理の例と、それが最終的な画像に与える影響です。

撮影フレーム

カメラの初期画像、ノイズが見える（拡大するとノイズがよく見える）。

減算

ダークフレーム

SharpCapによって生成されたダークフレーム画像。 これを生成するには、カメラのキャップを外すか、望遠鏡にカバーを付ける必要があります。

ノイズ除去

最終的な画像

カメラのノイズはほとんど除去されています。 ダークフレームの減算はSharpCap内で行っています。

ダークフレームの撮影処理

ここでは、ダークフレームを撮影して保存する処理を説明します。 この処理は、メインメニューの「キャプチャ」→「ダークフレームキャプチャ」から開始します。 ダークフレームの撮影を開始する前に、望遠鏡またはカメラをカバーして光を遮断する必要があります。

「ダークフレームキャプチャ」画面が開いている間は、SharpCapの機能を一切使用しないでください。 また、ダークフレームの撮影中（スタートボタンを押した後）は、カメラのコントロールを一切調整しないでください。 画面が閉じれば、ダークフレームの撮影処理が完了します。

テストカメラ 1（ディープスカイ）を使用し、上記の設定（10 フレーム）で、フォルダ構造を作成します。 このフォルダ構造は、カメラコントロールパネルのカメラ設定を表しています。

フォルダ gain_100には、以下のダークフレームセットが格納されています。

これはダークフレームの一例です。 白い点はホットピクセルで、背景には緑青の斑点があります。これをよく見るには、画像を150％以上に拡大してください。

ダークフレームは、ダークと同じ特性を持つ撮影（ライト）に対して適用する必要があります。 設定とカメラの温度を一致していることを確認するために、画像の撮影と同時にダークフレームを撮影するのが理想的です。

ダークフレームは、以下のように選択されたファイル形式で保存されます。

· 選択された出力フォーマットは、それが静止画フォーマットであり、16ビット画像をサポートしている場合に使用されます。そうでない場合は...

· 好ましい静止画フォーマットは、静止画フォーマットで16ビット画像に対応している場合に使用されます。そうでない場合は...

· ファイル形式はFITSを使用。

注意：カメラを ROI モードで動作させる場合、SharpCapは、ROIを一致させるために撮影された暗いフレーム（サイズと位置は同じである必要があります） または、カメラのフル解像度で撮影された暗いフレームのいずれかを使用できます。 フル解像度のダークフレームが使用されている場合、SharpCapはダークフレームの正しいサブ領域を自動的に選択します。

重要な注意：カメラに「フリップ」コントロールがある場合、ダークフレームはライトフレームやフラットフレームと同じフリップ設定で撮影する必要があります。


フラットフレームの撮影

フラットフレームの説明

フラットフレームは、フレーム内の不要な明るさの変化を補正するために使用されます。 このような明るさの変化は、レンズや望遠鏡の光学的構成により、フレームの端や隅に届く光が少なくなって暗くなること（ケラレと呼ばれる）や、 センサー、センサーガラス、フィルター上にほこりやゴミがあることが原因となる場合があります。 ホコリは、画像上の暗い斑点の原因となり、単純な斑点（下の画像に見られるような）や、 中心部に障害物がある望遠鏡を使用している場合には、小さな暗いドーナツ型になります。

スタック中のフレームの配置が異なると、未知の方法でフレームが広がり、スタック後に完全に修正できなくなるため、 画像をスタックする前にダストスポット（ほこりやゴミ）とケラレを修正する必要があります。

このような画像の欠陥を補正するために、フラットフレームを撮影します。フラットフレームとは、完全に均一な照明を受けた表面の画像のことであり、 フラットフレームの明るさの変化は、ケラレやダスト（ほこりやゴミ）の影響によるものだけになります。 下の画像は、上で使用したのと同じ（かなり汚れた）カメラセンサーで撮影したフラットフレームで、ほこりの斑点がはっきりと見えます。

実際には、多くのフラットフレームを撮影し、それらを平均化して、個々のフラットフレームよりもノイズの少ない「マスターフラット」を作成するのが良い方法です。 上のフラットフレーム画像は、実際には30枚の個別フラットフレームから作成されたマスターフラットであり、表示されているライトフレームよりも明らかにノイズが少ない。

フラットフレーム補正とは、フラットフレームが平均よりも暗くなっている部分の撮影画像を明るくして、 その部分のカメラセンサーに届く光の量が少なくなっていることを補正することです。 上の画像とフラットフレームを使って、補正後の画像を見てみると、下のようになります。 補正後の画像では、基本的にダストスポット（ほこりやゴミ）の影響を確認することはできません。

なお、フラットフレーム補正は、太陽電池の撮影で問題となる「ニュートンリング」のような光学的干渉パターンの影響を画像から取り除くのにも役立ちます。

フラットフレームの作成

「キャプチャ」メニューから「フラットフレームキャプチャ」を選択します。これで自動的にヒストグラムが有効になり、ウィンドウが表示されます。

フラットフレームの作成に必要な手順は以下の通りです。

ステップ1. フラットフィールド照明 Set up Flat Field Illumination

これは、望遠鏡やカメラの対物レンズや主鏡を均一に照射して、撮影画像の明るさの変化がゴミやケラレなどによるものだけになるように調整することです。

これは、フラットフレームを使用する上で最も難しい部分です。ネット上には様々な方法が紹介されていますが、簡単にまとめると以下のようになります。

· 望遠鏡の先端を白いTシャツで覆い、任意の光源を使用する

· 澄んだ青空に望遠鏡を向ける

· 曇り空の均一な空に望遠鏡を向ける

· エレクトロルミネッセントパネルの使用

フラットフレームを撮影した後、実際の目標画像を撮影するまでの間、撮像システムの向きや配置を変更しないようにしてください。

· カメラの回転

· カメラの取り外しと再装着

· フィルター、レデューサー、バローなどの追加／削除／変更

· 必要以上のピント調整（微調整はOK）

ステップ2. カメラの設定 Select Camera and adjust Settings

この段階では、カメラが正しい設定になっていることを確認してください。 1600x1200、ビン1、RAW12で撮影する場合は、フラットフレームを撮影する前にカメラをこの設定にします。 フラットフレームに同じ露出やゲインを使用する必要はありません（実際、これは通常機能しません）。 フラットフレームはできるだけノイズが少ない方が良いので、通常はゲインを低く設定するのが良いでしょう。

ステップ3. 適正なヒストグラムになるように露出を調整 Adjust exposure to get correct histogram

適切なフラットフレームを作成するには、適切な露出が重要です。 「フラットフレームキャプチャ」画面の「ヒストグラムステータス」エリアに表示されるテキストには、そのためのガイダンスが示されています。

理想的なフラットフレームのヒストグラムは、約50〜60％のレベルにピークがあり、20〜80％のレベルの間にすべてのヒストグラムがあるものです。 モノクロカメラとカラーカメラの場合、以下のようになります。

どちらの場合も、ヒストグラムの範囲を見やすくするために、対数ヒストグラムスタイルが使用されていることに注目してください。 また、カラーカメラの場合、青と赤のピクセルの明るさの違いから、両色のヒストグラムをすべて20〜80％の範囲に収めることはできませんでしたが、 ホワイトチャンネルのヒストグラムは45〜60％の範囲に収まっていることにも注目してください。

ステップ4. オプションの選択

「フラットフレームキャプチャ」画面では、以下のオプションを変更することで、フラットフレームの作成手順をカスタマイズすることができます。

· 「 平均化するフレーム数の選択 Choose number of Frames to Average 」ー SharpCapは、この数のフレームを撮影し、撮影したフレームを平均化してマスターフラットフレームを作成します。 ここでの数値が大きいほど、最終的なマスターフラットフレームでのノイズが少なくなり、最終的な画質の向上につながります。

· 「 バイアスフレームの撮影と減算 Capture and Subtract Bias Frames 」ー これを選択した場合、SharpCapは、フラットフレームを撮影した後にカメラの露出を最小に設定し、その後、同数の バイアスフレーム を撮影します。マスターフラットフレームは、すべてのフラットフレームの平均値から、 すべてのバイアスフレームの平均値を差し引いたものになります。 このオプションを選択すると、広い範囲の画像の明るさでより良いフラット補正を行うことができますが、 フラットフレームを撮影してから目標画像フレームを撮影するまでの間に、カメラのブラックレベル / オフセット / 輝度コントロールを変更しないことが必要です。

· 「 モノクロのフラットフレーム作成 Create Monochrome Flat Frame 」ー デフォルトでは選択されていますが、カラーカメラにのみ関係するオプションで、 カラーカメラでも作成されたフラットフレームはモノクロになります。モノクロのフラットフレームは、使用時に画像の明るさにのみ影響します。 このオプションが選択されていない場合は、カラーフラットフレームが作成され、使用時に撮影画像のホワイトバランスを変更する効果があります。

ステップ5. フラットフレームの撮影開始 Start Capturing Flat Frame

「Start」ボタンを押すと、フラットフレーム（オプションが選択されている場合はバイアスフレームも）の撮影が開始されます。 「 撮影完了時に新しいフラットを適用 Apply new flat when capture complete 」 オプションがチェックされている場合は、新しく作成されたマスターフラットフレームが準備完了時に自動的に選択されます。

また、 「 10秒後に開始 Start in 10 seconds 」 ボタンを使用することもできます。このボタンを使用すると、フラットフレームの撮影を開始する前に10秒間遅延します。 例えば、エレクトロルミネッセンスパネルを手で持ってフラット撮影する場合など、 フラット照明の設定とコンピューターのマウス／キーボードの操作を同時に行うことが困難な場合に有効です。

フラットフレーム補正の使い方

フラットフレームは、カメラコントロール「前処理」の フラット補正 コントロールを使って選択できます。

参照ボタンを押して、すでにディスクに保存されているフラットフレームを選択するか、ドロップダウンを使って最近使用したフラットフレームを選択します。 フラットフレーム補正を無効にするには、ドロップダウンから「なし」を選択します。

注意 1：カメラを ROI モードで動作させる場合、 SharpCapは、一致するROI用に撮影されたフラットフレーム（サイズと位置が同じである必要がある）、 またはカメラのフル解像度で撮影されたフラットフレームを使用することができます。 フル解像度のダークフレームを使用した場合、SharpCapはフラットフレームの正しいサブエリアを自動的に選択します。

注意 2：カメラに「フリップ」コントロールがある場合、フラットフレームは、ライトフレームやフラットフレームと同じフリップ設定で撮影する必要があります。

なお、他のソフトウェアで作成されたフラットフレームは、互換性のあるフォーマット（PNG、FITS、TIFF）で保存されていれば、SharpCapで使用することができます。

フラット補正を行うと、画面に表示される画像と、任意の撮影ファイルに保存される画像データの両方に影響を与えるため、 SharpCapでフラット補正を行った場合は、後の処理でフラット補正を行う必要はありません。

SharpCapのフラットフレーム補正は高速度カメラでも可能です。 LifeCam Cinemaは1280x720x30fpsで実行され、フラットフレームを適用するとCPU使用率が1％しか増加しません。 SharpCapは最新のCPUの特別なビデオ処理命令を使用して、フラットフレームを非常に効率的に適用します 。 高速CPUを使用すると、1920x1080x150fpsで実行されているUSB3カメラにフラットフレームを適用できます。

フラットフレーム補正の効果

フラットフレーム補正を行うには、いくつかの注意が必要です。 ディープスカイ画像を撮影し、最終的に画像を引き伸ばして処理する場合（SharpCapのライフスタックや外部のスタック/処理アプリケーションを使用する場合）は、 月/太陽/惑星画像のほこりの影を除去するためにフラット補正を使用する場合よりも、はるかに大きな注意が必要です。 ディープスカイの撮影では、画像が引き伸ばされるため、フラットフレーム補正の不正確さがより顕著になります。

ディープスカイ画像では、以下の手順でフラットフレームを撮影と使用することをお勧めします。

· フラットフレームを撮影する際には、 バイアスフレームを減算するオプション を使用するか、フラットフレームと同じカメラ設定で撮影したダークフラットフレームを使用します。

· ライトフレームを撮影する際には、必ずダークフレーム減算を行い、 ダークフレームがライトフレームと同じカメラ設定、同じ温度で撮影されていることを確認してください。

注意：ライトフレームを撮影する際にダークフレームを使用しなかった場合、 フラットフレームが過剰に補正される傾向があります（以前は暗かった部分が平均よりも明るくなります）。 バイアスフレームを減算するオプション またはダークフラットフレームのいずれかを使用しないと、 フラットフレームが過小補正になる傾向があります。

月 / 太陽 / 惑星の撮影では、以下の手順で撮影することをお勧めします。

· フラットフレームを撮影する際には、 バイアスフレームを減算するオプション を使用します。暗いフラットフレームを使用する必要はありません

· ライトフレームを撮影する際には、ダークフレームを使用しないでください。 SharpCapは、フラットフレームのオフセット情報を使用して、画像のペデスタル (pedestal) オフセットを計算します。

· ライトフレームとフラットフレームを（できるだけ）同じカメラ設定で撮影してください。 特に、オフセット / ブラックレベル / 輝度コントロールは変更せず、ゲインもできるだけ変更しないようにしてください。


キーボード ショートカット

SharpCapの操作には、以下のキーボード ショートカットが使用できます。

<CTRL>while opening SharpCap | 起動時にカメラを開かない、起動時のスクリプトやシーケンスを実行しない
<SHIFT> while opening SharpCap | SharpCapのログをすぐに表示
<CTRL> while opening a camera | カメラに保存されているデフォルトの画像プロファイルを読み込まず、以前使用したカメラの設定を復元しない
<SHIFT> while adjusting histogram stretch levels | ヒストグラムのストレッチレベルを、マウスの動きの10倍の速さで動かすことで、細かな制御が可能
<CTRL> + Mouse Wheel over image | ズーム イン/アウト
Mouse Wheel over image | 上下にスクロール
<SHIFT> + Mouse Wheel over Image | 左右にスクロール
F1 | 露出を減らす
F2 | 露出を増やす
F3 | ゲインを減らす
F4 | ゲインを増やす
F5 | ブラックレベル / オフセット / 輝度を減らす
F6 | ブラックレベル / オフセット / 輝度を増やす
F7 | フォーカサーをマイナス方向に移動
F8 | フォーカサーをプラス方向に移動
<ALT+F11> | スクリプトコンソールの表示
F11 | フルスクリーンモードの切替え
F12 | ナイトモードの切替え
<CTRL>+F12 | 2つのモニターモードの切替え
<ALT>+S | 撮影開始
<ALT>+Q | クイック撮影（最近使用した長さ）
<ALT>+T or <ESCAPE> while Capturing | 撮影停止
<ALT>+A | スナップショット 1フレーム
<ALT>+L | ライブスタックの有効化
<ALT>+F4 | SharpCapの終了
<CTRL>+J, <CTRL>+NUMPAD 4 | マウントを左に移動
<CTRL>+L, <CTRL>+NUMPAD 6 | マウントを右に移動
<CTRL>+I, <CTRL>+NUMPAD 2 | マウントを上に移動
<CTRL>+K, <CTRL>+NUMPAD 8 | マウントを下に移動
<ESCAPE> (while capturing) | 撮影停止

なお、マウント移動キーは、 マウント制御 の左右上下の方向ボタンと同じで、キーを押している間はマウントが移動し続けます。


SharpCapの設定

SharpCapの設定は、「ファイル」メニューから「SharpCapの設定」ダイアログにアクセスして行います。

全般タブ

全般タブには、「起動」「シャットダウン」「画面」「その他」の4つのグループに分けられた様々な設定項目があります。

起動設定

SharpCapの起動時にヒントを表示

この「起動時にヒントを表示する Show tips on startup 」オプションはデフォルトでチェックされています。 「今日のヒント Tip of the Day 」は、SharpCapの起動時に表示されますが、次回以降の起動時にはここで無効にするか、 SharpCapの起動時に無効にすることができます。

SharpCapの起動時に、最近使用したカメラに自動的に再接続

設定すると、SharpCapの起動時に最近使用したカメラに自動的に再接続します。 設定されている場合は、SharpCapの起動時にControlキーを押しながら起動すると、この設定が無効になり、起動時にカメラを開くことがなくなります。 この設定は、デフォルトで有効になっています。

カメラを開く時に、最後に使用したカメラ設定を自動的に復元

設定すると、カメラを閉じたとき（またはSharpCapを閉じたとき）に、各カメラの現在の設定が保存され、次にカメラを開いたときにその設定が復元されます。 保存された設定は、「_autosave」という非表示の撮影プロファイルに保存されます （このプロファイルは、同じPCで使用している古いバージョンのSharpCapでは表示されている場合があります）。 以前の設定を再読み込みしたくない場合は、カメラを開いている間に<CTRL>キーを押してください。この設定はデフォルトでチェックされています。

シャットダウンの確認

この設定を行うことで、SharpCapを閉じようとしたときに、確認を求めるかどうかを設定することができます。設定できる項目は

· 「しない」ー SharpCapは常にすぐに閉じて、確認を求めない。

· 「キャプチャまたはライブスタック時」ー SharpCapは、画像を有効に撮影したり、またはライブスタックを行うときに確認を求めます。

· 「カメラが開いている時」ー カメラが選択されている場合、SharpCapは確認を求めます。

· 「いつも」ー SharpCapは、必ずシャットダウンの確認を行います。

なお、シーケンスプランナーやシーケンスエディターのシーケンス実行中にSharpCapを閉じることはできませんので、 シーケンスを停止してからSharpCapを閉じる必要があります。

画面設定

翻訳が利用可能な場合でも、常に英語でSharpCapを表示

SharpCapでは、他の言語への部分的な翻訳が可能になりました（現在は、フランス語、ドイツ語、スペイン語、日本語、ロシア語、中国語）。 これらの翻訳は、サポートされている言語のいずれかがWindowsの表示言語として設定されている場合、 自動的に有効になります。あなたの言語に翻訳がある場合でも、SharpCapを英語で表示したい場合は、このオプションを選択した後にSharpCapを再起動してください。

暗視カラーで表示

このオプションを選択すると、SharpCapは夜間の使用に適した暗い色調で表示されます。また、<F12>キーを押すことで、2つの配色を切り替えることができます。 デフォルトでは、このオプションはチェックされていません。

通常のカラー | 暗視カラー

目視で観察する場合は、暗視を使用して、撮影中に目の暗い順応を維持します。

SharpCapを使用している時に、画面とコンピューターの電源が切れるのを防ぐ

このオプションを有効にすると、SharpCapの実行中にパソコンやモニターがスリープ状態になるのを防ぐことができます。

自動ストレッチの強度

この設定は、ミニヒストグラムとライブスタックの自動ストレッチ機能の強さを制御します。 このオプションをより大きな値に設定すると、自動ストレッチボタンは画像の暗い部分をより強く明るくします。 このオプションは、自動ストレッチボタンが好みの結果になるまで調整することができます。

その他

保存された天体名

このオプションは、あらかじめ設定された天体名のリストです。 天体をリストに追加したり、リストから削除したり、リストを並べ替えたりすることができます。

新しい天体を追加するには、「M42」や 「渦巻き銀河 Whirlpool Galaxy 」などの名前を「天体名の保存」リストに任意で入力します。 「適用」をクリックすると、修正したリストが保存されます。 修正したリストは、次回SharpCapを起動したときに使用できます。

このリストは、画面上部のツールバーの「天体名」にも表示されます。 「天体名の保存」で追加された天体は、ツールバーのドロップダウンリストにも表示されます。

例を挙げると

· 天体名未定義（デフォルト）：フォルダーに保存されたキャプチャ：YYYY-MM-DD \ Capture

· 定義された天体名：フォルダーに保存されたキャプチャ：YYYY-MM-DD \ Object

· 天体名として選択された月：フォルダーに保存されたキャプチャ：YYYY-MM-DD \ Moon

保存タブ

このタブは、「ファイル形式」「キャプチャ情報の保存」「ファイル形式のオプション」の3つのグループに分けられた様々な設定項目があります。

ファイル形式

自動出力形式でカメラを起動

このオプションはデフォルトでチェックされています。 このオプションは、カメラが開いているときに出力形式を自動モードに設定します （使用中のカメラ設定や画像タイプと互換性がある場合）。 出力形式が自動モードの場合、5秒未満の露光時間では互換性のあるビデオ形式が自動的に選択され、 5秒以上の露光時間では互換性のある静止画ファイル形式が自動的に選択されます。 または、特定のファイル形式を選択するオプションがない場合に保存するときに使用されます。 可能であれば、優先形式が使用されます。

優先ビデオ形式

AVIはデフォルトのビデオ形式です。 これにより、カメラコントロールパネルのフォーマット部分でビデオ画像の自動選択形式が決まります。

優先静止画形式

PNGはデフォルトの静止画形式です。 これにより、カメラコントロールパネルのカメラ部分で、静止画の自動選択形式が決まります。

なお、この形式は、SharpCapが保存時にファイルタイプの入力を求めない場合にも使用されます （例えば、ライブスタックのRAWフレームの保存や、新規に作成したダークフレームやフラットフレームの保存など）。

キャプチャ情報の保存

各キャプチャと一緒にキャプチャ設定ファイルを保存

このオプションをオンにすると、SharpCapは、新しい撮影を開始するたびに、すべてのカメラ設定を含むテキストファイルを撮影ファイルと一緒に保存します。 このファイルは、特定の画像に使用された設定を後から確認するのに便利です。このオプションは、デフォルトで有効になっています。

22_06_22.avi & 22_06_22.カメラ設定.txt

右側のテキストファイルには、カメラコントロールパネルで設定した撮影の内容が含まれていますので、今後の観測の参考にしたり、後処理で解析したりするのに役立ちます。

テキストファイルの名前には作成時刻が反映されます。

撮影したデータ（動画または静止画）とカメラ設定.txtファイルのファイル名には、同じタイムスタンプが入ります。

各キャプチャと一緒に画像ヒストグラムデータをCSVで保存

このオプションをチェックすると、SharpCapは画像ヒストグラムのデータをCSV形式で撮影ファイルや撮影設定ファイルと一緒に保存します。 ヒストグラムのデータは、撮影の初期のフレーム（通常は最初の撮影フレーム）から取得されます。

ファイル形式のオプション

10/12/14ビットの画像を16ビットに拡大せずにFITSファイルに保存

このオプションはデフォルトではオフに設定されており、後処理ソフトウェアでストレッチ前の画像に問題があるような特殊な使用方法の場合にのみ有効にする必要があります。 疑問がある場合は、このオプションをオンにせず、撮影作業でこのオプションを使用する前に、必ずサンプル画像で正しい結果が得られるかどうかをテストしてください。 なお、このオプションは Altair、QHY、ZWOカメラのみに有効です。

デフォルトでは、SharpCapは10、12、および14ビットの画像をファイル（FITS、TIFF、PNG、またはSER形式）に保存するときに、 16ビットの全範囲（0〜65535）を使用するように拡大します。 このストレッチを適用しないと、保存された画像が非常に暗く表示され、画像が正しく表示される前にすべてを明るくする必要があるため、これは望ましいことです。 ただし、一部の画像処理ソフトウェア（特に測光ソフトウェア）では、このような事前に引き伸ばされた画像を正しく処理できません。 このような状況が発生した場合は、このオプションをオンにして、SharpCapにストレッチされていないFITSファイルを保存させることができます。

TIFFファイルを圧縮

このオプションは、SharpCapの新規インストールではデフォルトでオフになっています。つまり、SharpCapはTIFFファイルを圧縮しようとしません。 圧縮を使用するとファイルサイズが小さくなりますが、一部（例：PIPP）の画像処理アプリケーションは圧縮されたTIFFファイルを読み取ることができません。 このオプションを有効にする場合は、画像処理ソフトウェアでテストしてください。

ハードウェア タブ

下は、SharpCapをデフォルトでインストールした場合のハードウェア画面です。 「フォーカサー」、「フィルターホイール」、「マウント」の各項目が 「なし None 」 と表示されています。

コンピュータ制御のマウント、フォーカサー、フィルターホイールをお持ちの方は、このタブを使ってSharpCapとの通信を設定することができます。 ほとんどの場合、SharpCapは ASCOM に準拠して通信するように設定しますが、以下のSharpCapで直接制御できるハードウェアデバイスもあります。

· ZWO EFWフィルターホイール

· QHYフィルターホイールは、カメラの丸いプラグ（USBではない）を介して接続されています。

· SharpCap（Altair、Player One、QHY、SVBony、ZWO）から直接アクセスする場合は、選択したカメラにST4ケーブルを介して動きをマウントします。 ASCOMまたはDirectShowドライバーを介してカメラにアクセスする場合は使用できません。

· 手動のフィルターホイールです。これは実際には電子フィルターホイールを必要とせず、SharpCapのUIに設定可能なフィルターオプションの選択で表示します。 SharpCapでフィルターを手動で選択すると、電子フィルターホイールがなくてもSharpCapが保存ファイル名にフィルター名を含めることができます。

SharpCapでASCOMハードウェアを検出するには、特定のハードウェア用の ASCOMプラットフォーム とASCOMドライバの両方がインストールされている必要があります。 ドロップダウンに何も表示されない（またはほとんど表示されない）場合は、ASCOMプラットフォームがインストールされているか、 最新の状態であるかを確認してください（古いバージョンのASCOMプラットフォームでは、SharpCapが動作しない場合があります）。

ハードウェアの種別ごとに、ドロップダウンから使用可能にしたいデバイスを選択することができます。 また、ドロップダウンリストの右側にある 「プロパティ」ボタンを押すと、そのデバイスを設定することができます。「プロパティ」を押したときに表示されるウィンドウは、 通常、デバイスのASCOMドライバー（デバイスメーカーが作成）が提供するものです。 デバイスのプロパティウィンドウが表示されない場合は、タスクバーに新しいアイコンが表示されていないか確認してください。

カメラを開く時の自動接続

カメラを開くときにハードウェアを自動的に接続する オプションをチェックするかしないかで、SharpCapが自動的にハードウェアへの接続を試みるかどうかを制御できます。 これは個人的な好みの問題ですが、フォーカサー／マウント／フィルターホイールが常に使用可能な状態であれば、 自動接続を有効にすることで、毎回手動で接続する必要はありません。 ハードウェアが接続されていなかったり、電源が切れていたりすることがある場合、自動オプションを有効にすると、 カメラを開くときにエラーメッセージが表示されることがあり、まぎらわしく感じることがあります。

自動接続オプションを有効にしていない場合は、カメラを開いた後、デバイスの「接続済み」チェックボックスにチェックを入れて、 各デバイスを手動で接続する必要があります。

フォーカサーの設定

ドロップダウンのリストからお使いのフォーカスドライバーを選択します。 フォーカサーをまだ使用していない場合（または、コンピュータへの接続方法を変更した場合）、プロパティボタンを押してフォーカサーを設定する必要があるかもしれません。 多くの場合、フォーカサーが接続されているCOMポートを指定する必要があります。 再起動、Windowsアップデート、PCのハードウェア変更などにより、COMポート番号が予期せず変更されることがありますので、 フォーカサーが動作しなくなった場合には、この点を確認してください。

フォーカサーを設定すると、カメラを開いているときにカメラコントロールパネルの「望遠鏡制御」エリアからフォーカサーを使用できるようになります。

フォーカサーのバックラッシュ補正

SharpCapでは、フォーカサーのバックラッシュ補正を行うことができます（ASCOMドライバーでもこのオプションを提供している場合があります）。 SharpCapでもASCOMドライバーでもバックラッシュ補正を設定することで、フォーカスの信頼性が向上します。

バックラッシュ補正値を計算するには、既存のバックラッシュ補正をオフにして、ベストフォーカスの位置を2回測定します。 1回はフォーカサーを外側に移動し、もう1回は内側に移動します（セットアップに他の変更はありません）。 各測定では、ベストフォーカス位置から十分に離して開始し、フォーカスチェックを始めるようにしてください。

ベストフォーカスの2つの位置が21150（外側に移動）と21020（内側に移動）になったとすると、 この2つの値の差（130）を取ると、それが設定すべきバックラッシュ補正の量になります。 この値をASCOMドライバーで設定するか（「ASCOMドライバーで処理」オプションをチェックする）、「SharpCapで処理」オプションをチェックして、2つの測定値の差を 「適用量 」ボックスに入力します。

なお、SharpCapがバックラッシュ補正を行っている場合、SharpCapを閉じて再度開いても、 （SharpCapが接続されていない状態で、他のアプリケーションによってフォーカサーの位置が変更されない限りにおいて） フォーカサーの最後の移動方向とバックラッシュの状態は記憶されています。

また、SharpCapがバックラッシュ補正を行っている場合、SharpCapに表示されるフォーカサー位置の値は、 負の方向に移動する際のバックラッシュ調整を考慮したものになります。 つまり、SharpCapに表示される値は、フォーカスASCOMドライバーに属するユーザーインターフェースに表示される値とは異なる可能性があります。

フィルターホイールの設定

ドロップダウンのリストからお使いのフィルターホイールドライバーを選択します。 フィルターホイールをまだ使用していない場合（またはコンピューターへの接続方法を変更した場合）、フィルターホイールを設定するために 「プロパティ」ボタンを押す必要があるかもしれません。多くの場合、フィルター・ホイールが接続されているCOMポートを指定する必要があります。 再起動、Windowsアップデート、PCのハードウェア変更などにより、COMポート番号が予期せず変更されることがありますので、 フィルターホイールが動作しなくなった場合には、この点を確認してください。

ZWO EFWフィルターホイールは、SharpCapで直接検出することができ、ASCOMドライバーなしで使用することができます。

QHYフィルターホイールがUSBではなく丸いプラグでカメラに接続されている場合は、ここでASCOMドライバーを選択しないでください。 QHYカメラを開くと、SharpCapが自動的にホイールを検出して起動します。

フィルターホイールを設定すると、カメラを開いているときにカメラコントロールパネルの「望遠鏡制御」エリアで使用できるようになります。

フィルター変更時のフォーカスオフセット

フィルターホイールASCOMドライバーの中には、フィルターごとにフォーカスオフセット値を保存できるものがあります。 この値は、このフィルターを選択したときに、フォーカスを良好に保つためにフォーカサーを移動させなければならない量を示します（フィルターの光学的深度を調整します）。 「フォーカスオフセット情報を使用して、フィルター変更後のフォーカスを調整」オプションをチェックすると、SharpCapはフィルター変更時にこの情報を使用してフォーカスを調整します （SharpCapとASCOMフォーカサーが接続されていることが条件です）。

例えば、赤フィルター（フォーカスオフセット値12）から緑フィルター（フォーカスオフセット値17）に移動した場合、SharpCapはフィルターの変更に伴い、 フォーカサーの位置を＋5（17-12＝5）します。この機能を正常に動作させるためには、バックラッシュ補正を適切に設定することが重要です。

マウントの設定

ドロップダウンのリストからお使いのマウントドライバーを選択します。マウントをまだ使用していない場合（またはマウントのコンピュータへの接続方法を変更した場合）は、 「プロパティ」ボタンを押してマウントを設定する必要があるかもしれません。 多くの場合、マウントが接続されているCOMポートを指定する必要があります。 再起動、Windowsアップデート、PCのハードウェア変更などにより、COMポートの番号が予期せず変更されることがありますので、 マウントが動作しなくなった場合には、この点を確認してください。

このオプションを選択し、ST4ガイドポートがサポートされているカメラ（Altair、Player One、QHY、SVBony、ZWO）を使用している場合、 マウント移動ボタンが使用されると、SharpCapはST4ポートを介してガイドコマンドを送信します。 この場合、機能は制限されますが（現在の位置の表示などはありません）、カメラのST4ポートとマウントのST4ポートが接続されていれば、 SharpCap内でマウントの位置を調整することができます。

マウントを設定すると、カメラを開いているときに、カメラコントロールパネルの「望遠鏡制御」エリアからマウントを使用できるようになります。

また、矢印ボタンを押したときのマウントの動きが期待通りでない場合は、「水平 / 垂直移動ボタンを反転」を選択することもできます。

マウント座標系の注意点

プレートソルブ、最近の操作とGOTO操作を正しく正確に行うためには、ASCOMマウントの座標系の設定が正しく行われていることが重要です。

地球の軸の方向とその軌道の形は時間とともに変化します。 変化は小さくゆっくりですが、何年にもわたって大きくなり、目立つようになります。 これは、遠くの天体のRA座標とDec座標（リゲル星を例にとると）がゆっくりと変化することを意味します。 この問題に対処するために、天体の座標は通常、特定の日付のものとしてリストされます。J2000は一般的な参照日です。つまり、座標は年の初めに測定されたものです。 2000.天文学ソフトウェアは、地球の軌道が時間の経過とともにどのように変化するかを知っているため、 2000年のこれらの値を現在の時刻の正しい値（多くの場合、JNOW座標と呼ばれます）に変換できます。

リゲルの場合、J2000座標は次のとおりです。RA= 05h 14m 32s、Dec = −08°12 ′06″

JNOWの座標（2021年5月）は、RA = 05h 15m 31s Dec= -08° 10′ 44″ です。

これを考慮しないと、RAで約1分、Decで約1.5分の位置ずれが発生することがわかります。 マウントの座標系の設定が間違っていると、GOTO、プレートソルビング、最近の操作のたびに、このようなエラーが発生します。

JNOWとJ2000の座標の違いは、ASCOMのマウントドライバーが使用する座標系を正しく記録していれば、SharpCapが対応します。 理論的には、ASCOMドライバは5つの座標系のうちの1つを記録することができます。 B1950、J2000、J2050、JNOW、Unknown/Other。実際には、B1950とJ2050は使用される可能性が低く、処理されない。 他の3つのオプションは以下のように処理されます。

· JNOW ー SharpCapは、ASCOMドライバーが現在の日付に有効なRA / Dec座標を受け入れて記録することを前提としています。 ASCOMドライバーは、この座標系を記録する場合、日付に基づいて座標に内部修正を加えてはなりません。

· Unknown/Other ー SharpCapでは、「不明／その他 Unknown/Other 」 と表示されたASCOMドライバは、実際にはJNOW座標で動作していると仮定しています。これは、JNOW座標で動作するEQMODなどのデフォルト設定です。

· J2000 ー SharpCapは、J2000を報告するASCOMドライバーが真実を語っていると想定しています。 つまり、ASCOMドライバーは必要に応じてJ2000座標をJNOWとの間で内部変換し、GOTOをJ2000の位置にすると、実際の望遠鏡が JNOW座標を対象としています。 ASCOMドライバーがJ2000を記録し、この変換を実行しない場合、GOTO、プレートソルブ、および最近の呼び出し操作で位置エラーが発生します。

SharpCapがサポートするプレートソルブツールは、常にJ2000座標で結果を記録します。 お使いのマウントがJNOW座標を必要としている場合、SharpCapはこれらの値をJNOW座標に変換します。

他のアプリケーションを使用して ASCOM マウントを操作している場合（Cartes du Ciel や SkytechX などのプラネタリウムアプリケーション）、 GOTO 操作を行う際にマウントに正しい座標を送信するように設定する必要があります。 ここでも、プラネタリウムアプリケーションがJ2000座標をJNOWで動作するマウントに送信したり、 その逆を行ったりすると、GOTO位置がわずかに間違ったものになり、その後の「プレートソルブ後再同期」ツールの結果も間違ったものになります。

シミュレートされたハードウェア

ASCOMプラットフォームには、テストや実験に使用できるさまざまなハードウェアドライバーがシミュレートされています。

· ASCOM シミュレーター用フォーカサードライバー ASCOM Simulator Focuser Driver

· フィルターホイールシミュレーター [.NET] Filter Wheel Simulator [.Net]

· [.NET] 用望遠鏡シミュレーター Telescope Simulator for .NET

これらは、観測の前にSharpCapを使ってハードウェアの使い方を学ぶのに非常に役立ちます。また、以下のものも参考になります。

· EQMOD ASCOM シミュレーターは、スカイウォッチャー望遠鏡用のEQMOD ASCOMドライバーと同様の動作をする望遠鏡シミュレーター

· ASCOM Sky シミュレータ ー( https://sourceforge.net/projects/sky-simulator/ ) は、 ASCOMが提供するシミュレートされたフォーカサーとマウントにリンクできるシミュレートされたカメラを提供します。 マウントを移動すると、カメラによって生成された画像が生成されます、あなたが観察している空の部分を反映するように更新されます。

ファイル名 タブ

このタブでは、撮影した画像や動画の名前や整理の仕方を細かく設定できます。

キャプチャしたファイルの保存先

これにより、最上位のキャプチャフォルダーを選択することができます。 撮影したファイルはすべてこのフォルダー、 またはこのフォルダー内に作られたサブフォルダーに保存されます。

デフォルトのインストールでは、ログインしたユーザーのデスクトップにキャプチャフォルダがあり、「SharpCaptures」という名前になっています。 SharpCapは、SharpCapの起動時に、トップレベルのキャプチャフォルダが存在し、満杯になっていないかどうかをチェックすることに注意してください。 最上位のキャプチャフォルダが存在しない、いっぱいになっている、または読み取り専用になっていることが判明した場合、 そのフォルダはデフォルトの 「Desktop\SharpCap Captures」にリセットされます。

ブラウズボタンで、他のキャプチャフォルダーを選択または作成することができます。

書込みスピードテスト

「スピードテスト」ボタンを押すと、ディスクの書き込み速度に関するハードウェアパフォーマンステストが実行されます。 このテストを実行すると、ディスクの書き込み速度によってカメラの撮影速度が低下しているかどうかがわかります。 詳細は、ディスクの速度テスト を参照してください。

キャプチャしたファイルをサブフォルダに整理

チェックが入っていない場合、すべての撮影は最上位のキャプチャーフォルダーに保存されます。 チェックした場合、撮影したファイルは、以下で選択したルールに従ってサブフォルダーに保存されます。

フォルダ名とファイル名のオプションと組み合わせが利用可能です。 賢明なデフォルトは、初期のデフォルトインストールで提供されます。 オプションの使用例を以下に示します。

日付、次に天体名

以下は、保存されたファイルを日付と天体名で整理した例です。 ファイル名は撮影の作成時間から導き出され、HH_MM_SSという形式になっています。 上位のディレクトリには日付、内部のディレクトリには天体名が付けられています。

天体名、次に日付

以下は、保存したファイルを天体名と日付で整理し、通知バーに表示した例です（緑＝成功）。 上位のディレクトリには天体名が、内部のディレクトリには日付が付けられています。

ファイル名とフォルダー名にUTC時間を使用

このオプションをチェックすると、ファイル名の生成に使用される日付と時刻はすべてUTC時刻になります。 このオプションがチェックされていない場合は、ローカル時間が使用されます。

以下は、 UTC タイム形式で保存したファイルの例です。

文字はタイムゾーンを示し、Z =英国です。

並べ替え可能な日付形式を使用（YYYY-MM-DD）

チェックすると、すべての日付にYYYY-MM-DDの日付形式が使用され、Windowsエクスプローラでのファイル名やフォルダ名の並べ替えが容易になります。 チェックを外すと、PCの地域設定に応じた日付形式のルールが使用されます。 このオプションはデフォルトではチェックされています。

WinJUPOS互換のファイル名を作成

以下は、日付と時刻を組み合わせた WinJUPOS 互換の名前を使った保存ファイルの例です。 この例では、WinJUPOSの名前に撮影の中間点の時間を使用しています。 このオプションを使用すると、ビデオファイルをWinJUPOSに読み込んでデローテーションするのが簡単になります。

シーケンス（複数の静止画像）

ここでは、一連のファイルの一部として生成されるファイル名の追加オプションを提供します （例えば、フレームを PNG または FITS 形式で撮影する場合、撮影したフレームごとにファイルが作成されます）。 SharpCapシーケンサーやシーケンスプランナーと混同しないようにご注意ください。 これらのオプションは、SharpCap内で複数の静止画ファイルを作成した場合に適用されます （たとえば、スナップショットボタンを複数回押した場合など）。

ファイル名に時間を含める ー 撮影された各フレームのファイル名に現在の時刻（フレームが撮影された時刻）が含まれます。

シーケンスごとにサブフォルダーを作成 ー デフォルトで有効になっています。新しいシーケンスファイルがそれぞれ別のサブフォルダに保存されます。 無効にすると、上位のフォルダ名の選択によっては、多くのシーケンスが同じフォルダに保存されることがあります。

追加

「フィルタ名を追加」は、現在のフィルターの名前をファイル名に追加します。このオプションを有効にするには、 ハードウェアタブ でフィルターホイールを選択し、正しく接続されていることが必要です。

サンプルファイル名

ここでは、上記のファイル名とフォルダー名の選択に基づいて生成されるサンプルファイル名を示します。 最初のサンプルは、1つのファイルキャプチャ（複数のフレームがAVIまたはSER形式で単一のビデオファイルに保存される） に対してファイル名がどのように生成されるかを示しています。 2番目のサンプルは、一連のファイルキャプチャのファイル名がどのように生成されるかを示しています （保存された各フレームは、PNG、FITS、TIFFなどの形式で個別の画像ファイルに保存されます）。

ファイル名テンプレートが使用されている場合、これらのサンプルは、 「単一ファイル」および「順序」テンプレートによって生成されるファイル名を示しています。

ファイル名テンプレート

SharpCapのすべての撮影ファイル名は、ファイル名テンプレートのシステムを介して生成されます。 ファイル名のさまざまなチェックボックスとオプションを調整すると、SharpCapは選択内容を表すファイル名テンプレートを自動的に生成します。 これらのテンプレートは、後で実際のファイル名を生成するために使用されます。 実際、ファイル名とフォルダー名のさまざまなオプションを変更すると、タブの下部に表示されるファイル名テンプレートが更新されていくのがわかります。

使用可能なさまざまなファイルおよびフォルダーの名前付けオプションを使用して、希望通りのファイル名を取得できない場合があります。 この場合、ファイル/フォルダーの名前の選択に基づいてテンプレートを自動的に作成するのではなく、 「ファイル名テンプレートを手動で編集」を選択することができます。

ファイル名テンプレートを手動で編集するには多少の注意が必要ですが、保存したファイルの名前を最大限にコントロールすることができます。 各ファイル名テンプレートは、1つまたは複数のタグを含むテキストで構成されています。タグは、タグ名を中カッコ（'{'and'}'）で囲んだものです。 タグは、ファイル名が必要になったときに値に置き換えられるので、タグ「{Date}」は現在の日付に、「{Time}」は現在の時刻に置き換えられます。 利用可能なタグは以下の通りです。

{DateTime} | 撮影が開始された日付と時間
{Date} | 撮影が開始された日付
{Time} | 撮影が開始された時刻
{TargetName} | 入力された天体の名前（名前が入力されていない場合は「Capture」と表示される
{Camera} | 使用するカメラの名前
{Filter} | 現在選択されているフィルターの名前
{Extension} | ファイルの拡張子（例：AVIやPNG）です。テンプレートの最後に 「.{Extension}」を付ける必要はありません。
{Index} | シーケンス撮影のみ。シーケンスの中の現在のフレームのインデックスです。
{FrameDate} | シーケンス撮影のみ。現在のフレームが撮影された日付
{FrameTime} | シーケンス撮影のみ。現在のフレームが撮影された時間
{BitDepth} |
{StackedFrames} | ライブスタックのみ。これまでのスタックフレームの合計数
{TotalExposure} | ライブスタックのみ。これまでのスタックフレームの総露出量
{AutoSave} | ライブスタックのみ。 現在の保存は自動保存ですか？
{Exposure} | シーケンス撮影のみ。現在のフレームの露出。
{Gain} | シーケンス撮影のみ。現在のフレームのゲインです。
{BlackLevel} | シーケンス撮影のみ。現在のフレームの黒レベル（オフセット／輝度）。
{FrameType} | ツールバーのドロップダウンから選択したフレームタイプ（ライト／ダーク／フラットなど）。
{SubExposure} | ライブスタックのみ。スタックしている個々のフレームの露出時間です。
{BlackLevel} | 現在のフレームのカメラオフセット/輝度/ブラックレベル。

いくつかのタグは、ファイル名で使用される方法を変更するために、オプションの形式文字列を持つことができます。

形式 | 適用対象 | 意味 | 使用例
:S | 日付、日付時間、フレーム日付 | 日付には並べ替え可能な形式を使用する | {DateTime:S}
:Z | 任意の時間または日付のタグ | UTCの時間と日付の使用 | {FrameTime:Z}
:J | 日付時間、フレーム時間 | WinJupos互換のフォーマットを使用 | {DateTime:J}
:U | 任意の時間/日時タグ | UTC時刻を使用しますが、末尾のZは時刻に追加されません | {FrameTime:U}
:Y | 任意の日付/日時タグ | 現地の午前0時から正午までの間にある場合は、昨日の日付を使用します（午前0時には日付は変更されません、つまり、日付は深夜に変更されません）。 | {Date:Y}
:2-7 | インデックスタグ対象 | インデックスに使用する桁数 | {Index:6}

ファイル名のテンプレートに変更を加えると、前述の[サンプルファイル名]で更新された一般的なファイル名が表示され、 ファイル名テンプレートがどのように機能するかを理解するのに役立ちます。

ファイル名テンプレートをカスタマイズする際には、誤って望ましくない結果をもたらすテンプレートを設定してしまう可能性があるため、 注意が必要です（例えば、以前のキャプチャファイルを上書きしてしまうなど）。 ファイル名テンプレートを手動で変更した場合は、必ず観測を開始する前にテストする必要があります。

メモリー タブ

Microsoft Windowsの64ビット版では、SharpCapは、パフォーマンスを向上させるために追加のメモリにアクセスし、 非常に高解像度のカメラでのライブスタックの実行など、特定の機能を実行するために必要な大容量のメモリを処理することができます。

4Gb以下のメモリしかない場合、または32ビットバージョンのWindowsを使用している場合、 ここでの唯一のオプションは、メモリ管理の「クラシック」オプションのままにすることです。

4GB以上のメモリを搭載し、64ビット版のWindowsを使用している場合は、メモリ管理のデフォルトオプションとして 「ページング」が選択されます（ただし、必要に応じてクラシックに戻すことも可能です）。

「ページング」メモリを選択すると、SharpCapは合計でより多くのメモリにアクセスできます。 「ページング」メモリは、次の2つのカテゴリに分類されます。

· 「高速フレームキャッシュ」ー このメモリは、カメラで撮影したフレームをディスクに書き込む前に保存するためのものです。 高速なUSB3カメラを使用していて、ディスクドライブやSSDが追いつかず、撮影時にフレームが欠落する問題がある場合、大容量の高速フレームキャッシュが役立ちます。

· 「ライブスタックと画面」ー このメモリーは、ライブスタック操作や、画面に表示する前の画像の変換や処理をサポートするために使用されます。 高解像度のカメラでライブスタックを行う場合は、このカテゴリーに大容量のメモリーを割り当てることで、メモリー不足のエラーを防ぐことができます。

デフォルトでは、各カテゴリーに1Gbのページングされたメモリが割り当てられ、合計2Gbとなります。 SharpCap Proのライセンスをお持ちの場合は、各カテゴリーに割り当てられるメモリの量を、物理メモリの合計50％まで増やすことができます。 1つのカテゴリーに割り当てるメモリ量を増やしたい場合は、合計がこの制限以下になるように、 先に他のカテゴリーに割り当てるメモリ量を減らす必要があるかもしれません。

メモリタブで設定を変更した場合は、SharpCapを再起動して正しく反映させるようにしてください。

注意：64ビットバージョンのSharpCapには、クラシック / ページングメモリのオプションはありません。 64ビットバージョンでは、メモリ調整スライダーのみが表示されます。

プレートソルブ タブ

プレートソルブ とは、ある画像に含まれる星のパターンを、既知の星のインデックスと照らし合わせて認識することで、 その画像の天空での位置を算出する手法です。 望遠鏡で撮影したばかりの画像にこの手法を適用すると、算出される位置は、望遠鏡が指し示している空の位置になります。

サポートされているプレートソルブエンジンと検出

SharpCap は、Astap や astrometry.net プレートソルブエンジンをベースにしたさまざまなツールを含む、 数多くのプレートソルブツールと統合できます。このエンジンは、AstroTortilla 、 Ansvr 、All Sky Plate Solver などのプレートソルブツールに搭載されています。 画像をプレートソルブするためには、まずこれらのツールのいずれかをインストールして設定する必要があります。 プレートソルブ用のインデックスファイルもインストールする必要があります。 インデックスファイルのインストール方法やインストールするインデックスファイルについては、プレートソルブツールのドキュメントを参照してください。

SharpCapは、上記のプレートソルブツールがデフォルトの場所にインストールされていれば、自動的に検出し、検出状況の概要を表示します。

また、SharpCapは、各アプリケーションのインストール時によくある問題（インデックスファイルの欠落など）をチェックし、検出された問題にフラグを立てます。

カスタムの場所にインストールした場合や、別の astrometry.net ベースのツールをインストールした場合は、 「手動で入力」オプションを選択し、「solve-field 」スクリプトの場所を参照して、 実際のプレートソルブ処理を実行する「solve-field」コマンドの場所を設定する必要があることに注意してください。

プレートソルブ エンジンの選択

SharpCap が使用するプレートソルブエンジンは、 Astap またはインストールされている Astrometry.net エンジン（Astrotortilla/ASPS/Ansvr）のいずれかを選択できます。

Astrotortilla/ASPS/Ansvr のいずれを使用するかを選択したい場合（複数のものをインストールしている場合）は、 上記のように 「solve-field」スクリプトの場所を 手動で設定します。

プレートソルブの設定

SharpCapがプレートソルブ後に実行する作業を選択したり、望遠鏡の焦点距離を設定したりすることができます（プレートソルブ操作を高速化することができます）。

「望遠鏡の制御 / プレートソルブ後再同期メニュー 」から解決した後の作業のオプションは次のとおりです。

· 「マウントを同期し、天体を中央に再配置」ー このオプションは、プレートソルブの結果に基づいてマウントに ASCOM 同期コマンドを送信し、 元のマウント座標への再 GOTO を実行します。その結果、元の天体が見えるようになります。

· 「マウント同期のみ」ー このオプションは、プレートソルブの結果に基づいてマウントにASCOM 同期コマンドを送信するだけです。

· 「マウント位置をオフセットして、天体を中央に配置」ー このオプションは、（プレートソルブ結果と元のマウント座標に基づいて）計算された位置にGOTOを実行し、 天体を視野に入れようとします。このオプションは、ASCOMマウントで複雑な同期/ポインティングモデルを使用している場合、同期コマンドの送信を避けるために推奨されます。 ただし、天の極近くでは結果が不正確になる可能性があることに注意してください。

· 「何もしない」ー このオプションは、プレートソルブ後、何もしません。

望遠鏡の焦点距離を指定すると、SharpCapは焦点距離を使用してプレートソルブ処理を高速化しようとします。

注意：焦点距離の指定を誤ると、プレートソルブに失敗することがあります。

注意：一部のASCOMマウントでは、焦点距離を設定できません。マウントでASCOMオプションが選択しても、焦点距離の測定が提供されない場合、 SharpCapは「使用禁止」オプションが選択されているかのように続行します。

注意：SharpCapが望遠鏡のピクセルサイズを決定できない場合、焦点距離の設定は無視されます。

Astrotortilla / Ansvr / All Sky PlateSolver (ASPS) の設定

Astrometry.net ベースのプレートソルブエンジンを設定および微調整するためのその他のオプションは、以下のとおりです。

「星検出ノイズしきい値」 は、「（-シグマ）」パラメータの数値を調整することで設定できます。 値が大きいほど星の検出数が少なくなり、値が小さいほど星の検出数が多くなる傾向があります。星の検出数が少なすぎると（20-3以下）、 プレートソルブが失敗しやすくなります。検出される星の数が多すぎる場合（200個以上）、プレートソルブの完了までに非常に長い時間がかかることがあります。 このパラメータは、使用するカメラと望遠鏡の組み合わせによって調整する必要があります。

「解決時に大きな画像を自動的にダウンサンプリングする」が有効になっている場合、2000ピクセルより広い画像は、プレートソルブを試みる前に、 自動的にダウンサンプリング （ ビニング ）されて小さくなります。 このオプションは、多数の星が見える大きな画像をプレートソルブの速度と信頼性を劇的に向上します。

極軸合わせタブ

SharpCapが緯度と経度を知っている場合、SharpCapの極軸合わせはより正確で使いやすくなります。 デフォルトでは、SharpCapはコンピュータのタイムゾーン設定から経度を推定し、緯度を北緯45度または南緯45度と推定します。 極軸合わせが機能するにはこれで十分ですが、正しい緯度を設定すると、SharpCapが大気の屈折を補正して、より正確な結果を得ることができます。 正しい経度を設定すると、上下左右の移動指示が正確になります。

観測場所をデフォルト設定（「タイムゾーンから自動的に推定」）のままにするか、 「ASCOMマウントの位置情報を使用」するか、手動で位置情報を指定するか、2つの正確な位置情報オプションのいずれかを選択できます。 正確な場所を選択した場合は、「大気差を補正」するオプションを有効にすることができます。

位置情報は完全に正確である必要はありませんが、最も近い程度に緯度と経度があれば十分に正確です。

最後に、「 ジオロケート」ボタンを使用すると、インターネットに接続されている場合、自動的に現在地を見つけることができます。 この場合、あなたのIPアドレスがインターネットサーバーに送信され、そのサーバーからあなたのおおよその位置が返信されます。 この方法は、すべてのインターネットプロバイダーに対応しているわけではありません。 また、携帯電話でインターネットに接続している場合は、うまく機能しない可能性があります。

ガイディング タブ

SharpCapは、人気のあるフリーアプリケーション PHD2 およびMGEN3オートガイダーと連携して、シーケンサーツールまたはシーケンスプランナーを使用してライブスタックまたは 撮影シーケンスの実行中にガイドと ディザリング を監視および制御できます。 SharpCapは、ガイドアプリケーションを必要とせずに、ディザリングコマンドをASCOM GOTOマウントに送信することもできます。

PHD2 の使用

SharpCapとPHD2の連携を可能にするためには、以下の点を確認してください。

· PHD2は最新のバージョンであり、SharpCapと同じコンピューターで実行されていること。

· PHD2で 「サーバーを有効化」メニューが選択されている必要があります。

MGEN3 オートガイダーの使用

Lacerta MGEN3オートガイダーを使用するためには、MGEN3の Windowsドライバー をインストールする必要があります（スクロールダウンして、ドライバテーブルの最上段からWindowsドライバを選択してください）。 また、MGEN3デバイスとPCをUSBケーブルで接続する必要があります。

ディザのみのガイド使用

「ASCOMマウントパルスガイディングを使用したディザのみ」 のガイドは、実際にガイドアプリケーションやデバイスを有効にすることなく、ライブスタックや画像シーケンスにディザリングを含める方法を提供します。 ディザのみのガイドは、SharpCapによって常に有効（ガイド）であるとみなされますが、マウントにガイド補正を送信することはありません。 ただし、ディザのみのガイドでは、ディザリングが必要なときに、マウントに小さなランダムな移動コマンドを送信されます。

ASCOMマウントを使用している場合、「ディザのみ」のガイドはASCOMのパルスガイド機能を使用してマウントに移動要求を送ります。 この機能は、ほとんどのASCOMマウントで利用できます（すべてではありません）。 また、ASCOMマウントの設定では、パルスガイド要求に応じてマウントが移動する速度を調整できる場合があります。

GOTOマウントをお持ちでない場合や、ご使用のマウントがパルスガイドに対応していない場合でも、以下の場合にはこのオプションを使用することができます。

· カメラとマウントの両方にST4（ガイド）ポートがある場合。

· SharpCapは、カメラ（Altair、PlayerOne、QHY、SVBony、およびZWOカメラ）のST4制御をサポートします。

· カメラとマウントのST4ポートをST4ケーブルで接続する場合。

· SharpCapのハードウェア設定で、マウントに「On Camera ST4」を選択します。

ディザリング

SharpCap Proのユーザーは、ライブスタックまたはシーケンサー/シーケンスプランナーを使用して、サポートされているガイドオプションの1つを使用して、 ディザリングを有効にすることもできます。ディザリングを有効にするには、 「ライブスタック」の ガイドタブ で 「自動的にディザ Automatically Dither 」チェックボックスをチェックするか、「シーケンサー／シーケンスプランナー」で「ディザリング」を選択します。 ここでは、各ディザ操作の詳細を制御するためのオプションを設定できます。

最大ディザステップ ー これは、ガイドカメラのピクセル（SharpCapではなくPHD2のピクセル）で測定された、 ディザの動きが可能な最大距離を指定します。 MGENはこの設定を認識しないことに注意してください。 また、「ディザのみのガイド」が選択されている場合、この設定はディザ移動ステップのサイズ（秒単位）として解釈されることに注意してください。

しきい値を設定 ー 2つのガイドカメラフレーム間の動きがこのピクセル数以下になると、ディザは「落ち着いた」とみなされます。 つまり、マウントの動きが完了し、撮影した画像が動きによってぼやけることはなくなります。PHD2のガイドにのみ適用されます。

最小整定時間 ー この時間が経過する前にしきい値の解決に達した場合でも、 ディザは動きの終了からこの時間が経過するまでは解決されたとはみなされません。PHD2ガイドにのみ適用されます。

最大整定時間 ー ディザは、しきい値の解決に達していない場合でも、この時間が経過した後に常に解決されたと見なされます。 PHD2ガイドにのみ適用されます。

RAのみのディザ ー ディザリングを赤経軸のみに制限します。 PHD2ガイドにのみ適用されます。

ログ タブ

トラブルシューティング

SharpCapは、特に問題が発生した場合、デフォルトでかなりの量の情報をログに書き込みますが、問題を追跡するために追加の情報が必要になることもあります。

ここで1つ以上のオプションを選択することにより、問題の診断に役立つ追加情報をログに記録するようにSharpCapを構成できます。 これらのオプションの1つ以上がオンになっている場合、SharpCapはログにかなり多くの情報を書き込みます。 これらのオプションをオンにすると、追加情報がログに記録されるため、SharpCapの実行が遅くなったり、応答が低下したりする可能性があるため、 問題を追跡しようとしている場合やSharpCapサポートからの依頼がない限り、このオプションをオンにすることはお勧めしません。

これらのオプションを1つ以上オンにすると、SharpCapを起動するたびに、これらをオンにしておくかどうかの確認を求められます。

有効にすることができる追加ログの分類は以下の通りです。

· 「全般」ー 以下の分類に該当しないあらゆる情報。

· 「カメラ ハードウェア通信」ー SharpCapと使用中のカメラのハードウェア／メーカー提供のソフトウェアとの間で行われた通信の詳細。

· 「ホイール ハードウエア通信」ー SharpCapと、使用中のフィルターホイールのASCOMドライバーとの通信内容の詳細。

· 「マウント ハードウェア通信」ー SharpCapと使用中のマウントのASCOMドライバーとの通信の詳細。

· 「フォーカサー ハードウェア通信」ー SharpCapと使用中のフォーカサーのASCOMドライバーとの通信内容の詳細。

· 「カメラ制御値とキャプチャプロファイル」ー カメラ制御の変更に関する情報をログに記録する（ただし、他のカメラ関連情報は記録しません）

· 「ライブスタック」ー ライブスタックの進行状況やエラーに関する追加情報をSharpCapのメインログに記録する。

· 「ガイディング」ー SharpCapとガイディングアプリケーション/デバイス間の通信に関する追加情報を記録する。

GPS ログ

QHYの全GPSデータをファイルに記録

SharpCapは、GPSを内蔵したQHYカメラをサポートしています。 このようなカメラでGPSが有効になると、デフォルトの動作では、GPSデータ（時間、日付、場所）をFITSヘッダーまたは撮影設定ファイルに保存します。 このオプションを有効にすると、GPS対応カメラが使用されるたびに、ルートのキャプチャディレクトリにCSV形式のログファイルが作成されます。

このオプションはデフォルトでは無効になっているので、このオプションを変更した後は、確実に効果を発揮させるためにSharpCapを再起動してください。

ログファイルの各行の形式は

<PC Clock Time>, <GPS Status>, <Frame Number>, <Frame Start Time from GPS>, <Frame End Time from GPS>, <Latitude>, <Longitude>, <RawLatitude>, <RawLongitude>

<RawLatitude>および<RawLongitude>は、カメラから受け取ったデコードされていない値です。 これらの値を個別にデコードしたい場合や、デコードに必要な手順について、QHYにお問い合わせください。

起動スクリプト タブ

このタブでは、SharpCap起動時に実行されるPythonスクリプトのリストを設定できます。 このようなスクリプトは、SharpCapを起動するたびに、追加機能やカスタマイズを追加するために使用できます。 「追加」「削除」「上へ移動」「下へ移動」ボタンを使って、起動スクリプトのリストを管理します。

例えば、次のスクリプトは、押すと最初のカメラを選択するボタンをツールバーに作成します。 このコードは、 スクリプト の情報に従って作成し、保存することができます。

def selectFirstCamera():
SharpCap.SelectedCamera=SharpCap.Cameras[0]
SharpCap.AddCustomButton("Test", None, "Select the first camera", selectFirstCamera)

このスクリプトをデスクトップなどのどこかに保存し（SelectFirstCamera.pyなどと呼びます）、「ファイル」→「SharpCapの設定」→「起動スクリプト」を適宜構成します。

カメラの選択を解除してSharpCapを再起動すると、ツールバーの右端に「テスト」ボタンが追加され、カメラが選択された状態になります。

この手法は、カスタムツールバーボタンを作成し、SharpCapが起動するたびに読み込ませることができるため、「起動スクリプト」に使用するとよいでしょう。

テストボタンは、「ファイル」→「SharpCapの設定」→「起動スクリプト」で削除できます。 スクリプト「SelectFirstCamera.py」をハイライト表示し、「削除」を選択してSharpCapを再起動してください。

なお、現在、SharpCapシーケンサーを使って起動時にシーケンスを実行することはできませんが、Pythonスクリプトから以下の方法でシーケンスを起動することができます。

SharpCap.Sequencer.RunSequenceFile('<sequence file path and name>')


スクリプト

SharpCapにはスクリプト言語が組み込まれており、キーボードとマウスでSharpCapを制御するときに実行できるほぼすべての操作を実行できる簡単なプログラムを作成できます。 スクリプト言語は、.NETフレームワークへの Python プログラミング言語 のMicrosoftポートである「IronPython」と呼ばれる言語に基づいています。

スクリプト コンソール

スクリプトコンソールは、メニューバースクリプトメニューから コンソールを表示 を選択することで表示できます。 スクリプトコンソールは統合開発環境(IDE)です。 これにより、プログラミング言語「IronPython」を使用したコードの作成、実行、デバッグが可能で、SharpCapに統合されています。

help（）と<ENTER>をIronPythonコンソール画面に入力すると、次の基本的なヘルプ出力が得られます。

いくつかの例が表示されます。 その一つは、SharpCapで利用可能なカメラをリストアップするコードです。

#List the cameras available
print SharpCap.Cameras

＃で始まる行はコメント行であり、コンピューターによって無視されることを意味します。

コードはコンソールに直接入力するか、コンソール画面の下部にあるIronPython Padに貼り付けることができる。 画面の上部にコードを入力した場合は、<Enter>キーを押したときに実行されます。 長いコードは下部のエディタに入力してください。 「Run」ボタンが押されるまで実行されません。

SharpCapの制御には、各スクリプトセッションに自動的に読み込まれるSharpCapオブジェクトを使用します。いくつかの簡単なコマンドは...

SharpCap.SelectedCamera = None # Close the camera that is currently active

SharpCap.SelectedCamera = SharpCap.Cameras[0] # Open the first camera in the Cameras menu and start previewing it

カメラが起動したら、次のようにプロパティを調整します。

SharpCap.SelectedCamera.Controls.Exposure.Value = 1000 # Set the exposure to 1000ms (1s)

IronPython Padで、コード print SharpCap.Cameras を入力して、Runボタンを押します。

IronPythonコンソールに以下のような出力が表示されます。

フロッピーディスクのアイコンをクリックし、ファイル名を「camera.py」として保存すると、以下の「スクリプトの実行」メニューで使用できます。

APIの説明

エディターは、「 . 」を入力すると、天体の使用可能なメソッドとプロパティを自動的に表示します。 これは利用可能なAPI (アプリケーションプログラミングインタフェース) を探索するのに役立ちます。

IronPythonコンソールで、以下の2行を入力します（テキストの大文字と小文字、「 . 」が重要です）。

import System

from System.

「 . 」を入力するとすぐに、選択できるリストが表示されます。 この方法は、SharpCap APIの多くの部分に適用して、 使用可能なメソッドとそれらに必要なパラメーターを見つけることができます。

また、ヘルプコマンドを使って、任意の天体で利用可能なメソッドやプロパティを調べることもできます。

help(SharpCap)

help(SharpCap.SelectedCamera)

注意：SharpCapのスクリプトで使用できるAPIは、将来のバージョンで変更される可能性があります。 既存のスクリプトとの互換性を保つように努力しますが、必ずしもそうできるとは限りません。 アップデートされたバージョンのSharpCapで正しく動作し続けるためには、スクリプトの修正が必要な場合もあります。

スクリプトを実行

「スクリプトを実行」メニュー項目は、ファイルエクスプローラーウィンドウを開き、以前に作成したPythonスクリプトを選択することができます。

スクリプト（プログラム）は、Windows上で任意のテキストエディターを使って作成することもできます。 スクリプトは、拡張子を「.py」として保存する必要があります。

メニューから「スクリプト」→「スクリプトを実行」を選びます。

ファイル something.py を参照し、「開く」ボタンをクリックします。 スクリプトが実行されます。

使用例

1. メニューから「スクリプト」→「コンソールを表示」を選択します。

2. マウスを使用してIronPythonコンソールを片側にドラッグします。

3. メニューから「スクリプト」→「スクリプトを実行」を選択します。

4. 前の操作で作成したファイル camera.py に移動し、それを選択します。

5. スクリプトが実行され、その結果（利用可能なカメラ）が IronPythonコンソールに表示されます。

上記の例は実用的ではありませんが、SharpCapの機能の使い方を説明しています。

SharpCapスクリプトAPIで使用可能な多くのメソッドは、非同期的に実行されます（つまり、処理を開始し、処理が終了する前に戻ります）。 多くの場合、非同期の動作を伴わない代替方法があり、スクリプトを書く際にはその代替方法を選択する必要があります。 例えば、（SharpCap.SelectedCameraの「ヘルプ」より）。

| RunCapture(...)

| RunCapture(self: Camera)

|

| RunCaptureAsync(...)

| RunCaptureAsync(self: Camera, cancellationToken: CancellationToken) -> Task

可能であれば、メソッドの非同期バージョンを使用してください。例えば、RunCaptureAsyncではなくRunCaptureです。 Pythonスクリプトから非同期メソッドを使用する必要がある場合は、.Wait() または .Result を使用して完了を待ったり、 非同期メソッドの結果（戻り値）にアクセスすることができます。

スクリプトのチュートリアル

スクリプトの作成

ここでは、以下の方法を紹介します。

· IronPythonコンソールを使って、簡単なスクリプトを作成する。

· スクリプトを保存する。

· コンソール内でスクリプトを実行する。

· 保存したスクリプトを「スクリプトを実行」メニューオプションから直接実行する。

「コンソールを表示」を選択すると、統合開発環境（IDE）が表示される。 これにより、プログラミング言語「IronPython」を使ったコードの作成、実行、デバッグが可能になります。

以下のコードは、1枚のPNG画像を撮影し、ファイルに保存します。 保存先のd:\capture.pngは、お使いのコンピューターの都合の良い場所に変更してください。

SharpCap.SelectedCamera.CaptureSingleFrameTo("d:\capture.png")

以下の手順で、スクリプト機能をテストします。

1. SharpCapを起動し、メニューから「カメラ」→「テストカメラ1（ディープスカイ）」を選択します。

撮影表示領域にM42の画像が表示されるはずです。

2. カメラコントロールパネルの「出力形式」を「PNGファイル」に変更します。

3. メニューから「スクリプト」→「コンソールを表示」を選択します。

IronPythonコンソールが開きます。

4. 以下のコードをコピーしてください。

SharpCap.SelectedCamera.CaptureSingleFrameTo("d:\capture.png")

を Ctrl+V で貼り付けて(または直接入力して) IronPython Pad (IronPython コンソールの下部) に入力する。 貼り付け先(赤の下線)は、使用するPCに適したものに編集してください。

5. 「Run」アイコンを押す（またはF5）。

6. 保存先を確認すると、「capture.png」と「capture.png.CameraSettings.txt」という2つのファイルができているはずです。

7. コードを編集して、撮影ファイル名を「capture2.png」に変更します。

8. フロッピーディスクのアイコンをクリックすると、ファイルエクスプローラーのウィンドウが開きます。

ファイル名を「capture2.py」として保存します（ .pyの拡張子が重要です）。

9. IronPythonコンソールを閉じます。

もちろん、スクリプトの要点はSharpCapの使用を自動化することであり、上記のすべての手順は、より複雑なスクリプトによって自動化できます。 たとえば、次のようになります。

SharpCap.SelectedCamera = SharpCap.Cameras. Find ( lambda x:x.DeviceName == "Test Camera 1 (Deep Sky)")

SharpCap.SelectedCamera.Controls.OutputFormat.Value = "PNG Files (*.png)"

SharpCap.SelectedCamera.CaptureSingleFrameTo ("d:\capture.png")

SharpCapスクリプトオブジェクトモデル（参考）

アプリケーションを制御するために利用できる主要なオブジェクトは次のとおりです。

SharpCap | アプリケーションのメインオブジェクトで、他のすべてのオブジェクトはこのオブジェクトを介してアクセスされます。
SharpCap.Cameras | 利用可能なカメラのコレクション（「カメラ」メニューに表示されています ）
SharpCap.SelectedCamera | 現在開いているカメラ（開いているカメラがない場合は「None」と表示されます。
SharpCap.SelectedCamera.Controls | 現在開いているカメラで使用できるコントロール。多くの一般的なコントロールは直接アクセスできますが、 その他のコントロールは、必要なコントロールを見つけるために、配列の各項目をチェックする必要があります。
SharpCap.Focusers | SharpCapによって検出された（ASCOM）フォーカサーの種類です。SharpCap.Focusers.SelectedFocuserを使用して、 特定のフォーカサーに接続し、SelectedCamera.Controlsコレクションを介してアクセスすることができます。
SharpCap.Mounts, SharpCap.Wheels | ASCOMのマウントとフィルターホイールのコレクションは、フォーカサーと同じように機能します。
SharpCap.Transforms | SharpCap.Transforms.SelectedTransformプロパティを設定することで、 プレビューウィンドウに適用可能なフレームトランスフォームのコレクション（現時点ではバグがあります）。
SharpCap.MainWindow | SharpCapのメインアプリケーションウィンドウです。プロパティを変更したり、メソッドを呼び出したりすると、不具合が発生する可能性があるので注意が必要です。
SharpCap.Reticules | スクリーンに描画するために選択できるレティクルオーバーレイのコレクション（transformと同様、現在はバグがあります）。
SharpCap.Settings | すべてのアプリケーションの設定は、慎重に変更し、変更後は「 Save() 」を呼び出して有効にしてください。

一般的には、SharpCap.SelectCamera と SharpCap.SelectCamera.Controls が最もよく使われるオブジェクトです。

カメラ オブジェクト

SelectedCameraオブジェクトの最も重要なメソッドとプロパティは次のとおりです（情報を提供するプロパティは、選択されていない他のカメラでも機能します）。

CanCapture, CanStillCapture | カメラが動画と静止画をそれぞれ撮影できるかどうかを示します
CanPause | カメラはビデオ撮影を停止せずに一時停止できますか？
CaptureConfig | フレーム制限など、実行する撮影のタイプを制御する設定
PrepareToCapture() | RunCapture () を呼び出す前に、ビデオ撮影を設定するために呼び出さなければなりません。
RunCapture() | 準備されたビデオ撮影を開始します。 撮影は制限に達するか、StopCapture（）が呼び出されるまで実行されます。 出力ファイルには、選択した命名スキームに従って名前が付けられます。
CancelCapture() | （RunCaptureを使用して実行する代わりに）準備された撮影をキャンセルします。
CaptureSingleFrame() | 単一フレームのスナップショットを撮影します（出力ファイルには、選択した命名スキームに従って名前が付けられます）
CaptureSingleFrameTo(string filePath) | 単一のフレームを撮影し、指定された出力ファイル名で保存します。 パスはフルパスである必要があり、指定された拡張子は、SharpCap.SelectedCameras.Controls.OutputFormat.Valueで選択されたものと一致する必要があります
Name | アプリケーションUIで使用するカメラの名前
VideoDeviceId | カメラの内部識別子（空欄などの場合もあります）
StartPreview(), StopPreview() | カメラフレームのプレビューをそれぞれ開始、停止する
RestartPreview() | カメラのフレームプレビューを停止し、再度開始する
GetStatus(boolean allStats) | 撮影したフレームや平均フレームレートなど、カメラの状態を表すオブジェクトを返します。
IsOpen, IsPreviewing, CanCountFrames, Capturing | 名前付きの情報プロパティ
CapturedFrameCount | 前回、プレビューを開始したとき、または撮影を開始・停止したときから、カメラが処理したフレーム数（プレビューフレームを含む）。
ApplySelectedTransform() | 予約済み、内部使用のみ

以下のコントロールは、SelectedCamera の Controlsオブジェクトで直接利用できる場合があります。

Binning, ColourSpace, Exposure, FilterWheel, Focus, Gain, OutputFormat, Resolution

その他のコントロールは、「コントロール」コレクションの中にある可能性が高いので、名前などで検索する必要があります。

cooler = SharpCap.SelectedCamera.Controls.Find(lambda x: x.Name == "Cooler")

ただし、利用できるコントロールはカメラによって異なり、常に利用できるのはColourSpace、Exposure、Resolution、OutputFormatのみです。

コントロール オブジェクト

各コントロールには以下のプロパティがあります。

Available

コントロールが実際に値を読み書きできる状態であれば正常。

ReadOnly

コントロールからの読み取りのみ可能な場合は正常。（例：センサーの温度読み取り）

AutoAvailable

自動モードに設定できる場合は正常。

Auto

自動と手動の切り替え

Name

UIに表示されるコントロールの名前

Id

一般的なプロパティタイプの列挙で、現在は以下のものがあります。 Other、Exposure、FrameRate、Pan、Tilt、Resolution、ColourSpace、OutputFormat、Focus、FilterWheel、Binning、Gain。

Minimum, Maximum

数値コントロールの最小値と最大値の取得

Step

整数コントロールは、ステップ値が定義されている場合があり、この値の倍数でしか変更できません。このようなケースはほとんどありません。

Value

コントロールの値を取得し、（ReadOnlyでない場合は）変更することができます。

Type

コントロールが持つ値の種類。

Integer | 数値、整数値
Double | 数値、整数または10進法の値
Boolean | オン/オフの値（チェックボックス）
Command | UI上のボタンで起動する単一の動作
MultipleChoice | UIのドロップダウンコントロールとして表示されるオプションのリスト
Custom | その他のタイプのコントロール

AvailableValues

「MultipleChoice」コントロールの場合は、選択可能な選択肢のリスト。

スクリプトのサンプル

スクリプトの例題を以下に示します。

定期的な撮影とタイムスタンプ画像

以下のコードは、約15秒ごとに1つのPNG画像を撮影し、保存する前に画像自体にタイムスタンプを書き込みます。 コードを変更して、タイムスタンプ付きの各画像を異なるファイル名で保存するか、タイムスタンプ付きの手順を削除するのは簡単です。

このコードは、すでに選択されプレビューされているカメラと、カメラがPNGファイルに出力できることを前提としています （つまり、カメラが12/16ビットモードの場合は機能しません）。

import time

clr.AddReference("System.Drawing")

import System.Drawing

SharpCap.SelectedCamera.Controls.OutputFormat.Value = 'PNG files (*.png)'

if (SharpCap.SelectedCamera.Controls.Exposure.AutoAvailable):

SharpCap.SelectedCamera.Controls.Exposure.Automatic = True

while True:

SharpCap.SelectedCamera.CaptureSingleFrameTo("d:\capture.png")

time.sleep(1)

bm = System.Drawing.Bitmap("d:\capture.png")

g = System.Drawing.Graphics.FromImage(bm)

f = System.Drawing.Font("Arial", 12)

g.DrawString(System.DateTime.Now.ToString(), f, System.Drawing.Brushes.Red, System.Drawing.Point(0,0))

g.Dispose()

f.Dispose()

bm.Save("d:\\timestamped.png")

bm.Dispose()

# do more with png file here

time.sleep(15)

選択枠の制御

この例題を始める前に、適切なフォーカス スコア方式または画像ヒストグラムを選択し、プログラムによって生成された領域選択を表示できるようにします。 領域選択は、ツールバーのアイコンを使ってオフにする必要があります。

「スクリプト」→ 「コンソールを表示」から、IronPythonコンソールに次のコードを入力します。 演習の目的が損なわれるため、コピーして貼り付けないでください。 特定の場所で「 . 」を入力すると、可能な方式とプロパティを示すドロップダウンが表示されます。 適切なテキストを選択します。

import clr
clr.AddReference("System.Drawing")
from System.Drawing import Rectangle
SharpCap.Transforms.AreaSelection = True # turn on selection area
SharpCap.Transforms.SelectionRect = Rectangle(100,200,300,400) # adjust selection rectangle, parameters are (x, y, width, height)

入力されたコードは以下のようになります。 実行すると、コンソールに >>> が追加で表示される以外は、何も起こらないようです。 エラーメッセージが出ないのは良い兆候です。

これにより、領域選択の指定に必要な.NET型の System.Drawing.Rectangle を使用することができます。.NET型へのアクセスを可能にする最初の3行は、 他の.NET型にも使用できるため、ここでは重要なものです。

スクリプトの例題

次のような例題を考えてみましょう。

· LRGBフィルターを内蔵したUSBフィルターホイールの制御

· Lフィルターによる10×5分の露出を撮影

· Rフィルターに切り替え

· Rフィルターによる10×5分の露出を撮影

· Gフィルターに切り替え

· Gフィルターによる10×5分の露出を撮影

· Bフィルターに切り替え

· Bフィルターによる10×5分の露出を撮影

合計撮影時間= 3時間20分ですが、撮影がスクリプトによって管理されている場合、介入は必要ありません。


コマンドライン引数

SharpCapは、コマンドライン引数を選択して起動することができ、動作をカスタマイズしたり、異常な状況に対処することができます。

/language | SharpCapをWindowsのデフォルト言語以外の言語で実行します。SharpCapがサポートしている言語の言語コードを指定します （例：「fr」、「zh-CN」、「de」、「jp」）。 一例 : /language fr
/camera | SharpCap起動時に、指定したカメラを開く。カメラ名にスペースが含まれる場合は、「二重引用符 = (" ") 」で囲んでください。 一例 : /camera "ASCOM Camera Driver for DSLR"
/softwarerendering | SharpCapのUIの特定の部分に、グラフィックカードのアクセラレーションドライバーではなく、ソフトウェアレンダリングを強制的に使用します。 このオプションは、リモートアクセスソフトウェアでSharpCapを実行しているときに、SharpCapのウィンドウの一部が空白になる場合に使用します。
/runscript | SharpCapの読み込み終了後に、指定したPythonスクリプトファイルを実行します。詳細は スクリプト を参照してください。 一例 : /runscript d:\files\test.py
/dump | SharpCapに致命的なエラーが発生した場合、デスクトップ上に「クラッシュダンプ ミニダンプ ファイル」を作成します。 このオプションは、SharpCapがクラッシュし、バグレポートを提出する機会がない場合に使用します。 ミニダンプファイルは「SharpCap.dmp」という名前でデスクトップに保存されます。ミニダンプファイルは、 フォーラム 経由でテクニカルサポートにお送りください。
/instance | 別の構成でSharpCapを実行します。 2〜9の範囲で構成インスタンス番号を指定します。 一例: /instance 2 インスタンス番号を初めて使用する際には、SharpCapのすべての設定がデフォルトの設定からコピーされます。 それ以降、デフォルトのインスタンスで行った設定変更は、新しいインスタンスには影響しません （新しいインスタンスで行った設定変更も、デフォルトのインスタンスには影響しません）。 この方法では、同じコンピュータに複数の画像処理機器を接続している場合などに、SharpCapを2つ以上の設定にすることができます。 なお、以下の項目はインスタンス間で共有されています。 · SharpCap Proのライセンス · 以前のカメラ設定を自動的に復元するための「自動保存」プロファイルを含むキャプチャプロファイル · シーケンスエディターとシーケンスプランナーの設定を自動保存
/translate | このオプションを使用して、SharpCapの新しい言語への翻訳を開始します。 SharpCapの新しい翻訳を作成する方法の詳細については、 フォーラムのここを を参照してください。 他のSharpCapユーザーに利益をもたらすことができるように、SharpCapの公式バージョンに翻訳を提供することを検討してください。


バグとクラッシュ

バグやその他の問題を報告する前に、そのバグが既に修正されている可能性があるため、SharpCapの最新バージョンが使用されていることを確認してください。 また、同じ問題を報告している他のユーザーをフォーラムで検索すると、すでに回避策があるかもしれません。

SharpCapのバグやクラッシュを報告するためのフォーラムは、以下の場所にあります。 http://forums.sharpcap.co.uk

バグの報告方法

SharpCapのクラッシュを伴わない、SharpCapのバグを発見した場合は、 「バグレポート Bug Reports 」 フォーラムに以下の詳細を投稿してください。

• 問題点を簡潔に説明した件名。

• 何をしようとしていたのかの説明。

• バグを発生させるために必要な手順のリスト。

• 問題が発生した後に収集されたSharpCapログの内容。

ログの文章は長くなりますので、本文ではなく添付ファイルとして投稿してください。

SharpCapの実行中には、「ヘルプ」メニュー項目の「ログを表示」でログテキストを取得できます。 また、ログは「%LOCALAPPDATA%%SharpCap\logs」というフォルダに保存されており、 ログウィンドウの「Locate on Disk」ボタンを押すことで簡単にアクセスできます。

または、「C:Users\user name」フォルダにアクセスし、SharpCap終了後のログファイルをご確認ください。

クラッシュの報告方法

クラッシュレポートの提出

SharpCapがクラッシュした場合、バグレポートの提出を求めるメッセージが表示されることがあります。

インターネットに接続されている場合は、 「送信して終了 Send and Quit 」ボタンを押すと、SharpCapのバグアーカイブにバグレポートが自動的にアップロードされます。 必要に応じて、クラッシュが発生したときに何が起こっていたかの説明を追加してください。

インターネットに接続されていない場合は、「送信して終了」の横にある下矢印を押すと、 バグレポートを電子メールで送信したり、フォーラムで共有できるようにファイルとして保存するなどの追加オプションが表示されます。

· 「ウェブにアップロード Upload to Web 」ー 「送信して終了」を押したときのデフォルトの動作として、インターネット上のSharpCapのバグレポートサーバーにレポートがアップロードされます。

· 「電子メールで送信 Send via Email 」ー インターネットに接続されている場合（PCにもメールアプリケーションが設定されている必要があります）。

· 「手動でレポートを送信 Send report manually 」ー 生成されたレポートは、フォーラムに手動で提出できるようにZIPファイルとして保存されます。

このバグレポートには、SharpCapがクラッシュする原因となった問題の説明とSharpCapのログの内容が含まれており、 クラッシュの原因となった問題を追跡するのに役立ちます。

クラッシュレポートがなし？

まれに、SharpCapがエラーレポートメッセージを表示せずにクラッシュすることがあります。 このような場合、バグを追跡するには、SharpCapをコマンドプロンプトから再実行し、 コマンドラインに「 /dump」オプションを追加して、次のように実行する必要があります。

"c:\Program Files (x86)\SharpCap 4.0\SharpCap.exe" /dump

この方法でSharpCapを実行したら、もう一度クラッシュを起こしてみてください。 クラッシュが発生すると、「SharpCap.dmp」というファイルがデスクトップに作成されます。 SharpCap.dmpファイルへのリンクと、クラッシュが起きたときに何をしていたかの説明を含めて、フォーラムに投稿してください。 ダンプファイルはサイズが大きいので、アップロードするためのリンクを提供してください。 ここでは、Dropbox、Google Drive、MicrosoftのOne Driveが便利な技術ですが、他にもあるかもしれません。


トラブルシューティング

ここでは、遭遇した問題からヒントを得ることができます。

ハードウェア

画像撮影に関するハードウェアの問題は、USBの規格を理解していないことが原因となっています。 詳細および最大ケーブル長については、 https://en.wikipedia.org/wiki/USB を参照してください。

いくつかの定義があります。

· USB2.0規格では、High Speed（HS）として480メガビット/sが規定されています。

· USB 3.0規格では、スーパースピード（SS）を5ギガビット/sと規定していますが、 タイミングオーバヘッドがあるため、データ効率は3.2ギガビット/sが妥当と考えられます。

· パッシブ型のUSB延長ケーブルは、電子部品のない単純なケーブルです。

· 有効なUSB延長ケーブルは、USB信号を再生成するための電子機器が含まれています。 基本的にはハブとケーブルを組み合わせたものです。

· 電源の入っていないUSBハブは、パソコンのUSBポートから電源を取っています。

· 電源付きUSBハブは、独自の外部電源を備えています。

· PC / ノートパソコンの黒いUSBポートは、USB2接続が可能であることを示しています。

· PC / ノートパソコンの青いUSBポートは、USB3接続が可能であることを示しています。

考慮すべき点は...

· カメラの電源は、パソコンのUSBポートから供給されます。

· 冷却ファンを搭載したカメラは、パソコンのUSBポートからさらに多くの電力を消費します。

· 電力不足により、USB3デバイスがUSB2の速度に戻ってしまうことがあります。

· 品質の低い（または破損している）USBケーブルを使用すると、問題が発生する可能性があります。

· 銅張りアルミニウム（CCA）製のUSBケーブルは問題を引き起こす可能性があります。

· 全てのUSBポートが同じではありません。 例えば、マイクロ / ミニPCのフロントUSBポートやバッテリー駆動のノートPCなどです。 原因不明のトラブルが発生した場合は、同じパソコンで別のポートを試してみてください。

· 内蔵のPCI USBカードに電源コネクタがある場合は、内蔵の電源リードが接続されていることを確認してください。

USBTreeView は、 USB接続されたデバイスの動作速度を確認するのに便利なユーティリティです。 このユーティリティは、速度をHS（High Speed = USB2）またはSS（SuperSpeed = USB3）として表示します。

トラブルのない実行のために、次のことを考慮してください。

· カメラメーカーが提供するUSBケーブルを使用してください。 問題が発生した場合は、USBケーブル / ハブの問題を除外するために、少なくとも2本の短いUSBケーブルでテストしてください。

· 長さが必要な場合は、良質な無抵抗 延長ケーブルを使用すれば、 通常、USB3速度の場合は全長3.5m、USB2速度の場合は全長4.5mまでは十分です。

· この長さを超えると、ハブの使用や有効なケーブルが必要になります。

· 1つのUSBハブで2台以上のデバイスを動かす場合は、 電源の入っていないハブではなく、電源の入ったハブを検討してください。

ソフトウェア

· 正しいハードウェアドライバーがインストールされ、最新の状態になっていることを確認してください。 インストールされているグラフィックスカードの正しいドライバーがインストールされていないと、 カードが低パフォーマンスの「互換モード」で動作し、フレーム率が低下したり、クラッシュしたりすることがあります。

· Windowsの「N」バリアント（デフォルトでメディア機能がインストールされていない）では、 SharpCapが特定のカメラで正しく機能する前に、「Windows MediaFeaturePack」をインストールする必要がある場合があります。

画像

明るすぎる画像

問題点 ー 次の画像には木星の衛星がいくつか写っていますが、木星には特徴がありません。

解決策 ー カメラの露出設定が高すぎます。 惑星の特徴が見えるようになるまで、カメラコントロールパネルの露出の値を減らします（衛星が見えない場合もあります）。

1,000フレーム程度のビデオを撮影します。 これを「AutoStakkert」などでスタックすると、スタックされた最終画像に衛星が再び現れるようになる。 これは、ビデオでは見えなくても、処理後の画像では衛星が見えるようになるため、処理の早い段階でトリミングすることを避けるための議論でもあります。

びくびくしたAVIがスタックしない

以下の手順で、風が強いときに作られたびくびくしたビデオの救出を試みます。

問題点 ー 月面や太陽面でのビデオがびくびくになってしまうと、スタックしません。

解決策 ー PIPPのウェブサイトで 画像安定化処理 をご覧ください。

粒子の粗い画像

問題点 ー 非常に粒子の粗い画像。

解決策 ー カメラコントロールパネルの「ゲイン」を下げてください。

下の画像は、おおぐま座にある淡い惑星状星雲、M92「ふくろう星雲」です。 ゲインを下げ、ライブスタックを使用してより良い画像を作成します。

ギャップのあるヒストグラム

以下は、ギャップのあるヒストグラムの一例です。

問題点 ー ヒストグラムに縦棒や隙間が現れる。

解決策 ー ホワイトバランスをデフォルトに戻して（ヒストグラムのギャップをなくして）、重ね合わせた後にカラーバランスを補正するのがベストです。 これにより、SharpCapでデジタルホワイトバランス補正を行った場合のデータ損失を防ぐことができます。

色が違う

以下は、実際に壊れたヒストグラムの一例と、それを改善するために何をすべきかです。

問題点 ー 色がおかしい。

解決策 ー ツールバーの「画像ヒストグラム」を起動します。 LRGBのヒストグラムがほぼ一致しているはずですが、一致していません。 カメラコントロールパネルの「ホワイトバランス」または「カラーバランス」で、4つのヒストグラムがほぼ揃うように調整してください。

この撮影は、USB2ビデオ撮影デバイスを備えたAVSDSO-1アナログビデオカメラを使用して撮影されました。 ビデオグラバーはDirectShowデバイスとして分類されており、SharpCapではカメラコントロールが公開されていないため、 カメラの内部メニューを使用して調整が行われます。 このタイプのカメラでは、赤と青を変更することで緑が調整されます。


付録

書込み速度のテスト

以下のデータは、様々なハードウェア構成で実施した「書込み速度のテスト」の概要です。 書込み速度のテストボタンは、「ファイル」→「SharpCapの設定」→ 「 ファイル名 」 タブにあります。 ハードウェアによってメガバイト/sやフレーム/秒に大きな差があることがわかります。

テストの進行中は、回転する円が表示されます（テスト中は目に見えるフィードバックはありません）。 テストが終わると、結果が表示されます。

このテストでは、215Mb/sの書き込み速度が得られました （10,000rpmのWestern Digital Raptorドライブを、Quad Core Xeonプロセッサのマザーボードと16Gbのメモリで動作させた場合）。 プラットフォームはWindows 10 Pro 64ビットです。 この結果は、ハードウェアの性能によって異なります。

この表は、さまざまなハードウェア構成のパフォーマンスを比較したものです。 すべてのテストで、1280×960で4,882フレームを書き出しました。

ハードウェア | プロセッサー | メモリ | ハードドライブ | OS | テスト結果
 |  |  |  |  | Mb/s | *fps
HP Z220 Workstation | Xeon Quad Core, 3.4GHz | 16Gb | 500GB SATA2, 10,000 rpm | Windows 10 Pro, 64-bit | 215 | 184
ThinkPad W510 laptop | i7 Quad Core, 1.73GHz | 16Gb | 500Gb SATA2, 7,200rpm | Windows 10 Pro, 64-bit | 240 | 205
ThinkPad T400 laptop | Core 2 Duo, 2.4GHz | 8Gb | 240Gb SATA2 SSD | Windows 10 Pro, 64-bit | 191 | 163
ThinkPad X61 laptop | Core 2 Duo, 1.86GHz | 4Gb (3Gb usable) | 120Gb SATA2 SSD | Windows 10 Pro, 32-bit | 97 | 83
Linx 10 Tablet | Atom Z3735F, 1.33GHz | 2Gb | 32GB eMMC | Windows 10 Home, 32-bit | 44 | 38

注: *fps = フレーム／秒

高フレーム率のカメラを購入する際には、ハードウェアへの要求を考慮してください。

SharpCapアンインストールとクリーンアップ

SharpCapをアンインストールした後、オプションで次の手順を実行できます。

[オプション] プロファイルデータの削除（作成されている場合）ー プロファイルデータは「％APPDATA％\ SharpCap \ CaptureProfiles」に保存されます。 [検索]または[実行]からこのフォルダーに移動し、「CaptureProfiles」フォルダーの内容を削除します。

以下の手順は省略できますが、念のため記載します。 レジストリを変更する前には必ずバックアップを取ってください。

[オプション] レジストリエントリの削除 ー 「Regedit」を実行します（レジストリエディターの起動）。念のため、レジストリをエクスポートしておきます。 HKEY_CURRENT_USER%SOFTWARE%ASTROSHARP LIMITED%SharpCapに移動し、4.0キーを削除します。

キャプチャープロファイルの管理

木星 RGB32などの新しいキャプチャープロファイルを作成すると、次のようになります。

1. Jupiter RGB32（有効なカメラの名前 > .ini）というテキストファイルがフォルダー「％APPDATA％\ SharpCap \ CaptureProfiles」に保存されます。

2. 保存されたプロファイルの場所には、「％APPDATA％\ SharpCap \ CaptureProfiles」をコピーしてWindowsの検索バーに貼り付けることでアクセスできます。 これは、不要なキャプチャプロファイルを削除する方法です。


便利なソフトウェア

· AutoStakkert!2, 画像シーケンスのアライメントとスタッキング用。

· DeepSky Stacker, ディープスカイ写真の前処理用。

· FITS Liberator, FITSファイルの画像処理用。

· GIMP, 画像処理用、（2017年リリース予定のv2.10では16/32ビット）

· Image Composite Editor, モザイク画を作成するためのマイクロソフトの画像スティッチングソフトウェア。

· PIPP, 惑星画像（太陽、月面も含む）の前処理を行います。

· Registax, 画像スタックとウェーブレットフィルター。

· SER Player, SERファイル用のビデオプレーヤーです。

· VirtualDub, AVI ビデオを個々のフレームに分割します（ここではISSビデオを想定）。


用語集

ASCOM

マウント、フォーカサー、画像デバイスなど、さまざまな天文機器への標準的なインターフェースを提供し、Microsoft Windowsプラットフォーム上で動作します。 詳細は、 ASCOM Standards のウェブサイトをご覧ください。

FITS

このファイル形式は、天文学界で採用されているデータ保存のためのオープンスタンダードです。 詳細は以下のサイトをご覧ください。 https://fits.gsfc.nasa.gov/fits_documentation.html

プレートソルブ

画像に写っている星のパターンから、その画像が空のどの位置にあるかを計算するソフトウェアです。 All Sky Plate Solver はその一例で、撮影したFITSファイルやJPEGファイルの天球座標を自動的に検出することができます。

UTC

協定世界時 ー タイムゾーンに依存しない方法で時間を測定するための世界標準規格。 実際には、UTC時刻はGMT時刻と同じです。 UTC Time Offsetsの説明については、 https://en.wikipedia.org/wiki/List_of_UTC_time_offsets を参照してください。

WinJUPOS

惑星の回転の影響をデジタル補正することにより、木星や他の惑星の画像を改善するのに役立つソフトウェアツールです。 木星の画像キャプチャの処理を支援する情報については、 http://jupos.privat.t-online.de/index.htm を参照してください。

アンプグロー

カメラ本体やセンサーの回路の影響で、画像の一部分が隣の部分よりも明るく輝くこと。

バンディング

カメラが画像の暗部に様々な横帯を表示する状態。

バイアスフレーム

シャッターを閉じたCCDカメラを使用して撮影された長さ 0 の画像です。 CCDチップとカメラの電子機器のピクセル固有のオフセットを補正するために使用されます。

ビット深度

画像の輝度レベルを格納するのに必要なビット数で、RGB画像の場合はRGBAの各チャンネルの量子化ビットの合計となる。 画像処理では、信号の大きさを表現するためのビット数を「量子化ビット数」と呼ぶ。 ビット数が多いほど、微妙な大きさの違いを表現できる（量子化誤差が少ない）が、データ量が多くなる。 データ圧縮では、量子化ビット数を減らすと、データ量は減りますが、量子化誤差は増えます。

ビニング

画像の S/N比（信号対雑音比） を向上させるために、解像度を下げて使用される技術。 ビニングは、センサー上の2つ以上の隣接したピクセルの値を取得し、それらを加算または平均して1つの出力ピクセルの値を生成します。 ビニングは通常対称的であり、つまり、各方向で同じ数のピクセルが平均化されます。 例えば、ビニング値が「2x2」または単に「2」の場合、2×2ブロックのセンサーピクセルを使用して最終画像の各ピクセルを作成することを意味します。 これにより、最終画像の解像度は2分の1になりますが、画像のS/N比は2倍に増やします。

圧縮アーティファクト

画像の保存に圧縮ファイル形式（JPG、WMVなど）を使用した場合に生じる画像の変化。これらは一般的に画像の品質を低下させますが、 出力ファイルサイズを大幅に減らしたいユーザーにとっては問題ないかもしれません。

コーデック

符号化方式を使ってデータのエンコード（符号化: アナログ信号やデジタルデータに特定の方法で、後に元の信号またはデータに戻せるような変換を加えること） とデコード（復号）を双方向にできる装置やソフトウェアなどのこと。また、そのためのアルゴリズムを指す用語としても使われる。

カラーキャスト

画像の全部または一部に見られる好ましくない色の変化。

ディザリング

天文学におけるディザリングとは、撮影したフレームの間でマウントのポインティングポジションを意図的に徐々に変化させることです。 これにより、最終的なスタック画像にノイズパターンが現れるのを防ぐことができます。 例えば、異常に明るいピクセルがある場合、ディザリングによってそのピクセルの効果が画像内で移動し、余分な明るさがかき消されます。

ディベイヤリング

RAW画像をフルカラーにすること。

ダイナミックレンジ

これは、カメラを飽和させずに撮影できる最も明るい部分と、背景のノイズに負けずに目立たせることができる最も暗い部分の比率を意味します。 ノイズが増えるとダイナミックレンジが狭くなり、ノイズが減るとダイナミックレンジが広くなります。多くのフレームを重ねることで、レンジを広げることができます。

e/ADU（electrons per ADU）

CMOSイメージセンサーでは、測定された光電子の数をデジタル単位（ADU：Analog-to-Digital Conversion Unit）に変換する割合を意味します。

フレームレート

カメラがコンピューターに送信しようとする1秒あたりのフレーム数。FPS（フレーム/秒）の単位で表されます。

FWHM (Full-width, Half-Maximum = 半値全幅)

星などの像の大きさを表す指標。最大値の半分とは、明るさが中心値の半分になる中心からの距離を意味します。 全幅とは、測定値が半径ではなく、直径で示されることを意味します。 半径は、画像中の点光源のFWHMを2で割って求めることができ、点像分布関数モデルの半径の推定値として利用することができます。

フーリエ変換

任意波形を各周波数の成分に分解し、その大きさ（振幅）および位置（位相）を求める手法のこと。

ガウスぼかし

画像処理において、ガウス関数を用いて画像をぼかす処理のこと。デジタルカメラで撮影した画像のノイズ除去、アンシャープマスク、エッジ抽出の前処理などに応用できます。

ホットピクセル

光が当たっていないのに最大値を示すピクセル。

ラッキーイメージング

天体写真撮影に用いられる高解像度の天文画像技術の一種で、高速度カメラと短い露光時間（100ms以下）を用いて、露光中の地球の大気の変化を最小限に抑えることができます。

掩蔽 (えんぺい)

月などの天体が他の惑星などを隠す現象。

点像分布関数 (PSF)

恒星などの点光源を観測したときに得られる像の形状、シーイングや光学系などによる画像のぼやけ具合を表す関数。

ROI（関心領域）

カメラの場合、撮像範囲を狭くすることで、センサーの全範囲の中のごく一部を撮影することになり、これをROI（ region of interest ）撮影といいます。

信号対雑音比

SNR（Signal to noise ratio）とも呼ばれています。測定中の信号Sと雑音Nの（S / N）比を意味し、撮影精度の基本的な指標となります。

標準偏差 (Standard Deviation)

標準偏差は、データセット内のノイズの尺度です。 [ 二乗平均平方根（RMS）ー 各ピクセルの二乗を計算し、それらの二乗の合計を計算し、平方根を計算することにより、一連のデータポイント（ピクセル）で計算されます。 結果はピクセル数でスケーリングされ、存在するノイズの量を正確に測定します ] の方法で計算されます。 標準偏差は、統計的分布の広がり、および点像分布関数モデルの半径の尺度でもあります。

タイムスタンプ

画像が撮影された日時などを示す文字列。

TXT

TXTファイルとは、フォーマットされていないテキストを含む標準的なテキスト文書のことです。 このファイルは、メモ帳などのテキスト編集や、他の同様の文書の記録によく使われます。

しきい値

ある現象の影響が、その値以上では発生するが、その値以下では発生しない境界値であり、その影響が発生するときの最小値である。

ケラレ

フレームの端や隅に届く光が少なくなって暗くなること。画像の中心部と周辺部の輝度差。（周辺光量の減少)